Repository 32bit  Forum
Repository 64bit  Wiki

Upgrade Firefox.... e non va più nulla! [RISOLTO]

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Upgrade Firefox.... e non va più nulla! [RISOLTO]

Messaggioda Twenty-Seven » gio feb 21, 2013 1:15

Ciao, per la prima volta ho voluto cimentarmi in un upgrade e ho provato con Firefox. Con la Slack 13.0 avevo la versione 3.6. Ho scaricato il seguente file:

firefox-21.0a1.en-US.linux-i686.tar.bz2 (non so nemmeno se vada bene....)

ho letto come installare da sorgente e ho provato a installare da pacchetto una volta (flash-player con pkgtool, in realtà ha fatto tutto lui....). Ma sul sito di firefox ho letto che questo file è un file precompilato, quindi ne sorgente nè pacchetto. In teoria bastava lanciare l' eseguibile "firefox", solo che mi diceva che gli mancava una libreria (peraltro presente nel file decompresso). Allora io, che ignoro assolutamente come faccia un programma ad andare a prendersi le librerie condivise, ho avuto un lampo di genio: prendo la directory firefox nuova che ho appena scompattato e la copio in /usr/lib/firefox lasciando i files vecchi, aggiungendo eventuali nuovi e sovrascrivendo quelli comuni con la copia nuova.... Risultato:

:~# firefox
XPCOMGlueLoad error for file /usr/lib/firefox-3.5.2/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

Tra l' altro le due librerie che dice di non trovare ci sono, XPCOM non ho la più pallida idea di cosa sia..... Qualcuno mi può aiutare a capire cosa è successo?

Grazie
Ultima modifica di Twenty-Seven il mer feb 27, 2013 23:46, modificato 1 volta in totale.
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE

Re: Upgrade Firefox.... e non va più nulla!

Messaggioda 414N » sab feb 23, 2013 10:01

Un bel casotto, ecco quel che è successo :)
Innanzitutto, dato che firefox è un pacchetto che rientra in quelli distribuiti con Slackware, dovresti installare le nuove versioni scaricando gli aggiornamenti di sicurezza tramite slackpkg (attualmente c'è la versione 19). Se non l'hai mai usato (male!), ti rimando alla pagina apposita qui sulla wiki di slacky.eu.
Quella che riporti è una versione pre-beta di firefox (in beta c'è la versione 20 attualmente, e sul forum trovi un thread continuamente aggiornato da Trotto@81 con pacchetti già pronti), percui non la userei come aggiornamento di base.
Non riporti se il tuo sistema sia a 64 o a 32 bit: nel primo caso devi assicurarti di avere installati i pacchetti per le multilib di alien, altrimenti non potrai mai eseguire codice a 32 bit come quello contenuto nel tarball che hai scaricato.
Sistemato il discorso multilib, firefox dovrebbe funzionarti semplicemente estraendo quell'archivio in una qualsiasi directory ed eseguendo l'eseguibile "firefox" ivi contenuto. Se non dovesse ancora partire, temo che tu abbia qualche problema più grosso sul sistema.>
PS: se intendi aggiornare tramite slackpkg, ti consiglio di rimuovere prima la directory che hai contaminato (tanto verrà ricreata aggiornando il pacchetto), onde evitare di tenerti file "spuri" in giro.
PS2: a me il pacchetto alpha 2 (firefox-21.0a2.it.linux-i686.tar.bz2) funziona alla perfezione su Slackware64 14.0 (multilib ovviamente) e ti sto scrivendo proprio col firefox che ho estratto dall'archivio sotto /tmp.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Upgrade Firefox.... e non va più nulla!

Messaggioda Twenty-Seven » lun feb 25, 2013 0:03

Grazie mille 414N! Allora: ho seguito il tuo consiglio e ho provato slackpkg. Che dire? Il tempo di decommentare un paio di repositories, lanciare l' update, cercare il pacchetto e lanciare l' upgrade e... ha fatto tutto lui!!!! In tempo zero pacchetto nuovo installato e funzionante come un orologio svizzero. Una ripulita al sistema dalla roba che avevo scaricato e adesso è tutto ok.
Comunque, giusto per la cronaca, mi sa che il pacchetto che avevo scaricato io non era pienamente funzionante. Dopo essere riuscito a sistemare tutte le librerie che cercava non andava ancora.....

Quindi... problema risolto!!!

Mille grazie ancora.

P.S. Hai fatto bene a chiedermi di riportare se il mio sistema è a 32 o 64 bit, lo aggiungo nel profilo.
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE

Re: Upgrade Firefox.... e non va più nulla!

Messaggioda 414N » lun feb 25, 2013 10:02

La cosa strana è che praticamente tutte le librerie di cui necessita firefox sono incluse nel tarball che hai scaricato, quindi mi suona strano che tu abbia dovuto "aggiungerne" a mano alcune.
Se il problema è risolto, aggiungi il tag [RISOLTO] al thread modificando il titolo del tuo primo post ;)
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Upgrade Firefox.... e non va più nulla!

Messaggioda Twenty-Seven » mar feb 26, 2013 1:27

Purtroppo ho cantato vittoria troppo presto..... Firefox adesso funziona, però avevo installato anche chrome, che adesso non funziona più.... il motivo presumo sia questo:

libnss3.so.1d => not found
libnssutil3.so.1d => not found
libsmime3.so.1d => not found
libplds4.so.0d => not found
libplc4.so.0d => not found
libnspr4.so.0d => not found

In un file testo insieme al pacchetto di google chrome c' era scritto di non rimuovere firefox, perchè chrome ne utilizzava alcune librerie. Tuttavia pensavo che aggiornando firefox non avrei comunque perso le librerie necessarie al funzionamento di chrome. In effetti sembra che io nel sistema abbia delle versioni diverse di quelle librerie. Per esempio, se dò slocate libnssutil3 ottengo:

/usr/lib/libnssutil3.so
/usr/lib/thunderbird-2.0.0.23/libnssutil3.so

Come si fa ad andare a trovare quelle librerie che servono a chrome?
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE

Re: Upgrade Firefox.... e non va più nulla!

Messaggioda 414N » mar feb 26, 2013 9:09

Di quale chrome stai parlando? Di quello che trovi sotto la directory extra/ del DVD di Slackware oppure di un archivio precompilato scaricato dal sito di Chrome?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Upgrade Firefox.... e non va più nulla!

Messaggioda Twenty-Seven » mer feb 27, 2013 0:13

Il chrome che ho è un pacchetto scaricato da un repository:

google-chrome-5.0.375.53-i386-1slacky.txz

Sono anche riuscito a sistemare le librerie creando dei link e facendoli puntare a quelle di thunderbird (anche seamonkey aveva le stesse ma a chrome non piacevano perchè non avevano NSS...) \:D/ Lo so, lo so....... è una banalità, ma per uno che ha appena iniziato risolvere una micro magagna del genere è comunque un piccolo trionfo. Adesso va sia firefox che chrome. L' unica cosa è che quando chrome parte da terminale mi dice che che per un paio di librerie non è disponibile l' informazione della versione, comunque va.

/usr/bin/google-chrome: /usr/lib/libz.so.1: no version information available (required by /usr/bin/google-chrome)
/usr/bin/google-chrome: /usr/lib/libpng12.so.0: no version information available (required by /usr/bin/google-chrome)
/opt/google/chrome/chrome: /usr/lib/libz.so.1: no version information available (required by /opt/google/chrome/chrome)
/opt/google/chrome/chrome: /usr/lib/libpng12.so.0: no version information available (required by /opt/google/chrome/chrome)

I browsers adesso vanno tutti, meno rekonq per il quale mi manca il kde libwebkit ma non riesco a trovarlo da nessuna parte....
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE

Re: Upgrade Firefox.... e non va più nulla!

Messaggioda 414N » mer feb 27, 2013 9:16

README del pacchetto ha scritto:*** W A R N I N G ***
Google Chrome work with some Seamonkey-Solibs libraries.
Do not remove Seamonkey-Solibs package.

Controlla di avere installato il pacchetto seamonkey-solibs (fornito coi media di Slackware stessa). Per farlo puoi usare pkgtool oppure un semplice
Codice: Seleziona tutto
ls -l /var/log/packages/seamonkey*

Probabilmente tutti i tuoi problemi di librerie mancanti derivano dalla mancanza di questo pacchetto...
PS: mi sono accorto ora che hai detto di aver decommentato "un paio" di repositories in /etc/slackpkg/mirrors: devi lasciarne decommentato uno soltanto e questo deve riferirsi ad un mirror Slackware ufficiale, non a repository di pacchetti di terze parti.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Upgrade Firefox.... e non va più nulla!

Messaggioda Twenty-Seven » mer feb 27, 2013 23:46

I pacchetti di seamonkey li ho:

-rw-r--r-- 1 root root 239780 May 22 2011 /var/log/packages/seamonkey-1.1.17-i486-1
-rw-r--r-- 1 root root 1694 May 22 2011 /var/log/packages/seamonkey-solibs-1.1.17-i486-1

Ho cercato il warning "no version information available", è dovuto sostanzialmente al fatto che la libreria è una versione vecchia.

Per slackpkg ho lasciato decommentato un solo repository, funziona decisamente meglio.....

Per quanto riguarda la libreria mancante per rekonq non è un problema, non è una di quelle che è fornita con Slackware, qualora dovessi trovarla la scaricherò e proverò anche quel browser.

Visto che il problema su firefox (più quello successivo di chrome) sono risolti, metto "risolto".

Ti ringrazio di cuore per la disponibilità 414N.
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE

Re: Upgrade Firefox.... e non va più nulla! [RISOLTO]

Messaggioda 414N » gio feb 28, 2013 9:43

Figurati :)
Quando non trovi un programma/libreria già pacchettizzato per Slackware, spesso puoi trovarne lo SlackBuild su slackbuilds.org (detto anche SBo).
Per esempio, puoi trovare lo SlackBuild di webkit per Slackware 13.0 qui.
Se non hai la minima idea di cosa sia uno SlackBuild puoi trovare qualche informazione nella documentazione qui su slacky.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Upgrade Firefox.... e non va più nulla! [RISOLTO]

Messaggioda Twenty-Seven » ven mar 01, 2013 0:40

Quindi se ho capito bene lo slackbuild è sostanzialmente un file compresso con incluso un programmino che permette di creare un pacchetto installabile con i tool a diposizione.
Ma il webkit di cui mi hai messo il link è il webkit kde (cioè libkdewebkit.so.5)?
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE

Re: Upgrade Firefox.... e non va più nulla! [RISOLTO]

Messaggioda 414N » ven mar 01, 2013 9:30

No, lo SlackBuild è solo uno script shell con suffisso .SlackBuild: è semplicemente uno script che estrae il pacchetto dei sorgenti, li compila se devono essere compilati ed impacchetta il tutto nel formato di pacchetti Slackware (.tgz o .txz), in modo da poter installare il programma appena pacchettizzato tramite installpkg/upgradepkg.
Su SBo lo SlackBuild viene posto all'interno di un archivio assieme ad altri file:
  • un file README, che spiega cos'è il programma/pacchetto in questione aggiungendo note relative a procedure preliminari all'installazione (se necessario), obbligatorio su SBo ma non nella vita :);
  • un file slack-desc, contenente la descrizione del programma da inserire nel pacchetto in modo che durante l'installazione dello stesso venga mostrata all'utente (non strettamente obbligatorio);
  • un file .info, contenente vari metadati riguardo il pacchetto per automatizzarne la gestione all'interno del sito (quindi serve praticamente solo a SBo se non ti interessa controllare l'hash dei tarball che scarichi);
  • file di patch, se necessari;
  • un file doinst.sh, che viene utilizzato dal processo di post-installazione (se presente);
  • lo SlackBuild;
  • vari altri file, tipo icone per il programma, file .desktop per aggiungerlo ai menù dei vari desktop environment ecc.
Il webkit che ti ho riportato precedentemente credo sia quello "puro", tuttavia su SBo puoi trovare uno SlackBuild anche per rekonq stesso e non è riportata la dipendenza da webkit (forse perché lo include già).
Prova direttamente con lo SlackBuild per Slackware 14.0 e, se non dovesse funzionare, prova con una versione precedente.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Upgrade Firefox.... e non va più nulla! [RISOLTO]

Messaggioda Twenty-Seven » sab mar 02, 2013 15:59

Sì, il concetto era quello che avevo in mente, solo che lo avevo espresso malissimo e con termini impropri....

Proverò ad installare la webkit questo fine settimana... e vediamo come va.

Buon weekend
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti