Repository 32bit  Forum
Repository 64bit  Wiki

Mantenere contemporaneamente firefox15 e firefox aggiornato

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Mantenere contemporaneamente firefox15 e firefox aggiornato

Messaggioda varjag » mer mar 13, 2013 13:56

Buon giorno
Uso slackware64 14 , kernel 3.2.29.
Con multilib di Alien Bob.
Firefox aggiornato con slackpkg alla versione 19.0.2.
Purtroppo alcuni Add-ons che funzionavano in versione firefox15 sulla versione 19 non funzionano.
Per esempio mediaplayerconnectivity 0.9.4 con firefox19 non va.

è possibile installare e usare 2 versioni di firefox , firefox15 e firefox19?

grazie per la risposta
varjag
Linux 1.0
Linux 1.0
 
Messaggi: 88
Iscritto il: mer mag 11, 2011 18:32

Re: Mantenere contemporaneamente firefox15 e firefox aggiorn

Messaggioda conraid » mer mar 13, 2013 14:37

Certo, scarichi il binario dal sito mozilla.org e lo decomprimi in /opt e poi lo lanci da li

Però a volte per le estensioni basta modificare un file per renderle compatibili (se cerchi nel forum trovi vecchie discussioni)

p.s.
nelle prossime versioni mozilla cambia il modo di interazione con le estensioni, e quindi questo trucco (che già adesso non funziona con tutte) non funzionerà più
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11994
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Mantenere contemporaneamente firefox15 e firefox aggiorn

Messaggioda varjag » mer mar 13, 2013 15:24

Grazie per la risposta
ho scaricato dal sito: http://download.cdn.mozilla.net/pub/
versione firefox-15.0.1.tar.bz2
poi ho scompattato in /opt e lanciato da li.
Funzionano tutti Add-ons.
Come posso disabilitare aggiornamento? perche se vado in : help- about firefox: firrefox comincia aggiornarsi a release 19...
si puo creare un lanciatore ? per non andare ogni volta in /opt/fiefox..
varjag
Linux 1.0
Linux 1.0
 
Messaggi: 88
Iscritto il: mer mag 11, 2011 18:32

Re: Mantenere contemporaneamente firefox15 e firefox aggiorn

Messaggioda conraid » mer mar 13, 2013 15:50

Se si aggiorna da solo significa che lo lanci da root e questo è pessimo, molto pessimo :-)

Installalo in /opt da root, ma poi usalo da utente normale, e vedrai che non succede

per lanciarlo puoi fare in vari modi
- icona che lancia quell'eseguibile
- script fatto più o meno così
Codice: Seleziona tutto
#!/bin/sh

/opt/firefox-15etc.../firefox

naturalmente metti il nome giusto della directory
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11994
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Mantenere contemporaneamente firefox15 e firefox aggiorn

Messaggioda varjag » mer mar 13, 2013 15:59

ho scompattato in /opt da root
Codice: Seleziona tutto
# tar -jxvf firefox-15.0.1.tar.bz2

ma non ho lanciato dal root..
ho lanciato da utente e infatti non si aggiorna.
Hai raggione , ho controllato e non si aggiorna.
Semplicemente mi ricordavo che una cosa simile facevo su debian, per scompattavo firefox in /home da utente e lanciavo da utente e cosi si aggiornava automaticamente. Unica differenza che su debian ho cercato di aggiornare a release nuovo, perche su debian testing oggi ancora firefox alla versione 10.0.12.
E su slackware invece avevo bisogno di una versione vecchia :-)
Grazie per velocissimo aiuto.
varjag
Linux 1.0
Linux 1.0
 
Messaggi: 88
Iscritto il: mer mag 11, 2011 18:32


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron