Repository 32bit  Forum
Repository 64bit  Wiki

Installazione Linux completata ma parte solo Windows Xp

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Installazione Linux completata ma parte solo Windows Xp

Messaggioda phoenix1977 » mar mar 19, 2013 12:48

Buongiorno a tutti,

avrei un problema da sottoporvi e spero che qualcuno mi possa aiutare.

Ho appena installato Slackware 14 su un pc partizionato come segue:

Windows Xp
Linux
Linux Swap

Quando Linux mi ha chiesto dove installare il lilo, io ho scelto root (superblock) perchè ho letto nella guida slackware che in presenza di più sistemi operativi è meglio scegliere così altrimenti se avessi scelto l'MBR avrei potuto causari dei danni anche ad altri sistemi operativi presenti nel pc.

Fato stà che alla fine dell'installazione di Linux ho riavviato ma mi parte solo Windows Xp, senza che il lilo mi chieda se far partire uno o l'altro.

Cosa può essere successo e cosa posso fare?

Grazie anticipatamente.
phoenix1977
Linux 1.0
Linux 1.0
 
Messaggi: 2
Iscritto il: mar mar 19, 2013 12:40
Slackware: 14

Re: Installazione Linux completata ma parte solo Windows Xp

Messaggioda legura » mar mar 19, 2013 13:51

metti come partizione attiva quella in cui hai installato lilo.
legura
Linux 1.0
Linux 1.0
 
Messaggi: 14
Iscritto il: mer mar 23, 2011 12:07

Re: Installazione Linux completata ma parte solo Windows Xp

Messaggioda phoenix1977 » mar mar 19, 2013 14:09

Ciao, grazie per la celere risposta...

Come posso fare per rendere la partizione attiva dove è installato lilo?
phoenix1977
Linux 1.0
Linux 1.0
 
Messaggi: 2
Iscritto il: mar mar 19, 2013 12:40
Slackware: 14

Re: Installazione Linux completata ma parte solo Windows Xp

Messaggioda legura » mar mar 19, 2013 14:16

fai boot da una Live, poi con fdisk cambi la partizione attiva

in rete trovi facilmente una guida all'uso di fdisk.
legura
Linux 1.0
Linux 1.0
 
Messaggi: 14
Iscritto il: mer mar 23, 2011 12:07

Re: Installazione Linux completata ma parte solo Windows Xp

Messaggioda waka_jawaka » mer mar 20, 2013 11:45

Invece che ogni volta cambiare la partizione attiva, conviene sfruttare il bootloader di windows (la cui partizione quindi deve essere sempre quella attiva).
Da una live monta una pendrive
Codice: Seleziona tutto
dd if=/dev/sdxy of=/punto_di_mount/linux.img bs=512 count=1

dove sdxy è la partizione / di slackware e "punto_di_mount" è appunto il punto di mount del pendrive (o puoi crere linux.img direttamente in c:, che dovrai montare preventivamente su punto_di_mount).
Copia linux.img su c: di windows. Edita il file c:\boot.ini (probabilmente devi rendere visibili i file nascosti e quelli di sistema) ed aggiungi in fondo
Codice: Seleziona tutto
c:\linux.img="Slackware"
e salva. Riporta la visualizzazione dei file a default.
Riavviando, invece che partire direttamente windows, ti si dovrebbe presentare una schermata che ti consente di scegliere quale sistema avviare
Ciao

PS: la procedura è da ripetere ogni qualvolta reinstalli lilo tramite lilo -v
Avatar utente
waka_jawaka
Linux 2.6
Linux 2.6
 
Messaggi: 771
Iscritto il: mar ago 09, 2005 23:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Re: Installazione Linux completata ma parte solo Windows Xp

Messaggioda ZeroUno » mer mar 20, 2013 14:33

waka_jawaka ha scritto:Invece che ogni volta cambiare la partizione attiva

E perchè dovrebbe cambiarla ogni volta? le uniche volte che dovrà cambiarla sarà quando reinstalla windows o quando disinstalla linux.

il bootloader di windows (la cui partizione quindi deve essere sempre quella attiva).

Falso.
basta mettere su lilo.conf
other = /dev/sda1
label = Windows
table = /dev/sda


PS: la procedura è da ripetere ogni qualvolta reinstalli lilo tramite lilo -v

che accade più di frequente rispetto alla reinstallazione di windows.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Installazione Linux completata ma parte solo Windows Xp

Messaggioda waka_jawaka » mer mar 20, 2013 22:23

ZeroUno ha scritto:
waka_jawaka ha scritto:Invece che ogni volta cambiare la partizione attiva

E perchè dovrebbe cambiarla ogni volta? le uniche volte che dovrà cambiarla sarà quando reinstalla windows o quando disinstalla linux.

il bootloader di windows (la cui partizione quindi deve essere sempre quella attiva).

Falso.
basta mettere su lilo.conf
other = /dev/sda1
label = Windows
table = /dev/sda


PS: la procedura è da ripetere ogni qualvolta reinstalli lilo tramite lilo -v

che accade più di frequente rispetto alla reinstallazione di windows.


Avevo capito male... sorry. Mi era sembrato che il consiglio fosse: attiva la prtizione di "/" quando vuoi far partire slackware e attiva la partizione di"c:" per far partire windows. Ho sempre consigliato la procedura da me postata, ma devo dire che quella segnalata da voi è più pratica. Non avevo mai pensato ad una soluzione del genere; mi ritiro commosso. :oops:
Ari ciao a tutti
Ciao
Avatar utente
waka_jawaka
Linux 2.6
Linux 2.6
 
Messaggi: 771
Iscritto il: mar ago 09, 2005 23:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Re: Installazione Linux completata ma parte solo Windows Xp

Messaggioda ZeroUno » gio mar 21, 2013 16:53

Strano perchè tra l'altro è anche quella proposta dall'installer di slackware.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron