Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Salvataggio settaggi alsamixer

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Salvataggio settaggi alsamixer

Messaggioda yAri » lun apr 15, 2013 1:23

Salve. Mi trovo un altro problemino a cui non sono riuscito a trovare una soluzione. Non vengono salvati i settaggi di alsamixer. Neanche con
Codice: Seleziona tutto
alsactl store

Ci sono dei rimedi? grazie
Ultima modifica di yAri il ven apr 19, 2013 19:49, modificato 1 volta in totale.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Salvataggio settaggi alsamixer

Messaggioda tornadomig » lun apr 15, 2013 13:21

ciao!
ci provo...sperando sia per te corretto:
Codice: Seleziona tutto
$ alsamixer

ti aggiusti i tuoi settaggi, poi
Codice: Seleziona tutto
su -

poi da invio/enter e poi
Codice: Seleziona tutto
# alsactl store
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: Salvataggio settaggi alsamixer

Messaggioda rik70 » lun apr 15, 2013 19:11

Se il problema si presenta ad ogni riavvio, prova ad aggiungere (da root) anche:

Codice: Seleziona tutto
chmod -v +x /etc/rc.d/rc.alsa
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1206
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Salvataggio settaggi alsamixer

Messaggioda yAri » mar apr 16, 2013 14:51

Nulla non li salva... Magari dovrei aggiustare il tutto nel file rc.alsa?
Questo problema con la 13.37 non si presentava.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Salvataggio settaggi alsamixer

Messaggioda targzeta » mar apr 16, 2013 18:24

Come fai a sapere che non li salva? Hai controllato il file /var/lib/alsa/asound.state ?

Se lanci "alsactl store" da root i settaggi sono salvati lì.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6166
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Salvataggio settaggi alsamixer

Messaggioda yAri » mar apr 16, 2013 19:31

Il file è presente ed è questo:
Codice: Seleziona tutto
state.Intel {
   control.1 {
      iface MIXER
      name 'Headphone Playback Volume'
      value.0 64
      value.1 64
      comment {
         access 'read write'
         type INTEGER
         count 2
         range '0 - 64'
         dbmin -6400
         dbmax 0
         dbvalue.0 0
         dbvalue.1 0
      }
   }
   control.2 {
      iface MIXER
      name 'Headphone Playback Switch'
      value.0 true
      value.1 true
      comment {
         access 'read write'
         type BOOLEAN
         count 2
      }
   }
   control.3 {
      iface MIXER
      name 'Speaker Playback Volume'
      value.0 64
      value.1 64
      comment {
         access 'read write'
         type INTEGER
         count 2
         range '0 - 64'
         dbmin -6400
         dbmax 0
         dbvalue.0 0
         dbvalue.1 0
      }
   }
   control.4 {
      iface MIXER
      name 'Speaker Playback Switch'
      value.0 true
      value.1 true
      comment {
         access 'read write'
         type BOOLEAN
         count 2
      }
   }
   control.5 {
      iface MIXER
      name 'Mic Playback Volume'
      value.0 21
      value.1 21
      comment {
         access 'read write'
         type INTEGER
         count 2
         range '0 - 31'
         dbmin -3450
         dbmax 1200
         dbvalue.0 -300
         dbvalue.1 -300
      }
   }
   control.6 {
      iface MIXER
      name 'Mic Playback Switch'
      value.0 false
      value.1 false
      comment {
         access 'read write'
         type BOOLEAN
         count 2
      }
   }
   control.7 {
      iface MIXER
      name 'Auto-Mute Mode'
      value Enabled
      comment {
         access 'read write'
         type ENUMERATED
         count 1
         item.0 Disabled
         item.1 Enabled
      }
   }
   control.8 {
      iface MIXER
      name 'Mic Boost Volume'
      value.0 2
      value.1 2
      comment {
         access 'read write'
         type INTEGER
         count 2
         range '0 - 3'
         dbmin 0
         dbmax 3000
         dbvalue.0 2000
         dbvalue.1 2000
      }
   }
   control.9 {
      iface MIXER
      name 'Capture Switch'
      value.0 true
      value.1 true
      comment {
         access 'read write'
         type BOOLEAN
         count 2
      }
   }
   control.10 {
      iface MIXER
      name 'Capture Volume'
      value.0 23
      value.1 23
      comment {
         access 'read write'
         type INTEGER
         count 2
         range '0 - 31'
         dbmin -1650
         dbmax 3000
         dbvalue.0 1800
         dbvalue.1 1800
      }
   }
   control.11 {
      iface MIXER
      name 'Master Playback Volume'
      value 64
      comment {
         access 'read write'
         type INTEGER
         count 1
         range '0 - 64'
         dbmin -6400
         dbmax 0
         dbvalue.0 0
      }
   }
   control.12 {
      iface MIXER
      name 'Master Playback Switch'
      value true
      comment {
         access 'read write'
         type BOOLEAN
         count 1
      }
   }
   control.13 {
      iface MIXER
      name 'PCM Playback Volume'
      value.0 255
      value.1 255
      comment {
         access 'read write user'
         type INTEGER
         count 2
         range '0 - 255'
         tlv '0000000100000008ffffec1400000014'
         dbmin -5100
         dbmax 0
         dbvalue.0 0
         dbvalue.1 0
      }
   }
   control.14 {
      iface MIXER
      name 'Digital Capture Volume'
      value.0 90
      value.1 90
      comment {
         access 'read write user'
         type INTEGER
         count 2
         range '0 - 120'
         tlv '0000000100000008fffff44800000032'
         dbmin -3000
         dbmax 3000
         dbvalue.0 1500
         dbvalue.1 1500
      }
   }
}


Dicevo che non li salvava perchè al riavvio mi trovo il volume del microfono abassato, quindi dovrei ogni volta alzarlo da alsamixer e mi sembra una scocciatura.

rik70 ha scritto:Se il problema si presenta ad ogni riavvio, prova ad aggiungere (da root) anche:

Codice: Seleziona tutto
chmod -v +x /etc/rc.d/rc.alsa

Questo file ora è eseguibile ma il problema persiste.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Salvataggio settaggi alsamixer

Messaggioda targzeta » mar apr 16, 2013 21:43

Fai questi test:
  • setta il mixer con alsamixer
  • esegui come root
    Codice: Seleziona tutto
    alsactl store
  • postaci l'output di
    Codice: Seleziona tutto
    ls -l /var/lib/alsa/asound.state
  • postaci l'output di
    Codice: Seleziona tutto
    /etc/rc.d/rc.alsa
  • ricontrolla il mixer e vedi se è rimasto come l'avevi modificato al primo passo.
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6166
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Salvataggio settaggi alsamixer

Messaggioda yAri » mar apr 16, 2013 23:44

Ho settato il mixer, premuto esc.
eseguito come root
Codice: Seleziona tutto
alsactl store


output 1:
Codice: Seleziona tutto
root@packardbell:~# ls -l /var/lib/alsa/asound.state
-rw-r--r-- 1 root root 2885 Apr 17 00:29 /var/lib/alsa/asound.state

output 2:
Codice: Seleziona tutto
root@packardbell:~# /etc/rc.d/rc.alsa
Loading ALSA mixer settings:  /usr/sbin/alsactl restore


I settaggi sono rimasti come li ho messi io.
Ma al riavvio cambiano. La cosa strana (l'ho notata ora) è che dopo il riavvio i valori di master, headphone, speaker, pcm e mic vengono salvati come li ho settati io, ma cambiano quelli del capture, cioè: Mic Boost, Capture, Digital. Di conseguenza per far funzionare il microfono mi servono..
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Salvataggio settaggi alsamixer

Messaggioda boh » mer apr 17, 2013 15:47

Una volta impostato il tutto con alsactl store, visto che usi KDE prova ad aprire kmix e lasciarlo aperto nella tray bar.
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 949
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.10.17
Desktop: KDE 4.10.5

Re: Salvataggio settaggi alsamixer

Messaggioda yAri » mer apr 17, 2013 19:41

Allora, ho provato ad aprire kmix da root ma non so per quale motivo non lo apriva. A questo punto mi sono loggato con un utente diverso da root e con
Codice: Seleziona tutto
su -
ho preso root, ho aggiustato i settaggi con alsamixer, ho dato
Codice: Seleziona tutto
alsactl store
e ho aperto kmix. Per verificare che i salvataggi si mantengono, ho riavviato. Dopo il riavvio mi sono loggato con l'utente sempre diverso da root ed ha funzionato. Tutti i settaggi sono rimasti così come li ho messi io.
Problema:
Quando sono entrato nella kde con root, si sono resettati quelli del microfono che dicevo prima. E kmix da root non si avvia.
Idee?
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Salvataggio settaggi alsamixer

Messaggioda targzeta » mer apr 17, 2013 19:52

Ma perché usi l'utente root? Da terminale kmix che ti dice?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6166
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Salvataggio settaggi alsamixer

Messaggioda yAri » mer apr 17, 2013 20:12

La prima volta, quando avevo messo slackware, ho iniziato da subito usare root poichè non riuscivo a fare un paio di cose. Esempio stupido: il montaggio delle pennette usb automatico
E poi altre cose che ora non ricordo. Da quel momento ho utilizzato root..
Sono comunque poco informato mi dovrei leggere qualche guida perchè ho tempo e voglio imparare..
Comunque sembra strano che kmix da root non si avvia, c'è qualche motivo? Una cosa simile mi è capuitata con l'applicazione dell'HP.
Lanciandolo kmix da console:
Codice: Seleziona tutto
root@packardbell:~# kmix
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Salvataggio settaggi alsamixer

Messaggioda yAri » ven apr 19, 2013 18:25

Irrisolvibile?
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Salvataggio settaggi alsamixer

Messaggioda yAri » ven apr 19, 2013 19:48

Ho risolto.
Non apriva kmix perchè era aperto già.. (scusate la distrazione :oops: )
quindi:
1) setto i settaggi con alsamixer. esc
2) apro kmix
3)
Codice: Seleziona tutto
alsactl store

4) riavvio per verifcare.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE


Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti