Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] jack-audio-connection-kit e realtime scheduling

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] jack-audio-connection-kit e realtime scheduling

Messaggioda drumslack » lun mag 13, 2013 10:40

Buon inizio settimana a tutti,
sto cercando di mettere su una workstation audio con la slackware_14. Il problema è che quando metto in avvio qjackctl da user in modalità realtime fallisce l'operazione:

Codice: Seleziona tutto
11:20:33.205 Patchbay disattivato.
11:20:33.205 Resetta le statistiche.
11:20:33.207 Connessioni di ALSA cambiate.
11:20:33.224 Cambiamento nel grafico delle connessioni di ALSA.
11:22:53.830 JACK sta partendo...
11:22:53.831 /usr/bin/jackd -v -m -dfirewire -r44100 -p128 -n2
jackd 0.121.3
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
[b]JACK is running in realtime mode, but you are not allowed to use realtime scheduling.[/b]
11:22:53.838 JACK è stato avviato con PID=2856.
After applying these changes, please re-login in order for them to take effect.
You don't appear to have a sane system configuration. It is very likely that you
encounter xruns. Please apply all the above mentioned changes and start jack again!
11:22:53.846 JACK è stato fermato con stato di uscita 255.
11:22:55.876 Non sono riuscito ad avviare JACK come client. - Operazione fallita. - Impossibile connettersi al server JACK. Controlla la finestra dei messaggi per maggiori informazioni.


Sembra una questione di permessi perchè se avvio da root funziona. Ho cercato un po in giro ma non ho trovato nulla di risolutivo.
Ho compilato un kernel RT, ardour e tutte le dipendenze da slackbuild.org. Prima di avviare jack ho dato setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/qjackctl ma niente. Ho anche provato creare il file /etc/security/limits.conf con questi parametri:
@audio - rtprio 99
@realtime - memlock unlimited


Non so che altro fare per adesso. E' capitato anche a voi?
Ultima modifica di drumslack il gio mag 16, 2013 19:25, modificato 2 volte in totale.
In certi ambiti, le cose semplici sono le più facili da imparare, e spesso, è più difficile capire una cosa facile perchè rendendola tale si è dovuto complicarla.
~/ = 'sono a casa'
drumslack
Linux 1.0
Linux 1.0
 
Messaggi: 37
Iscritto il: sab mag 05, 2012 1:03
Località: San Bonifacio (VR)
Nome Cognome: Gianluca Pernigotto
Slackware: 13.37 32/64bit
Kernel: 2.6.37.6-smp
Desktop: Kde
Distribuzione: Debian

Re: jack-audio-connection-kit e realtime scheduling

Messaggioda Procopio » lun mag 13, 2013 11:46

prova a settare i fotogrammi/periodo a 1024 o superiori, ho paura che sia un problema di overrun...quello ti alzerà la latenza, ma per abbassarli devi smanettare sui parametri di jack, gli accorgimenti che puoi fare sul kernel non sono molti, ma sono importanti, ma per quello bisognerebbe aprire un therad apposta...;)

Tempo fa avevo provato a configurare una workstation su linux, ci avevo passato mesi e non era affidabile, anche se con una scheda audio esterna avevo abbassato la latenza a 2.9 senza overrun, non lo era (affidabile, intendo, per i live!) e mi capitava che quando cambiavo suono mi rimaneva la nota precedente e dovevo spegnere e riaccendere....non proprio l'ideale. Il mio livello di competenze era comunque medio, probabilmente avendo buone conoscenze dell'ambiente linux e di sintetizzatori si può sicuramente fare, ci sono diverse sale di registrazione che utilizzano solo software opensource, ma avranno tecnici con competenze non indifferenti.

Non conosco il tuo livello, ma se è solo medio/basso come lo era il mio, ti consiglio di partire da questa guida. é fatta per ubuntu, ma almeno inizi a far funzionare lì il software in modo automatizzato, poi quando ti sarai bene impratichito configuri su slackware solo le cose che ti interessano. Mi sento di darti questo consiglio proprio perchè ci ho perso molto tempo sopra, e comunque non è ancora vastissima la comunity di musicisti qua su slackware, ma anche in generale su unix...Fai sapere!!:)
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: jack-audio-connection-kit e realtime scheduling

Messaggioda drumslack » lun mag 13, 2013 12:51

@Procopio Grazie per l'intervento.
Adesso sono riuscito a far partire jack e ardour. Dovevo soltanto cambiare il nome del binario nel parametro da :
setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/qjackctl
a :
setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/jackd

Sto facendo funzionare una scheda audio firewire presonus firepod 10/10, uso una latenza 5.8 ms. per adesso sembra andare.

Tempo fa avevo provato a configurare una workstation su linux, ci avevo passato mesi e non era affidabile, anche se con una scheda audio esterna avevo abbassato la latenza a 2.9 senza overrun, non lo era (affidabile, intendo, per i live!) e mi capitava che quando cambiavo suono mi rimaneva la nota precedente e dovevo spegnere e riaccendere....

...Quello capitava anche con windows quando usavo cubase/nuendo con i vst e reason
Non uso sintetizzatori per il momento su linux ma lo farò prossimamente, quello che mi interessa ora è la registrazione multitraccia professionale di strumenti come la batteria su ardour.

Ora faccio i test poi posterò ancora se no metto risolto.
In certi ambiti, le cose semplici sono le più facili da imparare, e spesso, è più difficile capire una cosa facile perchè rendendola tale si è dovuto complicarla.
~/ = 'sono a casa'
drumslack
Linux 1.0
Linux 1.0
 
Messaggi: 37
Iscritto il: sab mag 05, 2012 1:03
Località: San Bonifacio (VR)
Nome Cognome: Gianluca Pernigotto
Slackware: 13.37 32/64bit
Kernel: 2.6.37.6-smp
Desktop: Kde
Distribuzione: Debian

Re: jack-audio-connection-kit e realtime scheduling

Messaggioda rik70 » mar mag 14, 2013 9:21

Se può interessare, io utilizzo set_rlimits con jackd, Ardour e compagnia cantante.

Non so le differenze rispetto a setcap, ma funziona.

La configurazione è simile al file /etc/security/linits.conf di PAM: puoi operare a livello utente o gruppo. Si può impostare nice, rtprio e memlock. Lo "svantaggio" è che ogni eseguibile deve essere lanciato facendo precedere set_rlimits. Ad es per jackd:
Codice: Seleziona tutto
/usr/bin/set_rlimits /usr/bin/jackd -R -P70 -t5000 -dalsa -dhw:0 -r96000 -p128 -n2 -s


Con una creative audigy riuscivo - prima che mi morisse tra le mani - a ottenere 1.3ms di latenza, valore + che buono per registrare/suonare in "tempo reale".

Kernel: vanilla + patch C. Kolivas. Ma forse è + indicato un kernel RT (non so, ma col -ck non ho mai avuto problemi).

Lascio però la parola ai + esperti.

Comunque se vuoi sperimentare set_rlimits, trovi tutto su SlackBuilds.org

Ciao
Ultima modifica di rik70 il mar mag 14, 2013 14:18, modificato 1 volta in totale.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 945
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: jack-audio-connection-kit e realtime scheduling

Messaggioda drumslack » mar mag 14, 2013 11:47

@rik70 molte grazie,
sono informazioni preziose, infatti con setcap non riesco a impostare il limite della memoria e quando avvio ardour mi esce sempre il messaggio relativo. Riesco a impostare solo quello relativo alla priorità in tempo reale. Ora provo con set_rlimits di Sbo.

Ma dove si trova la patch C.kolivas ? è applicabile ai nuovi kernel ?

Un'altra domanda: come avete impostato ACPI nella compilazione del kernel-RT, perchè per applicazioni audio in realtime viene consigliato di impostarlo diversamente per ottenere più performance, tipo impostare su governor etc.
In certi ambiti, le cose semplici sono le più facili da imparare, e spesso, è più difficile capire una cosa facile perchè rendendola tale si è dovuto complicarla.
~/ = 'sono a casa'
drumslack
Linux 1.0
Linux 1.0
 
Messaggi: 37
Iscritto il: sab mag 05, 2012 1:03
Località: San Bonifacio (VR)
Nome Cognome: Gianluca Pernigotto
Slackware: 13.37 32/64bit
Kernel: 2.6.37.6-smp
Desktop: Kde
Distribuzione: Debian

Re: jack-audio-connection-kit e realtime scheduling

Messaggioda rik70 » mar mag 14, 2013 14:16

Le patch -ck le trovi qui:
http://ck-hack.blogspot.it/

Sì, solitamente vengono rilasciate per tutti i kernel, anche gli ultimi.

Se decidi di provarlo, ricordati d'impostare Preemption Model ──> Preemptible Kernel (Low-Latency Desktop) e Timer frequency (1000 HZ). Non ricordo se di default è già impostato così.

Comqe anche il kernel RT è una buona scelta: anzi, teoricamente dovrebbe andare meglio.

Su RT e ACPI però non so risponderti.

Ciao.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 945
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: jack-audio-connection-kit e realtime scheduling

Messaggioda ponce » mar mag 14, 2013 14:27

in realta' anche il kernel di default (3.2.x) dovrebbe gia' andare bene per la latenza (le patch -rt non sono indispensabili): dai un'occhiata a questa pagina (su slackermedia, sito di riferimento per chi produce audio con slackware)

http://slackermedia.info/html/kernel.html

l'errore sul limite della memoria di ardour l'ho sempre ignorato (senza problemi apparenti).
Avatar utente
ponce
Linux 3.x
Linux 3.x
 
Messaggi: 1409
Iscritto il: mer mar 05, 2008 16:45
Località: limbo
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.14
Desktop: lxde

Messaggioda drumslack » mar mag 14, 2013 15:42

@rik70

Grazie ancora, ho installato set_rlimits e ho configurato il file impostando il gruppo audio:
Codice: Seleziona tutto
 @audio  /usr/bin/jackd  nice=-1  rtprio=80  memlock=1048576

poi ho rimosso i parametri precedenti che avevo dato a setcap.
Si sembra funzionare anche così.

@ponce

Bene , ancora meglio, grazie per il link alla pagina che sto leggendo ora; provo usare il kernel generic a questo punto. :-k

EDIT: sto usando il kernel generic con una latenza di 2.9 ms come riportato da ardour, ho avviato jack così:
Codice: Seleziona tutto
/usr/bin/set_rlimits /usr/bin/jackd -r -P70 -t5000 -dfirewire -r44100 -p128 -n2


Ma per fermare jack dal terminale non c'è un modo più elegante senza fare Ctrl+c ? nella pagina man non ho trovato un comando di stop..
In certi ambiti, le cose semplici sono le più facili da imparare, e spesso, è più difficile capire una cosa facile perchè rendendola tale si è dovuto complicarla.
~/ = 'sono a casa'
drumslack
Linux 1.0
Linux 1.0
 
Messaggi: 37
Iscritto il: sab mag 05, 2012 1:03
Località: San Bonifacio (VR)
Nome Cognome: Gianluca Pernigotto
Slackware: 13.37 32/64bit
Kernel: 2.6.37.6-smp
Desktop: Kde
Distribuzione: Debian

Re: jack-audio-connection-kit e realtime scheduling

Messaggioda rik70 » mar mag 14, 2013 17:29

@drumslack

Io utilizzo un semplice script bash per lanciare jack+Ardour2 (scheda audio: SB PCI 128). Eccolo:
Codice: Seleziona tutto
#!/bin/bash
if [ ! `/sbin/pidof -s jackd 2>/dev/null` ]; then
 set_rlimits /usr/bin/jackd -t 3000 \
  -R -P 20 -d alsa -r 48000 -p 128 -s > /dev/null 2>&1 &
fi

sleep 2

set_rlimits /usr/bin/ardour2 > /dev/null 2>&1

sleep 2

killall jackd

In pratica, prima controlla sche jackd non sia in esecuzione e nel caso lo avvia. Poi parte Ardour e quando lo chiudi viene "killato" jackd.
Quegli "sleep" forse non servono, e il tutto è sicuramente migliorabile: modificate, copiate etc. E' giusto un' idea. Sennò puoi usare qjackctl per avviare e fermare jackd: anche questo lo trovi su SlackBuilds o qui sui repo slacky.eu.

P.s.
Se la tua scheda supporta i 48000Hz, prova a cambiare -r 44100 con -r 48000: la latenza si abbassa ulterirmente.

@ponce
grazie per la dritta. In effetti io usavo per il rt un vecchio kernel 2.6.35.xx: non ho provato a "suonarci", ma col 3.7.5 sembra che non ci sia bisogno nemmeno delle patch -ck.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 945
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: jack-audio-connection-kit e realtime scheduling

Messaggioda drumslack » mar mag 14, 2013 20:59

@rik70

grazie, ancora troppo gentile, anche questo mi tornerà utile.

Aggiorno dicendo che con il kernel generic avevo impostato una latenza di 2.9 ms ma le registrazioni avevano degli 'xrun' (interruzioni audio) anche alzandola a 5,8 ms. Oggi stesso ho compilato un nuovo kernel 3.4.45 che ho configurato come low-latency ma senza patch RT.
Codice: Seleziona tutto
$ uname -a
Linux darkstar 3.4.45-smp #1 SMP PREEMPT Tue May 14 19:33:24 CEST 2013 i686 Intel(R) Core(TM)2 Quad CPU    Q9550  @ 2.83GHz GenuineIntel GNU/Linux

$ fgrep CONFIG_PREEMPT /boot/config-generic-smp-3.4.45-smp
CONFIG_PREEMPT_RCU=y
CONFIG_PREEMPT_NOTIFIERS=y
# CONFIG_PREEMPT_NONE is not set
# CONFIG_PREEMPT_VOLUNTARY is not set
CONFIG_PREEMPT=y
CONFIG_PREEMPT_COUNT=y
# CONFIG_PREEMPT_TRACER is not set

$ fgrep CONFIG_HZ /boot/config-generic-smp-3.4.45-smp 
# CONFIG_HZ_100 is not set
# CONFIG_HZ_250 is not set
# CONFIG_HZ_300 is not set
CONFIG_HZ_1000=y
CONFIG_HZ=1000

Gli xrun non ci sono ma ho una perplessità: devo sempre avviare jack in real-time (-R) o posso fare a meno con questo kernel low-latency per avere una bassa latenza ?
In certi ambiti, le cose semplici sono le più facili da imparare, e spesso, è più difficile capire una cosa facile perchè rendendola tale si è dovuto complicarla.
~/ = 'sono a casa'
drumslack
Linux 1.0
Linux 1.0
 
Messaggi: 37
Iscritto il: sab mag 05, 2012 1:03
Località: San Bonifacio (VR)
Nome Cognome: Gianluca Pernigotto
Slackware: 13.37 32/64bit
Kernel: 2.6.37.6-smp
Desktop: Kde
Distribuzione: Debian

Re: jack-audio-connection-kit e realtime scheduling

Messaggioda rik70 » mer mag 15, 2013 9:38

drumslack ha scritto:devo sempre avviare jack in real-time (-R) o posso fare a meno con questo kernel low-latency per avere una bassa latenza ?


Diciamo che se usi jack non in real-time, non hai bisogno di un kernel low-latency. Che poi è un modo diverso per dire: sì, per avere una bassa latenza jack va lanciato in real-time.

Ciao
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 945
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: jack-audio-connection-kit e realtime scheduling

Messaggioda drumslack » mer mag 15, 2013 21:31

Traggo le conclusioni in base a ciò che ho sperimentato in questi giorni per confermare che:

1) Kernel RT (compilato con patch RT in fully-preemption)
Per usarlo in realtime su slackware è necessario un setting a livello di priorità
processi e di permessi con "setcap" oppure "set_rlimits". Sui sistemi che usano pam
è senz'altro più comodo ma volendo può essere installato anche su slackware.
La latenza ottenibile con le dovute impostazioni è molto bassa, vicina allo zero, che per
applicazioni audio trovo esagerate se non inutili, del resto la latenza più bassa ottenibile
con i driver della scheda installati su windows non scende sotto i 2.5 ms, soglia che non avevo mai
sfiorato, rimanendo piuttosto su valori di 5 o 6 ms del tutto trascurabili, questo solo come
mera considerazione perchè qui siamo su linux.

2) Kernel generic (Voluntary Kernel Preemption (Desktop))
Con il kernel di default (ovviamente non in realtime) nessun crash di jack ma mi sono
imbattuto in frequenti xrun anche con latenze di 8 o 12 ms, a 20 ms nessun xrun; soglie
più basse di latenza sono impensabili qui.

3) Kernel low-latency (compilato con Preemptible Kernel (Low-Latency Desktop))
In questa configurazione ho avuto più problemi con l'uso del realtime attivo
(xrun, crash frequenti di jack anche a latenze medie 3/7 ms). Provando poi a disattivare
il realtime da qjackctl ho notato una certa stabilità generale e nessun crash pur rimanendo
su valori di latenza di 4/6 ms (con 2.7 ms c'è qualche xrun ma non crasha) e con frequenza
di campionamento a 48000 Hz. Non ho provato a salire di frequenza perché non uso frequenze
spinte anche se la capacità della scheda arriva a 96000 Hz. Questi valori sono più che sufficienti
per applicazioni audio che richiedono il monitoraggio in cuffia in tempo reale (o quasi) e di ciò
che si sta suonando per esempio con uno strumento virtuale o non.
Sfido chiunque a sentire differenze di latenza per qualche ms.

Personalmente ho scelto di usare un kernel compilato con low-latency e con l'opzione realtime di jack o qjackctl disattivata.

@rik70

Diciamo che se usi jack non in real-time, non hai bisogno di un kernel low-latency. Che poi è un modo diverso per dire: sì, per avere una bassa latenza jack va lanciato in real-time.


Questa tesi non è vera perchè altrimenti non ci sarebbero state differenze, con realtime disabilitato su jack, tra un kernel generic e uno compilato con low-latency. [-X ;)

Spero di essere stato utile. :thumbright:

Ciao. :D
In certi ambiti, le cose semplici sono le più facili da imparare, e spesso, è più difficile capire una cosa facile perchè rendendola tale si è dovuto complicarla.
~/ = 'sono a casa'
drumslack
Linux 1.0
Linux 1.0
 
Messaggi: 37
Iscritto il: sab mag 05, 2012 1:03
Località: San Bonifacio (VR)
Nome Cognome: Gianluca Pernigotto
Slackware: 13.37 32/64bit
Kernel: 2.6.37.6-smp
Desktop: Kde
Distribuzione: Debian

Re: jack-audio-connection-kit e realtime scheduling

Messaggioda rik70 » gio mag 16, 2013 8:34

drumslack ha scritto:
@rik70

Diciamo che se usi jack non in real-time, non hai bisogno di un kernel low-latency. Che poi è un modo diverso per dire: sì, per avere una bassa latenza jack va lanciato in real-time.


Questa tesi non è vera perchè altrimenti non ci sarebbero state differenze, con realtime disabilitato su jack, tra un kernel generic e uno compilato con low-latency. [-X ;)

Ciao. :D


Uhm... non sono d'accordo, o mi sono "capito" male: compilare un kernel low-latency o rt, per poi usare jackd non in real-time, è una perdita tempo. Ovviamente secondo il mio modesto e irrilevante parere. Che poi ci siano delle differenze tra un kernel e l'altro questo è un altro paio di maniche.

Per quanto rigurada le latenze, dipende da cosa/come suoni|fai: 5.3 ms sono troppi se hai tra le mani una chitarra elettrica ad esempio. Fai un bending o un vibrato e hai la "sensazione" di arrivare sempre fuori tempo di un soffio.
Se poi registri "sopra" una traccia in riproduzione, il "difetto" è ancora più evidente. Gli xrun poi vanno evitati come la peste se stai registrando.

Poi non lo so, ognuono ha il suo orecchio.

Comunque grazie per il report 8)

Ciao
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 945
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re:[RISOLTO] jack-audio-connection-kit e realtime scheduling

Messaggioda drumslack » gio mag 16, 2013 17:10

Si, confermo che la latenza è molto ridotta con un kernel low-latency rispetto al generic, anche senza impostare realtime da jack.
Tuttavia senza un setting della priorità del processo realtime (rtprio) con set_rlimits, ardour potrebbe generare interruzzioni o xrun
in particolare con latenze molto basse.

Leggendo il sito linkato da @ponce ho risolto impostando set_rlimits così:
Codice: Seleziona tutto
drumslack  /usr/bin/jackd  nice=-1  rtprio=80  memlock=100000
drumslack  /usr/bin/ardour2  nice=-1  rtprio=80  memlock=100000
drumslack  /usr/bin/qjackctl  nice=-1  rtprio=80  memlock=100000


usando poi qjackctl e ardour, ho dovuto aggiungere ai lanciatori:
Codice: Seleziona tutto
set_rlimits /usr/bin/qjackctl
set_rlimits /usr/bin/ardour2


In questa modo funziona senza errori, tranne che per l'avviso sul limite della memoria di ardour, ma che vado ignorando
come ha riportato @ponce.

@rik70

Comunque grazie per il report 8)

Ciao


Grazie a te, mi sei stato veramente di aiuto ! questo dimostra che i confronti non sono mai inutili.

Ciao.
In certi ambiti, le cose semplici sono le più facili da imparare, e spesso, è più difficile capire una cosa facile perchè rendendola tale si è dovuto complicarla.
~/ = 'sono a casa'
drumslack
Linux 1.0
Linux 1.0
 
Messaggi: 37
Iscritto il: sab mag 05, 2012 1:03
Località: San Bonifacio (VR)
Nome Cognome: Gianluca Pernigotto
Slackware: 13.37 32/64bit
Kernel: 2.6.37.6-smp
Desktop: Kde
Distribuzione: Debian

Re: jack-audio-connection-kit e realtime scheduling

Messaggioda rik70 » gio mag 16, 2013 18:27

drumslack ha scritto:In questa modo funziona senza errori, tranne che per l'avviso sul limite della memoria di ardour, ma che vado ignorando
come ha riportato @ponce.


E fate bene ad ignorarlo: quel WARNING è dovuto a questa parte di codice dello script che lancia ardour:
Codice: Seleziona tutto

MLOCK_LIMIT=$(ulimit -l)
if [ "$MLOCK_LIMIT" != "unlimited" ]; then
        echo "WARNING: Your system has a limit for maximum amount of locked memory!"
        echo "         This might cause Ardour to run out of memory before your system runs"
        echo "         out of memory. You can view the memory limit with 'ulimit -l', and it"
        echo "         is normally controlled by /etc/security/limits.conf"
        echo ""

fi


Forse un giorno capiremo perché non "si fida di noi" e vuole tutta la memoria bloccata :)

Vabbè, no problem.

Ciao.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 945
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti