Repository 32bit  Forum
Repository 64bit  Wiki

configurare il sistema per l'uso di una cuffia bluetooth

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

configurare il sistema per l'uso di una cuffia bluetooth

Messaggioda F4B1CK » mar mag 21, 2013 0:48

Ciao a tutti,
premetto che il mio sistema è una current, aggiornata a kde 4.10.3 e bluez 4.99.
Ho appena acquistato una cuffia bluetooth (una Flyte della Manhattan) per poter ascoltare i film al volume che desidero senza disturbare i vicini :p
Purtroppo non ho capito come configurare il sistema per fargli usare la cuffia come uscita audio quando la connetto.
Il pairing della cuffia funziona perfettamente ma qualsiasi cosa mandi in play viene riprodotta tramite le casse. La cuffia funziona perché l'ho testata con lo smartphone, però non ho capito come settarla sotto linux.
Ho pensato che dovrei fare qualche modifica al file /etc/bluetooth/audio.conf, che attualmente è così :

Codice: Seleziona tutto
# Configuration file for the audio service                                                                                                                                               

# This section contains options which are not specific to any                                                                                                                             
# particular interface                                                                                                                                                                   
[General]                                                                                                                                                                                 

# Enable the audio socket                                                                                                                                                                 
Enable=Sink,Source,Gateway                                                                                                                                                               

# Switch to master role for incoming connections (defaults to true)                                                                                                                       
#Master=true                                                                                                                                                                             

# If we want to disable support for specific services                                                                                                                                     
# Defaults to supporting all implemented services                                                                                                                                         
#Disable=Control,Source                                                                                                                                                                   

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)                                                                                                             
# Defaults to HCI                                                                                                                                                                         
#SCORouting=PCM                                                                                                                                                                           

# Automatically connect both A2DP and HFP/HSP profiles for incoming                                                                                                                       
# connections. Some headsets that support both profiles will only connect the                                                                                                             
# other one automatically so the default setting of true is usually a good
# idea.
#AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=1

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incomming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=false

# Just an example of potential config options for the other interfaces
#[A2DP]
#SBCSources=1
#MPEG12Sources=0


ma non so cosa toccare (sono un pò a digiuno su tale argomento).

Qualcuno di voi ha qualche consiglio per la configurazione?

Grazie a tutti in anticipo per le risposte!!
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: configurare il sistema per l'uso di una cuffia bluetooth

Messaggioda F4B1CK » gio mag 23, 2013 22:27

Non c'è nessuno disposto a darmi una dritta?? :cry: :cry:
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: configurare il sistema per l'uso di una cuffia bluetooth

Messaggioda gigiobagiano » ven mag 24, 2013 17:47

Io ho smadonnato un po' per impostare un adattatore logitech bluetooth, ma in realtà avessi letto meglio qualche file d'esempio già presente (mi pare di ricordare /etc/alsa/bluetooth.conf) avrei risparmiato un sacco di tempo. Comunque più o meno quello che devi inserire è questo in /etc/asound.conf

Codice: Seleziona tutto
pcm.cuffiebluetooth {
   type plug
   slave {
       pcm {
           type bluetooth
           device XX:XX:XX:XX:XX:XX
           profile "auto"
       }   
   }   
   hint {
       show on
       description "cuffie bluetooth"
   }   
}
ctl.cuffiebluetooth {
  type bluetooth


nota che cuffiebluetooth è un nome scelto da me per le cuffie (originalissimo), puoi mettere ciò che vuoi...
Avatar utente
gigiobagiano
Linux 2.6
Linux 2.6
 
Messaggi: 504
Iscritto il: dom mar 11, 2007 12:58
Slackware: 11 - 13.1
Kernel: 2.6.35.6_tuxonice
Desktop: Openbox

Re: configurare il sistema per l'uso di una cuffia bluetooth

Messaggioda F4B1CK » sab mag 25, 2013 0:27

Ho editato il file asound.conf (che tra l'latro nella mia /etc/ non esisteva, quindi l'ho creato ex-novo), riavviato il servizio, le cuffie si sono regolarmente appaiate ma nulla...l'audio continua ad uscire dalle casse e non arriva alle cuffie :-(
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: configurare il sistema per l'uso di una cuffia bluetooth

Messaggioda gigiobagiano » sab mag 25, 2013 10:02

In audacious o qualunque altro programma di musica dovrai scegliere nelle preferenze l'uscita che non sarà più la tua scheda audio ma "cuffie bluetooth" o come hai deciso di chiamare le cuffie.
Avatar utente
gigiobagiano
Linux 2.6
Linux 2.6
 
Messaggi: 504
Iscritto il: dom mar 11, 2007 12:58
Slackware: 11 - 13.1
Kernel: 2.6.35.6_tuxonice
Desktop: Openbox

Re: configurare il sistema per l'uso di una cuffia bluetooth

Messaggioda F4B1CK » lun mag 27, 2013 20:35

Ma se io volessi dirottare tutto l'audio del sistema verso le cuffie? Ad esempio, sotto Amarok non sono riuscito a capire come dirgli di mandare l'audio alle cuffie (mentre sotto audacious esiste, come suggerito da gigiobagiano, la possibilità di dire su quale periferica inviare il flusso audio). Altro esempio: ascolto spesso la radio in streaming da siti web...come faccio a dire al player integrato nell'interfaccia (che spesso usa flash o, peggio, moonlight) di inviare l'audio alle cuffie?
Mi servirebbe più qualcosa come uno switch (anche uno script da console) che avvio e dirotta tutti i flussi radio verso le cuffie.
Se poteste suggerirmi qualcosa ve ne sarei grato.
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: configurare il sistema per l'uso di una cuffia bluetooth

Messaggioda gigiobagiano » mar mag 28, 2013 11:54

Con flash player non ho idea, però per renderla l'uscita predefinita dovresti dire quale uscita usare di default ad alsa sempre tramite asound.conf. Questo potrebbe darti una mano...
Avatar utente
gigiobagiano
Linux 2.6
Linux 2.6
 
Messaggi: 504
Iscritto il: dom mar 11, 2007 12:58
Slackware: 11 - 13.1
Kernel: 2.6.35.6_tuxonice
Desktop: Openbox

Re: configurare il sistema per l'uso di una cuffia bluetooth

Messaggioda F4B1CK » mar mag 28, 2013 23:41

Per tenere aggiornato il forum (magari qualcuno potrebbe incorrere nella mia stessa esigenza), aggiungo un piccolo passo fatto nella configurazione delle cuffie.

Per prima cosa ho aggiunto l'headset bluetooth alle periferiche audio disponibili, tramite questo file .asoundrc creato nella mia /home:

pcm.bluetooth {
type bluetooth
device XX:XX:XX:XX:XX:XX
}

ctl.bluetooth {
type bluetooth
}


Leggendo i link suggeritimi dagli altri utenti, ho modificato il file /etc/bluetooth/audio.conf così :

Codice: Seleziona tutto
# Configuration file for the audio service                                                                                                                                               

# This section contains options which are not specific to any                                                                                                                             
# particular interface                                                                                                                                                                   
[General]                                                                                                                                                                                 
Enable=Source,Sink,Headset,Gateway,Control,Socket,Media                                                                                                                                   

# Enable the audio socket                                                                                                                                                                 
#Enable=Sink,Source,Gateway                                                                                                                                                               

# Switch to master role for incoming connections (defaults to true)                                                                                                                       
Master=true                                                                                                                                                                               

# If we want to disable support for specific services                                                                                                                                     
# Defaults to supporting all implemented services                                                                                                                                         
#Disable=Control,Source                                                                                                                                                                   

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)                                                                                                             
# Defaults to HCI                                                                                                                                                                         
SCORouting=PCM                                                                                                                                                                           

# Automatically connect both A2DP and HFP/HSP profiles for incoming                                                                                                                       
# connections. Some headsets that support both profiles will only connect the                                                                                                             
# other one automatically so the default setting of true is usually a good
# idea.
AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=1

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incomming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=false

# Just an example of potential config options for the other interfaces
#[A2DP]
#SBCSources=1
#MPEG12Sources=0


e adesso, una volta eseguito il pairing con le cuffie posso mandare uno streaming audio, ad esempio :

aplay -D cuffiebluetooth Bugle.wav

Il prossimo passo sarà testare se posso far diventare in maniera automatica le cuffie il Master PCM di default, oppure se posso dire al sistema di usare entrambe le uscite audio, quando connesse (tanto a quel punto mi basterebbe spegnere le casse).

Ho visto qualcosa a riguardo nel wiki di alsa, ma dovrò smanettarci un pò appena ho tempo.

Se qualcuno avesse qualche soluzione da propormi, gliene sarei grato. :D
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: configurare il sistema per l'uso di una cuffia bluetooth

Messaggioda lennynero » sab giu 01, 2013 21:21

gigiobagiano ha scritto:
Codice: Seleziona tutto
pcm.cuffiebluetooth {
   type plug
   slave {
       pcm {
           type bluetooth
           device XX:XX:XX:XX:XX:XX
           profile "auto"
       }   
   }   
   hint {
       show on
       description "cuffie bluetooth"
   }   
}


Io con questa configurazione sono riuscito a rendere visibile la periferica BT al sistema, poi dopo diversi esperimenti/ricerche un pò a vuoto sono sono anche riuscito a renderla default aggiungendo nel medesimo file(~/.asoundrc) il codice in calce:

Codice: Seleziona tutto
pcm.!default {
        type plug
        slave.pcm "cuffiebluetooth"
}


Per utilizzare le cuffie e fargli fare il pairing automatico quando le accendo ho utiizzato la GUI "Blueman Device Manager": dopo il searching e il pairing facendo il trust diventano autoaccoppiabili, spero che funzioni anche a te;)

p.s. segnalo un MIO thread (http://www.slacky.eu/forum/viewtopic.php?f=1&t=36661) nel quale ponevo la questione...e suggerivo la mia soluzione.
Avatar utente
lennynero
Linux 2.6
Linux 2.6
 
Messaggi: 567
Iscritto il: dom mag 02, 2004 23:00
Località: Salerno
Slackware: 14.1-x64
Kernel: 3.10.17
Desktop: xfce-4.10


Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 5 ospiti