[RISOLTO]Firefox e caratteri rotti

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
Messaggi: 567
Iscritto il: mar apr 21, 2009 17:25
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox
Località: Palermo
Contatta:

[RISOLTO]Firefox e caratteri rotti

Messaggioda RedSkull92 » mer mag 22, 2013 2:54

Ho appena aggiornato la mia -current 64bit
Ma andando su github.com mi dà questo bel risultato: http://i.imgur.com/G7U8RvQ.jpg
Magari con questo si nota meglio, è un pdf aperto con firefox: http://i.imgur.com/J2KSOXu.jpg
ovviamente questo problema prima non c'era, da cosa può essere causato ?
Come risolvo ?
Fortunatamente non succede con tutti i siti (per ora solo su github e con i pdf), il letto di pdf epdfview invece me lo apre normalmente.
Grazie ^^
Ultima modifica di RedSkull92 il lun lug 15, 2013 22:14, modificato 3 volte in totale.

Avatar utente
slux
Linux 2.6
Linux 2.6
Messaggi: 789
Iscritto il: dom mar 20, 2005 0:00
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10
Località: Prato
Contatta:

Re: Firefox e caratteri rotti

Messaggioda slux » mer mag 22, 2013 19:43

Prova a scaricare il binario orginale dal sito di mozilla firefox e scompattalo nella tua home.Esegui firefox da quella directory e controlla.Se hai lo stesso difetto forse sono i tuoi font da ripristinare.Magari ne hai aggiunto qualcuno manualmente che ha dei problemi?
Prova anche a rigenerare la cache dei font :

Codice: Seleziona tutto

fc-cache -f

Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
Messaggi: 567
Iscritto il: mar apr 21, 2009 17:25
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox
Località: Palermo
Contatta:

Re: Firefox e caratteri rotti

Messaggioda RedSkull92 » gio mag 23, 2013 0:55

Magari sono davvero i fonts, come ripristino quelli iniziali ?
Comunque, ora avviando firefox ho notato questo messaggio
(process:18257): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

Che hanno le glib che non vanno ?

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6352
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: Firefox e caratteri rotti

Messaggioda targzeta » gio mag 23, 2013 1:11

Ma perché, quelli non sono i caratteri di github :). Allora io ho il tuo stesso problema. Pensavo fosse solo un problema relativo ai PDF perchè solo alcuni li visualizza male, ma generalmente va tutto bene.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
Messaggi: 567
Iscritto il: mar apr 21, 2009 17:25
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox
Località: Palermo
Contatta:

Re: Firefox e caratteri rotti

Messaggioda RedSkull92 » gio mag 23, 2013 1:19

Eh ma tutto questo una volta aggiornata la -current, prima non dava problemi.
E pensavo fossero i fonts dato che c'ho messo mano qualche sera prima.

Avatar utente
ponce
Master
Master
Messaggi: 1847
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.6.0-rc6
Desktop: lxde
Località: Pisa
Contatta:

Re: Firefox e caratteri rotti

Messaggioda ponce » gio mag 23, 2013 7:33

e' fontconfig-2.10.92 che ha dei problemi, basta aggiornarlo alla 2.10.93: l'ho segnalato a Pat su linuxquestions e ha detto che lo sistemera' quanto prima.

Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
Messaggi: 567
Iscritto il: mar apr 21, 2009 17:25
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox
Località: Palermo
Contatta:

Re: Firefox e caratteri rotti

Messaggioda RedSkull92 » gio mag 23, 2013 14:17

Ho aggiornato alla 2.10.93 e il problema su github e nei pdf non si verifica più, metto risolto!
Grazie ponce, utilissimo come sempre! ^^

Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
Messaggi: 567
Iscritto il: mar apr 21, 2009 17:25
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox
Località: Palermo
Contatta:

Re: [RISOLTO] Firefox e caratteri rotti

Messaggioda RedSkull92 » dom lug 14, 2013 19:57

Il problema si è ripresentato
Magari dopo l'aggiornamento alla current
Ho fatto uno screenshot
Immagine
Questa volta a cosa può essere dovuto ?
Ecco fontconfig
fontconfig-2.10.93-x86_64-1
fontconfig-compat32-2.10.93-x86_64-1compat32

Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
Messaggi: 567
Iscritto il: mar apr 21, 2009 17:25
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox
Località: Palermo
Contatta:

Re: [RISOLTO] Firefox e caratteri rotti

Messaggioda RedSkull92 » dom lug 14, 2013 20:56

Uhm, a quanto vedo mi sta capitando solo su gist (gist.github.com) qualcuno può darmi qualche feedback al riguardo?

Avatar utente
conraid
Staff
Staff
Messaggi: 12654
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: [RISOLTO] Firefox e caratteri rotti

Messaggioda conraid » lun lug 15, 2013 9:07

Io in current vedo i font bene. Anzi, meglio di prima. Qualche sito li mostra male (google+), ma penso sia dovuto al "tipo" di font usato ed a quelli installati nel sistema.
Comunque io ogni volta che viene modificato freetype le ricompilo con la patch per il supixel (è già tutto nella directory source, basta decommentare una riga) e dopo ricompilo a cascata fontconfig, libXft e cairo.
Prova, magari migliora le cose

rik70
Master
Master
Messaggi: 1686
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: 4.0.x-smp
Desktop: Xfce 4.12

Re: [RISOLTO] Firefox e caratteri rotti

Messaggioda rik70 » lun lug 15, 2013 12:28

Ciao,

ma il problema è solo con Firefox?
Con chrome/chromium cambia qualcosa?

Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
Messaggi: 567
Iscritto il: mar apr 21, 2009 17:25
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox
Località: Palermo
Contatta:

Re: [RISOLTO] Firefox e caratteri rotti

Messaggioda RedSkull92 » lun lug 15, 2013 13:24

Il problema è solo con firefox, con chromium si vedono perfettamente.
Cosa può essere?

rik70
Master
Master
Messaggi: 1686
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: 4.0.x-smp
Desktop: Xfce 4.12

Re: [RISOLTO] Firefox e caratteri rotti

Messaggioda rik70 » lun lug 15, 2013 14:12

Hai per caso una vga nvidia?

Prova a fare questo tentativo:

1 - barra degli indirizzi ----> about:config

2 - usa il campo cerca per trovare la stringa gfx.xrender.enabled: cambia il valore da true a false;

3 - riavvia Firefox e vedi se cambia qualcosa.

Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
Messaggi: 567
Iscritto il: mar apr 21, 2009 17:25
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox
Località: Palermo
Contatta:

Re: Firefox e caratteri rotti

Messaggioda RedSkull92 » lun lug 15, 2013 21:10

La scheda NVIDIA l'ho disattivata, ora sto usando la Intel.
Ho eseguito comunque il passaggio ma continuo a non vedere bene i font di gist con firefox
Cosa potrebbe essere successo?

Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
Messaggi: 567
Iscritto il: mar apr 21, 2009 17:25
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox
Località: Palermo
Contatta:

Re: Firefox e caratteri rotti

Messaggioda RedSkull92 » lun lug 15, 2013 22:14

Ora sono riandato su Gist ed e riesco a vederle, non ho effettuato altre modifiche.
Boh, magari serviva più tempo :|


Torna a “Slackware64”

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti