Repository 32bit  Forum
Repository 64bit  Wiki

Ed eccomi finalmente su Slackware!!!

Sezione per tutti i nuovi utenti del forum di Slacky.eu
Potete presentarvi e fatevi conoscere, diteci chi siete e quali sono i vostri interessi. Vi daremo un caloroso benvenuto.

Moderatore: Staff

Regole del forum
1) Niente religione, niente politica, niente offese personali.
2) Usate questo forum per tutte le discussioni che non potete trattare negli altri forum.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza dell'ultima regola porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Ed eccomi finalmente su Slackware!!!

Messaggioda aschenaz » ven ago 16, 2013 12:54

tornadomig ha scritto:occhio! 8)

...una gpu con nvidia o ati se passerai a -current ultimissimo kernel, per ora non installare con slackbuilds.org i drivers proprietari 319.32 di nvidia. usa gli ultimi beta presi dal sito nvidia. purtroppo eccetto questi, tutti gli altri non compilano col kernel 3.10.6.
...


Anche col 3.10.5 ho dovuto necessariamente installare i driver beta 325.15 (che sembrano funzionare molto bene, finora). Andranno bene anche col kernel 3.10.7?
pensieriemotivi.aschenaz.eu - music-blog
Avatar utente
aschenaz
Staff
Staff
 
Messaggi: 4435
Iscritto il: mar lug 27, 2004 23:00
Località: Reggio Calabria
Nome Cognome: Nino
Slackware: current 64bit
Kernel: 3.14.18
Desktop: KDE 4.10.5

Re: Ed eccomi finalmente su Slackware!!!

Messaggioda ZeroUno » ven ago 16, 2013 13:31

a compilare compilano.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Ed eccomi finalmente su Slackware!!!

Messaggioda tano70 » ven ago 16, 2013 16:16

ZeroUno ha scritto:slackpkg update
slackpkg upgrade-all
slackpkg install-new
slackpkg clean-system

il primo rilegge il changelog nuovo
il secondo effettua l'aggiornamento di tutti i pacchetti installati
il terzo installa i pacchetti aggiunti dalla 14.0 ad oggi
il quarto rimuove i pacchetti che sono stati eliminati da slackware 14.0 ad oggi

Sul mirror trovi informazioni importanti per l'aggiornamento
http://slackware.osuosl.org/slackware64 ... _HINTS.TXT


Dopo l'aggiornamento dei pacchetti con slackpkg, se è stato aggiornato il kernel ti propone il lancio di "lilo" per rileggere la configurazione.
Se hai fatto una installazione standard lato bootloader, allora dai Yes.

Al termine dell'aggiornamento dei pacchetti inoltre se è stato aggiornato qualche file di configurazione il vecchio non viene sovrascritto per evitare di farti perdere personalizzazioni, ma potrebbe essere necessario sovrascrivere i vecchi o fare dei merge. Da slackware 14.0 ad oggi credo che i file aggiornati siano molti.
Se un pacchetto ha una configurazione /etc/xxx.conf, l'installer crea /etc/xxx.conf.new e poi slackpkg ti chiede cosa fare; puoi sovrascriverlo o ignorarlo. La regola è che se tu non hai modificato manualmente il file (e quindi non sai cosa sia) digli 'O' di overwrite. Se invece l'hai modificato significa che sai cosa fa quel file; allora ti puoi permettere di decidere se sovarscriverlo perdendo le tue modifiche (nota; il vecchio viene salvato in xxx.old o xxx.orig) o rieditarlo a mano successivamente.

Per quanto riguarda il kernel, slackware64 ti installa due kernel, kernel-huge e kernel-generic. Poi con lilo decidi se usare l'uno o l'altro.
Se hai fatto una installazione standard allora starai usando il primo.
I due differiscono dal fatto che uno ha molti driver compilati staticamente (huge, infatti il vmlinuz risultante è bello grosso), mentre l'altro (generic) contiene un set minimale per far partire il sistema e poi tutti gli altri li carichi come moduli. Questo ha il vantaggio di essere più piccolo, ma di contro all'interno non ha il driver per il filesystem ext4 che quindi dovrai caricare con un initrd (cosa che già facevi forse senza sapere con ubuntu).
Quindi dovrai creare l'initrd con il comando mkinitrd e modificare la configurazione di lilo. (v. /boot/README.initrd)
nel 90% dei casi puoi fare così:
# mkinitrd -c -k 3.10.7 -m ext4 -f ext4 -r /dev/sda1
in cui sda1 è la tua root; ovviamente cambiala se non è quella.
poi modifica lilo.conf aggiungendo
image = /boot/vmlinuz-generic-3.10.7
root = /dev/sda1
label = generic
read-only
initrd = /boot/initrd.gz

suggerisco di lasciare anche l'altro perchè in caso fai casino con l'initrd hai l'altro con cui partire.
Poi lancia il comando 'lilo -v'
Ad ogni aggiornamento del kernel dovrai ricreare l'initrd e modificare la versione del kernel in lilo.conf e rilanciare 'lilo -v'

Finalmente sono a casa e mi appresto ad aggiornare il tutto per passare alla current. Ho ancora un dubbio sul kernel:
Se lancio quei comandi che mi hai scritto sopra, in pratica si aggiorna la distro alla currente ma il kernel mi resta quello che ho adesso di default, e cio' 3.2.29? e quindi non mi compare quel richiamo a lilo per cui dovrei digitare yes?
Oppure mi installa il kernel generic 3.10.7 e necessariamente io poi devo dare quei comandi che mi hai postato tu, cioe questi:

Codice: Seleziona tutto
# mkinitrd -c -k 3.10.7 -m ext4 -f ext4 -r /dev/sda1
in cui sda1 è la tua root; ovviamente cambiala se non è quella.
poi modifica lilo.conf aggiungendo
image = /boot/vmlinuz-generic-3.10.7
  root = /dev/sda1
  label = generic
  read-only
  initrd = /boot/initrd.gz


Mi devi chiarire meglio questa parte relativa alla scelta del kernel, perche' e' fondamentale. Poi se scegliessi quello generic (3.10.7) mi pare di capire che al riavvio mi troverei con una macchina che non ha alcun modulo configurato? quindi wifi da riconfigurare....quelli della vga...quelli del touchpad...ecc ecc? insomma tutto? perche' se fosse cosi non saprei davvero da dove iniziare....a me interessa che riavvio e mi riconosce tutto il mio hardware out of box, cosi' come e' avvenuto dopo la mia installazione di slackware, non ho dovuto aggiungere alcun driver, ne tantomeno quello del wifi, ho lanciato network manager e mi ha subito reso disponibili le reti senza fili capitate e mi sono autenticato alla mia.
Ultimissima cosa ancora: mi pare di avere letto da qualche parte che qualche utente che voleva aggiornare la sua distro alla current, ha avuto blocchi alla connessione wifi durante la fase di scaricamento dei pacchetti, e questo ha pregiudicato tutto, obbligandolo a riformattare da zero, e quindi esisteva una opzione durante questa fase di aggiornamento, per dire di scaricare tutti i pacchetti prima di cominciare a compilare. Vorrei delle dritte pure in questo grazie
Avatar utente
tano70
Linux 2.4
Linux 2.4
 
Messaggi: 211
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: current 64bit
Kernel: 3.14.17
Desktop: Xfce

Re: Ed eccomi finalmente su Slackware!!!

Messaggioda ZeroUno » ven ago 16, 2013 17:09

tano70 ha scritto:Se lancio quei comandi che mi hai scritto sopra, in pratica si aggiorna la distro alla currente ma il kernel mi resta quello che ho adesso di default, e cio' 3.2.29? e quindi non mi compare quel richiamo a lilo per cui dovrei digitare yes?
Oppure mi installa il kernel generic 3.10.7 e necessariamente io poi devo dare quei comandi che mi hai postato tu, cioe questi:

Stai confondendo le versioni del kernel (3.2 vs. 3.10) con i tipi di kernel (generic vs. huge).
slackware 14.0 ha due kernel: kernel-generic-3.2.29 e kernel-huge-3.2.29
slackware current ha due kernel: kernel-generic 3.10.7 e kernel-huge-3.10.7
e li hai entrambi sul sistema.
Se hai fatto una installazione di default allora hai configurato lilo per usare il kernel-huge-3.2.29
Se fai un aggiornamento a current di default allora hai configurato lilo per usare il kernel-huge-3.10.7, allora non hai bisogno di tutta quella cosa su mkinitrd e lilo.

Per ora mi limiterei a fare l'aggiornamento a current; vedi che tutto funziona e dopo configuri il sistema per usare il kernel generic.

Mi devi chiarire meglio questa parte relativa alla scelta del kernel, perche' e' fondamentale. Poi se scegliessi quello generic (3.10.7) mi pare di capire che al riavvio mi troverei con una macchina che non ha alcun modulo configurato?

No. Ti ritroverai con un kernel che non ha molti driver 'built-in' ovvero che il kernel di suo conosce pochi driver (e tra questi che conosce non c'è quello del filesystem, quindi serve l'initrd).
Ma dopo che ha montato il filesystem vengono in aiuto gli script di inizializzazione che vanno a caricare in automatico i vari moduli che gli servono.
Da quel punto di vista lato tuo è completamente indifferente usare un kernel generic piuttosto che un kernel huge; le configurazioni che devi fare per uno sono le stesse che devi fare per l'altro.



P.S.: Quando rispondi evita di quotare l'intero post; è sufficiente quotare pezzettini di solito, giusto per inquadrare il contesto della risposta.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Ed eccomi finalmente su Slackware!!!

Messaggioda tano70 » ven ago 16, 2013 20:11

Allora, ho avviato il lungo aggiornamento ...e la sua relativa compilazione di tutto quello che ha scaricato, alla fine di tutto il processo automatizzato udite udite, per una mia grossolana sbadataggine,disattenzione o qualsivoglia la si voglia chiamare, mi sono dimenticato di dare un comando fondamentale il "lilo -v" quello cioè che permetteva al sistema di capire con quale kernel avviarsi e di rigenerare la routine di boot!! ed infatti quando ho riavviato non trovava assolutamente nulla, quindi impossibilità totale di usare la distro. Ma non mi sono perso d'animo...e forte di una mia sufficiente esperienza in ambito linux, ho pensato di entrare in chroot, usando una chiavetta usb live di ubuntu che avevo in casa (dio benedica ubuntu) e con pochi comandi che piu o meno ricordavo ma che ho rivisto in internet, mi sono montato da ubuntu live la partizione di slack, e quando sono riuscito ad entrare nella Bash# ho tirato un sospiro di sollievo, e cosi ho dato il fatidico comando "lilo -v".
La macchina si è regolarmente avviata e sono arrivato alla console tty, ho digitato il mio nome utente e pass, e allo startx ho però avuto l'amara sorpresa che non ci entra, idem provando da root. Questo l'errore che mi genera:

xfce4-session: error while loading shared libraries: libharfbuzz.so.0: cannot open shared object file: No such file or directory
xinit: connection to X server lost


Adesso cosa posso fare? ci sta un modo per ripristinare il corretto avvio dell'interfaccia grafica? o dopo tutto questo sbattimento, devo essere costretto a riformattare?
premetto che ho provato da root a lanciare altre interfaccie grafiche diverse da xfce e non mi ci fa entrare, non riesce a caricare lo X server, o forse sbaglio io a dare i comandi per entrarci. ad esempio ho provato con startfluxbox ed esce fuori questo:
root@darkstar:# startfluxbox
xmodmap: unable to open display ' '
Error: Couldn't connect to Xserver passing null display


In rete ho trovato questa guida ad un problema analogo di libreria con la distro gentoo e il fix che hanno dato, purtroppo io non so metterci le mani e non voglio fare ulteriori casini, qualcuno forbito mi indica i comandi giusti da dare in root per risolvere?

ht t p: sevencapitalsins.wordpress.com/2007/11/01/error-while-loading-shared-libraries-libexpatso0-cannot-open-shared-object-file-no-such-file-or-directory/
ho tolto la parte iniziale di http altrimenti vi stava la censura dal sito
Avatar utente
tano70
Linux 2.4
Linux 2.4
 
Messaggi: 211
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: current 64bit
Kernel: 3.14.17
Desktop: Xfce

Re: Ed eccomi finalmente su Slackware!!!

Messaggioda ZeroUno » ven ago 16, 2013 20:49

premesso che non ho una slack a portata di mano, sembra che tu non abbia fatto l'aggiornamento completo.
Hai dato TUTTI i comandi citati? Ovvero sia l'update sia l'upgrade-all sia l'install-new sia il clean-system?
Suggerirei di ridarli tutti così vedi se si é dimenticato qualcosa.

fluxbox non si lancia in quel modo. Sempre con startx. dentro /var/log/setup o qualcosa del genere dovrebbe esserci uno script per far ricomparire la schermata che hai avuto in fase di installazione per scelta del window manager. Rilancialo.

Ps. Non mi risulta che slacky banni i link.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Ed eccomi finalmente su Slackware!!!

Messaggioda tano70 » ven ago 16, 2013 21:46

ZeroUno ha scritto:premesso che non ho una slack a portata di mano, sembra che tu non abbia fatto l'aggiornamento completo.
Hai dato TUTTI i comandi citati? Ovvero sia l'update sia l'upgrade-all sia l'install-new sia il clean-system?
Suggerirei di ridarli tutti così vedi se si é dimenticato qualcosa.

fluxbox non si lancia in quel modo. Sempre con startx. dentro /var/log/setup o qualcosa del genere dovrebbe esserci uno script per far ricomparire la schermata che hai avuto in fase di installazione per scelta del window manager. Rilancialo.

Ps. Non mi risulta che slacky banni i link.

sei un grandeeeee!! in effetti pensavo che avesse installato tutto e non ho dato il comando slackpkg install-new e nemmeno il clean, dati i comandi adesso mi ha ripristinato lo X server!! sono ultrafelice!! =D> tra l'altro non so se il kernel o altro...ma l'autonomia della mia batteria che era ridotta a sole 2 ore e mezza scarse....mi e' salita ad oltre 4 ore!!! e non scalda come un fornellino come prima!! sono contentissimo!!!!!!!!!
Avatar utente
tano70
Linux 2.4
Linux 2.4
 
Messaggi: 211
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: current 64bit
Kernel: 3.14.17
Desktop: Xfce

Precedente

Torna a Presentazioni

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti