Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto] Dopo upgrade 21agosto slackware bloccato al boot

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto] Dopo upgrade 21agosto slackware bloccato al boot

Messaggioda tano70 » gio ago 22, 2013 11:06

Mi serve un aiuto urgente: premetto che uso slackware14- 64 bit, già aggiornato alla current e kernel 3.10.7 e filava tutto a meraviglia.
Stamattina faccio il consueto upgrade del sistema (datato 21 agosto) dove oltre al kernel 3.10.9 mi ha aggiornato i vari driver video di xf86_64. Al reboot mi trovo il sistema piantato su BIOS data check successfull e da li non va avanti!! che fare??
da chroot sono entrato nel sistema e lanciato un lilo -v e questi sono i 3 warnig che ottengo:

Warning: LBA32 addressing asumed
Reading Boot Sector from /dev/sda
Warning: Unable to determing video adapter in use in the present system
Using Bitmap Secondary Loader
Caling map_insert_data_
Mapping bitmap file /boot/slack.bmp
Calling map_insert_file
warning: Video adapter does not support VESA BIOS extensions needed for display of 256 colors. Boot loader will fall back to TEXT only operation.
calling map_insert_file

Boot other: /dev/sda1, on /dev/sda, loader CHAIN

Boot Image: /boot/vmlinuz
Adding Linux*
Boot Other: /dev/hda1, on /dev/dev/hda, loader CHAIN

Come risolvo questa sitiuazione?

P.S cercando in rete ho trovato quwesta discussione che mi ha aiutato a fare partire normalmente il sistema:
https://www.slacky.eu/forum/viewtopic.php?f=1&t=12259
in pratica da chroot ho inserito al mio lilo.conf la riga:
lba32
e poi ho lanciato il comando lilo per rigenerarlo
Restano comunque gli altri due worning che con il vostro aiuto vorrei comunque risolvere, specie quello legato al mancato riconoscimento dalla scheda video del sistema. Mi dite i comandi che devo postare per potere riuscire a configurare tutto ad hoc in ambito video?
Ultima modifica di tano70 il gio ago 22, 2013 11:45, modificato 2 volte in totale.
Avatar utente
tano70
Linux 2.4
Linux 2.4
 
Messaggi: 201
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: current 64bit
Kernel: 3.14.17
Desktop: Xfce

Re: Dopo upgrade del 21 agosto slackware bloccato al boot

Messaggioda ZeroUno » gio ago 22, 2013 11:22

Io ho aggiornato ma non ho ancora riavviato.

Ma lilo -v l'ai lanciato PRIMA di rebootare?

quei 3 warning sono ok. Quello che non va bene è
Boot Other: /dev/hda1, on /dev/dev/hda, loader CHAIN

e questo potrebbe aver fermato l'esecuzione di lilo.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4393
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Dopo upgrade del 21 agosto slackware bloccato al boot

Messaggioda tano70 » gio ago 22, 2013 11:31

ZeroUno ha scritto:Io ho aggiornato ma non ho ancora riavviato.

Ma lilo -v l'ai lanciato PRIMA di rebootare?

quei 3 warning sono ok. Quello che non va bene è
Boot Other: /dev/hda1, on /dev/dev/hda, loader CHAIN

e questo potrebbe aver fermato l'esecuzione di lilo.

no no...ho sbagliato io a copiarli visto che i miei errori erano pari pari uguali a quelli trovati in una discussione su internet ho fatto che copiare tutte le stringhe di errore, senza pero ricordarmi di adattare invece quelli della mia macchina, infatti nella mia quella riga era>
Boot other: /dev/sda1, on /dev/sda, loader CHAIN
added Windows
Comunque in effetti non avevo lanciato lilo -v dopo che mi ha fatto l'aggiornamento!! sara' dovuto a questo il problema? lo devo lanciare obbligatoriamente ad ogni aggiornamento di kernel il lilo -v? pensavo che il sistema lo facesse in automatico...visto che alla fine dell'upgrade mi chiede se voglio lanciare o meno lilo e io rispondo Y (yes)
Comunque direi che posso mettere risolto...o meglio autorisolto :D =D>
Avatar utente
tano70
Linux 2.4
Linux 2.4
 
Messaggi: 201
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: current 64bit
Kernel: 3.14.17
Desktop: Xfce

Re: Dopo upgrade del 21 agosto slackware bloccato al boot

Messaggioda ZeroUno » gio ago 22, 2013 11:51

se hai risposto Y a slackpkg si, l'ha fatto lui, quindi doveva funzionare.
Però a me dava "Added Linux" non "Adding Linux"

Vedi che data ha /boot/map
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4393
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Dopo upgrade del 21 agosto slackware bloccato al boot

Messaggioda tano70 » gio ago 22, 2013 14:20

ZeroUno ha scritto:se hai risposto Y a slackpkg si, l'ha fatto lui, quindi doveva funzionare.
Però a me dava "Added Linux" non "Adding Linux"

Vedi che data ha /boot/map

Sempre errore mio di battitura :D la scritta è corretta: Added linux anche da me
Comunque adesso non sono a casa ma in ufficio e non ho con me il portatile con slack, stasera posto quello che mi chiedi. In effetti per questo non ho dato lilo -v proprio perchè mi aspettavo che lo avesse fatto lui in automatico dopo che mi ha chiesto di lanciare lilo ed ho risposto yes. Ma a questo punto evidentemente qualcosa per qualche strano motivo non va come deve...quindi reduce da questa esperienza, ad ogni aggiornamento futuro che farò per precauzione lancerò sempre il lilo -v
Avatar utente
tano70
Linux 2.4
Linux 2.4
 
Messaggi: 201
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: current 64bit
Kernel: 3.14.17
Desktop: Xfce

Re: Dopo upgrade del 21 agosto slackware bloccato al boot

Messaggioda tano70 » gio ago 22, 2013 19:34

ZeroUno ha scritto:
Vedi che data ha /boot/map


se intendi dalle proprieta' visto che il file ha una X rossa e non posso aprirlo, mi dice modificato e ultimo accesso oggi
Avatar utente
tano70
Linux 2.4
Linux 2.4
 
Messaggi: 201
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: current 64bit
Kernel: 3.14.17
Desktop: Xfce

Re: [Risolto] Dopo upgrade 21agosto slackware bloccato al bo

Messaggioda ZeroUno » gio ago 22, 2013 22:37

la data di ultima modifica la vedi con 'ls -l /boot/map' ma ormai non serve più visto che funziona.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4393
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti