Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] jack-audio-connection-kit e realtime scheduling

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda Procopio » ven set 20, 2013 21:54

ciao a tutti!! mi trovo a configurare jack anch io,

il mio problema è questo: vorrei che rimanesse il mio unico server audio, cioè che rimpiazzasse in tutto phonon, avviandosi automaticamente all'avvio e gestendo tutti i suoni, compresi quelli di sistema. Per fare questo è necessario disinstallare in toto phonon, o posso semplicemente editare qualche file di sistema?

Cercando qua e là ho solo trovato gente alle prese col tentativo di far funzionare il realtime, barcamenarsi tra set_rlimits e kernel RT... io sarei ancora allo step prima, cioè sostituire phonon con jack e cominciare a farlo funzionare senza real time, e a quello ci penso dopo (tra l'altro l'avevo già fatto, tempo fa, compilando il kernel RT ed era andato tutto liscio, ed ora ho scoperto questo comando, set_rlimits, quindi magari, quando ci proverò, tenterò con quello senza mettere la patc RT) c'è qualcuno che può aiutarmi??
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda rik70 » sab set 21, 2013 10:34

Procopio ha scritto:ciao a tutti!! mi trovo a configurare jack anch io,

il mio problema è questo: vorrei che rimanesse il mio unico server audio, cioè che rimpiazzasse in tutto phonon, avviandosi automaticamente all'avvio e gestendo tutti i suoni, compresi quelli di sistema. Per fare questo è necessario disinstallare in toto phonon, o posso semplicemente editare qualche file di sistema?


Sul modo migliore per avviare jackd in automatico non saprei dirti.

Per il resto, guarda se questo può esserti utile:
http://jackaudio.org/routing_phonon
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda Procopio » sab set 21, 2013 11:00

rik70 ha scritto:Per il resto, guarda se questo può esserti utile:
http://jackaudio.org/routing_phonon


Mmmh interessante, ma in quel modo continuo a dover passare da phonon, e non solo, ma anche dallo stesso gstreamer (il suo motore)...ma sarà mica che non posso fare a meno di phonon e gstreamer, e l'unico modo è bypassarlo in quel modo?? qualcuno mi sa dire qualcosa di preciso in questo senso?
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda rik70 » sab set 21, 2013 11:27

Phonon è un backend - o impropriamente detto da ignoranti come me sound server - che utilizza o xine o gstreamer. E' utilizzato dalle applicazione scritte per KDE. Per non usarlo, o non usi kde, o utilizzi applicazioni che non richiedono phonon.

Se per esempio tu volessi che i suoni di sistema di KDE passino per jackd, allora devi per forza utilizzare quel sistema indicato nell'articolo.

Dipende da cosa vuoi fare. Con i programmi audio in realtime, come Ardour, Hydrogen, etc. che ci sia phonon o meno in mezzo ai piedi poco importa: tanto non lo utilizzano. Però potrebbero andare in conflitto altre applicazioni - quelle appunto di KDE che passano per phonon.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda Procopio » sab set 21, 2013 11:43

rik70 ha scritto:Phonon è un backend - o impropriamente detto da ignoranti come me sound server - che utilizza o xine o gstreamer. E' utilizzato dalle applicazione scritte per KDE. Per non usarlo, o non usi kde, o utilizzi applicazioni che non richiedono phonon.

Se per esempio tu volessi che i suoni di sistema di KDE passino per jackd, allora devi per forza utilizzare quel sistema indicato nell'articolo.

ah ok, così mi è già più chiaro...allora le cose cambiano un po'...


rik70 ha scritto:Dipende da cosa vuoi fare. Con i programmi audio in realtime, come Ardour, Hydrogen, etc. che ci sia phonon o meno in mezzo ai piedi poco importa: tanto non lo utilizzano. Però potrebbero andare in conflitto altre applicazioni - quelle appunto di KDE che passano per phonon.
cosa che succede puntualmente, infatti ad esempio da jack non sono mai riuscito a sentire i browsers unitamente ad ardour o al vlc...bella bega perchè con questa scheda audio esterna continuo ad avere i suoni di sistema che si sentono dagli speaker del laptop, e il resto che esce dalle casse, phonon che mi mette una lista di 15 dispositivi quando ne ho solo due e ogni volta è un pasticcio dirgli quale prendere, perchè ovviamente phonon non me lo fa in automatico, kmix che ogni volta parte con la scheda audio sbagliata e devo settare quella esterna ad ogni avvio della sessione, alsamixer che per quanto io imposti una scheda piuttosto che un altra continua a farmi sentire i suoni come vuole....bel casino....
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda rik70 » sab set 21, 2013 13:25

Per i browser c'è questo:

http://linux-audio.4202.n7.nabble.com/A ... 45050.html

E ti posso dire che funziona perfettamente, almeno con firefox (edit: + flashplayer, con html5 non so) - l'unico che provai a suo tempo.

Per i programmi come vlc e mplayer, devi impostarli in modo che utilizzino jackd.

Per mplayer è sufficiente modificare il file /etc/mplayer.conf - oppure per il solo utente: ~/.mplayer/config - aggiungendo ad esempio:

Codice: Seleziona tutto
ao=jack,alsa,


Per vlc, dalle preferenze.

E così vale per gli altri programmi audio che vorrai utilizzare - sempreché siano stati compilati col supporto a jack. Diversamente vanno ricompilati.

Insomma, come dicevo nell'altra discussione, con slackware devi un pò tribolare, sopratutto per il realtime dato che manca pam. Ma una volta sistemato il tutto, funziona alla perfezione!

Per phonon, ripeto la soluzione migliore è quella linkata sopra - ammesso che funzioni: leggo che alcuni usano xine al posto di gstreamer. Oppure disattivi i suoni di sistema - dalle impostazione di configurazione o quello che è - e a quel punto non rompe più. Per il resto, KDE per me è un perfetto sconosciuto.

OT

Io personalmente, per il realtime, sto sperimentando questo e la resa è micidiale:

http://subversion.ffado.org/wiki/IrqPriorities

Per Ardour è necessario usare set_rlimits, o almeno così è nel mio caso: con setcap non parte.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda Procopio » sab set 21, 2013 16:24

no, niente da fare con jack,
ho installato il plugin che mi hai suggerito con
Codice: Seleziona tutto
matteo@darkstar:~>git clone git://repo.or.cz/libflashsupport-jack.git 
Cloning into 'libflashsupport-jack'...
remote: Counting objects: 79, done.
remote: Compressing objects: 100% (35/35), done.
remote: Total 79 (delta 44), reused 79 (delta 44)
Receiving objects: 100% (79/79), 21.77 KiB, done.
Resolving deltas: 100% (44/44), done.
matteo@darkstar:~>



ho settato il set_rlimits.conf
Codice: Seleziona tutto
matteo@darkstar:~>cat /etc/set_rlimits.conf
# Configuration file for set_rlimits.  Format is:
#
#   name   program   max_nice_priority  max_realtime_priority
# or
#   name   program   <key>=<value> ...
#
# name is expected to be a username, a groupname if preceeded by a @ sign,
# or ALL (which matches all users).  Negative priorities effectively
# disallow any setting of the respective priority for the matching entry.
# <key> can be rtprio, nice or memlock.
# Example entry:
#
#   mark  /usr/local/bin/jackd  -1  80
#
# Here, user mark can execute /usr/local/bin/jackd using set_rlimits to set
# a realtime priority up to and including 80, but setting of a nice priority
# through set_rlimits is disallowed.  Alternatively, if an `audio' group
# existed, the entry
#
#   @audio  /usr/local/bin/jackd  -1  80
#
# would allow the same except the permission would extend to all members of
# the `audio' group.  The same effect could be achieved with the key/value
# syntax:
#
   @audio  /usr/bin/jackd  nice=-1  rtprio=80 memlock=250000
#
# For more details on the format and use of this file please refer to
# the set_rlimits manual page.
matteo@darkstar:~>


poi ho tentato di farlo patrire con
Codice: Seleziona tutto
set_rlimits /usr/bin/jackd -R -v -dalsa -dhw:0 -r48000 -p512 -n2

ma niente, anche se non mi da errori ne overrun e sembrerebbe tutto funzionare bene, le casse restano mute....


dalla gui neanche, tanto più che non posso neanche mettere il server path, in questa versione di qjackctl, ma server prefix e server suffix, se vuoi ti allego una schermata del mio setup di jack...

in entrambi i casi quando provo a vedere un video da youtube con firefox se sono con jack il video si crasha dopo 3 secondi, se invece chiudo jack vedo tutto normale....
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda rik70 » sab set 21, 2013 16:29

Spetta...
come l'hai installato? A me qua funziona, com'è che a te non va?

Dopo averlo "clonato" l'hai compilato? Si/No? Se si, qual'è il percorso della risultante 'libflashsupport.so' ?

P.s.

Per ora set_rlimits lascialo stare. Non ti serve se non devi usare jackd in realtime. E poi hai già dato setcap su jackd, quindi è superfluo - sia col realtime che senza.

Si, allega tutto quello vuoi ;)
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda Procopio » sab set 21, 2013 17:12

rik70 ha scritto:Spetta...
come l'hai installato? A me qua funziona, com'è che a te non va?

Dopo averlo "clonato" l'hai compilato? Si/No? Se si, qual'è il percorso della risultante 'libflashsupport.so' ?


mmmmmmh no caro :-' mi ero fermato al clone :roll: non avevo capito che si dovesse installare 9.9 ma con quel colone dove me lo mette il file da compilare?

questo è il mio setup di jack, il driver era oss solo in quel frangente se no di solito uso alsa!
1ac2.png
1ac2.png (72.78 KiB) Osservato 950 volte
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda rik70 » sab set 21, 2013 17:24

Allora fai così se puoi.

Allega:

Codice: Seleziona tutto
cat ~/.jackdrc
cat /proc/asound/cards


E per la faccenda del real_time - che se hai voglia vediamo in un secondo momento:
Codice: Seleziona tutto
cat /etc/set_rlimits.conf


Questo ad esempio è firefox che riproduce un video sul tubo tramite jack-audio in raltime con set_rlimits (su kernel -rt):

Codice: Seleziona tutto
ps -eLo rtprio,cls,pid,pri,nice,cmd | grep "FF" | sort -r
45  FF  9689  85   - /usr/lib/firefox-23.0.1/plugin-container /usr/lib/mozilla/plugins/libflashplayer.so -greomni /usr/lib/firefox-23.0.1/omni.ja -appomni /usr/lib/firefox-23.0.1/browser/omni.ja -appdir /usr/lib/firefox-23.0.1/browser 9656 true plugin

Si sto facendo il gradasso come se ne capissi qualcosa :): intuisco però dall'output che firefox è eseguito in realtime e il plugin funziona - ed è così infatti.

P.s.
Per il plugin: compilalo e installalo. Mi raccomando col 'prefisso' in /usr

Es:
Codice: Seleziona tutto
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var

make

# se non da errori, da root:

make install



Il clone crea una directory libflashsupport-jack/ e ovviamente devi 'entrarci' prima.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda Procopio » sab set 21, 2013 17:48

ecco i cat:
Codice: Seleziona tutto
matteo@darkstar:~/libflashsupport-jack>cat ~/.jackdrc
/usr/bin/jackd -v -m -doss -r44100 -p1024 -n2 -w16

root@darkstar:/home/matteo>cat /proc/asound/cards
 0 [CODEC          ]: USB-Audio - USB Audio CODEC
                      Burr-Brown from TI USB Audio CODEC at usb-0000:00:1d.7-3.2, full speed
 1 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfc300000 irq 46



Codice: Seleziona tutto
root@darkstar:/home/matteo>cat /etc/set_rlimits.conf
# Configuration file for set_rlimits.  Format is:
#
#   name   program   max_nice_priority  max_realtime_priority
# or
#   name   program   <key>=<value> ...
#
# name is expected to be a username, a groupname if preceeded by a @ sign,
# or ALL (which matches all users).  Negative priorities effectively
# disallow any setting of the respective priority for the matching entry.
# <key> can be rtprio, nice or memlock.
# Example entry:
#
#   mark  /usr/local/bin/jackd  -1  80
#
# Here, user mark can execute /usr/local/bin/jackd using set_rlimits to set
# a realtime priority up to and including 80, but setting of a nice priority
# through set_rlimits is disallowed.  Alternatively, if an `audio' group
# existed, the entry
#
#   @audio  /usr/local/bin/jackd  -1  80
#
# would allow the same except the permission would extend to all members of
# the `audio' group.  The same effect could be achieved with the key/value
# syntax:
#
   @audio  /usr/bin/jackd  nice=-1  rtprio=80 memlock=250000
#
# For more details on the format and use of this file please refer to
# the set_rlimits manual page.
root@darkstar:/home/matteo>


il git non mi scarica il configure, quindi non riesco a eseguire il ./configure per la compilazione...
Codice: Seleziona tutto
root@darkstar:~/libflashsupport-jack>ls
Makefile.am  bootstrap.sh  configure.ac  flashsupport.c
root@darkstar:~/libflashsupport-jack>./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
bash: ./configure: No such file or directory


il se al posto del configure do /configure.ac mi dice
Codice: Seleziona tutto
root@darkstar:~/libflashsupport-jack>./configure.ac --prefix=/usr --sysconfdir=/etc --localstatedir=/var
bash: ./configure.ac: Permission denied
devo dargli un chmod o proprio non c'entra il configure.ac?
Ultima modifica di Procopio il sab set 21, 2013 18:17, modificato 1 volta in totale.
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda rik70 » sab set 21, 2013 17:52

Prova a dare prima:
Codice: Seleziona tutto
./bootstrap.sh
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda rik70 » sab set 21, 2013 17:57

P.s.

il cat ~/.jackdrc da utente normale, non da root.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda Procopio » sab set 21, 2013 18:14

ah ecco avevo intuito che avrei dovuto eseguire il bootstrap, ma non ho preso l'iniziativa...:)
ad ogni modo l'ho fatto, e mi ha tirato fuori i vari files per la compilazione... il configure è andato a buon fine, il make no, gli manca un file:
Codice: Seleziona tutto
matteo@darkstar:~/libflashsupport-jack>make
make  all-am
make[1]: Entering directory `/home/matteo/libflashsupport-jack'
/bin/sh ./libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.      -lsamplerate    -g -O2 -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wshadow -Wendif-labels -Wpointer-arith -Wcast-align -Wwrite-strings -Winline -Wno-unused-parameter -ffast-math -MT libflashsupport_la-flashsupport.lo -MD -MP -MF .deps/libflashsupport_la-flashsupport.Tpo -c -o libflashsupport_la-flashsupport.lo `test -f 'flashsupport.c' || echo './'`flashsupport.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -lsamplerate -g -O2 -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wshadow -Wendif-labels -Wpointer-arith -Wcast-align -Wwrite-strings -Winline -Wno-unused-parameter -ffast-math -MT libflashsupport_la-flashsupport.lo -MD -MP -MF .deps/libflashsupport_la-flashsupport.Tpo -c flashsupport.c  -fPIC -DPIC -o .libs/libflashsupport_la-flashsupport.o
flashsupport.c:184:28: fatal error: linux/videodev.h: No such file or directory
compilation terminated.
make[1]: *** [libflashsupport_la-flashsupport.lo] Error 1
make[1]: Leaving directory `/home/matteo/libflashsupport-jack'
make: *** [all] Error 2


googlando ho trovato che bastava fare un link simbolico, ma non è bastato...
Codice: Seleziona tutto
matteo@darkstar:~/libflashsupport-jack>ln -s videodev2.h videodev.h
matteo@darkstar:~/libflashsupport-jack>make
make  all-am
make[1]: Entering directory `/home/matteo/libflashsupport-jack'
/bin/sh ./libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.      -lsamplerate    -g -O2 -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wshadow -Wendif-labels -Wpointer-arith -Wcast-align -Wwrite-strings -Winline -Wno-unused-parameter -ffast-math -MT libflashsupport_la-flashsupport.lo -MD -MP -MF .deps/libflashsupport_la-flashsupport.Tpo -c -o libflashsupport_la-flashsupport.lo `test -f 'flashsupport.c' || echo './'`flashsupport.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -lsamplerate -g -O2 -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wshadow -Wendif-labels -Wpointer-arith -Wcast-align -Wwrite-strings -Winline -Wno-unused-parameter -ffast-math -MT libflashsupport_la-flashsupport.lo -MD -MP -MF .deps/libflashsupport_la-flashsupport.Tpo -c flashsupport.c  -fPIC -DPIC -o .libs/libflashsupport_la-flashsupport.o
flashsupport.c:184:28: fatal error: linux/videodev.h: No such file or directory
compilation terminated.
make[1]: *** [libflashsupport_la-flashsupport.lo] Error 1
make[1]: Leaving directory `/home/matteo/libflashsupport-jack'
make: *** [all] Error 2
matteo@darkstar:~/libflashsupport-jack>



e neanche quest'altro link simbolico, che non sono riuscito a fare
Codice: Seleziona tutto
matteo@darkstar:~/libflashsupport-jack>/usr/include/linux/videodev.h -> /usr/include/libv4l1-videodev.h
bash: /usr/include/libv4l1-videodev.h: Permission denied
matteo@darkstar:~/libflashsupport-jack>su
Password:
root@darkstar:/home/matteo/libflashsupport-jack>/usr/include/linux/videodev.h -> /usr/include/libv4l1-videodev.h
bash: /usr/include/linux/videodev.h: No such file or directory
root@darkstar:/home/matteo/libflashsupport-jack>


P.S.:
rik70 ha scritto:P.s.

il cat ~/.jackdrc da utente normale, non da root.

ho corretto sopra e ho messo il cat da utente normale
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: [RISOLTO] jack-audio-connection-kit e realtime schedulin

Messaggioda rik70 » sab set 21, 2013 18:55

Rimouovi i link simbolici creati.

Apri con un editor il file flashsupport.c
Trova questa riga:
Codice: Seleziona tutto
#define V4L1


Modificala in
Codice: Seleziona tutto
//#define V4L1


Poi da un bel
Codice: Seleziona tutto
make distclean


E rifai da capo.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

PrecedenteProssimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti