Repository 32bit  Forum
Repository 64bit  Wiki

Epson 3520 non stampa (RISOLTO)

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Epson 3520 non stampa (RISOLTO)

Messaggioda Ocram » sab set 28, 2013 13:18

Buongiorno a tutti ed un grazie anticipato a chi gentilmente vuole provare a darmi una mano.
Ho una slackware-xfce 3.2.29 64 bit , oltre a Lxde (una derivata lubuntu)
Dopo anni o deciso di sostitutire la mia vecchia stampante con una Epson WorkForce WF-3520DWF, lo scanner funziona a dovere sia su slack che su ubuntu (chiamerò ubuntu lxde dato che è una derivata) mentre la stampa viene effettuata correttamente solo su ubuntu,
ho provato vari forum (googlando) tra cui alcuni in inglese (dove purtroppo nn sono molto ferrato)
http://www.linuxquestions.org/questions/slackware-14/how-to-get-an-epson-wf-3540-printer-working-under-slackware-4175448790/

(quest per esempio sembrerebbe avvicinarsi al mio problema, ma nn ho capito come viene risolto)
ma i risultati sono sempre gli stessi, la stampante si installa correttamente, ma al momento di dare la stampa da il solito errore.....
/opt/epson-inkjet-printer-201212w/cups/lib/filter/ failed"

(cambiando drive la scritta cabia di poco ma siamo lì)
Ho provato sia a convertire il pacchetto .deb con alien che il pacchetto rpm con rpm2txz (o tgz)
ho anche cercato su slackbuild.org e li trovo un drive generico in versione 1.2.2 (mi pare) provo a scaricarlo ma niente,
allora ho scaricato solo lo slackbuild ed ho preso il sorgente 1.3.xxx aggiornato lo slackbuild e proceduto alla creazione del pacchetto, tutto bene
in tmp ho trovato il pacchetto...... installato correttamente con installpkg ed al momento dell'installazione della stampante, viene addirittura rilavata automaticamente
poi al momento della stampa.......... solita cosa non stampa ed il messaggio finisce sempre allo stasso modo, cambia qualcosa suoi percorsi iniziali.
Ho controllato i percorsi per vedere cosa c'era, e dentro vi è un'eseguibile chiamto appunto epson_inkjet_printer_filter
Ho visto altri forum (più vecchi) di discussione (mi sebra di ricordare uno su suse) e suggeriscono di passare alla versione di guteprint 5.25
ho controllato quella in uso qui e mi sebra che sia la 5.27
Qualcuno ha qualche suggerimento da dare? Un saluto ed un grazie.
Ultima modifica di Ocram il lun set 30, 2013 22:30, modificato 1 volta in totale.
Ocram
Linux 1.0
Linux 1.0
 
Messaggi: 4
Iscritto il: gio set 26, 2013 21:50

Re: Epson 3520 non stampa

Messaggioda 414N » sab set 28, 2013 14:24

Ciao.
Da quanto si legge in quel thread, bisogna verificare il linker al quale tenta di collegarsi il filtro di stampa (ovvero il programma epson_inkjet_printer_filter) all'avvio tramite
Codice: Seleziona tutto
strings epson_inkjet_printer_filter | grep lib

Se tenta di collegarsi a /lib64/ld-lsb-x86-64.so.3 come riportano nel thread allora devi creare un link simbolico che punti al linker presente in Slackware, per esempio così:
Codice: Seleziona tutto
ln -s /lib64/ld-linux-x86-64.so.2 /lib64/ld-lsb-x86-64.so.3

In questo modo, all'esecuzione successiva, il filtro troverà il suo bel linker e dovrebbe riuscire a funzionare.
Offtopic: Mi pare tu abbia le idee un po' confuse riguardo LXDE/Lubuntu: il primo è solo un ambiente desktop mentre la seconda è una distro derivata da Ubuntu che presenta LXDE come ambiente desktop principale.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Epson 3520 non stampa

Messaggioda Ocram » sab set 28, 2013 16:57

Ciao e grazie per il suggerimento.
Avevo un blocco sul come procedere, infatti nn capivo come fare per vedere il linker ( :oops: )
poi al tuo suggerimento è arrivata l'illuminazione :idea: (a dire il vero un pò me ne vergogno..... una vera svista dal peggiore dei niubbi)
in pratica il comando
strings epson_inkjet_printer_filter | grep lib

lo dovevo dare nella directory del file .......... lo so e stata un mega svista, ma e tre / quattro giorni che sono dietro a smanettare e sto cominciando ad andare a testoni (oltre a non capirci + niente)
ti posto il risultato:
marco[filter]$ strings epson_inkjet_printer_filter | grep lib
/lib64/ld-lsb-x86-64.so.3
libdl.so.2
libstdc++.so.6
libcupsimage.so.2
libcups.so.2
libjpeg.so.62
libpthread.so.0
libm.so.6
libc.so.6
__libc_start_main
/opt/epson-inkjet-printer-201212w/lib64
%s:%d <<%s>>: load core library
%s:%d <<%s>>: Unload library
%s:%d <<%s>>: Unload core library
%s:%d <<%s>>: Unload core library completed
load_core_library
__libc_csu_fini
__libc_start_main@@GLIBC_2.2.5
__libc_csu_init

Sembra identico............ solo che (come ti dicevo prima) siccome oramai non sapevo + che pesci pigliare..
il link l'avevo creato lo stesso....... senza effettivamente verificare a quale libreria puntasse.....
però il risultato è lo stesso.... non stampa :evil: :evil:
Gentilmente puoi spiegarmi meglio il link simbolico? Cioè, se il file string epson punta a questa libreria ld-lsb-x86-64.so.3
perchè lo devo collegare a /lib64/ld-linux-x86-64.so.2 ?????????????
Ho visto nella dir lib64 e li (se nn leggo male ) ho un collegamento al collegamento, cioè:
10 feb 9 2013 ld-linux-x86-64.so.2 -> ld-2.15.so
17 set 23 23:43 ld-lsb-x86-64.so.3 -> /lib64/ld-2.15.so

:?: :?: e normale che puntino alla libreria ld-2.xxxx :?: :?: :?:
comunque si ostina ancora a non funzionare, aggiungo che sto usando il pacchetto come nel tread da me postato, volendo posso disinstallarlo ed installare il pacchetto
che ho pronto in /tmp (quello creato dallo slackbuild,i due pacchetti sembrano differenti,quello creato da rpm2tgx e specifico per questa stampante,quando lo installo con installpgk mi scrive un elenco di due o tre stampanti,tra cui questa, mentre lo slackbuild dovrebbe esser + generico)
Un saluto


Offtopic: Hai ragione ho fatto un pò di confusione, infatti la distro si chiama LXLE derivata diretta di lubuntu, mi piace dilettarmi in distro derivate e possibilmente dai DE leggero, anche se la macchina può sopportare benissimo anche KDE
Ocram
Linux 1.0
Linux 1.0
 
Messaggi: 4
Iscritto il: gio set 26, 2013 21:50

Re: Epson 3520 non stampa

Messaggioda Ocram » sab set 28, 2013 23:36

A mali estremi estremi rimedi........
ho analizzato l'eseguibile (il filtro) sia qui che su ubuntu, entrambi sembrano collegare alla libreria ld-2.15.so (in ubuntu la versione e 2.13)
la differenza e che in slack deve fare più strada , cioè si collega il filtro alla libreria so.3 che punta alla so.2 che a sua volta punta alla libreria condivisa 2.15
(ho provato anche con un collegamento diretoo, nisba)
ho visto che l'eseguibile in questione non sembrerebbe un normale eseguibile..... lo rinominato ed ho copiato quello di ubuntu nella sua dir, risultato:
printer-state-message="/usr/lib64/cups/filter/gstoraster failed" :( :( :( :( :( :( :(
almeno (forse) un passo avanti l'ho fatto.
Ovviamnete ho provato la stessa manovra con il nuovo filtro (da ubuntu a slack) ma il risultato è lo stesso.
ho fatto una veloce ricerca con google:
http://www.linuxquestions.org/questions/linux-hardware-18/epson-wf3540-in-cups-with-all-features-working-4175453461/
http://www.pclinuxos.com/forum/index.php?topic=97359.0
Purtroppo di inglese ne so poco, ed anche il traduttore mi aiuta poco, se gentilmante voleste dargli un'occhiata.....
un saluto
Ocram
Linux 1.0
Linux 1.0
 
Messaggi: 4
Iscritto il: gio set 26, 2013 21:50

Re: Epson 3520 non stampa (RISOLTO)

Messaggioda Ocram » lun set 30, 2013 22:45

DELLA SERIE ME LA SUONO E ME LA CANTO.
Risolto............ \:D/ \:D/ \:D/ \:D/ \:D/
lo scrivo 100 volte :^o su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l su -l

Piccola guida per chi è niubbo come me........ innanzitutto lasciate perdere tutte le guide che trovate in giro in merito a qst stampante o della stessa famiglia
(wf-3520 wf-3540 etc .etc.) che vi invitano ad usare rpm2tgz o alien (da rpm a slack / deb a slack) per la trasformazione del pacchetto, non va bene.

Andate sul sito dell'epson e scaricate i driver per linux adatto a qst stampante (ma penso che essendo un drive genrico vada bene anche per molti altri modelli)
scaricate il sorgente tar.gz e mettetelo in una directory.
poi andate sul sito slackbuild.org e scaricate lo slackbuild ( a dire il vero sul sito c'è anche il pacchetto dei drive epson ma non funziona, molto probabilmente e da aggiornare.......)
corregete lo slackbuid per la versione corretta ed unitelo nella directory dove c'è il sorgente precedentemente scaricato.
Aprite un terminale [u]e loggatevi come root ma con su -l [/u] (questo è stato il mio errore :oops: aver usato solo su................ sembra che eventuali patch non verrebbero inserite)
lanciate lo slackbuild ................ e create il pacchetto.
poi spostatevi in /tmp e installatelo............. poi installate la stampante.
Ocram
Linux 1.0
Linux 1.0
 
Messaggi: 4
Iscritto il: gio set 26, 2013 21:50


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron