prestazioni gimp [risolto]

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
sya54M
Master
Master
Messaggi: 1579
Iscritto il: mer giu 06, 2007 14:44
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 4.6.x
Desktop: KDE
Località: (Salerno)
Contatta:

prestazioni gimp [risolto]

Messaggioda sya54M » ven ott 04, 2013 21:59

Salve a tutti, purtroppo ho anch'io il dual boot, Slackware current e Windows 8... su Windows ci tengo solo 3ds max, autocad e gimp, insomma lo uso solo per disegnare e su Linux faccio tutto il resto.
La cosa strana è che già da un po' di tempo gimp su Slackware è esasperatamente lento in alcune operazioni (scala, prospettiva, ruota, ...), non mi sono reso conto da quando ha iniziato ad essere così e di recente mi sono accorto che invece su Windows 8 è velocissimo a fare queste operazioni.
GIMP è la stessa versione su entrambi i sistemi e su Slackware ho anche provato a resettarne la configurazione rinominando la sua directory ma non è cambiato nulla.
Come è possibile? eppure in rete si trovano casi opposti al mio
Ultima modifica di sya54M il mar dic 17, 2013 9:23, modificato 2 volte in totale.

gyrodeck
Linux 1.0
Linux 1.0
Messaggi: 26
Iscritto il: ven gen 25, 2013 19:08
Slackware: current
Kernel: 3.7.1
Desktop: kde

Re: prestazioni gimp

Messaggioda gyrodeck » ven ott 04, 2013 23:08

Succede anche a me,ruota, scala, prospettiva e inclina sono estremamente lenti,ho disinstallato gimp , cancellato i file in root e reinstallato ma tutto è rimasto uguale.Io ho la current aggiornata al 2/10 con kernel 3.10.12.Pero' questo problema mi si era posto gia' da diverso tempo,speravo che gli aggiornamenti successivi risolvessero il problema ma niente.Se qualcuno ha suggerimenti lo ringrazio fin d'ora.

Avatar utente
brg
Linux 2.4
Linux 2.4
Messaggi: 377
Iscritto il: sab mar 12, 2011 14:20
Slackware: 14.2
Kernel: 4.4.14
Desktop: KDE4
Località: Montecatini
Contatta:

Re: prestazioni gimp

Messaggioda brg » dom ott 06, 2013 18:27

Io ho la 2.8.2, la versione standard di Slackware 14.0, e non riscontro nessun problema. Con una rapida ricerca su Google ho trovato questa discussione su Linuxquestions: http://www.linuxquestions.org/questions ... 175451662/ . Praticamente fanno notare che dalla versione 2.8.0 Gimp usa GEGL, che è una libreria accelerata dalla scheda video, come sono messi i vostri driver video?

Avatar utente
sya54M
Master
Master
Messaggi: 1579
Iscritto il: mer giu 06, 2007 14:44
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 4.6.x
Desktop: KDE
Località: (Salerno)
Contatta:

Re: prestazioni gimp

Messaggioda sya54M » dom ott 06, 2013 19:05

Infatti la 2.6 funzionava sicuramente bene e con gegl dicevano che avrebbe aumentato le prestazioni, e invece... io ho una nvidia con gli ultimi driver ufficiali e funziona perfettamente l'accelerazione

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3391
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: prestazioni gimp

Messaggioda Trotto@81 » dom ott 06, 2013 21:31

Da me sempre una scheggia con GeForce 8600GT e driver proprietari.

Avatar utente
sya54M
Master
Master
Messaggi: 1579
Iscritto il: mer giu 06, 2007 14:44
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 4.6.x
Desktop: KDE
Località: (Salerno)
Contatta:

Re: prestazioni gimp

Messaggioda sya54M » dom ott 06, 2013 23:43

io ho una geforce gt440 su una current a 64bit

gyrodeck
Linux 1.0
Linux 1.0
Messaggi: 26
Iscritto il: ven gen 25, 2013 19:08
Slackware: current
Kernel: 3.7.1
Desktop: kde

Re: prestazioni gimp

Messaggioda gyrodeck » lun ott 07, 2013 2:01

io ho una nvidia gtx 670 con driver proprietari e funziona tutto bene

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4551
Iscritto il: mer lug 28, 2004 0:00
Nome Cognome: Nino
Slackware: 14.2 64bit
Kernel: 4.4.14
Desktop: XFCE
Località: Reggio Calabria
Contatta:

Re: prestazioni gimp

Messaggioda aschenaz » lun ott 07, 2013 7:54

Io ho provato recentemente con diverse schede video Nvidia (tra cui una Quadro) e invece rilevo le stesse problematiche segnalate. Ma mi riferisco solo a quelle singole funzioni (rotazione soprattutto); per il resto tutto ok.

Avatar utente
sya54M
Master
Master
Messaggi: 1579
Iscritto il: mer giu 06, 2007 14:44
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 4.6.x
Desktop: KDE
Località: (Salerno)
Contatta:

Re: prestazioni gimp

Messaggioda sya54M » lun ott 07, 2013 8:46

sì infatti è estremamente lento solo con gli strumenti ruota, scala, inclina e prospettiva ed ho i driver 325.15

gyrodeck
Linux 1.0
Linux 1.0
Messaggi: 26
Iscritto il: ven gen 25, 2013 19:08
Slackware: current
Kernel: 3.7.1
Desktop: kde

Re: prestazioni gimp

Messaggioda gyrodeck » lun ott 07, 2013 14:26

Chiarisco quanto detto nell'ultimo post , va tutto bene salvo il problema con gimp

Avatar utente
brg
Linux 2.4
Linux 2.4
Messaggi: 377
Iscritto il: sab mar 12, 2011 14:20
Slackware: 14.2
Kernel: 4.4.14
Desktop: KDE4
Località: Montecatini
Contatta:

Re: prestazioni gimp

Messaggioda brg » lun ott 07, 2013 16:50

Ho provato sul mio fisso, scheda AMD, driver proprietari, Slackware 64 14.0, e lo strumento prospettiva di Gimp è fluido come l'aria con un'immagine 3000x5000, mentre sul mio portatile, scheda nVidia, driver 304.60, Slackware 64 14.0, lo strumento prospettiva è un po' scattoso anche con immagini relativamente piccole. Tuttavia non è niente di scandaloso, la griglia si muove abbastanza fluidamente, mentre l'immagine distorta dentro è aggiornata più lentamente. A questo punto credo che sia un problema tra i driver nVidia e Gimp sotto Slackware.

Avatar utente
conraid
Staff
Staff
Messaggi: 12773
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: prestazioni gimp

Messaggioda conraid » mar ott 08, 2013 14:31

sul notebook con driver intel non ho questi problemi. Almeno a basse risoluzioni, quando la risoluzione aumenta ho lentezza in ogni operazione con gimp, ma questo è per il pc poco potente per questo genere di cose.

Avatar utente
Rama
Linux 2.4
Linux 2.4
Messaggi: 288
Iscritto il: sab mar 29, 2008 12:18
Slackware: 14.2 64bit
Kernel: 4.7.0 preemptive
Desktop: KDE 4.14.21
Distribuzione: Kubuntu
Località: Novara, provincia
Contatta:

Re: prestazioni gimp

Messaggioda Rama » mer ott 09, 2013 13:09

avete provato a lanciarlo da shell?
a me dice:

bash-4.2$ gimp
While parsing XMP metadata:
Errore: nessun pacchetto XMP trovato

ma funziona regolarmente e ruota, scala ecc... sono veloci;
Geforce 8400 GS con driver proprietari, Gimp 2.8.2;

r
sulla tosticità della Slackware, ovvero distro sedicenti facili e realmente tali:
http://www.umpf.net/ramapage/sulla.htm

Avatar utente
sya54M
Master
Master
Messaggi: 1579
Iscritto il: mer giu 06, 2007 14:44
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 4.6.x
Desktop: KDE
Località: (Salerno)
Contatta:

Re: prestazioni gimp

Messaggioda sya54M » mer ott 09, 2013 13:12

a me non esce alcun errore sul terminale ed ho gimp della current (gimp-2.8.6-x86_64-1)

Avatar utente
conraid
Staff
Staff
Messaggi: 12773
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: prestazioni gimp

Messaggioda conraid » sab ott 12, 2013 16:45

idem, nessun errore su current a 64bit. E non ho quei rallentamenti con driver intel


Torna a “Packages”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite