Repository 32bit  Forum
Repository 64bit  Wiki

Microfono interno non riconosciuto e ridotta autonomia

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Microfono interno non riconosciuto e ridotta autonomia

Messaggioda tano70 » mer ott 09, 2013 10:36

Eccomi qui con un nuovo post :D molti diranno sempre lui...ehehehe ma a quanto pare sono uno dei pochi più attivi o più niubbi qui dentro, quindi perdonatemi se continuo a chiedere l'aiuto dei guru più smaliziati :D ho racchiuso in questo post gli unici due problemi che vorrei risolvere, cioè il secondo quello della scarsa autonomia più che a un vero problema rientra in un suggerimento per migliorare qualcosa se possibile.
Allora dopo tante fatiche e con l'aiuto del bravissimo ed esperto hashbang, rik70 ed altri utenti davvero gentilissimi sono finalmente riuscito ad installare la slackware current 64 sul mio nuovo portatile efi, Lenovo X1 Carbon. Mi sono configurato senza problemi tutto, l'unica cosa che non va è il microfono interno che resta muto, non riesco in alcun modo ad utilizzarlo ad esempio su skype. Ho smanettato nelle impostazioni audio di skype viene regolarmente rilevato come HDA intel PCH, ALC269VC, Analog Device (sysdefault:CARD:PCH)
Utilizzo alsa, il suono ha funzionato subito out of the box, non ho dovuto settare nulla, ma il microfono anche settando le altre opzioni da apposita tendina ma che sono tutte riferite empre ad HDA Intel PCH ma agli speaker, non ottengo nulla. Ho anche aperto mixer, aumentando al massimo i tag riferiti al microfono, al mic booster, ad internal, ma il microfono mi sta sempre muto. Questo il mio hardware:

Codice: Seleziona tutto
bash-4.2# lspci -v
00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
   Subsystem: Lenovo Device 21f9
   Flags: bus master, fast devsel, latency 0
   Capabilities: [e0] Vendor Specific Information: Len=0c <?>

00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device 21f9
   Flags: bus master, fast devsel, latency 0, IRQ 45
   Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
   Memory at e0000000 (64-bit, prefetchable) [size=256M]
   I/O ports at 4000 [size=64]
   Expansion ROM at <unassigned> [disabled]
   Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
   Capabilities: [d0] Power Management version 2
   Capabilities: [a4] PCI Advanced Features
   Kernel driver in use: i915

00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04) (prog-if 30 [XHCI])
   Subsystem: Lenovo Device 21f9
   Flags: bus master, medium devsel, latency 0, IRQ 41
   Memory at f1500000 (64-bit, non-prefetchable) [size=64K]
   Capabilities: [70] Power Management version 2
   Capabilities: [80] MSI: Enable+ Count=1/8 Maskable- 64bit+
   Kernel driver in use: xhci_hcd

00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
   Subsystem: Lenovo Device 21f9
   Flags: bus master, fast devsel, latency 0, IRQ 42
   Memory at f1515000 (64-bit, non-prefetchable) [size=16]
   Capabilities: [50] Power Management version 3
   Capabilities: [8c] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Kernel driver in use: mei_me

00:16.3 Serial controller: Intel Corporation Panther Point KT Controller (rev 04) (prog-if 02 [16550])
   Subsystem: Lenovo Device 21f9
   Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 19
   I/O ports at 4090 [size=8]
   Memory at f151b000 (32-bit, non-prefetchable) [size=4K]
   Capabilities: [c8] Power Management version 3
   Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
   Kernel driver in use: serial

00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04) (prog-if 20 [EHCI])
   Subsystem: Lenovo Device 21f9
   Flags: bus master, medium devsel, latency 0, IRQ 16
   Memory at f151a000 (32-bit, non-prefetchable) [size=1K]
   Capabilities: [50] Power Management version 2
   Capabilities: [58] Debug port: BAR=1 offset=00a0
   Capabilities: [98] PCI Advanced Features
   Kernel driver in use: ehci-pci

00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
   Subsystem: Lenovo Device 21f9
   Flags: bus master, fast devsel, latency 0, IRQ 44
   Memory at f1510000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: [50] Power Management version 2
   Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
   Capabilities: [100] Virtual Channel
   Capabilities: [130] Root Complex Link
   Kernel driver in use: snd_hda_intel

00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
   I/O behind bridge: 00003000-00003fff
   Memory behind bridge: f0d00000-f14fffff
   Prefetchable memory behind bridge: 00000000f0400000-00000000f0bfffff
   Capabilities: [40] Express Root Port (Slot+), MSI 00
   Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit-
   Capabilities: [90] Subsystem: Lenovo Device 21f9
   Capabilities: [a0] Power Management version 2
   Kernel driver in use: pcieport

00:1c.1 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 2 (rev c4) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
   Memory behind bridge: f0c00000-f0cfffff
   Capabilities: [40] Express Root Port (Slot+), MSI 00
   Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit-
   Capabilities: [90] Subsystem: Lenovo Device 21f9
   Capabilities: [a0] Power Management version 2
   Kernel driver in use: pcieport

00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04) (prog-if 20 [EHCI])
   Subsystem: Lenovo Device 21f9
   Flags: bus master, medium devsel, latency 0, IRQ 23
   Memory at f1519000 (32-bit, non-prefetchable) [size=1K]
   Capabilities: [50] Power Management version 2
   Capabilities: [58] Debug port: BAR=1 offset=00a0
   Capabilities: [98] PCI Advanced Features
   Kernel driver in use: ehci-pci

00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
   Subsystem: Lenovo Device 21f9
   Flags: bus master, medium devsel, latency 0
   Capabilities: [e0] Vendor Specific Information: Len=0c <?>
   Kernel driver in use: lpc_ich

00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04) (prog-if 01 [AHCI 1.0])
   Subsystem: Lenovo Device 21f9
   Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 40
   I/O ports at 4088 [size=8]
   I/O ports at 409c [size=4]
   I/O ports at 4080 [size=8]
   I/O ports at 4098 [size=4]
   I/O ports at 4060 [size=32]
   Memory at f1518000 (32-bit, non-prefetchable) [size=2K]
   Capabilities: [80] MSI: Enable+ Count=1/1 Maskable- 64bit-
   Capabilities: [70] Power Management version 3
   Capabilities: [a8] SATA HBA v1.0
   Capabilities: [b0] PCI Advanced Features
   Kernel driver in use: ahci

00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
   Subsystem: Lenovo Device 21f9
   Flags: medium devsel, IRQ 18
   Memory at f1514000 (64-bit, non-prefetchable) [size=256]
   I/O ports at efa0 [size=32]
   Kernel driver in use: i801_smbus

02:00.0 System peripheral: Ricoh Co Ltd MMC/SD Host Controller (rev 07) (prog-if 01)
   Subsystem: Lenovo Device 21f3
   Flags: bus master, fast devsel, latency 0, IRQ 16
   Memory at f0d00000 (32-bit, non-prefetchable) [size=256]
   Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
   Capabilities: [78] Power Management version 3
   Capabilities: [80] Express Endpoint, MSI 00
   Capabilities: [100] Virtual Channel
   Capabilities: [800] Advanced Error Reporting
   Kernel driver in use: sdhci-pci

03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 (rev 96)
   Subsystem: Intel Corporation Device c220
   Flags: bus master, fast devsel, latency 0, IRQ 43
   Memory at f0c00000 (64-bit, non-prefetchable) [size=8K]
   Capabilities: [c8] Power Management version 3
   Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Capabilities: [e0] Express Endpoint, MSI 00
   Capabilities: [100] Advanced Error Reporting
   Capabilities: [140] Device Serial Number
   Kernel driver in use: iwlwifi

questo il sistema e kernel che ho in uso:

[codeLinux darkstar 3.10.14 #1 SMP Tue Oct 1 15:57:54 CDT 2013 x86_64 Intel(R) Core(TM) i7-3667U CPU @ 2.00GHz GenuineIntel GNU/Linux][/code]

Ci sta qualche cosa che posso fare a livello di impostazioni per fare andare questo benedetto microfono interno? (quello a lato la cam del portatile per intenderci), un qualche file che devo settare io mettendo delle impostazioni specifiche ad esempio? in rete ho guardato altre discussioni inerenti il discorso skype e microfono non rilevato ma non ho trovato nulla adattato alla mia situazione.
Premetto che su altro portatile Lenovo che utilizzo (modello X220) che piu o meno ha lo stesso hardware, il microfono interno funziona senza problemi, cambia solo la sigla del dispositivo, dalla finestra impostazioni audio di skype viene sempre rilevato come HDA intel PCH, ALCaltrasigla, Analog Device (sysdefault:CARD:PCH)
ma cambia appunto la sigla dopo ALC.
Premetto che su Windows 8 il microfono su skype funziona regolarmente, questo per evitare che qualcuno pensi che magari sia guasto.
2 problema: scarsa autonomia del portatile
Premetto che su Windows 8 con il medesimo utilizzo, quindi in navigazione con qualche programma aperto come skype, msn, arrivo ad avere 6 ore piene di autonomia, su slackware ci faccio 4 ore scarse, come è possibile tutta questa differenza? pensavo che anzi linux usando meno risorse riuscisse a darmi quel quid in più, invece mi ritrovo con una autonomia molto ridotta, e per chi usa come me il portatile molto anche fuori casa, è un fattore molto importante. Non vi dico poi che autonomia mi da se inizio a guardare filmati su youtube o guardo qualche video, 2 ore scarse ed anche meno. Ci sta qualche cosa che va attivata per consumare meno? premetto anche che ho la luminosià del display ridotta sempre al minimo, e queste 4 ore scarse li faccio a casa sotto wifi, che dovrebbe consumarmi anche meno rispetto a collegamenti con chiavetta usb.
Premetto anche che sull'altro mio portatile Lenovo con slackware stessa versione e stesso utilizzo riesco a tirarci fuori una autonomia davvero importante, quasi 6 ore. capisco che quello ha un core i5 di seconda generazione, e uno schermo da 12.1 e non da 14 come questo che uso adesso, ma considerando che qui ho disco ssd (che dovrebbe consumare meno di quello meccanico) e processore intel core i7 di terza generazione, pensavo che i consumi potessero essere equivalenti. Qualche dritta??
Ultima modifica di tano70 il lun ott 28, 2013 11:06, modificato 2 volte in totale.
Avatar utente
tano70
Linux 2.0
Linux 2.0
 
Messaggi: 154
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: 14.1 stable 64bit
Kernel: 3.10.17
Desktop: Xfce

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda rik70 » mer ott 09, 2013 11:58

Per il microfono puoi provare a passare al modulo snd-hda-intel l'argomento 'model=', utilizzando uno di questi:
Codice: Seleziona tutto
ALC269/270/275/276/28x/29x
======
  laptop-amic           Laptops with analog-mic input
  laptop-dmic           Laptops with digital-mic input
  alc269-dmic           Enable ALC269(VA) digital mic workaround
  alc271-dmic           Enable ALC271X digital mic workaround
  inv-dmic              Inverted internal mic workaround
  lenovo-dock           Enables docking station I/O for some Lenovos
  dell-headset-multi    Headset jack, which can also be used as mic-in
  dell-headset-dock     Headset jack (without mic-in), and also dock I/O


Nella coolonna di sinistra il modello, a destra la descrizione.

Per fare questo senza dover ogni volta riavviare la macchina, da root dai 'init 3'

Poi rimuovi il modulo con:
Codice: Seleziona tutto
modprobe -v -r snd-hda-intel


Lo ricarichi con l'argomento model.
Es:
Codice: Seleziona tutto
modprobe -v snd-hda-intel model=alc269-dmic


Poi:
Codice: Seleziona tutto
sh /etc/rc.d/rc.alsa


Lanci alsamixer, premi tab per passare alla sezione "capture", regoli il mic, poi dai init 4 per ritornare alla sessione grafica e vedi se cambia qualcosa.

Se hai cul* funziona.

I "model" provali tutti, in particolare quelli che fanno riferimento al microfono.

Ps
A tuo rischio e pericolo ;)
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda tano70 » mer ott 09, 2013 12:52

Grazie per la dritta, sei puntualissimo e disponibile come sempre. Adesso sono a lavoro ma stasera quando torno a casa faccio subito la prova. Il procedimento è chiarissimo, anche se non capisco quella tua frase finale "a tuo rischio e pericolo" in che senso? che facendo quella operazione ci sta anche il rischio che scombino tutto il modulo o il buon funzionamento della macchina o di tutto l'hardware sonoro?? eventuali altre soluzioni meno invasive che potrei provare non ce ne stanno vero?
Avatar utente
tano70
Linux 2.0
Linux 2.0
 
Messaggi: 154
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: 14.1 stable 64bit
Kernel: 3.10.17
Desktop: Xfce

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda rik70 » mer ott 09, 2013 13:12

No, non scombussoli niente ne rompi niente.

Ma sai com'è... il PC non è mio, di conseguenza ... 8)
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda tano70 » mer ott 09, 2013 13:19

ah ok :) allora farò la procedura... e speriamo che risolvo!! a parte questo, slackware su questo portatile con ssd decolla!!! tutto alla grande, stabilissimo e velocissimo......
Ancora una cosa rik, se in uno dei futuri aggiornamenti "slackpkg update" per caso dovesse uscire una nuova versione del kernel superiore a quella che ho adesso in uso (3.10.14) per utilizzare poi questa nuova versione, devo rifare tutto quel laborioso procedimento sul boot efi? cioè ricreare initrd su quel nuovo kernel, metterlo sotto la directory efi e poi rinominare in efi? questo affinchè refind si accorga ed avvii il nuovo kernel? l'altro nel frattempo 3.10.14 mi resterebbe attivo o verrebbe cancellato? perchè se non ricordo male, tutte le volte che nell'altro portatile non efi dove ho slack, ho aggiornato il kernel, poi dovevo rilanciare lilo -v per fargli riconoscere il nuovo kernel, in quanto il vecchio veniva cancellato, altrimenti mi dava un boot error!! Anche in questo caso con "REFIND" (il bootloader che ho in uso adesso) sarebbe cosi? che se non ricompilo il modulo sul nuovo kernel e creo il relativo initrd, slackware non si avvierebbe?
Avatar utente
tano70
Linux 2.0
Linux 2.0
 
Messaggi: 154
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: 14.1 stable 64bit
Kernel: 3.10.17
Desktop: Xfce

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda rik70 » mer ott 09, 2013 13:55

tano70 ha scritto:ah ok :) a parte questo, slackware su questo portatile con ssd decolla!!! tutto alla grande, stabilissimo e velocissimo......

Immagino... e di questo, bonariamente, t'invidio :)

tano70 ha scritto:
Ancora una cosa rik, se in uno dei futuri aggiornamenti "slackpkg update" per caso dovesse uscire una nuova versione del kernel superiore a quella che ho adesso in uso (3.10.14) per utilizzare poi questa nuova versione, devo rifare tutto quel laborioso procedimento sul boot efi? cioè ricreare initrd su quel nuovo kernel, metterlo sotto la directory efi e poi rinominare in efi? questo affinchè refind si accorga ed avvii il nuovo kernel? l'altro nel frattempo 3.10.14 mi resterebbe attivo o verrebbe cancellato? perchè se non ricordo male, tutte le volte che nell'altro portatile non efi dove ho slack, ho aggiornato il kernel, poi dovevo rilanciare lilo -v per fargli riconoscere il nuovo kernel, in quanto il vecchio veniva cancellato, altrimenti mi dava un boot error!! Anche in questo caso con "REFIND" (il bootloader che ho in uso adesso) sarebbe cosi? che se non ricompilo il modulo sul nuovo kernel e creo il relativo initrd, slackware non si avvierebbe?


Allora, in linea generale la risposta è sì: dovrai ricreare un initrd copiarlo insieme al nuovo vmlinuz nella EFI, esattamente come hai fatto fin'ora.

Se rimane quello vecchio, questo non lo ricordo di preciso, ma penso di no. Ad ogni modo te ne accorgi guardando nella directory /lib/modules, nella directory /boot e /usr/src. Comunque mantienili sempre i "vecchi" initrd e vmlinuz che hai nella EFI, magari te li metti da parte.

In ogni caso ti consiglio di prendere a riferimento il sito dell'autore di rEfind.
A proposito di quest'ultimo:
http://www.rodsbooks.com/efi-bootloaders/refind.html

In particolare, dopo una lettura generale, soffermati su:
Adjusting refind_linux.conf

E' spiegato come rEFInd legge i "loaders" - vmlinuz e initrd (viene spiegato che refind può caricarli anche "fuori" dalla EFI) - e ti spiega come li puoi/devi "nominare" per fare sì che a uno specifico vmlinuz venga associato il proprio initrd e non un altro. Utilissimo ad esempio se ha più kernel per lo stesso sistema operativo.

Non solo:
sempre sul sito viene trattata anche la configurazione "avanzata" di refind.
Puoi fare praticamente di tutto:
ad es. creare delle sezioni - e sottosezioni - per caricare il sistema operativo tramite uno specifico bootloader (Ubuntu tramite GRUB2 ad esempio), kernel e impostazioni differenti, etc:
http://www.rodsbooks.com/refind/configfile.html
Insomma da leggere sicuramente! Troverai risposte a molte domande, anche a quelle che hai fatto nell'altra discussione.

Poi per la faccenda del mic: spero che funzioni.

Ciao
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda tano70 » gio ott 10, 2013 19:42

ho provato il comando che mi hai detto, ma quando do init 3 intanto non fa nulla, il terminale mi va semplicemente a capo, e poi digitando il modprobe essendo in uso non me lo fa cancellare. Quindi devo avviare da una live ed agire da chroot per fare la procedura consigliata?

Codice: Seleziona tutto
bash-4.2# init 3
bash-4.2# modprobe -v -r snd-hda-intel
modprobe: FATAL: Module snd_hda_intel is in use.


Oppure intendevi dire che per dare questi comandi devo fare un logout e darli dalla console tty come root? senza entrare in startx per intenderci
Avatar utente
tano70
Linux 2.0
Linux 2.0
 
Messaggi: 154
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: 14.1 stable 64bit
Kernel: 3.10.17
Desktop: Xfce

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda rik70 » gio ott 10, 2013 20:21

Tu usi startx?

Allora basta che esci dalla sessione grafica e lasci perdere init.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda tano70 » ven ott 11, 2013 19:21

niente da fare purtroppo il microfono continua a non essere rilevato. Magari aspetto una futura versione del kernel...chissà che non possa risolvere con il 3.11.X
Al momento è l'unica cosa che non va....poi il sistema è davvero perfetto!! se qualcuno ha qualche idea di soluzione posti pure. Ringrazio sempre e comunque la immensa disponibilità di rik70
A proposito se può essere utile posto anche il mio asound.conf che ho creato seguendo una indicazione in un forum...che in effetti mi amplifica il livello massimo del voume di alsa, dandomi una voce in piu nel mixer, che è appunto quella che mi gestisce l'amplificazione:

Codice: Seleziona tutto
[pcm.!default {
      type plug
      slave.pcm "softvol"
  }

  pcm.softvol {
      type softvol
      slave {
          pcm "dmix"
      }
      control {
          name "Pre-Amp"
          card 0
      }
      min_dB -5.0
      max_dB 20.0
      resolution 6
  }


che magari debba inserire qualche valore o voce in questo file per fare andare il microfono?
Avatar utente
tano70
Linux 2.0
Linux 2.0
 
Messaggi: 154
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: 14.1 stable 64bit
Kernel: 3.10.17
Desktop: Xfce

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda rik70 » sab ott 12, 2013 9:23

No, secondo me non è un problema di ~/.asoundrc o /etc/asound.conf.

Probabilmente è la solita questione del modulo snd-hda-intel che va configurato.

Nella directory dei sorgenti del kernel ('/usr/src/linux-{versione_kernel}) trovi la documentazione che riguarda il problema.

I file son questi:

Documentation/sound/alsa/HD-Audio-Controls.txt
Documentation/sound/alsa/HD-Audio-Models.txt
Documentation/sound/alsa/HD-Audio.txt

Gli ultimi 2 in particolare, partendo dall'ultimo.

Ciao
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda rik70 » lun ott 14, 2013 11:13

Prova anche questa:
incolla il risultato di
Codice: Seleziona tutto
arecord -L


Aggiungi anche una schermata di:
Codice: Seleziona tutto
alsamixer -V capture


Infine:
Codice: Seleziona tutto
cat /proc/asound/cards
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda tano70 » lun ott 14, 2013 20:55

rik70 ha scritto:Prova anche questa:
incolla il risultato di
Codice: Seleziona tutto
arecord -L


Codice: Seleziona tutto
bash-4.2$ arecord -L
null
    Discard all samples (playback) or generate zero samples (capture)
sysdefault:CARD=PCH
    HDA Intel PCH, ALC269VC Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC269VC Analog
    Front speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC269VC Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC269VC Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC269VC Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, ALC269VC Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, ALC269VC Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers]


Aggiungi anche una schermata di:
Codice: Seleziona tutto
alsamixer -V capture


Infine:
Codice: Seleziona tutto
cat /proc/asound/cards


Codice: Seleziona tutto
bash-4.2$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf1510000 irq 45
29 [ThinkPadEC     ]: ThinkPad EC - ThinkPad Console Audio Control
                      ThinkPad Console Audio Control at EC reg 0x30, fw unknown
Allegati
alsamixer.png
alsamixer.png (42.96 KiB) Osservato 1030 volte
Avatar utente
tano70
Linux 2.0
Linux 2.0
 
Messaggi: 154
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: 14.1 stable 64bit
Kernel: 3.10.17
Desktop: Xfce

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda rik70 » mar ott 15, 2013 9:06

Ok.

Premessa: in effetti ci sono alcuni controlli che non "quadrano". Dalla schermata di alsamixer nota come Mic Boost, che dovrebbe essere un interruttore, viene visto come un "cursore". Stessa cosa per "Capture". Ma aspetta: questo non è detto che sia sbagliato col tuo hardware

A questo punto prova:

spostati con le frecce sul controllo "Capture", premi la barra spaziatrice e vedi se si muove qualcosa. Dovrebbe servire a selezionare il dispositivo di cattura, e vedo che ne hai almeno 2: un ingresso analogico - presumo - e uno digitale.

Se non accade nulla, riprova come hai fatto prima a selezionare un"model" da passare al modulo snd-hda-intel. E controlla sempre da alsamixer se nella sezione "Capture" cambiano i nomi dei controlli o il tipo (interruttore/cursore).

Dopo che hai ricaricato il modulo controlla anche l'output di 'dmesg' - e lancia sempre 'sh /etc/rc.d/rc.alsa'.

Se puoi, metti da parte il file .asoundrc|asound.conf quando fai queste prove, onde evitare che interferisca con il rilevamento dei controlli. E se noti dei cambiamenti, magari ci fai un'altra bella istantanea di 'alsamixer -V capture'.

Infine:

fai tutto questo possibilmente non da KDE. Avvia una sessione grafica XFCE, ti verrà più comodo scaricare/ricaricare il modulo del kernel ed è molto meglio che stare su tty. Ovviamente dovrai chiudere i programmi che utilizzano l'audio.

Concludiamo con un altro parametro del modulo che puoi provare ad utilizzare in combinazione con l'altro o anche da solo:

enable_msi=

anche se penso che non c'entri con la questione, prova a mettere alternativamente o il valore 0 oppure 1.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda tano70 » mar ott 15, 2013 9:29

grazie per il tuo costante interessamento al mio problema rik. Per quanto riguarda il mio de, ho già in esecuzione xfce, odio KDE quindi di default ho messo solo quello. Oggi ho anche fatto tutti gli aggiornamenti proposti da slackware (finalmente dopo quasi 2 settimane si sono decisi ad aggiornare qualcosa) e sembra che questa sia la prima release candidate per essere la slack 14.1 ufficiale :D per fare andare la cosa ho dovuto fare da chroot lo stesso procedimento di creazione del vmlinuz e del ramdisk (con mkinitrd) sul nuovo kernel (3.10.16) e tutto ha funzionato come un fascino :) Ho solo un dubbio sul perchè sia stato costretto a fare i passaggi da chroot e non dal mio sistema slackware in uso, (ovviamente con la partizione ESP (sda2) che ho naturalmente montato). In pratica avevo cancellato il vecchio initrd e vmlinuz che erano risalenti al kernel 3.10.14 e ho semplicemente copiato i nuovi vmlinuz e initrd creati dal nuovo kernel in automatico nella directory boot di slackware, ma riavviando non aveva funzionato, il boot si bloccava. Così ho dovuto fare il procedimenti da chroot, andando nuovamente a dare il comando ./mkinitrd_command_generator e poi dando il comando mkinitrd ecc ecc, ho ricopiato dalla directory boot di slack (alla stessa maniera come avevo fatto precedentemente dal sistema in uso) e rinominandoli sempre in efi, e al riavvio tutto è andato bene. Solo per capire il perchè....non per altro :)
Per quando riguarda il microfono, anche con il kernel 3.10.16 continua a non essere rilevato....sta diventando davvero la mia bestia nera, ed è un peccato, visto che uso molto skype e non potere avere il microfono mi condiziona la funzionalità del sistema. Spero con i tuoi consigli di risolvere....stasera quando torno da lavoro proverò a seguire i tuoi consigli....
Avatar utente
tano70
Linux 2.0
Linux 2.0
 
Messaggi: 154
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: 14.1 stable 64bit
Kernel: 3.10.17
Desktop: Xfce

Re: Microfono interno non riconosciuto e ridotta autonomia

Messaggioda rik70 » mar ott 15, 2013 10:09

tano70 ha scritto:In pratica avevo cancellato il vecchio initrd e vmlinuz che erano risalenti al kernel 3.10.14 e ho semplicemente copiato i nuovi vmlinuz e initrd creati dal nuovo kernel in automatico nella directory boot di slackware, ma riavviando non aveva funzionato, il boot si bloccava.


Se non ho capito male, forse l'errore l'hai fatto nella parte in grassetto.

Non c'è nessun initrd creato in automatico quando aggiorni il kernel:
prima di riavviare, devi sempre ricrearlo "passando" a mkinitrd la versione del nuovo kernel. Probabilmente hai copiato il vecchio initrd e quindi giustamente il sistema non partiva.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti