Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto] problema Arduino

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto] problema Arduino

Messaggioda rfringuello89 » sab ott 19, 2013 12:47

Salve a tutti,
sono in possesso di un Arduino Uno e lo utilizzo da diverso tempo senza problemi, fino ad oggi!
Premetto che fin'ora veniva rilevato senza problemi, e anche adesso viene rilevato allo stesso modo ma quando avvio l'IDE arduino non mi permette di scegliere la porta su cui usarlo e di conseguenza non posso usarlo!
Non so se il problema possa essere correlato ma stamattina ho disinstallato e reinstallato il pacchetto kio-mtp-fae62fc_20121225git-x86_64-1
Qualche idea?
Grazie

Codice: Seleziona tutto
tail -f /var/log/messages
Oct 19 13:39:05 darkstar kernel: usb 5-2: new full-speed USB device number 5 using uhci_hcd
Oct 19 13:39:05 darkstar kernel: usb 5-2: New USB device found, idVendor=2341, idProduct=0043
Oct 19 13:39:05 darkstar kernel: usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=220
Oct 19 13:39:05 darkstar kernel: usb 5-2: Manufacturer: Arduino (www.arduino.cc)
Oct 19 13:39:05 darkstar kernel: usb 5-2: SerialNumber: 55330343731351907091
Oct 19 13:39:05 darkstar kernel: cdc_acm 5-2:1.0: ttyACM1: USB ACM device
Oct 19 13:39:05 darkstar mtp-probe: checking bus 5, device 5: "/sys/devices/pci0000:00/0000:00:1d.0/usb5/5-2"
Oct 19 13:39:05 darkstar mtp-probe: bus: 5, device: 5 was not an MTP device

dmesg
cdc_acm 5-2:1.0: ttyACM0: USB ACM device
usb 5-2: USB disconnect, device number 4
usb 5-2: new full-speed USB device number 5 using uhci_hcd
usb 5-2: New USB device found, idVendor=2341, idProduct=0043
usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=220
usb 5-2: Manufacturer: Arduino (www.arduino.cc)
usb 5-2: SerialNumber: 55330343731351907091
cdc_acm 5-2:1.0: ttyACM1: USB ACM device

ls -l /dev/ttyACM1
crw-rw---- 1 root dialout 166, 1 Oct 19 13:39 /dev/ttyACM1
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: problema Arduino

Messaggioda rfringuello89 » sab ott 19, 2013 15:29

Problema risolto... A quanto pare la libreria rxtx crea qualche problemino e l'ho dovuta cancellare....
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: problema Arduino

Messaggioda Vito » mer ott 23, 2013 10:25

Aggiungo "Risolto" al nome del topic.
Buon divertimento con Arduino! :thumbright:

P.S. hai visto l'ultimo arrivato? Il robot mobile che monta arduino:
http://arduino.cc/en/Main/Robot
http://www.youtube.com/watch?v=vlxH0DAv5ds
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4134
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti