Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Sync non funziona su chromium 30/31 stable

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Sync non funziona su chromium 30/31 stable

Messaggioda boh » mer nov 13, 2013 0:47

Ciao a tutti!
Oggi ho aggiornato alla 14.1 e ho compilato chromium 30.0.1599.114 (ho usato lo slackbuild di marlavo). La compilazione è andata a buon fine e il browser funziona, tranne per una cosa: la sincronizzazione.
In pratica quando cerco di loggarmi per sincronizzare i preferiti (e tutto il resto) ottengo "Oops sync has stopped working" e non mi fa entrare. Ovviamente username e password sono corretti perchè li uso con google chrome in cui sync funziona perfettamente.
Cercando in internet risulta che questo errore fa parte di un bug di maggio (2013) e che adesso dovrebbe essere risolto.

A qualcun'altro capita?
Intanto vi lascio il pacchetto nel caso vogliate provare (magari ho sbagliato qualcosa io): https://www.dropbox.com/sh/9642vsyxmpo2bqu/v9UvBSRcJF

P.S: problema e pacchetto a 64bit, su 32 non ho ancora provato.
Ultima modifica di boh il ven nov 15, 2013 12:51, modificato 1 volta in totale.
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 968
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.14.1
Desktop: KDE 4.13.3

Re: Sync non funziona su chromium 30/31 stable

Messaggioda boh » mer nov 13, 2013 17:53

Ho provato a compilare l'ultima stable (31.0.1650.48) e l'errore persiste :( (ho dovuto togliere chromedriver altrimenti non compilava; gli slackbuild infatti sono diversi)

Qualcuno potrebbe provare i pacchetti per capire se è un problema del mio sistema o del browser in sè?

Trovate entrambi i pacchetti (14.1 64bit) sempre qui: https://www.dropbox.com/sh/9642vsyxmpo2bqu/v9UvBSRcJF

Ci tengo a precisare che su chrome ripacchettizzato da binari .deb tutto funziona egregiamente (anche l'ultima stable).
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 968
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.14.1
Desktop: KDE 4.13.3

Re: Sync non funziona su chromium 30/31 stable

Messaggioda tano70 » gio nov 14, 2013 9:35

ciao boh, anche io ho avuto sempre lo stesso problema con chromium, che quando accedo, mi da un errore sulla sincronizzazione, al contrario di google chrome che invece mi sincronizza tutto senza problemi. Che ci sia una qualche libreria che manca nella versione chromium? Poi altra cosa.....il pacchetto che hai postato tu, la 31 etc, è una versione ufficiale e stabile di chromium? perchè io attualmente sto usando questa Versione 30.0.1599.114 (229842) e vorrei mettere l'ultima stable. Mi garantisci che posso installarla senza problemi nel mio sistema? porta qualche particolare miglioria evidente rispetto alla versione che uso io? premetto che anche io ho uso slackware 14.1 64 bit, su portatile con cpu core i7. Non vorrei che quella versione che hai postato tu l'hai compilata su un sistema diverso e usando quindi flag particolari. Dimmi qualcosa a tal proposito, grazie. Poi altra cosa ancora...mi posteresti già che ci siamo anche l'ultima versione stabile di google chrome pronta per essere installata? cioè in formato txz Grazie ancora :) Purtroppo qui sul sito nessuno posta mai versioni aggiornate....e questa su slackware è a mio avviso l'unica nota dolente rispetto agli altri sistemi linux che integrano sempre aggiornamenti continui per i pacchetti che uno vuole aggiornare. I browser per le varie problematiche legate alla sicurezza a mio avviso sono quei programmi che dovrebbero sempre essere aggiornati spesso!!
Avatar utente
tano70
Linux 2.4
Linux 2.4
 
Messaggi: 211
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: current 64bit
Kernel: 3.14.17
Desktop: Xfce

Re: Sync non funziona su chromium 30/31 stable

Messaggioda miklos » gio nov 14, 2013 11:12

chromium per sfruttare i servizi online di google richiede l'utilizzo delle 'google api keys'.
Dato che una volta generate è possibile inserirle a compile time, lo slackbuild di slacky intenzionalmente non le imposta perchè sono chiavi personali. E' possibile comunque indicarle a runtime.
Non uso e non usero' mai queste funzionalità, ma se con chrome funzionano out of the box, evidentemente quest'ultimo ha di suo delle chiavi incluse nel binario.
Per maggior info leggete qui

ciau

EDIT: se con altre distribuzioni, tipo arch linux funziona anche li' out-of-the box sappiate che probabilmente vengono usate chiavi 'generiche' per distribuzione (arch linux so per certo che lo fa perchè ho visto l'equivalemten 'slackbuild', con tutto quello che ne comporta!

RI-EDIT: tutto questo sempre che non le abbiate già impostate :)
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1288
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: Sync non funziona su chromium 30/31 stable

Messaggioda boh » gio nov 14, 2013 14:58

tano70 ha scritto:ciao boh, anche io ho avuto sempre lo stesso problema con chromium, che quando accedo, mi da un errore sulla sincronizzazione, al contrario di google chrome che invece mi sincronizza tutto senza problemi. Che ci sia una qualche libreria che manca nella versione chromium? Poi altra cosa.....il pacchetto che hai postato tu, la 31 etc, è una versione ufficiale e stabile di chromium? perchè io attualmente sto usando questa Versione 30.0.1599.114 (229842) e vorrei mettere l'ultima stable. Mi garantisci che posso installarla senza problemi nel mio sistema? porta qualche particolare miglioria evidente rispetto alla versione che uso io? premetto che anche io ho uso slackware 14.1 64 bit, su portatile con cpu core i7. Non vorrei che quella versione che hai postato tu l'hai compilata su un sistema diverso e usando quindi flag particolari. Dimmi qualcosa a tal proposito, grazie. Poi altra cosa ancora...mi posteresti già che ci siamo anche l'ultima versione stabile di google chrome pronta per essere installata?


Ciao tano, come ha detto miklos, il problema riguarda le api keys, ancora non so come risolvere, mi devo documentare.
La versione postata è stabile (quella che hai tu è l'ultima stabile prima di questa) pertanto non credo avrai problemi; il pacchetto è fatto per un'architettura a 64bit generica, quindi senza ottimizzazioni.
Il pacchetto di chrome lo sto caricando su dropbox proprio ora e lo trovi al link di prima ;)
Per avere un .txz di chrome, comunque, è veramente facile: prendi questi file, scarica la versione di google chrome in formato .deb (la trovi qui, scegli l'architettura giusta) e lanci lo slackbuild.

miklos ha scritto:chromium per sfruttare i servizi online di google richiede l'utilizzo delle 'google api keys'.
Dato che una volta generate è possibile inserirle a compile time, lo slackbuild di slacky intenzionalmente non le imposta perchè sono chiavi personali. E' possibile comunque indicarle a runtime.
Non uso e non usero' mai queste funzionalità, ma se con chrome funzionano out of the box, evidentemente quest'ultimo ha di suo delle chiavi incluse nel binario.
Per maggior info leggete qui

ciau

EDIT: se con altre distribuzioni, tipo arch linux funziona anche li' out-of-the box sappiate che probabilmente vengono usate chiavi 'generiche' per distribuzione (arch linux so per certo che lo fa perchè ho visto l'equivalemten 'slackbuild', con tutto quello che ne comporta!

RI-EDIT: tutto questo sempre che non le abbiate già impostate :)


Grazie della dritta! Mi usciva quel messaggio, ma non avevo intuito potesse essere questo il problema.
In effetti nel pkgbuild di Arch le chiavi sono specificate. Non mi è molto chiaro il loro funzionamento; soprattutto, che senso ha chiamare una chiave segreta se poi la si mette in uno script pubblico? Deduco che non servano a crittografare :badgrin:
Ma quindi se imposto le variabili di ambiente, sono a posto? È sufficiente farlo una volta sola?
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 968
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.14.1
Desktop: KDE 4.13.3

Re: Sync non funziona su chromium 30/31 stable

Messaggioda miklos » gio nov 14, 2013 15:32

boh ha scritto:Non mi è molto chiaro il loro funzionamento
in realtà è molto semplice perchè servono per autorizzare l'utilizzo di particolari chiamate http (le api di google appunto) identificando al tempo stesso chi le sta usando, inteso come software.
boh ha scritto:che senso ha chiamare una chiave segreta se poi la si mette in uno script pubblico?
infatti queste chiavi non implicano che poi tu non debba comunque inserire le credenziali del tuo account. servono solo ad identificare "l'applicazione".. in questo caso chromium targato arch linux.. in linea teorica, e del tutto a titolo di esempio per farti capire meglio visto che romperesti il disclaimer che ti riporto, potresti usare le chiavi del pacchetto in questione al posto di generartene delle tue
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
# get your own set of keys. Feel free to contact foutrelis@archlinux.org for
# more information.
su arch linux hanno adottato una strategia alla chrome, ovvero si sono creati e forniscono le loro chiavi.
Per fare la stessa cosa qui' su slacky occorrebbe generare delle chiavi targate 'slacky' da poter di conseguenza condividere cosi' da creare un pacchetto "chromium slacky". Cosa che al momento non so dirti se e quando si fara'.
boh ha scritto:Ma quindi se imposto le variabili di ambiente, sono a posto? È sufficiente farlo una volta sola?
dipende dove le setti.. se a livello di utente (quindi nei vari .bashrc o .bash_profile) o all'atto di invocare chromium con
Codice: Seleziona tutto
VARIABILE=pippo chromium
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1288
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: Sync non funziona su chromium 30/31 stable

Messaggioda boh » gio nov 14, 2013 15:52

E a google cosa serve sapere chi sta usando cosa? Sempre in termini di software, ovviamente.
Comunque la richiesta di chiavi non è complicata. Servirebbe a qualcosa chiedere a Pat di richiederle e condividerle con la comunità slackware?
Altrimenti, appunto, potremmo richiederle anche noi di slacky.
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 968
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.14.1
Desktop: KDE 4.13.3

Re: Sync non funziona su chromium 30/31 stable

Messaggioda miklos » gio nov 14, 2013 16:04

boh ha scritto:E a google cosa serve sapere chi sta usando cosa? Sempre in termini di software, ovviamente.
prova ad indovinare... :D
comunque 'illazioni' a parte questo tipo di 'infrastruttra' fa si che sia molto piu' semplice tracciare chi fa cosa e con quale account (google-analytics per esempio riconosce cosi' un particolare sito e popola il database delle statistiche di conseguenza) con il meraviglioso vantaggio di poter in qualsiasi momento revocare le chiavi utilizzate da software 'malevolo' (e non mi riferisco solo a google.. parlo anche del proprietario delle chiavi).
boh ha scritto:Comunque la richiesta di chiavi non è complicata. Servirebbe a qualcosa chiedere a Pat di richiederle e condividerle con la comunità slackware?
si ho visto.. il problema è che per quanto riguarda slacky, io non ho il 'potere' necessario a fare la richiesta con account ufficiali, e comunque per come la vedo io una volta individuato il problema costa poco farsene di proprie.. per il discorto di Pat ci si puo' provare, ma immagino già la risposta :D
considerando pure che chromium non è nemmeno fra i pacchetti ufficiali.
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1288
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: Sync non funziona su chromium 30/31 stable

Messaggioda tano70 » ven nov 15, 2013 8:28

Grazie per le dritte Boh :D
Ho installato direttamente i pacchetti che hai postato, di entrambi i browser, li ho aggiornati senza alcun problema. Al momento tutto ok, resta sempre il problema delle api keys su chromium, ma quello ovviamente viste le considerazioni che sono state fatte è normale che non vada. vedremo in futuro se sarà saggio integrarle o meno.
Avatar utente
tano70
Linux 2.4
Linux 2.4
 
Messaggi: 211
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: current 64bit
Kernel: 3.14.17
Desktop: Xfce

Re: Sync non funziona su chromium 30/31 stable

Messaggioda boh » ven nov 15, 2013 9:01

miklos ha scritto:
boh ha scritto:E a google cosa serve sapere chi sta usando cosa? Sempre in termini di software, ovviamente.
prova ad indovinare... :D
comunque 'illazioni' a parte questo tipo di 'infrastruttra' fa si che sia molto piu' semplice tracciare chi fa cosa e con quale account (google-analytics per esempio riconosce cosi' un particolare sito e popola il database delle statistiche di conseguenza) con il meraviglioso vantaggio di poter in qualsiasi momento revocare le chiavi utilizzate da software 'malevolo' (e non mi riferisco solo a google.. parlo anche del proprietario delle chiavi).
boh ha scritto:Comunque la richiesta di chiavi non è complicata. Servirebbe a qualcosa chiedere a Pat di richiederle e condividerle con la comunità slackware?
si ho visto.. il problema è che per quanto riguarda slacky, io non ho il 'potere' necessario a fare la richiesta con account ufficiali, e comunque per come la vedo io una volta individuato il problema costa poco farsene di proprie.. per il discorto di Pat ci si puo' provare, ma immagino già la risposta :D
considerando pure che chromium non è nemmeno fra i pacchetti ufficiali.


Chiedendo a Loris per slacky? Lo so che potrei chiedermi le mie, ma mi sembra molto meglio chiederne un set per la community e mettere tale opzione nello slackbuild :)

tano70 ha scritto:Grazie per le dritte Boh :D
Ho installato direttamente i pacchetti che hai postato, di entrambi i browser, li ho aggiornati senza alcun problema. Al momento tutto ok, resta sempre il problema delle api keys su chromium, ma quello ovviamente viste le considerazioni che sono state fatte è normale che non vada. vedremo in futuro se sarà saggio integrarle o meno.


Prego :)
Giusto per la cronaca, è uscita un'atra stable di chrome, la trovi sempre al link sopra (in 10min circa).
Ultima modifica di boh il ven nov 15, 2013 13:23, modificato 1 volta in totale.
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 968
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.14.1
Desktop: KDE 4.13.3

Re: Sync non funziona su chromium 30/31 stable

Messaggioda tano70 » ven nov 15, 2013 12:39

sei mitico boh!! la scarico subito...ma analogamente anche per chromium è disponibile la stessa stable? se si...cortesemente posti sempre il txz aggiornato anche di chromium? graze ancora boh!!
Avatar utente
tano70
Linux 2.4
Linux 2.4
 
Messaggi: 211
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: current 64bit
Kernel: 3.14.17
Desktop: Xfce

Re: Sync non funziona su chromium 30/31 stable

Messaggioda boh » ven nov 15, 2013 12:51

tano70 ha scritto:sei mitico boh!! la scarico subito...ma analogamente anche per chromium è disponibile la stessa stable? se si...cortesemente posti sempre il txz aggiornato anche di chromium? graze ancora boh!!


È disponibile sicuro, ma non l'ho ancora compilato e finchè non risolvo con le chiavi non so se lo farò :roll:
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 968
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.14.1
Desktop: KDE 4.13.3

Re: [RISOLTO] Sync non funziona su chromium 30/31 stable

Messaggioda tano70 » sab nov 16, 2013 14:59

Boh sto cercando di compilarmi l'ultima versione stable di chromium, visto che tu hai detto di non seguirla piu, Ho scaricato il sorgente dell'ultima versione stable con finale 57 e sto usando lo slackbuilds di marlavo, ma ottengo un errore sul chromium driver in fase di compilazione. Mi dici cosa hai disattivato di preciso nello slackbuilds per fare andare questa versione *.57?
Esattamente cosa comporta o quali funzionalità mancano disattivando questa chromium driver? mi spieghi in parole molto base, cosa sono e a cosa servono?
Avatar utente
tano70
Linux 2.4
Linux 2.4
 
Messaggi: 211
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: current 64bit
Kernel: 3.14.17
Desktop: Xfce

Re: [RISOLTO] Sync non funziona su chromium 30/31 stable

Messaggioda boh » sab nov 16, 2013 15:09

Prendi lo slackbuild della versione 31 dal link di dropbox, è modificato per escludere chromedriver ;)
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 968
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.14.1
Desktop: KDE 4.13.3

Re: [RISOLTO] Sync non funziona su chromium 30/31 stable

Messaggioda tano70 » sab nov 16, 2013 16:14

perfetto grazieeee :)
Avatar utente
tano70
Linux 2.4
Linux 2.4
 
Messaggi: 211
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: current 64bit
Kernel: 3.14.17
Desktop: Xfce

Prossimo

Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite