Repository 32bit  Forum
Repository 64bit  Wiki

14.1: il server X crasha

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: 14.1: il server X crasha

Messaggioda samiel » lun nov 18, 2013 2:58

Potrebbe essere il driver Nouveau a dare problemi?

No, perché in questo pc io ho una vecchia ATI Radeon ...
Sono stupito anch'io per questo inconveniente,
per cui allo stato attuale non posso usare convenientemente la Slack :-(
Se fosse un bug, sarebbe sconcertante dopo un anno di lavoro
per passare dalla 14.0 alla 14.1. Eppure stesso problema
in due configurazioni diverse, non dipende certo dal tuo hd.
Che facciamo, segnaliamo a info@slackware.com ?
Altri hanno problemi simili? In google al momento non trovo
notizia di un simile inconveniente da altri
m
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Re: 14.1: il server X crasha

Messaggioda sixjan » lun nov 18, 2013 10:05

Anch'io ho cercato su Google e non trovo altri casi per ora, ed è strano. Sembra un bug molto specifico. La notizia che hai ATI è sconfortante, nel senso che avevo intenzione di reinstallare e provare con i driver proprietari. Sulla segnalazione, non so. Oggi provo a reinstallare con solo XFCE e vedo coma va.
sixjan
Linux 2.4
Linux 2.4
 
Messaggi: 407
Iscritto il: dom gen 06, 2008 11:46
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: Xfce 4.10

Re: 14.1: il server X crasha

Messaggioda samiel » lun nov 18, 2013 10:17

Sì, è un pc vecchio e ci ho messo una ancora più vecchia ATI Radeon
dopo che la Nvidia si era bruciata. Ovvio che non può dipendere
né dalla ISO né da problemi hardware dei nostri pc. Anch'io
ho riformattato verificando lo stato dell'hd, ma è impossibile
che abbiamo gli stessi settori danneggiati e che ci va sempre
sopra lo stesso file. Purtroppo aggiungere a mano la libreria
di cui lamenta la mancanza non ha risolto perché escono
a effetto domino altri problemi. Davvero sconcertante.
Intanto ho rimesso la 14.0, ma non è certo una soluzione...

m
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Re: 14.1: il server X crasha

Messaggioda sixjan » lun nov 18, 2013 11:35

Dunque. Ho appena reinstallato. Stavolta, per cambiare, ho formattato ext3 e ho installato solo XFCE. XFCE parte, ma poi ho di nuovo quel crash che non lascia traccia: se clicco l'icona del browser nel pannello inferiore. Anch'io ho nu PC vecchio (7 anni). Farò qualche altro esperimento.
sixjan
Linux 2.4
Linux 2.4
 
Messaggi: 407
Iscritto il: dom gen 06, 2008 11:46
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: Xfce 4.10

Re: 14.1: il server X crasha

Messaggioda sixjan » lun nov 18, 2013 12:18

Ok. Piccolo passetto avanti. Con XFCE funziona quasi tutto, tranne Firefox e Thunderbird e qualche volta Seamonkey. Ho intercettato l'errore di FF prima che X vada in crash:

GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

Questo bug è noto, si trova traccia nel web, anche in altre distro. Ad alcuni capita proprio così, cioè che X va in crash. Ad altri semplicemente non parte FF. A te Firefox e Thunderbird partono con la 14.1? Forse alcune macchine hanno dei problemi con queste librerie glib? Da lì i problemi con KDE? Non capisco perè perché Calligra mi funzionava e kubrik crashava però.
Ultima modifica di sixjan il lun nov 18, 2013 12:32, modificato 1 volta in totale.
sixjan
Linux 2.4
Linux 2.4
 
Messaggi: 407
Iscritto il: dom gen 06, 2008 11:46
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: Xfce 4.10

Re: 14.1: il server X crasha

Messaggioda rik70 » lun nov 18, 2013 12:26

Prima di segnalare bug, io proverei a fare il boot col kernel generic - niente huge - e poi a disabilitare l'estensione "Composite" di xorg:
http://slackware.osuosl.org/slackware-14.1/CHANGES_AND_HINTS.TXT ha scritto:
Use one of the provided generic kernels for daily use. Do not report
bugs until/unless you have reproduced them using one of the stock
generic kernels. You will need to create an initrd in order to boot
the generic kernels - see /boot/README.initrd for instructions.
--------

[...]try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection



I problemi con nouveau, o anche con radeon su vecchie schede ati, sono tutt'altro che inconsueti.

Occhio anche alla questione framebuffer + KMS.

Questo ovviamente non ha niente a che vedere con errori dovuti a librerie mancanti.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1217
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: 14.1: il server X crasha

Messaggioda samiel » lun nov 18, 2013 16:30

Col generic mi va in kernel panic....

m
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Re: 14.1: il server X crasha

Messaggioda rik70 » lun nov 18, 2013 16:55

samiel ha scritto:Col generic mi va in kernel panic....

m


Con errore.... ?

Vedi se per caso c'è qualcosa che fa riferimento alla root.

Hai caricato i moduli necessari al boot nell'initrd, come ad es. ext3/4?

Se ce la fai, incolla qui /etc/fstab e il config del bootloader che utilizzi.

Ciao
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1217
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: 14.1: il server X crasha

Messaggioda sixjan » lun nov 18, 2013 17:05

A me il generic-smp parte correttamente su partizione ext3 e initrd relativo, sia disabilitando composite che non. Il problema di firefox è strano: se elimino la directory .mozilla parte regolarmente anche se mi dà il messaggio d'errore. Adesso provo a reinstallare KDE e poi i driver proprietari Nvidia.
sixjan
Linux 2.4
Linux 2.4
 
Messaggi: 407
Iscritto il: dom gen 06, 2008 11:46
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: Xfce 4.10

Re: 14.1: il server X crasha

Messaggioda samiel » lun nov 18, 2013 17:45

A parte il kernel panic (la partizione è in EXT4),
con fbox non vanno in crash né Firefox né Thunderbird.
Il mio problema è "limitato" a KDE...

comunque attualmente avvio da DEbian. Ecco fstab:
Codice: Seleziona tutto
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# was on/dev/sda1 during installation
UUID=ACF03CCFF03CA20E /mnt/windows ntfs-3g silent,umask=000,locale=it_IT.utf8 0 0
# / was on /dev/sda2 during installation
UUID=e7edeb75-4b08-43c6-ae0a-8673590b3f77 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda3 during installation
UUID=02704c1d-31e5-44ad-b0d6-58f395a47bdb /home           ext4    defaults        0       2
# /mnt/archivio was on /dev/sdb2 during installation
UUID=a8dde9fd-f180-4345-9377-fd7c557011d9 /mnt/archivio   ext4    defaults        0       2
# /mnt/slackware was on /dev/sdb1 during installation
UUID=09eb8723-34fa-4d67-bad3-22b60b45c476 /mnt/slackware  ext4    defaults        0       2
# swap was on /dev/sda4 during installation
UUID=028b047a-0aaa-4ebe-bc98-1470a5c486bc none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

Uso Grub2, e ni /boot/grub/grub.cfg Slack è indicata così:
Codice: Seleziona tutto
menuentry "Slackware Linux (Slackware 14.1) (on /dev/sdb1)" --class gnu-linux --class gnu --class os {
   insmod part_msdos
   insmod ext2
   set root='(hd1,msdos1)'
   search --no-floppy --fs-uuid --set=root 09eb8723-34fa-4d67-bad3-22b60b45c476
   linux /boot/vmlinuz-generic-3.10.17 root=/dev/sdb1
}
menuentry "Slackware Linux (Slackware 14.1) (on /dev/sdb1)" --class gnu-linux --class gnu --class os {
   insmod part_msdos
   insmod ext2
   set root='(hd1,msdos1)'
   search --no-floppy --fs-uuid --set=root 09eb8723-34fa-4d67-bad3-22b60b45c476
   linux /boot/vmlinuz-generic-smp-3.10.17-smp root=/dev/sdb1
}
menuentry "Slackware Linux (Slackware 14.1) (on /dev/sdb1)" --class gnu-linux --class gnu --class os {
   insmod part_msdos
   insmod ext2
   set root='(hd1,msdos1)'
   search --no-floppy --fs-uuid --set=root 09eb8723-34fa-4d67-bad3-22b60b45c476
   linux /boot/vmlinuz-huge-3.10.17 root=/dev/sdb1
}
menuentry "Slackware Linux (Slackware 14.1) (on /dev/sdb1)" --class gnu-linux --class gnu --class os {
   insmod part_msdos
   insmod ext2
   set root='(hd1,msdos1)'
   search --no-floppy --fs-uuid --set=root 09eb8723-34fa-4d67-bad3-22b60b45c476
   linux /boot/vmlinuz-huge-smp-3.10.17-smp root=/dev/sdb1

Perché
Codice: Seleziona tutto
insmod ext2
se è EXT4 ???
m
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Re: 14.1: il server X crasha

Messaggioda rik70 » lun nov 18, 2013 18:29

samiel ha scritto:
Codice: Seleziona tutto
menuentry "Slackware Linux (Slackware 14.1) (on /dev/sdb1)" --class gnu-linux --class gnu --class os {
   insmod part_msdos
   insmod ext2
   set root='(hd1,msdos1)'
   search --no-floppy --fs-uuid --set=root 09eb8723-34fa-4d67-bad3-22b60b45c476
   linux /boot/vmlinuz-generic-3.10.17 root=/dev/sdb1
}

Perché
Codice: Seleziona tutto
insmod ext2
se è EXT4 ???
m


Cito solo la parte che interessa, fstab lo prendiamo per buono, dato che dagli UUID non si capisce a quale device punta, ma a questo credo ci abbia pensato tu ;)

Allora, da quello che vedo - tieni presente che grub2 lo conosco poco - manca l'initrd nel file di configurazione. In sostanza carichi l'immagine del kernel generico, ma non l'initrd che ti serve per caricare quantomeno il modulo ext4. A quel punto va in panic perché non riesce a montare la root ( root=/dev/sdb1 ). O almeno così pare. La soluzione: creare l'initrd per il kernel generic includendo il modulo ext4 ed inserire l'entry nel file di configurazione di grub.

Quel 'insmod ext2' credo sia corretto - ma bisognerebbe guardare il man di grub2. Se non ricordo male, al di la del nome "fuorviante", carica il modulo necessario per leggere i filesystem ext. Però magari controlla, perché ripeto... di grub2 so poco. Comunque a intuito, se Debian ce l'hai in ext3/4 e parte , allora è giusto.

Quanto a KDE: prova come detto sopra a disabilitare il Compositing e vedi se il crash persiste.

Ciao
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1217
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: 14.1: il server X crasha

Messaggioda sixjan » lun nov 18, 2013 19:03

Buone notizie.

rik70 mi ha messo sulla direzione giusta:

try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection


Ho creato quel file. Poi ho reinstallato KDE con installpkg *.txz dentro la dir kde del DVD d'installazione. Reboot e finalmente KDE è partito. Ho provato sia col kernel huge che col generic e KDE parte con entrambi.

Sintesi: disabilitare Composite ha risolto la parte KDE.

Firefox sotto KDE parte, sotto XFCE al secondo avvio crasha X. Poi c'è kubrik che mi crasha tutto (scoperto per caso).

Conclusioni personali: per me KDE, visto la vecchiaia del mio PC è inutilizzabile. Risolverò in qualche modo il problema di FF (ho visto che un altro utente ha un problema simile).

Penso che il Composite dovrebbe essere disabilitato di default alla prima installazione. Un nuovo utente che arriva a Slackware magari ha qualche difficoltà a disabilitarlo e si trova KDE impallato.

Grazie rik70, grazie samiel.
sixjan
Linux 2.4
Linux 2.4
 
Messaggi: 407
Iscritto il: dom gen 06, 2008 11:46
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: Xfce 4.10

Re: 14.1: il server X crasha

Messaggioda samiel » lun nov 18, 2013 20:25

Dopo provo! comunque, non è che viva per vedere il cubo rotante di KDE,
ma in questo modo si perdono irreparabilmente tutti gli effetti?
Se fosse così certo no si perde nulla di essenziale,
ma evidentemente c'è qualcosa che non funziona...

m
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Re: 14.1: il server X crasha

Messaggioda rik70 » mar nov 19, 2013 14:43

samiel ha scritto:Dopo provo! comunque, non è che viva per vedere il cubo rotante di KDE,
ma in questo modo si perdono irreparabilmente tutti gli effetti?
Se fosse così certo no si perde nulla di essenziale,
ma evidentemente c'è qualcosa che non funziona...

m


Sì, ovviamente gli effetti di kde li perdi.

Puoi provare a fare un downgrade dei driver ati, sempre che compilino sulla nuova Slack. Ad esempio prova con la versione 6.14.4, quella utilizzata in slackware 14.0. Poi riabiliti il composite e vedi come va.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1217
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: 14.1: il server X crasha

Messaggioda samiel » mar nov 19, 2013 14:54

Allora. ho creato il file /etc/X11/xorg.conf.d/disable-composite.conf
col contenuto indicato, ho creato l'initrd che mancava e adesso infatti
avvio anche col kernel generic. Ma al momento di lanciare KDE:
Codice: Seleziona tutto
xauth:  file /root/.serverauth.1390 does not exist

X.Org X Server 1.14.3
Release Date: 2013-09-12
X Protocol Version 11, Revision 0
Build Operating System: Slackware 14.1 Slackware Linux Project
Current Operating System: Linux darkstar 3.10.17 #1 Wed Oct 23 17:38:30 CDT 2013 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-generic-3.10.17 root=/dev/sdb1
Build Date: 09 October 2013  09:56:03PM
 
Current version of pixman: 0.30.2
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 19 14:46:52 2013
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
(II) [KMS] Kernel modesetting enabled.
xset:  bad font path element (#10), possible causes are:
    Directory does not exist or has wrong permissions
    Directory missing fonts.dir
    Incorrect font server address or syntax
startkde: Starting up...
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kbuildsycoca4 running...
kbuildsycoca4(1469) KBuildSycoca::checkTimestamps: checking file timestamps
kbuildsycoca4(1469) KBuildSycoca::checkTimestamps: timestamps check ok
kbuildsycoca4(1469) kdemain: Emitting notifyDatabaseChanged ()
This backend is only for XRandR 1.1, your version is:  1 . 3
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kded(1466) Kded::loadModule: Could not load library "kded_powerdevil" . [ "Cannot load library /usr/lib/kde4/kded_powerdevil.so: (libXxf86vm.so.1: cannot open shared object file: No such file or directory)" ]
QObject::connect: Cannot connect (null)::deviceFound(Device*) to BlueDevilDaemon::deviceFound(Device*)
QObject::connect: Cannot connect QTimer::timeout() to (null)::stopDiscovery()
kded(1466) Kded::loadModule: Could not load library "kded_keyboard" . [ "Cannot load library /usr/lib/kde4/kded_keyboard.so: (libXxf86vm.so.1: cannot open shared object file: No such file or directory)" ]
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kded(1466)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.5'
Could not open library ksmserver: Cannot load library /usr/lib/libkdeinit4_ksmserver.so: (libXxf86vm.so.1: cannot open shared object file: No such file or directory)
ksmserver: error while loading shared libraries: libXxf86vm.so.1: cannot open shared object file: No such file or directory
startkde: Shutting down...
klauncher: Exiting on signal 1
QThread: Destroyed while thread is still running
startkde: Running shutdown scripts...
startkde: Done.
xinit: connection to X server lost

waiting for X server to shut down (EE) Server terminated successfully (0). Closing log file.

E siamo al punto di partenza..... Però nel logo leggo fra l'altro:
Codice: Seleziona tutto
Initializing built-in extension COMPOSITE
e mi insospettisco.
L'ho disabilitato davvero? Serve aggiungere quel file? Perché non lavorare
all'interno dei file di configurazione già presenti?

m
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

PrecedenteProssimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Exabot [Bot], Google [Bot] e 1 ospite