Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] 14.1 crash di amule

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] 14.1 crash di amule

Messaggioda Rama » dom nov 10, 2013 9:33

a volte, guardando un filmato in firefox 25.0, succede che amule 2.2.6 si chiude;
capita anche a voi?
uso la 2.2.6 perché versioni più recenti non mi danno la possibilità di tenere agevolmente d'occhio i file in up, cosa che m'interessa particolarmente, essendo un rilasciatore;
proverò ad usare per un po' chromium, ma se avete suggerimenti fatevi avanti;

EDIT: con chromium non c'è problema, solo che non mi apre i link ed2k, penso che dovrei modificare xdg-open ma non ci ho capito nulla

RIEDIT: succede anche con chromium, ho provato l'ultima versione di amule e il risultato non cambia, allora ho ricompilato la 2.2.6, con un piccolo intoppo: ho dovuto correggere il file ObservableQueue.h -ora sembra andare, incrociando i diti ;-P

r
Ultima modifica di Rama il gio nov 21, 2013 12:47, modificato 1 volta in totale.
Un Minuto Per Favore: http://www.umpf.net
Home Page, The Pentangle, I Salon di Baudelaire
Avatar utente
Rama
Linux 2.4
Linux 2.4
 
Messaggi: 227
Iscritto il: sab mar 29, 2008 12:18
Località: Novara, provincia
Slackware: 14.1 64bit
Kernel: 3.12.6 preemptive
Desktop: KDE 4.10.5
Distribuzione: Debian testing

Re: 14.1 problema con firefox+amule

Messaggioda Rama » ven nov 15, 2013 19:54

niente da fare, ho dovuto fare uno script da mettere in cron per monitorare ogni 5 minuti se amule è in funzione;
al riavvio lancerò amule da shell sperando mi dia qlc suggermento sul problema;

r
Un Minuto Per Favore: http://www.umpf.net
Home Page, The Pentangle, I Salon di Baudelaire
Avatar utente
Rama
Linux 2.4
Linux 2.4
 
Messaggi: 227
Iscritto il: sab mar 29, 2008 12:18
Località: Novara, provincia
Slackware: 14.1 64bit
Kernel: 3.12.6 preemptive
Desktop: KDE 4.10.5
Distribuzione: Debian testing

Re: 14.1 problema con firefox+amule

Messaggioda Rama » sab nov 16, 2013 21:27

si è aggiunto un altro problema;
è defunto l'APC back-ups, ne ho preso un altro ma ora apcupsd non riesce a connettersi, programma e settaggi sono gli stessi della 14;
penso che comunque l'APC dovrebbe funzionare lo stesso ma nel dubbio, e visti anche i problemi con amule, sono ritornato alla 14;
se c'è chi ha avuto questi problemi ed ha risolto scriva come qui sotto ;-P

r
Un Minuto Per Favore: http://www.umpf.net
Home Page, The Pentangle, I Salon di Baudelaire
Avatar utente
Rama
Linux 2.4
Linux 2.4
 
Messaggi: 227
Iscritto il: sab mar 29, 2008 12:18
Località: Novara, provincia
Slackware: 14.1 64bit
Kernel: 3.12.6 preemptive
Desktop: KDE 4.10.5
Distribuzione: Debian testing

Re: 14.1 problema con firefox+amule

Messaggioda Rama » mer nov 20, 2013 22:49

forse ci siamo, incrociando i diti;
apcupsd ora va, prob. quando l'ho compilato avevo dimenticato qlc opzione nel config;
per amule avevo riciclato la configurazione della 14, partendo da zero sembra andare, se regge fino a domani si possono considerare i problemi risolti;

r
Un Minuto Per Favore: http://www.umpf.net
Home Page, The Pentangle, I Salon di Baudelaire
Avatar utente
Rama
Linux 2.4
Linux 2.4
 
Messaggi: 227
Iscritto il: sab mar 29, 2008 12:18
Località: Novara, provincia
Slackware: 14.1 64bit
Kernel: 3.12.6 preemptive
Desktop: KDE 4.10.5
Distribuzione: Debian testing

Re: [RISOLTO] 14.1 crash di amule

Messaggioda Rama » dom nov 24, 2013 9:14

ultimo (spero) aggiornamento: amule in versione 2.2.6 ha resistito quasi 24 ore, poi è crashata, la 2.3.1 finora va;
peccato che con questa versione non si possano avere sott'occhio contemporaneamente i file in down e quelli in up, pazienza;
per chi avesse il problema e non riuscisse a risolverlo, in rete ho trovato uno script che riavvia amule in caso di crash, migliore di quello che avevo fatto io:

#!/bin/bash
while [ 1 ]
do
amule
if test $? -eq 0
then
exit 1
fi
done

per chi non è esperto: le righe vanno copiate in un file di testo con nome a piacere, gli va dato il permesso di esecuzione e messo come root preferibilmente in /usr/local/bin;
per lanciarlo basta immettere il nome del file in una shell o in Esegui comando;
si può anche fare in modo che il lanciatore di amule nel pannello o nel menu punti ad esso, in KDE cliccando col destro su Kmenu, quindi in Modifica applicazioni/Internet/aMule/Comando si sceglie il file;

r
Un Minuto Per Favore: http://www.umpf.net
Home Page, The Pentangle, I Salon di Baudelaire
Avatar utente
Rama
Linux 2.4
Linux 2.4
 
Messaggi: 227
Iscritto il: sab mar 29, 2008 12:18
Località: Novara, provincia
Slackware: 14.1 64bit
Kernel: 3.12.6 preemptive
Desktop: KDE 4.10.5
Distribuzione: Debian testing


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron