Repository 32bit  Forum
Repository 64bit  Wiki

connessione tcp pacchetti persi

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

connessione tcp pacchetti persi

Messaggioda dafrasaga » lun dic 02, 2013 14:01

Ciao a tutti,
ho implementato da poco un router-firewall con una distro linux a cui ho collegato vari pc cablati e due AP wifi multi SSID.
Da rete cablata non vi sono problemi, ma dalla rete wifi non riesco ad accedere, se su VLAN, alla porta 80 per il management del FW.
Da una dump di tcp dump sembra che ad un certo punto della connessione tcp si perdano i pacchetti.

Vi spiego, da tcpdump:

18:20:54.494716 192.168.20.67.38183 > 192.168.20.1.443: S 1201239132:1201239132(0) win 14600 <mss 1460,sackOK,timestamp 62707 0,nop,wscale 6> (DF)
18:20:54.494816 192.168.20.1.443 > 192.168.20.67.38183: S 927215762:927215762(0) ack 1201239133 win 14480 <mss 1460,sackOK,timestamp 160757241 62707,nop,wscale 7> (DF)
18:20:54.497130 192.168.20.67.38183 > 192.168.20.1.443: . ack 927215763 win 229 <nop,nop,timestamp 62710 160757241> (DF)
18:20:54.497640 192.168.20.67.38183 > 192.168.20.1.443: P 1201239133:1201239452(319) ack 927215763 win 229 <nop,nop,timestamp 62710 160757241> (DF)
18:20:54.497695 192.168.20.1.443 > 192.168.20.67.38183: . ack 1201239452 win 122 <nop,nop,timestamp 160757242 62710> (DF)
18:20:54.522811 192.168.20.1.443 > 192.168.20.67.38183: . 927215763:927217211(1448) ack 1201239452 win 122 <nop,nop,timestamp 160757248 62710> (DF)
18:20:54.522849 192.168.20.1.443 > 192.168.20.67.38183: P 927217211:927218120(909) ack 1201239452 win 122 <nop,nop,timestamp 160757248 62710> (DF)
18:20:54.526541 192.168.20.67.38183 > 192.168.20.1.443: . ack 927215763 win 229 <nop,nop,timestamp 62739 160757242,nop,nop,sack sack 1 {927217211:927218120} > (DF)
18:20:54.725662 192.168.20.1.443 > 192.168.20.67.38183: . 927215763:927217211(1448) ack 1201239452 win 122 <nop,nop,timestamp 160757299 62739> (DF)
18:20:55.133659 192.168.20.1.443 > 192.168.20.67.38183: . 927215763:927217211(1448) ack 1201239452 win 122 <nop,nop,timestamp 160757401 62739> (DF)
18:20:55.949687 192.168.20.1.443 > 192.168.20.67.38183: . 927215763:927217211(1448) ack 1201239452 win 122 <nop,nop,timestamp 160757605 62739> (DF)
18:20:57.585673 192.168.20.1.443 > 192.168.20.67.38183: . 927215763:927217211(1448) ack 1201239452 win 122 <nop,nop,timestamp 160758014 62739> (DF)
18:21:00.857669 192.168.20.1.443 > 192.168.20.67.38183: . 927215763:927217211(1448) ack 1201239452 win 122 <nop,nop,timestamp 160758832 62739> (DF)


Come vedere ad un certopunto il 192.168.20.67 si aspetta la sequenza tcp n° 927215763 che il 192.168.20.1 gli rimanda in contonuazione senza avere il che minimo acknowledge.

Sono oramai settimate che ci stò battendo il capo ma non riesco a capire cosa succeda.
Il problema lo ho con slack64 14.0.

Se invece non setto nessuna VLAN il tutto funziona regolarmente.
dafrasaga
Linux 1.0
Linux 1.0
 
Messaggi: 79
Iscritto il: mar set 08, 2009 10:39
Località: Vinci -FI-
Slackware: 14 64 bit
Kernel: 3.3.1

Re: connessione tcp pacchetti persi

Messaggioda kobaiachi2 » gio dic 05, 2013 22:32

ha il bit Dont Fragment settato sui quei pacchetti ......
gli impedisci di frammentare il pacchetto prova a toglierlo.
se hai impostato i due access point per trasmettere sullo stesso canale si fanno interfernza a vicenda.
kobaiachi2
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: gio dic 05, 2013 22:14
Slackware: 14.0

Re: connessione tcp pacchetti persi

Messaggioda dafrasaga » lun dic 09, 2013 14:44

Ciaio kobaiachi2,
non saprei dove effettuare l'abilitazione di cui parli e dove ( client o server ).. :( ma poi volevo dire che la navigazione normale in internet funziona regolarmente; il problema lo ho con il server sulla porta 80. :?:
dafrasaga
Linux 1.0
Linux 1.0
 
Messaggi: 79
Iscritto il: mar set 08, 2009 10:39
Località: Vinci -FI-
Slackware: 14 64 bit
Kernel: 3.3.1

Re: connessione tcp pacchetti persi

Messaggioda kobaiachi2 » lun dic 09, 2013 17:19

le macchine che stanno su rete wireless devono poter frammentare il pacchetto .

quindi se server e client stanno su wireless tutti e due se no quella che ci sta.


2) non ho capito un cavolo di cosa non ti funziona ?
se vai verso internet la rete funziona bene ?
mentre wirless verso lan fissa funziona male ?

mi posti il piano di indirizzamento assegnato e uno schema di cablaggio ?
kobaiachi2
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: gio dic 05, 2013 22:14
Slackware: 14.0

Re: connessione tcp pacchetti persi

Messaggioda dafrasaga » mar dic 10, 2013 15:33

Ciao,
provo a descriverti il dilemma....
come vedi ho implementato un router/firewall con Zeroshell al quale faccio capo con due switch ( uno managed ed uno no) ai quali ho implementato una rete wifi ed un arete cablata.
un Ap è stato configurato come multi SSID con VLAn in modo da separare guest da private.

Dalla rete cablata e tramite lo switch NETGEAR non ho nessun problema sia di navigazione su internet che di accesso alla pagina web (porta 80) di Zeroshell all'indirizzo 192.168.220.1. che alle pagine web di amministrazione degli AP.
Il tutto funziona anche dai pc collegati sull'AP non multi SSID su per es. 192.168.220.60

Il problema lo ho sui pc connessi all'AP multi SSID: la navigazione internet va ottimamente ma il problema l'ho se tento di accedere alle pagine di amministrazione sia del router (Zeroshell) che degli AP. Lo strano è che pingo sia ZS che gli AP, ma se tento di accedere sia con il browser sia con wget alla porta 80, il tutto , dopo lo 3-way-handshake , si blocca.
Per info: se mi metto con netcat in ascolto su di una porta in Zeroshell posso tranquillamente non netcat in modalità cliente scambiare pacchetti tcp.

Spero di essere stato chiaro, in caso contrario fammi domande :)

Grazie

Immagine
dafrasaga
Linux 1.0
Linux 1.0
 
Messaggi: 79
Iscritto il: mar set 08, 2009 10:39
Località: Vinci -FI-
Slackware: 14 64 bit
Kernel: 3.3.1

Re: connessione tcp pacchetti persi

Messaggioda dafrasaga » mer gen 15, 2014 16:45

up :-)
dafrasaga
Linux 1.0
Linux 1.0
 
Messaggi: 79
Iscritto il: mar set 08, 2009 10:39
Località: Vinci -FI-
Slackware: 14 64 bit
Kernel: 3.3.1


Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti

cron