Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto] schermo nero all'uscita dallo screensaver su KDE

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto] schermo nero all'uscita dallo screensaver su KDE

Messaggioda F4B1CK » ven gen 31, 2014 12:42

Ciao, è da un bel pò che ho questo problemino e finalmente mi sono deciso a chiedere quì per vedere se qualcuno può aiutarmi.
Praticamente accade questo : se parte lo screensaver (impostato a 30 min) l'ho impostato che dopo altri 120 secondi attiva la richiesta della password per riautenticarmi ed accedere al desktop, solo che inserita la password, lo schermo diventa nero (si vede solo il cursore del mouse) e per visualizzare il desktop ci mette svariati secondi (anche questi variabili, di soito devo aspettare nell'ordine dei 10 secondi, a volte sono di meno a volte di più). E' come se qualche componente del desktop manager (magari plasma, non saprei) ci mettesse più tempo ad avviarsi.
Ho testato che non dipende nemmeno dall'hardware (avviandolo con delle live questo non accade).

Ho pensato fosse un problema di kernel/drivers o versione di KDE, ma passando tra i vari aggiornamenti di questi tre componenti il problema persiste.

La mia Slackware è in current, a 32 bit, tengo tutto aggiornato dunque ho il kernel 3.10.17-smp , driver NVidia 331.20, KDE 4.12.1 (alienbob).
Il problema, a memoria, mi si è presentato sin dalla KDE 4.9 e non mi ha più abbandonato...

Se sapete consigliarmi come effettuare un pò di debug per capire la fonte del problema ve ne sarei grato.
Ultima modifica di F4B1CK il mer feb 05, 2014 13:50, modificato 1 volta in totale.
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: schermo nero all'uscita dallo screensaver su KDE

Messaggioda waka_jawaka » mar feb 04, 2014 0:54

Ho avuto il tuo stesso problema. Ha a che fare con i drivers nvidia; infatti è sparito da quando sono passato ai nuoveau. Non ho indagato più di tanto perché mi sono accorto che la mia vga (geforce 8200 integrata) va meglio con gli open che con i drivers ufficiali.
Consigli? Prova i nouveau o qualche versione vecchiotta dei drivers ufficiali. Ho la sensazione che le modifiche che, a mano a mano, aggiungono i programmatori per supportare le schede più recenti vadano in parte a sputtanare quello alle schede più vecchie.
Ciao
Avatar utente
waka_jawaka
Linux 2.6
Linux 2.6
 
Messaggi: 769
Iscritto il: mar ago 09, 2005 23:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Re: schermo nero all'uscita dallo screensaver su KDE

Messaggioda F4B1CK » mar feb 04, 2014 1:11

Il fatto è che ho una GTS450...mica tanto vecchia. Mi pare davvero strano che abbiano incasinato i drivers così tanto. Ho il sospetto che possa dipendere da qualche parametro di configurazione dei drivers proprietari, ma non ho idea da dove cominciare per fare un pò di debug.
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: schermo nero all'uscita dallo screensaver su KDE

Messaggioda lablinux » mar feb 04, 2014 9:42

Magari qualche log che potrebbe aiutarti
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 742
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: schermo nero all'uscita dallo screensaver su KDE

Messaggioda waka_jawaka » mar feb 04, 2014 11:20

Ho beccato questa discussione sul forum di Arch Linux, che conferma nvidia come causa ma che, purtroppo, non aggiunge niente alla discussione
https://bbs.archlinux.org/viewtopic.php?pid=1354332
Avatar utente
waka_jawaka
Linux 2.6
Linux 2.6
 
Messaggi: 769
Iscritto il: mar ago 09, 2005 23:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Re: schermo nero all'uscita dallo screensaver su KDE

Messaggioda F4B1CK » mer feb 05, 2014 13:50

Dopo aver aggiornato i drivers proprietari all'ultima release (v331.38) il problema pare essere scomparso.

Grazie comunque per le risposte!
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE


Torna a Slackware

Chi c’è in linea

Visitano il forum: Bing [Bot] e 2 ospiti