Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto]Problema dual boot Slackware-Salix: no init found

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto]Problema dual boot Slackware-Salix: no init found

Messaggioda Twenty-Seven » sab feb 22, 2014 13:54

Ciao,
Su un portatile avevo installato Slackware come unco OS. Ho voluto provare ad installare anche Salix in dual boot. Durante l' installazione ho fatto sovrascrivere il LILO di Slackware con quello di Salix, con intenzione di entrare nel lilo.conf di Salix successivamente ed aggiungere la voce per far partire anche Slackware.

Il LILO di Salix era così configurato:
Codice: Seleziona tutto
image = /boot/vmlinuz   
  label = linux
  root = /dev/sda3
   read-only


Io ho sostanzialmete replicato i parametri, modificando la label e naturalmente mettendo la partizione di root /dev/sda1 di Slackware al posto di /dev/sda3.

Però Salix parte correttamente, ma Slackware, subito dopo aver iniziato il caricamento mi resttuisce il seguente errore:

Kernel Panic -not syncing: No init found. Try to passing init= option to kernel. Pid: 1, comm: ...

Qualcuno ha idea di come risolvere?

Grazie mille
Ultima modifica di Twenty-Seven il dom mar 02, 2014 19:11, modificato 1 volta in totale.
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE

Re: Problema con dual boot Slackware-Salix: no init found

Messaggioda zoros » sab feb 22, 2014 14:42

Da Salix vai in chroot su Slackware,
modifica lilo.conf per installare lilo (di Slackware) sul boot-record, piuttosto che sull'MBR
Codice: Seleziona tutto
boot = /dev/sda1

torna a Salix e aggiungi il lilo.conf
Codice: Seleziona tutto
other = /dev/sda1
  label = Slackware
  table = /dev/sda

e reinstalla lilo, ovviamente
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Problema con dual boot Slackware-Salix: no init found

Messaggioda Twenty-Seven » sab feb 22, 2014 16:41

Grazie mille zoros per la risposta. Però dopo che monto /dev/sda1 non mi fa fare il chroot, mi dice:

Codice: Seleziona tutto
impossibile eseguire il comando "/bin/bash" : Formato eseguibile non valido
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE

Re: Problema con dual boot Slackware-Salix: no init found

Messaggioda zoros » sab feb 22, 2014 17:02

mah, avrai due sistemi, 32 e 64 bit
altre strade sono:

eseguire il lilo di Salix sulla partizione di Slackware, cioè da Salix:
Codice: Seleziona tutto
mount /dev/sda1 /mnt/dovevuoi
lilo  -r /mnt/dovevuoi
(ma non credo possa funzionare se hai 64 vs 32)
oppure:
avviare da DVD di installazione Slackware ed eseguire il chroot da lì.
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Problema con dual boot Slackware-Salix: no init found

Messaggioda Twenty-Seven » dom feb 23, 2014 10:28

Esatto, su quel pc ho Slackware a 64 bit, mentre Salix è a 32. Allora proverò a riscaricarmi il dvd di slackware e farò quell' operazione e vediamo come va. Per intanto grazie mille
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE

Re: Problema con dual boot Slackware-Salix: no init found

Messaggioda Twenty-Seven » dom mar 02, 2014 19:10

Ho riscaricato la slackware 14.0_64 e l' ho fatta partire da usb. Ho fatto il chroot e scritto il lilo di slackware su sda1. Ha funzionato perfettamente!

Grazie mille
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE


Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti