Repository 32bit  Forum
Repository 64bit  Wiki

Installazione con bios UEFI

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Installazione con bios UEFI

Messaggioda rizzotti91 » sab mar 08, 2014 0:47

Ciao a tutti, a distanza di diversi anni dall'ultimo utilizzo di Slackware, sono qui a reinstallarlo nuovamente con hardware nuovo...

Ho un notebook con bios UEFI e con Windows 8.1, ho scaricato il dvd di Slackwarex64, fatto il boot, utilizzato gdisk, eseguito il setup, installato e tutto ok.
Ho anche installato ULILO ma al momento del boot parte in automatico soltanto windows 8.1.
Cosa ho sbagliato?
Grazie.
rizzotti91
Linux 1.0
Linux 1.0
 
Messaggi: 89
Iscritto il: dom gen 09, 2005 0:00

Re: Installazione con bios UEFI

Messaggioda Cenni » sab mar 08, 2014 8:58

ciao,
dovresti capire se l'installazione è andata a buon fine e il problema è solo del tuo UEFI bios che non ti lascia vedere slackware.
In fase di avvio vedi se hai qualche tasto di funzione che ti mostra un menu di boot, nel mio caso (HP) è f9
Se hai un portatile HP credo tu sia in questa caso:
http://www.zdnet.com/the-refind-boot-lo ... 000010275/

qui su slacky c'è un wiki su UEFI:
http://www.slacky.eu/slacky/Dual_Boot_U ... _Windows_7, credo tu possa saltare la prima parte.
Ciao C.
Avatar utente
Cenni
Linux 2.0
Linux 2.0
 
Messaggi: 104
Iscritto il: mar feb 27, 2007 15:12
Località: Torino
Nome Cognome: Cenni
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: XFCE
Distribuzione: salix e puppeee

Re: Installazione con bios UEFI

Messaggioda rizzotti91 » sab mar 08, 2014 11:23

Ciao, grazie per la risposta.

Ho cercato nel boot menu ed effettivamente c'è una voce "Slackware".
Ho provato a selezionarla ma dopo pochi secondi mi da un errore di "Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(0,0)".

Cosa posso fare?
rizzotti91
Linux 1.0
Linux 1.0
 
Messaggi: 89
Iscritto il: dom gen 09, 2005 0:00

Re: Installazione con bios UEFI

Messaggioda robbybby » sab mar 08, 2014 14:48

Prova a leggere qui.
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1188
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Installazione con bios UEFI

Messaggioda rizzotti91 » sab mar 08, 2014 16:23

robbybby ha scritto:Prova a leggere qui.


Ho visto che devo installare rEFInd ma il problema è che anche se seleziono la voce "Slackware" dal boot menu del bios ottengo un kernel panic.
Adesso ho reinstallato Slackware e non ottengo più il kernel panic ma dopo i vari messaggi di caricamento dei moduli, mi resta lo schermo nero.

Se non riesco ad essere all'interno di slackware non posso installare rEFInd..
rizzotti91
Linux 1.0
Linux 1.0
 
Messaggi: 89
Iscritto il: dom gen 09, 2005 0:00

Re: Installazione con bios UEFI

Messaggioda duturo1953 » sab mar 08, 2014 18:43

Ma, anchio mi sono trovato col tuo stesso problema. Ho semplicemente seguito le istruzioni fornite da Pat sul cd - dvd di installazione.
Alla fine dell'installazione, crei una chiavetta di avvio, avvii con quella, installi con elilo e il mio pc si avvia, di default, con slackware.
Se voglio avviare windows, con f12 (ho un dell inspiron 15), scelgo l'atro S.O.
senza installare rEFInd
Ferrari Renato
email: renatoferrari@tiscali.it
--
Linux Registered User #219791
Linux Registered Machine #104061
renatoferrari@tiscali.it
Avatar utente
duturo1953
Linux 1.0
Linux 1.0
 
Messaggi: 5
Iscritto il: sab mar 08, 2014 18:34
Località: Milano
Nome Cognome: Ferrari Renato Maria
Slackware: 14.1 - 64 bit
Kernel: 3.10.17
Desktop: xfce

Re: Installazione con bios UEFI

Messaggioda robbybby » dom mar 09, 2014 12:12

rizzotti91 ha scritto:Se non riesco ad essere all'interno di slackware non posso installare rEFInd..

Almeno per una prova puoi farne a meno. Creai una chiavetta USB copiandoci l'immagine di rEFInd e fai il boot da quella. Magari provi anche ad avviare direttamente il kernel, senza passare da eLILO; rEFInd ti propone il boot di tutti il vmlinuz, e bzImage che trova.
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1188
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Installazione con bios UEFI

Messaggioda rizzotti91 » dom mar 09, 2014 13:04

robbybby ha scritto:
rizzotti91 ha scritto:Se non riesco ad essere all'interno di slackware non posso installare rEFInd..

Almeno per una prova puoi farne a meno. Creai una chiavetta USB copiandoci l'immagine di rEFInd e fai il boot da quella. Magari provi anche ad avviare direttamente il kernel, senza passare da eLILO; rEFInd ti propone il boot di tutti il vmlinuz, e bzImage che trova.


Come posso creare una pendrive con rEFInd senza avere installato una distribuzione linux? Con windows posso farlo?
rizzotti91
Linux 1.0
Linux 1.0
 
Messaggi: 89
Iscritto il: dom gen 09, 2005 0:00

Re: Installazione con bios UEFI

Messaggioda robbybby » dom mar 09, 2014 14:10

Esistono dei tool per copiare immagini del disco sulle chiavette USB, ma adesso non ricordo quali sono.
Un modo semplice è scaricare l'immagine di rEFInd, fare il boot dal CD di Slackware (che è una live a tutti gli effetti) e fare il dd sulla chiavetta da lì.

dd if=/tuo_path/refind-flashdrive-0.7.7.img of=/dev/sdx bs=1M; sync
al posto di sdx ci devi mettere il device assegnato alla tua chiavetta.
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1188
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Installazione con bios UEFI

Messaggioda rizzotti91 » dom mar 09, 2014 14:27

robbybby ha scritto:Esistono dei tool per copiare immagini del disco sulle chiavette USB, ma adesso non ricordo quali sono.
Un modo semplice è scaricare l'immagine di rEFInd, fare il boot dal CD di Slackware (che è una live a tutti gli effetti) e fare il dd sulla chiavetta da lì.

dd if=/tuo_path/refind-flashdrive-0.7.7.img of=/dev/sdx bs=1M; sync
al posto di sdx ci devi mettere il device assegnato alla tua chiavetta.


Io sto facendo qualche prova ma non credo che il problema riguardi il bootloader...

Quando dal boot menu del bios seleziono Slackware, il caricamento avviene, ma alla fine mi resta una schermata nera... non credete che il problema possa essere altro?

EDIT: sono riuscito ad installare rEFInd da Windows e quando tento di avviare Slackware, dopo i vari caricamenti, mi resta lo schermo nero...
rizzotti91
Linux 1.0
Linux 1.0
 
Messaggi: 89
Iscritto il: dom gen 09, 2005 0:00

Re: Installazione con bios UEFI

Messaggioda Cenni » dom mar 09, 2014 21:01

Ciao, anche a me rimane lo schermo nero, ma lo attivo manualmente con i tasti di luminosità dello schermo, nel mio caso f3 (mi pare ...non ho il pc sottomano) ora prova anche tu se hai lo stesso problema.
Non h ancora avuto tempo di risolvere automaticamete, fai sapere se hai lo stesso problema.
Ciao
Avatar utente
Cenni
Linux 2.0
Linux 2.0
 
Messaggi: 104
Iscritto il: mar feb 27, 2007 15:12
Località: Torino
Nome Cognome: Cenni
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: XFCE
Distribuzione: salix e puppeee

Re: Installazione con bios UEFI

Messaggioda Procopio » mer mar 04, 2015 1:00

avete provato a disabilitare il secure boot di windows? si fa dal menù del bios (o uefi o come si chiama)
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 705
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Installazione con bios UEFI

Messaggioda Paoletta » mer mar 04, 2015 19:35

ciao, un'altra cosa che dovresti tentare di fare nel bios è abilitare l'opzione CSM (compatibilty support mode) che permette il caricamento di un SO tradizionale (senza uefi). Questo mi ha premesso di avviare X sul pc da cui sto scrivendo. Refind l'ho installato anche io, ma non mi è stato necessario il comando dd...ho semplicemente copiato il programma su una chiavetta qualunque, bootato slackware da cd, montato la chiavetta, montato anche la partizione UEFI (quella con /boot/efi, sul mio pc è /dev/sda1) e poi usato lo script install.sh (come si spiega in http://www.rodsbooks.com/refind/installing.html nella sezione Quick install.sh Instructions)
Avatar utente
Paoletta
Staff
Staff
 
Messaggi: 3924
Iscritto il: dom apr 24, 2005 23:00
Località: Varese
Slackware: 13.1
Desktop: fluxbox

Re: Installazione con bios UEFI

Messaggioda Eberoth » gio mar 05, 2015 2:52

Ammetto che dovrei aggiornare la pagina del wiki... sembra che, nonostante dalla 14.1 in poi l'installer di slackware sia in grado di "maneggiare" sistemi UEFI, girino ancora un sacco di problemi.
Il fatto è che non ho accesso ad una macchina con windows 8/8.1 per sperimentare eventuali variazioni alla procedura e, come se non bastasse, temo di non averne il tempo. Quella guida è stata mesa assieme, più per necessità che per altro, dagli appunti che ho preso tentando di installare slackware sul mio (allora) nuovo pc... nella speranza di risparmiare ad altri un certo numero di mal di testa ed imprecazioni.
Purtroppo, però, vedo che la situazione dei firmware non è affatto migliorata e, spesso, i problemi che incontro sono dovuti più alle scelte dei produttori che altro. Per di più, io sono tutto fuorché un'esperto in materia: la mia conoscenza è emperica e basata su un numero ristretto di casi... e questo si riflette negativamente sul valore del wiki.

Ciò detto, se qualcuno se la sente è più che libero di modificare quella guida per aggiornarla o di usarla come base per una nuova versione che riguardi la 14.1/current e windows 8.
La mia intenzione è sempre stata quella di risistemare la mia guida (ci sono un certo numero di errori che sono sfuggiti alla rilettura) e, magari, aggiungere le dovute modifiche per la 14.1/current... ma non sono ancora riuscito a trovare il tempo.
So che questo messaggio è solo lontanamente legato all'argomento della discussione, ma sono cose che volevo comunicare da un po', e così ho colto l'occasione...
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 389
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti