Repository 32bit  Forum
Repository 64bit  Wiki

Sito in locale problemi

Forum dedicato alla programmazione.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il linguaggio di programmazione usato.
2) Se possibile portare un esempio del risultato atteso.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Sito in locale problemi

Messaggioda gigiobagiano » sab mar 08, 2014 12:39

Ciao a tutti,
devo provare alcune cose con joomla per qualche sito e quindi volevo avere una copia in locale dove poter fare modifiche senza ripercussioni. Ho installato slack64 14.1 full, fatti tutti gli aggiornamenti di sicurezza, preso da SBo phpmyadmin, l'unica cosa che ho toccato è l'aggiunta di index.php al DirectoryIndex di httpd, e scaricato e scompattato joomla sotto /var/www/.
Fatta questa premessa il problema che riscontro è che, avviato httpd, all'indirizzo localhost compare "It works", invece se vado su localhost/phpmyadmin mi trovo la pagina di codice index.php. Non avendo toccato quasi nulla, direi che mi manca qualcosa...ma cosa?
Avatar utente
gigiobagiano
Linux 2.6
Linux 2.6
 
Messaggi: 501
Iscritto il: dom mar 11, 2007 12:58
Slackware: 11 - 13.1
Kernel: 2.6.35.6_tuxonice
Desktop: Openbox

Re: Sito in locale problemi

Messaggioda d4z_c0nf » sab mar 08, 2014 13:04

Nel tuo httpd.conf vedi qualcosa tipo:
Codice: Seleziona tutto
#
# DirectoryIndex: sets the file that Apache will serve if a directory
# is requested.
#
<IfModule dir_module>
    DirectoryIndex index.html
</IfModule>


Aggiungi index.php dopo index.html
E poi riavvia httpd.
Avatar utente
d4z_c0nf
Packager
Packager
 
Messaggi: 1293
Iscritto il: mar mar 14, 2006 18:07
Località: Salerno
Nome Cognome: Rocco Aliberti
Slackware: 14.1-64bit
Kernel: 3.10.17
Desktop: xfce

Re: Sito in locale problemi

Messaggioda Ansa89 » sab mar 08, 2014 13:44

Oltre a quello che ha detto d4z_c0nf, credo tu debba abilitare php in apache:
Codice: Seleziona tutto
#Uncomment the following line to enable PHP:
#
Include /etc/httpd/mod_php.conf
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2623
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1

Re: Sito in locale problemi

Messaggioda gigiobagiano » sab mar 08, 2014 14:11

Grazie ad entrambi per le risposte...in effetti Ansa hai beccato in pieno! grazie mille ora funziona! \:D/
Avatar utente
gigiobagiano
Linux 2.6
Linux 2.6
 
Messaggi: 501
Iscritto il: dom mar 11, 2007 12:58
Slackware: 11 - 13.1
Kernel: 2.6.35.6_tuxonice
Desktop: Openbox

Re: Sito in locale problemi

Messaggioda Ansa89 » lun mar 10, 2014 8:32

Mi fa piacere che tu abbia risolto.
Ora per completezza dovresti aggiungere il tag "[RISOLTO]" nel titolo del topic.
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2623
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1


Torna a Programmazione

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti