Repository 32bit  Forum
Repository 64bit  Wiki

Orario indietro di un'ora

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Orario indietro di un'ora

Messaggioda Trotto@81 » lun mar 10, 2014 16:28

Qualche volta allo shutdown o al reboot mi ritrovo l'orario del BIOS indietro di un'ora esatta. Il fuso orario è impostato come localtime ed ho schedulato la sincronizzazione dell'orario ad ogni ora.
Da cosa può dipendere la cosa? Non mi era mai successo con la 14.0!! Mi conviene passare a UTC?
Ho anche Windows 7 su un'altra partizione, ma l'orario è impostato in UTC e spesso me lo ritrovo indietro indietro anche senza fare un reboot da Windows.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3029
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: Orario indietro di un'ora

Messaggioda targzeta » lun mar 10, 2014 19:36

Io avevo questo tipo di problemi solo in un dual boot con Windows. Ma avveniva solo i giorni del cambio di orario. Dove punta il tuo /etc/localtime-copied-from? Cosa riporta:
Codice: Seleziona tutto
ls -l /etc/localtime-copied-from


Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Orario indietro di un'ora

Messaggioda Trotto@81 » lun mar 10, 2014 20:33

Punta su Roma, lo configuro sempre in localtime alla fine dell'installazione.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3029
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: Orario indietro di un'ora

Messaggioda marlavo » mar mar 11, 2014 10:21

Trotto@81 ha scritto:Qualche volta allo shutdown o al reboot mi ritrovo l'orario del BIOS indietro di un'ora esatta. Il fuso orario è impostato come localtime ed ho schedulato la sincronizzazione dell'orario ad ogni ora.

Come sincronizzi l'orario? Non è che per qualche motivo è questa sincronizzazione a sballare l'ora?

Trotto@81 ha scritto:Da cosa può dipendere la cosa? Non mi era mai successo con la 14.0!! Mi conviene passare a UTC?

Anche io ho un dual boot con Windows e non mi è mai successo, ora uso la 14.1 e ancora nessun problema di orario. Però io mantengo l'orario sincronizzato con NTP. Passare a UTC sarebbe la soluzione migliore se decidessi di non fare mai boot su Windows, altrimenti ti ritroveresti con il problema originale, ovvero lo sfalsamento dell'orario ogni volta che riavvii.

Trotto@81 ha scritto:Ho anche Windows 7 su un'altra partizione, ma l'orario è impostato in UTC e spesso me lo ritrovo indietro indietro anche senza fare un reboot da Windows.

Strano, comunque io proverei ad imnpostare sia Windows che Slackware su localtime e poi vediamo che succede.
Avatar utente
marlavo
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven lug 02, 2010 15:38
Nome Cognome: Marco Lavorini
Slackware: 14.1 01 00 00 00
Kernel: 3.10.54
Desktop: XFCE 4.10

Re: Orario indietro di un'ora

Messaggioda Trotto@81 » mer mar 12, 2014 13:18

L'orario lo sincronizzo con NTP, schedulando
Codice: Seleziona tutto
00 */1 * * * /usr/sbin/ntpd -g -q > /dev/null 2>&1
Tendo ad escludere un problema della mobo, va sempre indietro di un'ora esatta, ma potrebbe anche essere.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3029
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: Orario indietro di un'ora

Messaggioda robbybby » mer mar 12, 2014 17:39

Anch'io sul portatile ho il dual boot Linux e Windows (8.1 :( ). L'orologio è impostato su UTC, come è giusto che sia. C'è una chiave del registro di Windwos (che ora non ricordo, ma bastano 5 minuti di google per trovarla) per dire a Windows che l'orologio è UTC e non ora locale.
Sincronizzo l'ora in Linux con:
Codice: Seleziona tutto
# Run whenever crond is running, and sees that at least one day is elapsed since last
# successfull run
@daily ID=jobsynctime /usr/sbin/ntpdate it.pool.ntp.org 1> /dev/null
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1176
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Orario indietro di un'ora

Messaggioda Trotto@81 » mer mar 12, 2014 17:47

Ma perchè non era già di default su UTC? Perlomeno da me su Seven è già su UTC+1, senza intervento alcuno.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3029
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: Orario indietro di un'ora

Messaggioda tgmx » gio mar 20, 2014 9:29

Io ho avuto un problema simile.
Ogni volta che avviavo windows mi ritrovavo sulla slack l'ora sballata.

Per me la soluzione piu' veloce e' stata quella di impostare windows per "non aggiornare automaticamente l'ora".
Cosi' mi ritrovo con windows che sempre l'ora sbagliata ma poco male....
Avatar utente
tgmx
Linux 3.x
Linux 3.x
 
Messaggi: 1330
Iscritto il: ven apr 28, 2006 13:40
Località: Ancona
Slackware: 13.37
Desktop: KDE 4

Re: Orario indietro di un'ora

Messaggioda Trotto@81 » gio mar 20, 2014 9:38

Windows la aggiorna una volta ogni 7 giorni, nel mio caso poi avviene di rado la cosa.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3029
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: Orario indietro di un'ora

Messaggioda robbybby » gio mar 20, 2014 14:41

Trotto@81 ha scritto:Ma perchè non era già di default su UTC? Perlomeno da me su Seven è già su UTC+1, senza intervento alcuno.

Cero, il localtime è UTC+1; il problema è che, di default, Windows imposta l'orologio del PC (quello hardware) sul localtime, anziché su UTC.

Questa dovrebbe essere la chiave del registry di Windows da modificare per fare in modo che anche Windows utilizzi l'orologio del BIOS su UTC, anziché sul localtime:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
"RealTimeIsUniversal"=dword:00000001
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1176
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Orario indietro di un'ora

Messaggioda Trotto@81 » ven mar 21, 2014 17:30

Allora, Slackware perfettamente in regola con l'ora, riavvio per verificare una cosa ed entro nel BIOS e l'ora è magicamente indietro di sessanta minuti esatti. Il colpevole non è Windows!!
Secondo me è hwclok che mi fa questo scherzo.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3029
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Google [Bot] e 3 ospiti