Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] acroread su slackware 64

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] acroread su slackware 64

Messaggioda sbabaro » mer mag 28, 2014 14:12

Sto combattendo per far funzionare acrobat su slack64 14.1
Sulla 14.0 (sempre 64) funzionava perfettamente
Ho installato le multilib di Alien.
Ho provato ad installare adobe acrobat direttamente, usando il pacchetto sul repository e utilizzando il pacchetto del repo con il convert-compat32
In tutti i casi acroread non parte, con lo stesso laconico messaggio

Codice: Seleziona tutto
(acroread:22939): Gtk-WARNING **: Impossibile trovare il motore del tema in module_path: «oxygen-gtk»,

(acroread:22939): Gtk-WARNING **: Impossibile trovare il motore del tema in module_path: «oxygen-gtk»,
Unable to initialize user interface.


non so come mai
ho provatoad aggiungere nello script di avvio
Codice: Seleziona tutto
export PATH="/usr/bin/32:/usr/lib/qt/bin:$PATH"
export GTK_PATH="/usr/lib/gtk-2.0"

ma nessun risultato
Suggerimenti?
Ultima modifica di sbabaro il mar giu 03, 2014 11:26, modificato 1 volta in totale.
sbabaro
Packager
Packager
 
Messaggi: 388
Iscritto il: gio set 08, 2005 23:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Re: acroread su slackware 64

Messaggioda gyrodeck » mer mag 28, 2014 15:13

Oxigen-gtk e' un pacchetto di kde,ce ne sono due oxygen-gtk2 e oxygen-gtk3,se utilizzi kde li hai sicuramente installati percio' forse non funzionano per via di qualche dipendenza non rispettata oppure se non hai installato kde ,devi installarli.Non ti so dire altro in quanto non utilizzo ne' multilib ne ' acreobat e il problema non l'ho mai incontrato.
gyrodeck
Linux 1.0
Linux 1.0
 
Messaggi: 22
Iscritto il: ven gen 25, 2013 19:08
Slackware: current
Kernel: 3.7.1
Desktop: kde

Re: acroread su slackware 64

Messaggioda Ansa89 » mer mag 28, 2014 15:14

Hai installato i pacchetti "oxygen-gtk2-1.4.0-x86_64-1" e "oxygen-gtk3-1.2.0-x86_64-1"?
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2625
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.6-ck2
Desktop: XFCE 4.6.1

Re: acroread su slackware 64

Messaggioda sbabaro » mer mag 28, 2014 15:16

Ho installato infatti oxygen-gtk2 a 32bit, ma non è cambiato nulla
posso provare a installare quelli a 64 bit......
sbabaro
Packager
Packager
 
Messaggi: 388
Iscritto il: gio set 08, 2005 23:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Re: acroread su slackware 64

Messaggioda sbabaro » gio mag 29, 2014 10:17

ho inserito le gtk-2 e 3 a 32 bit oltre a quelle a 64: ora non mi dà più errore sul tema, si limita a darmi
Codice: Seleziona tutto
# /usr/bin/32/acroread
Unable to initialize user interface.
sbabaro
Packager
Packager
 
Messaggi: 388
Iscritto il: gio set 08, 2005 23:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Re: acroread su slackware 64

Messaggioda ponce » gio mag 29, 2014 17:44

hai provato a cambiare tema gtk (da oxygen-gtk a qualcos'altro)?
Avatar utente
ponce
Master
Master
 
Messaggi: 1514
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.18-rc2
Desktop: lxde

Re: acroread su slackware 64

Messaggioda sbabaro » gio mag 29, 2014 18:07

no, ma soono su kde: come faccio a cambiare il tema gtk? e poi non stà più dando errore tema dopo l'installazione dei pacchetti
sbabaro
Packager
Packager
 
Messaggi: 388
Iscritto il: gio set 08, 2005 23:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Re: acroread su slackware 64

Messaggioda ponce » gio mag 29, 2014 18:19

sbabaro ha scritto:no, ma soono su kde: come faccio a cambiare il tema gtk? e poi non stà più dando errore tema dopo l'installazione dei pacchetti

tentar non nuoce, considerato anche che il binario di acroread e' linkato alle gtk (l'interfaccia e' in gtk).
per cambiare il tema gtk in uso, credo che il metodo piu' semplice sia usare lxappearance (ti puoi anche fare un pacchetto da solo con lo script di build su SBo).

hai un installazione completa di slackware64-14.1 (te lo chiedo perche' a me acroread funziona)?
oltre alle multilib, hai installato anche i pacchetti compat32 che fornisce Alien Bob?
Avatar utente
ponce
Master
Master
 
Messaggi: 1514
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.18-rc2
Desktop: lxde

Re: acroread su slackware 64

Messaggioda sbabaro » ven mag 30, 2014 9:23

si, la slack è completa.
Per i compat32, ho installato tutte le librerie di Alien Bob previste nell'installazione multilib, altri pacchetti no.........
sbabaro
Packager
Packager
 
Messaggi: 388
Iscritto il: gio set 08, 2005 23:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Re: [RISOLTO] acroread su slackware 64

Messaggioda sbabaro » mar giu 03, 2014 11:27

Vi confermo ceh è risolto, grazia ad aiuto su Linuxquestion
Ho semplicemente usato il pacchetto di slackbuilds
Probabilmente il problema è legato allo strip, che su SBo non viene fatto
sbabaro
Packager
Packager
 
Messaggi: 388
Iscritto il: gio set 08, 2005 23:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite