Repository 32bit  Forum
Repository 64bit  Wiki

shell di kde con tastiera italiana, come fare? [risolto]

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

shell di kde con tastiera italiana, come fare? [risolto]

Messaggioda plinius » mar lug 15, 2014 15:59

io uso la slackware 14.1 e a me non c'è nessun file /etc/X11/xorg.conf al massimo c'è un xorg.conf-vesa ma se in questo attivo la stringa "XkbLayout" "it" non mi cambia nulla.
Premetto che avevo il desktop Xcfe ma non essendoci abituato l'ho cambiato successivamente l'installazione nel desktop kde

PS Inoltre come faccio a sapere quale tastiera ho?
Ultima modifica di plinius il mer lug 16, 2014 7:35, modificato 1 volta in totale.
plinius
Linux 1.0
Linux 1.0
 
Messaggi: 20
Iscritto il: mar lug 15, 2014 15:40
Nome Cognome: giavit
Slackware: 14.1
Kernel: 3.10.17
Desktop: kde

Re: shell di kde che riconosce la tastiera italiana, come fa

Messaggioda conraid » mar lug 15, 2014 16:43

xorg.conf non c'è più, ora devi usare i file separati nella directory xorg.conf.d, come anche descritto nel file di accompagnamento della distribuzione
ftp://ftp.slackware.com/pub/slackware/s ... _HINTS.TXT
Anche se in teoria è sempre possibile usare xorg.conf, ma sconsigliato
In pratica fai un file /etc/X11/xorg.conf.d/90-keyboard-layout.conf così

Codice: Seleziona tutto
Section "InputClass"
        Identifier "keyboard-all"
        MatchIsKeyboard "on"
        Driver "evdev"
        Option "XkbLayout" "it"
        #Option "XkbVariant" ""
        Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection


Da KDE volendo lo cambia da impostazioni di sistema, ma ti conviene una soluzione che vale per tutti gli ambienti grafici.

P.S.
Ti ho messo il post in nuovo topic visto che in 10 anni di cose ne son cambiate :-)
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12016
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: shell di kde con tastiera italiana, come fare? [risolto]

Messaggioda plinius » mer lug 16, 2014 7:38

funziona , grazie mille per l'aiuto,
ma sono arrivato a questa richiesta perché da impostazione di sistema non trovo la modifica di layout della lingua
plinius
Linux 1.0
Linux 1.0
 
Messaggi: 20
Iscritto il: mar lug 15, 2014 15:40
Nome Cognome: giavit
Slackware: 14.1
Kernel: 3.10.17
Desktop: kde


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite