Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO]XDM e login

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO]XDM e login

Messaggioda rik70 » mer ago 27, 2014 9:39

Una curiosità: a voi funziona xdm su Slackware 14.1?
Qui niente: dopo aver inserito le credenziali per il login, lo schermo diventa nero e ritorna immediatamente sulla schermata di login. E come se non trovasse la sessione grafica da avviare.

Non è un grosso problema, dato che uso lxdm. Ma vorrei capire il perché.

In /etc/X11/xinitrc ho:
Codice: Seleziona tutto
/etc/X11/xinit/xinitrc -> /etc/X11/xinit/xinitrc.xfce*


In /var/log/xdm.log non c'è nulla di rilevante.

Da voi com'è?
Ultima modifica di rik70 il mer ago 27, 2014 11:07, modificato 1 volta in totale.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: XDM e login

Messaggioda rik70 » mer ago 27, 2014 11:06

Trovato.

Avevo installato il pacchetto bash-completion-2.1-noarch-1.

Grazie a questo post su LQ ho modificato il filre /etc/X11/xdm/Xsession rimuovendo '2>&1' dalle sringhe 'source $profile'.

Così ho individuato il problema in .xsession-errors: era causato dal file '/etc/bash_completion.d/pulseaudio-bash-completion.sh'.

Uh, pulseaudio! Se ne parlava no? Ma è solo una coincidenza :)
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: [RISOLTO]XDM e login

Messaggioda ponce » mer ago 27, 2014 11:20

un motivo in piu' per non installarlo ;)
Avatar utente
ponce
Master
Master
 
Messaggi: 1501
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.17-rc3
Desktop: lxde

Re: [RISOLTO]XDM e login

Messaggioda rik70 » mer ago 27, 2014 11:25

ponce ha scritto:un motivo in piu' per non installarlo ;)


Già, o per tenerlo fuori dalle balls il più possibile :D
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: [RISOLTO]XDM e login

Messaggioda rik70 » mer ago 27, 2014 11:29

Però è strano:
se fai un 'source pulseaudio-bash-completion.sh' non restituisce errori.

Chi sa perché invece xdm s'incasina....
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti