Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Multihead laptop Dell con monitor Dell

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Multihead laptop Dell con monitor Dell

Messaggioda Procopio » dom ago 31, 2014 9:02

Ciao a tutti,

il problema è dei più classici, ma ho già provato le soluzioni di diversi wiki e forum, senza riuscire a configurare.

Il laptop è un precision m3800 e il monitor un Dell u2412m ed è compatibile. La cosa strana è che neanche windows 8 me lo riconosce.

Li collego attraverso un cavo HDMI-to-DVI e il comando xrandr -q mi da questo output
Codice: Seleziona tutto
vrso ~ $ xrandr -q
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 346mm x 194mm
   3200x1800     59.98*+
   2048x1536     60.00 
   1920x1440     60.00 
   1856x1392     60.01 
   1792x1344     60.01 
   1600x1200     60.00 
   1400x1050     59.98 
   1280x1024     60.02 
   1280x960      60.00 
   1024x768      60.00 
   800x600       60.32    56.25 
   640x480       59.94 
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected (normal left inverted right x axis y axis)
   1920x1200     59.95 +
   1600x1200     60.00 
   1680x1050     59.88 
   1280x1024     60.02 
   1280x960      60.00 
   1024x768      60.00 
   800x600       60.32 
   640x480       60.00 
   720x400       70.08 
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
quindi comunque in qualche modo il monitor viene riconosciuto.

con xrandr o con display però sembra che non venga riconosciuto
Codice: Seleziona tutto
root /home/vrso # DISPLAY=:0.1 urxvt &
[1] 1632
root /home/vrso # urxvt: can't open display :0.1, aborting.

[1]+  Uscita 1                DISPLAY=:0.1 urxvt


Codice: Seleziona tutto
root /home/vrso # xrandr --output VGA1 --auto --output HDMI1 --auto --right-of VGA1
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  7 (RRSetScreenSize)
  Serial number of failed request:  42
  Current serial number in output stream:  43


gli altri metodi di configuarzione, cioè quelli che contemplano l'editing di files .conf di xorg mi sono falliti tutti, credo principalmente perchè non so neanche con quali voci vadano compilati quei files e come reperire quelle voci. Quindi i metodi tipo xinerama twinview e configuration using xorg.conf sono stati per me tutti fallimentari.

Codice: Seleziona tutto
root /home/vrso # lspci | grep -e VGA -e 3D
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
02:00.0 3D controller: NVIDIA Corporation GK107GLM [Quadro K1100M] (rev a1)
root /home/vrso #
schede video sono queste.

Non sono riuscito ad installare driver nvidia causa il fatto che non ho una configurazione canonica ma sul laptop è presente la tecnologia nvidia optimus, ma per quello ho già aperto un TD a parte, quindi non ho ancora potuto tentare il multihead su nvidia, ma appena troverò una quadra tenterò anche quello.

Intanto spero che qualcuno di voi riesca a darmi una mano da una parte o dall'altra.
Ultima modifica di Procopio il gio set 18, 2014 15:32, modificato 1 volta in totale.
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Multihead laptop Dell con monitor Dell

Messaggioda Procopio » gio set 18, 2014 15:32

allora, ho poi risolto:

in sostanza tramite la porta HDMI non è possibile collegare alcun dispositivo, perchè il mio PC ha un problema a quella porta, e dovrei portarlo in assistenza.
Tramite la porta displayoprt invece funziona e gestisco il multihead tramite xrandr con un comando di questo tipo
Codice: Seleziona tutto
xrandr --output eDP1 --off --output DP1 --auto



dove eDP1 è il monitor integrato del portatile, mentre DP1 è il monitor esterno.
Codice: Seleziona tutto
vrso ~ $ xrandr -q
Screen 0: minimum 8 x 8, current 1920 x 1200, maximum 32767 x 32767
eDP1 connected (normal left inverted right x axis y axis)
   3200x1800     59.98 +
   2048x1536     60.00 
   1920x1440     60.00 
   1856x1392     60.01 
   1792x1344     60.01 
   1600x1200     60.00 
   1400x1050     59.98 
   1280x1024     60.02 
   1280x960      60.00 
   1024x768      60.00 
   800x600       60.32    56.25 
   640x480       59.94 
DP1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200     59.95*+
   1920x1080     59.99 
   1600x1200     60.00 
   1680x1050     59.95 
   1280x1024     60.02 
   1280x960      60.00 
   1024x768      60.00 
   800x600       60.32 
   640x480       60.00 
   720x400       70.08 
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite