Repository 32bit  Forum
Repository 64bit  Wiki

Nvidia Optimus

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Nvidia Optimus

Messaggioda Procopio » dom ago 31, 2014 8:55

Ciao a tutti!!!

Ancora non mi spiego come mai sull'argomento la letteratura sia così limitata, anche nei forum, e infatti ho ancora molti dubbi a riguardo, ma facciamo con ordine:

come è possibile verificare se l'opzione optimus è attiva quando nel BIOS non è presente lo switch apposito? è sempre possibile scegliere se abilitare o disabilitare l'opzione optimus?

Secondo punto: bumblebee è appunto solo un demone? lui istruisce bbswitch a spegnere ed accendere la scheda nvidia in base a se ci sono o meno programmi che utilizzano l'accelerazione 3D? Quindi se bbswitch non è avviato o non installato di fatto bumblebee non fa nulla e la gestione optimus delle schede non è in funzione?
In questo caso la configurazione è quella di alte prestazioni e viene utilizzata sempre l'accelerazione 3D per tutti i programmi attivi che la richiedono? la cosa avviene in automatico o bisogna istruire ogni singolo programma che può utilizzarla a farlo?

Terzo punto: volendo disabilitare quell'opzione e lavorare ad alte prestazioni, le due schede video vanno comunque fatte lavorare parallelamente? (come la setto una configurazione di quel tipo, nel senso, basta semplicemente installare entrambi i driver (Nvidia e intel/nouveau?)
In quel caso i programmi utilizzano la gpu dedicata in modo automatico o dobbiamo istruirli ogni volta?(come invece accade quando l'opzione è abilitata)

le mie schede video sono queste
Codice: Seleziona tutto
root /home/vrso # lspci | grep -e VGA -e 3D
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
02:00.0 3D controller: NVIDIA Corporation GK107GLM [Quadro K1100M] (rev a1)
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Nvidia Optimus

Messaggioda ScorpionIT » dom ago 31, 2014 19:12

bumblebee gestisce lo switch delle schede video e tramite il comando optirun lancia una determinata applicazione con la vga dedicata
bbswitch è un modulo del kernel che permette di gestire l'alimentazione della vga dedicata

di default, almeno dalle mie esperienze, viene usata sempre la vga integrata.
per usare la dedicata dovrebbe bastare il driver nvidia/nouveau e un xorg.conf con i parametri giusti

bumblebee per lanciare xorg con i driver nvidia usa questa conf:
Codice: Seleziona tutto
Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting may be needed in some platforms with more than one
#   nvidia card, which may confuse the proprietary driver (e.g.,
#   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
#   BusID "PCI:01:00:0"

#   Setting ProbeAllGpus to false prevents the new proprietary driver
#   instance spawned to try to control the integrated graphics card,
#   which is already being managed outside bumblebee.
#   This option doesn't hurt and it is required on platforms running
#   more than one nvidia graphics card with the proprietary driver.
#   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
#   If this option is not set, the new Xorg may blacken the screen and
#   render it unusable (unless you have some way to run killall Xorg).
    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "none"
EndSection


invece per i nouveau usa questa conf:
Codice: Seleziona tutto
Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nouveau"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting is needed on Ubuntu 13.04.
#   BusID "PCI:01:00:0"

EndSection


penso basti usare una di queste due configurazioni per farlo andare sempre con la dedicata
Avatar utente
ScorpionIT
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: mar ago 25, 2009 12:32
Nome Cognome: Elia Devito
Slackware: 14.1
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: Nvidia Optimus

Messaggioda Procopio » dom ago 31, 2014 23:11

ok, ioutilizzo i driver proprietari, ma non funge ne con quella section aggiunta all' xorg.conf nè senza.

Dà sempre lo stesso errore:
Codice: Seleziona tutto
vrso ~ $ optirun glxspheres64 -info
[  918.630138] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) systemd-logind: failed to get session: PID 445 does not belong to any known session

[  918.630165] [ERROR]Aborting because fallback start is disabled.
vrso ~ $ optirun glxgears -info
[  930.136958] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) systemd-logind: failed to get session: PID 445 does not belong to any known session

[  930.137021] [ERROR]Aborting because fallback start is disabled.
vrso ~ $



quel caso fortunatamente è contemplato nel wiki di arch
Codice: Seleziona tutto
systemd-logind: failed to get session: PID XXX does not belong to any known session

If the console output is (PID varies):

[ERROR]Cannot access secondary GPU - error: [XORG] (EE) systemd-logind: failed to get session: PID 753 does not belong to any known session
[ERROR]Aborting because fallback start is disabled.

In /etc/mkinitcpio.conf change the MODULES var to:

MODULES="i915 bbswitch"

And run:

# mkinitcpio -p linux
ma ho fatto come dice lui e non va ugualmente, sempre lo stesso errore.

Al che ho googlato un po' in giro ma anche se in qualche post sostenevano di aver risolto non ho trovato nulla che risolvesse.

Mi è allora venuto il dubbio di non avere le schede video correttamente impostate nell'xorg.conf e così ne ho generato uno con nvidia-xconfig per assicurarmi che sta volta X usasse i driver proprietari e al riavvio non è partito. Questo è il log
Codice: Seleziona tutto
vrso ~ $ cat .local/share/xorg/Xorg.0.log
[    29.860]
X.Org X Server 1.16.0
Release Date: 2014-07-16
[    29.860] X Protocol Version 11, Revision 0
[    29.860] Build Operating System: Linux 3.15.5-2-ARCH x86_64
[    29.861] Current Operating System: Linux dellstar 3.16.1-1-ARCH #1 SMP PREEMPT Thu Aug 14 07:40:19 CEST 2014 x86_64
[    29.861] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=03315c70-331b-4c3d-9878-35aaa970d6a1 rw quiet
[    29.861] Build Date: 31 July 2014  11:53:19AM
[    29.861] 
[    29.861] Current version of pixman: 0.32.6
[    29.861]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    29.861] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    29.862] (==) Log file: "/home/vrso/.local/share/xorg/Xorg.0.log", Time: Mon Sep  1 00:03:05 2014
[    29.862] (==) Using config file: "/etc/X11/xorg.conf"
[    29.862] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    29.862] (==) ServerLayout "X.org Configured"
[    29.862] (**) |-->Screen "Screen0" (0)
[    29.862] (**) |   |-->Monitor "Monitor0"
[    29.862] (**) |   |-->Device "Card0"
[    29.862] (**) |-->Screen "Screen1" (1)
[    29.862] (**) |   |-->Monitor "Monitor1"
[    29.862] (**) |   |-->Device "Card1"
[    29.862] (**) |-->Input Device "Mouse0"
[    29.862] (**) |-->Input Device "Keyboard0"
[    29.862] (==) Automatically adding devices
[    29.862] (==) Automatically enabling devices
[    29.862] (==) Automatically adding GPU devices
[    29.862] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    29.862]    Entry deleted from font path.
[    29.862]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    29.862] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    29.862]    Entry deleted from font path.
[    29.862]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    29.862] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    29.862]    Entry deleted from font path.
[    29.862]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    29.862] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    29.862]    Entry deleted from font path.
[    29.862]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    29.862] (**) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/
[    29.862] (**) ModulePath set to "/usr/lib/xorg/modules"
[    29.862] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    29.862] (WW) Disabling Mouse0
[    29.862] (WW) Disabling Keyboard0
[    29.862] (II) Loader magic: 0x818d80
[    29.862] (II) Module ABI versions:
[    29.862]    X.Org ANSI C Emulation: 0.4
[    29.862]    X.Org Video Driver: 18.0
[    29.862]    X.Org XInput driver : 21.0
[    29.862]    X.Org Server Extension : 8.0
[    29.864] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[    29.864] (II) xfree86: Adding drm device (/dev/dri/card0)
[    29.864] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[    29.865] (--) PCI:*(0:0:2:0) 8086:0416:1028:060d rev 6, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[    29.865] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    29.865] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    29.865] (II) LoadModule: "glx"
[    29.865] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    29.866] (II) Module glx: vendor="X.Org Foundation"
[    29.866]    compiled for 1.16.0, module version = 1.0.0
[    29.866]    ABI class: X.Org Server Extension, version 8.0
[    29.866] (==) AIGLX enabled
[    29.866] (II) LoadModule: "nvidia"
[    29.866] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    29.866] (II) Module nvidia: vendor="NVIDIA Corporation"
[    29.866]    compiled for 4.0.2, module version = 1.0.0
[    29.866]    Module class: X.Org Video Driver
[    29.866] (II) NVIDIA dlloader X Driver  340.32  Tue Aug  5 20:13:04 PDT 2014
[    29.866] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    29.866] (++) using VT number 1

[    29.866] (--) controlling tty is VT number 1, auto-enabling KeepTty
[    29.866] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[    29.866] (EE) No devices detected.
[    29.866] (EE)
Fatal server error:
[    29.866] (EE) no screens found(EE)
[    29.866] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    29.866] (EE) Please also check the log file at "/home/vrso/.local/share/xorg/Xorg.0.log" for additional information.
[    29.866] (EE)



almeno del fatto che X non riesce a utilizzare la scheda video dedicata riesci a darmi qualche dritta? qua da un problema ne saltano fuori otto come al solito :)
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Nvidia Optimus

Messaggioda ScorpionIT » lun set 01, 2014 10:04

Dai log salta fuori systemd, su che distribuzione sei?(mkinitcpio quindi dovresti essere su arch?)

Non ho capito se vuoi configurare bumblebee o usare solo la vga integrata. Ne primo caso ti basta installare bumblebee + dipendenze senza modificare la configurazione di xorg. Se mi dici su che distribuzione sei vediamo di configurare il tutto
Avatar utente
ScorpionIT
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: mar ago 25, 2009 12:32
Nome Cognome: Elia Devito
Slackware: 14.1
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: Nvidia Optimus

Messaggioda Procopio » lun set 01, 2014 11:11

Si certo ora sono su arch, non l'ho scritto perchè l'avevo messo nei dati utente sulla destra, scusa!
Comunque in realtà volevo un po tutti e due, cioè capire cosa fa bumblebee e come funziona, e capire anche come funziona il sistema senza l'opzione optimus: cioè se usa comunque due schede video (quella integrata il lavoro "ordinario" e quella dedicata per il rendering pesante) o se ne usa una sola.

ScorpionIT ha scritto:Ne primo caso ti basta installare bumblebee + dipendenze senza modificare la configurazione di xorg.
purtroppo non è così: qua su arch il file xorg.com è tendenzialmente deprecato, infatti io non ce l'ho e ne ho creato una apporsta con
Codice: Seleziona tutto
Xorg :0 -configure
per potervi aggiungere quelle stringhe che mi avevi consigliato tu, comunque sia con il file xorg.conf originale, sia con quelle stringhe aggiunte, sia senza il file xorg.conf, quando cerco di verificare se la scheda dedicata è in funzione mi da sempre lo stesso errore
Codice: Seleziona tutto
vrso ~ $ optirun glxgears -info
[   22.294114] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) systemd-logind: failed to get session: PID 485 does not belong to any known session

[   22.294143] [ERROR]Aborting because fallback start is disabled.


le dipendenze ovviamente sono tutte installate e il demone bumblebeed è attivo
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Nvidia Optimus

Messaggioda ScorpionIT » lun set 01, 2014 12:57

Da quanto ho capito bumblebee lancia una seconda istanza di xorg con il driver nvidia e "porta la finestra" sulla prima istanza... il file xorg.conf è deprecato perché hanno suddiviso i file di configurazione nella directory xorg.conf.d comunque viene ancora letto. Nel file xorg però deci mettere solo la configurazione che ho postato su se usi. Il tool per generare la configurazione ti dovrebbe settare l'intel cquindi io proverei con un xorg con solo i parametri che ti ho postato su inoltre se setti la vga dedicata come predefinita non devi usare optirun in quanto viene processato tutto dalla vga dedicata
Avatar utente
ScorpionIT
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: mar ago 25, 2009 12:32
Nome Cognome: Elia Devito
Slackware: 14.1
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: Nvidia Optimus

Messaggioda Procopio » lun set 01, 2014 13:12

ScorpionIT ha scritto:il file xorg.conf è deprecato perché hanno suddiviso i file di configurazione nella directory xorg.conf.d comunque viene ancora letto.
la mia dir xorg.conf.d è vuota anche perché il files lì dentro andrebbero tutti a comporre l'xorg.conf quindi sarebbero di fatto la stessa cosa. Se vuoi ti faccio vedere un tree della mia dir /etc e vedi che non c'è traccia di files xorg.conf

ScorpionIT ha scritto:io proverei con un xorg con solo i parametri che ti ho postato su
perfetto ora lo provo!!

ScorpionIT ha scritto:se setti la vga dedicata come predefinita non devi usare optirun in quanto viene processato tutto dalla vga dedicata
e la vga dedicata la setto inserendo la configurazione che hai postato su nell'xorg.conf e null'altro, giusto? provo tutto e ti faccio sapere!
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Nvidia Optimus

Messaggioda Procopio » lun set 01, 2014 13:29

purtroppo con un xorg.conf con i soli parametri che mi hai postato non parte X...questo è il log:
Codice: Seleziona tutto
[    20.735]
X.Org X Server 1.16.0
Release Date: 2014-07-16
[    20.735] X Protocol Version 11, Revision 0
[    20.735] Build Operating System: Linux 3.15.5-2-ARCH x86_64
[    20.736] Current Operating System: Linux dellstar 3.16.1-1-ARCH #1 SMP PREEMPT Thu Aug 14 07:40:19 CEST 2014 x86_64
[    20.736] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=03315c70-331b-4c3d-9878-35aaa970d6a1 rw quiet
[    20.736] Build Date: 31 July 2014  11:53:19AM
[    20.736] 
[    20.736] Current version of pixman: 0.32.6
[    20.736]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    20.736] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    20.736] (==) Log file: "/home/vrso/.local/share/xorg/Xorg.0.log", Time: Mon Sep  1 14:24:42 2014
[    20.737] (==) Using config file: "/etc/X11/xorg.conf"
[    20.737] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    20.737] (==) ServerLayout "Layout0"
[    20.737] (==) No screen section available. Using defaults.
[    20.737] (**) |-->Screen "Default Screen Section" (0)
[    20.737] (**) |   |-->Monitor "<default monitor>"
[    20.737] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[    20.737] (**) |   |-->Device "DiscreteNvidia"
[    20.737] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[    20.737] (**) Option "AutoAddDevices" "false"
[    20.737] (**) Option "AutoAddGPU" "false"
[    20.737] (**) Not automatically adding devices
[    20.737] (==) Automatically enabling devices
[    20.737] (**) Not automatically adding GPU devices
[    20.737] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    20.737]    Entry deleted from font path.
[    20.737]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    20.737] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    20.737]    Entry deleted from font path.
[    20.737]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    20.737] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/
[    20.737] (==) ModulePath set to "/usr/lib/xorg/modules"
[    20.737] (==) |-->Input Device "<default pointer>"
[    20.737] (==) |-->Input Device "<default keyboard>"
[    20.737] (==) The core pointer device wasn't specified explicitly in the layout.
   Using the default mouse configuration.
[    20.737] (==) The core keyboard device wasn't specified explicitly in the layout.
   Using the default keyboard configuration.
[    20.737] (II) Loader magic: 0x818d80
[    20.737] (II) Module ABI versions:
[    20.737]    X.Org ANSI C Emulation: 0.4
[    20.737]    X.Org Video Driver: 18.0
[    20.737]    X.Org XInput driver : 21.0
[    20.737]    X.Org Server Extension : 8.0
[    20.738] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[    20.738] (II) xfree86: Adding drm device (/dev/dri/card0)
[    20.739] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[    20.740] (--) PCI:*(0:0:2:0) 8086:0416:1028:060d rev 6, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[    20.740] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    20.740] (II) LoadModule: "glx"
[    20.740] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    20.740] (II) Module glx: vendor="X.Org Foundation"
[    20.741]    compiled for 1.16.0, module version = 1.0.0
[    20.741]    ABI class: X.Org Server Extension, version 8.0
[    20.741] (==) AIGLX enabled
[    20.741] (II) LoadModule: "nvidia"
[    20.741] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    20.741] (II) Module nvidia: vendor="NVIDIA Corporation"
[    20.741]    compiled for 4.0.2, module version = 1.0.0
[    20.741]    Module class: X.Org Video Driver
[    20.741] (II) LoadModule: "mouse"
[    20.741] (WW) Warning, couldn't open module mouse
[    20.741] (II) UnloadModule: "mouse"
[    20.741] (II) Unloading mouse
[    20.741] (EE) Failed to load module "mouse" (module does not exist, 0)
[    20.741] (II) LoadModule: "kbd"
[    20.741] (WW) Warning, couldn't open module kbd
[    20.741] (II) UnloadModule: "kbd"
[    20.741] (II) Unloading kbd
[    20.741] (EE) Failed to load module "kbd" (module does not exist, 0)
[    20.741] (II) NVIDIA dlloader X Driver  340.32  Tue Aug  5 20:13:04 PDT 2014
[    20.741] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    20.741] (++) using VT number 1

[    20.741] (--) controlling tty is VT number 1, auto-enabling KeepTty
[    20.741] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[    20.741] (EE) No devices detected.
[    20.741] (EE)
Fatal server error:
[    20.741] (EE) no screens found(EE)
[    20.741] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    20.741] (EE) Please also check the log file at "/home/vrso/.local/share/xorg/Xorg.0.log" for additional information.
[    20.741] (EE)
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Nvidia Optimus

Messaggioda ScorpionIT » lun set 01, 2014 16:22

facciamo una cosa, partiamo da un'installazione di default di bumblebee, installado i pacchetti indicati sul wiki di arch ovvero:
Codice: Seleziona tutto
- bumblebee
- bbswitch
- virtualGL
- primus
- intel-dri
- xf86-video-intel
- nvidia


aggiungendo il tuo utente al gruppo bumblebee con conseguente logout e login

Codice: Seleziona tutto
gpasswd -a $USER bumblebee


e abilitando e avviando il servizio

Codice: Seleziona tutto
systemctl enable bumblebeed
systemctl start bumblebeed


con optirun

Codice: Seleziona tutto
optirun glxspheres(64)


dovrebbe andare senza fare nessuna consigurazione a xorg, in caso prova anche a riavviare e vedi se va
Avatar utente
ScorpionIT
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: mar ago 25, 2009 12:32
Nome Cognome: Elia Devito
Slackware: 14.1
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: Nvidia Optimus

Messaggioda Procopio » lun set 01, 2014 17:30

è esattamente quello che ho fatto, io seguo il wiki di arch, ma non va. Tutti i comandi che ho postato sopra li ho fatti dopo aver seguito il wiki in italiano e in inglese, i driver e i programmi li ho anche installati contemporaneamente come consiglia il wiki inglese, ma non funge... è anche per questo che ho aperto il topic.
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Nvidia Optimus

Messaggioda pino » lun set 01, 2014 18:25

Una domanda stupida da uno che ha un vecchio computer
Ma tutti i computer che hanno la cpu intel con scheda video a bordo e la scheda video nvidia sono da considerare con tecnologia optimus?
pino
Linux 2.4
Linux 2.4
 
Messaggi: 489
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Re: Nvidia Optimus

Messaggioda ScorpionIT » lun set 01, 2014 20:47

Forse ho trovato il problema edita il file /etc/bumblebee/xorg.conf.nvidia decommenta e modifica la riga

Codice: Seleziona tutto
BusID "PCI:01:00:0"


Con

Codice: Seleziona tutto
BusID "PCI:02:00:0"
Avatar utente
ScorpionIT
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: mar ago 25, 2009 12:32
Nome Cognome: Elia Devito
Slackware: 14.1
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: Nvidia Optimus

Messaggioda Procopio » mar set 02, 2014 0:15

pino ha scritto:Una domanda stupida da uno che ha un vecchio computer
Ma tutti i computer che hanno la cpu intel con scheda video a bordo e la scheda video nvidia sono da considerare con tecnologia optimus?
bè non è una domanda stupida, pensa che ad ora io sul mio non ho certezza che ci sia questa tecnologia...un modo per saperlo con certezza è quello di guardare se hai l'opzione nel bios, in caso affermativo sei certo di avercela. In caso negativo invece non puoi comunque essere sicuro di non averla, perchè magari non puoi semplicemente disattivare l'opzione ma ce l'hai.
Comunque per vedere se nel bios c'è fai una cosa di questo tipo:

Enter the BIOS and changed the default graphics setting from 'Optimus' to 'Discrete' and the install NVIDIA drivers (295.20-1 at time of writing) recognized the screens.

Steps:

Enter BIOS.
Find Graphics Settings (should be in tab Config > Display).
Change 'Graphics Device' to 'Discrete Graphics' (Disables Intel integrated graphics).
Change OS Detection for Nvidia Optimus to "Disabled".
Save and exit.

Tested on a Lenovo W520 with a Quadro 1000M and Nvidia Optimus


ScorpionIT ha scritto:Forse ho trovato il problema edita il file /etc/bumblebee/xorg.conf.nvidia decommenta e modifica la riga

Codice: Seleziona tutto
BusID "PCI:01:00:0"


Con

Codice: Seleziona tutto
BusID "PCI:02:00:0"
bell'idea, ma purtroppo non funge. Nel mio file /etc/bumblebee/xorg.conf.nvidia non c'era la voce BusID "PCI:01:00:0", l'ho aggiunta io a mano, ma purtroppo non ha funzionato e quando provo a far partire optirun mi da sempre lo stesso problema...
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Nvidia Optimus

Messaggioda ScorpionIT » mar set 02, 2014 0:59

prova a dare da terminale

Codice: Seleziona tutto
cat /proc/acpi/bbswitch


dovrebbe restiture un output simile a questo:

Codice: Seleziona tutto
0000:01:00.0 OFF


che in questo caso significa che la vga dedicata è spenta
Avatar utente
ScorpionIT
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: mar ago 25, 2009 12:32
Nome Cognome: Elia Devito
Slackware: 14.1
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: Nvidia Optimus

Messaggioda Procopio » mar set 02, 2014 9:06

e infatti
Codice: Seleziona tutto
vrso ~ $ cat /proc/acpi/bbswitch
0000:02:00.0 OFF


comunque la situazione è molto strana perchè sembra che proprio che questa scheda vga dedicata non si riesca ad accendere, infatti:
ora ho un file xorg.conf in cui quella scheda viene configurata
Codice: Seleziona tutto
root /home/vrso # cat /etc/X11/xorg.conf
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   Screen      1  "Screen1" RightOf "Screen0"
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Monitor"
   Identifier   "Monitor1"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
   Identifier  "Card0"
   Driver      "nvidia"
   BusID       "PCI:2:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "DRI"                   # <str>
        #Option     "Present"               # [<bool>]
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "VSync"                 # [<bool>]
        #Option     "PageFlip"              # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "ReprobeOutputs"        # [<bool>]
        #Option     "DeleteUnusedDP12Displays"    # [<bool>]
        #Option     "XvMC"                  # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "VirtualHeads"          # <i>
        #Option     "TearFree"              # [<bool>]
        #Option     "PerCrtcPixmaps"        # [<bool>]
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "DebugFlushBatches"     # [<bool>]
        #Option     "DebugFlushCaches"      # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "BufferCache"           # [<bool>]
   Identifier  "Card1"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "Screen"
   Identifier "Screen1"
   Device     "Card1"
   Monitor    "Monitor1"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

questo file è stato creato con il comando Xorg :0 -configure e mi carica correttamente il server x


eppure come vedete non sembra in uso
Codice: Seleziona tutto
root /home/vrso # glxinfo | grep NVIDIA
root /home/vrso #
Ultima modifica di Procopio il mar set 02, 2014 12:46, modificato 1 volta in totale.
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Prossimo

Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite