Impossibile riprodurre video web e gif

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Linuxofilo
Linux 1.x
Linux 1.x
Messaggi: 157
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14.2 x64

Impossibile riprodurre video web e gif

Messaggioda Linuxofilo » ven gen 05, 2018 14:38

Ciao a tutti,
non riesco a riprodurre video da facebook, nè da siti come LaRepubblica.it, quando vi clicco sopra, carica 5 secondi e torna all'immagine dell'anteprima, mentre su youtube tutto ok a parte che se clicco sulla timeline in un settore non ancora caricato il video parte dall'inizio. Neanche le gif vengono caricate. Flash installato, ma ho alcuni dubbi sull'installazione di Java che ho effettuato: in pratica ho scaricato il pacchetto x64 .tar.gz e l'ho copiato in una directory in /usr/Java. Mi sono spostato in questa directory con la console e ho dato tar zxvf e mi ha creato una sottocartella con tutti i file contenuti nel pacchetto. Può bastare così o devo eseguire qualche file?

Avatar utente
conraid
Staff
Staff
Messaggi: 13221
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Impossibile riprodurre video web e gif

Messaggioda conraid » ven gen 05, 2018 15:38

Non ho capito come hai installato java, mi sa che che hai scaricato il pacchetto loro generico, non instabbile così su slackware, la via standard è copiare quel file in una directory insieme a questi file
ftp://ftp.slackware.com/pub/slackware/s ... xtra/java/
e poi crearti il pacchetto con

Codice: Seleziona tutto

# sh java.SlackBuild

e poi installarlo normalmente con installpkg

Altrimenti usa i file su slackbuilds.org

Ma non c'entra niente con quel problema dei video, credo nemmeno flash, ormai son tutti html5, forse ti manca qualche pacchetto

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2499
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: Impossibile riprodurre video web e gif

Messaggioda ponce » ven gen 05, 2018 15:43

credo che il problema della mancata visualizzazione dei video sia dovuto all'assenza di ffmpeg (firefox usa quello di default): puoi anche prenderlo da Alien BOB.

Avatar utente
conraid
Staff
Staff
Messaggi: 13221
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Impossibile riprodurre video web e gif

Messaggioda conraid » ven gen 05, 2018 15:52

Ah già, è solo in current.

Linuxofilo
Linux 1.x
Linux 1.x
Messaggi: 157
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14.2 x64

Re: Impossibile riprodurre video web e gif

Messaggioda Linuxofilo » ven gen 05, 2018 16:31

ponce ha scritto:credo che il problema della mancata visualizzazione dei video sia dovuto all'assenza di ffmpeg (firefox usa quello di default): puoi anche prenderlo da Alien BOB.


Scusami, ma basta eseguire il comando ./doinst.sh della build? Mi ha creato una ventina di collegamenti lib.. nella directory della build. E i video non riesco ancora a vederli.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2499
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: Impossibile riprodurre video web e gif

Messaggioda ponce » ven gen 05, 2018 16:36

se visiti il link che ti ho postato ( http://bear.alienbase.nl/mirrors/people ... kg64/14.2/ ) c'e' il pacchetto da installare per la 14.2.

il doinst.sh e' nella directory col tarball dei sorgenti e lo SlackBuild e non va eseguito: da quella directory, se ti vuoi compilare un pacchetto da solo, devi lanciare (diventando prima root con "su -" -nota bene lo spazio e il segno del meno dopo il "su")

Codice: Seleziona tutto

./ffmpeg.SlackBuild

Linuxofilo
Linux 1.x
Linux 1.x
Messaggi: 157
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14.2 x64

Re: Impossibile riprodurre video web e gif

Messaggioda Linuxofilo » ven gen 05, 2018 16:40

ponce ha scritto:se visiti il link che ti ho postato ( http://bear.alienbase.nl/mirrors/people ... kg64/14.2/ ) c'e' il pacchetto da installare per la 14.2.


Sì, mi riferivo proprio alla build che mi hai postato. Ho scaricato il pacchetto .txz, l'ho scompattato, sono entrato nella directory install e ho eseguito il file doinst.sh. Mi ha creato 20 collegamenti lib-qualcosa nella stessa directory e in console mi riporta questo risultato:

Codice: Seleziona tutto

bash-4.3$ ./doinst.sh
mv: cannot stat 'etc/ffserver.conf.new': No such file or directory
./doinst.sh: line 19: cd: usr/lib64: No such file or directory
./doinst.sh: line 20: cd: usr/lib64: No such file or directory
./doinst.sh: line 21: cd: usr/lib64: No such file or directory
./doinst.sh: line 22: cd: usr/lib64: No such file or directory
./doinst.sh: line 23: cd: usr/lib64: No such file or directory
./doinst.sh: line 24: cd: usr/lib64: No such file or directory
./doinst.sh: line 25: cd: usr/lib64: No such file or directory
./doinst.sh: line 26: cd: usr/lib64: No such file or directory
./doinst.sh: line 27: cd: usr/lib64: No such file or directory
./doinst.sh: line 28: cd: usr/lib64: No such file or directory
./doinst.sh: line 29: cd: usr/lib64: No such file or directory
./doinst.sh: line 30: cd: usr/lib64: No such file or directory
./doinst.sh: line 31: cd: usr/lib64: No such file or directory
./doinst.sh: line 32: cd: usr/lib64: No such file or directory
./doinst.sh: line 33: cd: usr/lib64: No such file or directory
./doinst.sh: line 34: cd: usr/lib64: No such file or directory
./doinst.sh: line 35: cd: usr/lib64: No such file or directory
./doinst.sh: line 36: cd: usr/lib64: No such file or directory
./doinst.sh: line 37: cd: usr/lib64: No such file or directory
./doinst.sh: line 38: cd: usr/lib64: No such file or directory
./doinst.sh: line 39: cd: usr/lib64: No such file or directory
./doinst.sh: line 40: cd: usr/lib64: No such file or directory
./doinst.sh: line 41: cd: usr/lib64: No such file or directory
./doinst.sh: line 42: cd: usr/lib64: No such file or directory
./doinst.sh: line 43: cd: usr/lib64: No such file or directory
./doinst.sh: line 44: cd: usr/lib64: No such file or directory
./doinst.sh: line 45: cd: usr/lib64: No such file or directory
./doinst.sh: line 46: cd: usr/lib64: No such file or directory
./doinst.sh: line 47: cd: usr/lib64: No such file or directory
./doinst.sh: line 48: cd: usr/lib64: No such file or directory
./doinst.sh: line 49: cd: usr/lib64: No such file or directory
./doinst.sh: line 50: cd: usr/lib64: No such file or directory
./doinst.sh: line 51: cd: usr/lib64: No such file or directory
./doinst.sh: line 52: cd: usr/lib64: No such file or directory
./doinst.sh: line 53: cd: usr/lib64: No such file or directory
./doinst.sh: line 54: cd: usr/lib64: No such file or directory

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2499
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: Impossibile riprodurre video web e gif

Messaggioda ponce » ven gen 05, 2018 16:47

quello e' un pacchetto Slackware da installare con installpkg... perche' l'hai scompattato?

Linuxofilo
Linux 1.x
Linux 1.x
Messaggi: 157
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14.2 x64

Re: Impossibile riprodurre video web e gif

Messaggioda Linuxofilo » ven gen 05, 2018 16:57

ponce ha scritto:quello e' un pacchetto Slackware da installare con installpkg... perche' l'hai scompattato?


perchè ho visto il file doinst.sh e ho pensato si dovesse scompattare. Inoltre mi hai detto che c'è da eseguire il file ffmpeg.SlackBuild dopo aver inserito il comando su -. Quindi devo usare installpkg?

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2499
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: Impossibile riprodurre video web e gif

Messaggioda ponce » ven gen 05, 2018 17:06

Linuxofilo ha scritto:
ponce ha scritto:quello e' un pacchetto Slackware da installare con installpkg... perche' l'hai scompattato?

perchè ho visto il file doinst.sh e ho pensato si dovesse scompattare.

ma il file doinst.sh e' dentro il pacchetto, quindi lo avevi gia' scompattato, senno' non lo potevi vedere :D

Inoltre mi hai detto che c'è da eseguire il file ffmpeg.SlackBuild dopo aver inserito il comando su -.

io veramente ho scritto
ponce ha scritto:il doinst.sh e' nella directory col tarball dei sorgenti e lo SlackBuild e non va eseguito: da quella directory, se ti vuoi compilare un pacchetto da solo, devi lanciare (diventando prima root con "su -" -nota bene lo spazio e il segno del meno dopo il "su")

Codice: Seleziona tutto

./ffmpeg.SlackBuild

quindi, devi farlo *solo nel caso* che tu ti voglia fare un pacchetto da solo (non ne vedo il motivo).

Quindi devo usare installpkg?

si, con il file ffmpeg-3.4-x86_64-2alien.txz che trovi nella directory che ti ho linkato (la rilinko http://bear.alienbase.nl/mirrors/people ... kg64/14.2/)

Linuxofilo
Linux 1.x
Linux 1.x
Messaggi: 157
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14.2 x64

Re: Impossibile riprodurre video web e gif

Messaggioda Linuxofilo » lun gen 08, 2018 9:11

Scusate i vari misunderstanding. Comunque ho installato ffmpeg e ora i video sul web riesco a vederli. Grazie a tutti ;)

Linuxofilo
Linux 1.x
Linux 1.x
Messaggi: 157
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14.2 x64

Re: Impossibile riprodurre video web e gif

Messaggioda Linuxofilo » lun gen 08, 2018 13:55

ragazzi scusate se riprendo il discorso, ma ho notato che su whatsappweb non mi fa vedere i video che mi inviano. Tento di farli caricare ma torna sempre sull'anteprima. Forse whatsapp web usa un altro formato di riproduzione?

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2499
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: Impossibile riprodurre video web e gif

Messaggioda ponce » lun gen 08, 2018 14:21

Linuxofilo ha scritto:ragazzi scusate se riprendo il discorso, ma ho notato che su whatsappweb non mi fa vedere i video che mi inviano. Tento di farli caricare ma torna sempre sull'anteprima. Forse whatsapp web usa un altro formato di riproduzione?

non saprei.
prova a scaricarli e a visualizzarli tramite mplayer usando l'opzione "-identify", ti dovrebbe dare tutta una serie di informazioni utili sul formato: un esempio

Codice: Seleziona tutto

ID_DEMUXER=lavfpref
ID_VIDEO_FORMAT=HEVC
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1280
ID_VIDEO_HEIGHT=720
ID_VIDEO_FPS=25.000
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=MP4A
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
ID_START_TIME=0.00
ID_LENGTH=1796.26

provalo anche con qualche video che ti funziona e guarda le differenze

Linuxofilo
Linux 1.x
Linux 1.x
Messaggi: 157
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14.2 x64

Re: Impossibile riprodurre video web e gif

Messaggioda Linuxofilo » lun gen 08, 2018 14:47

non saprei.
prova a scaricarli e a visualizzarli tramite mplayer usando l'opzione "-identify", ti dovrebbe dare tutta una serie di informazioni utili sul formato: un esempio

Codice: Seleziona tutto

ID_DEMUXER=lavfpref
ID_VIDEO_FORMAT=HEVC
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1280
ID_VIDEO_HEIGHT=720
ID_VIDEO_FPS=25.000
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=MP4A
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
ID_START_TIME=0.00
ID_LENGTH=1796.26

provalo anche con qualche video che ti funziona e guarda le differenze


non me li fa neanche scaricare. La freccetta del download è in grigio e non posso cliccarci sopra.

Linuxofilo
Linux 1.x
Linux 1.x
Messaggi: 157
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14.2 x64

Re: Impossibile riprodurre video web e gif

Messaggioda Linuxofilo » lun gen 08, 2018 14:51

rettifico, è solo un video che non riesco nè a scaricare nè a visualizzare. Gli altri tramite whatsapp web riesco a vederli tranquillamente, non capisco perchè solo quello.