Kernel 4.15.1 non parte

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
boh
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven set 16, 2005 0:00
Slackware: 14.2 (x64)
Kernel: 4.4.111
Desktop: KDE 4.14.32
Località: Milano
Contatta:

Kernel 4.15.1 non parte

Messaggioda boh » dom feb 04, 2018 21:50

Ciao a tutti!
Oggi pomeriggio, incuriosito da questo post, ho provato a compilare il kernel 4.15.1 sulla mia slackware 14.2.
Al momento ero ancora sull'ultimo ufficiale, il 4.4.111.
I passi seguiti sono i soliti:

Codice: Seleziona tutto

make olddefconfig
make
make modules_install

e poi copio il bzImage ottenuto nella partizione EFI. Aggiorno il conf di elilo e di solito parte tutto, ma non stavolta :D
Il file di conf di elilo è il seguente (nulla di trascendentale):

Codice: Seleziona tutto

prompt
chooser=simple
delay=10
timeout=100
default=linux_4.4.111
#
image=vmlinuz-huge-4.4.111
        label=linux_4.4.111
        read-only
        append="root=/dev/sda2 ro"

image=vmlinuz-huge-4.15.1
        label=linux_4.15.1
        read-only
        append="root=/dev/sda2 ro"


Quello che succede è che viene caricato il kernel, poi schermata scura e torno sul prompt di elilo (una specie di bootloop).

Qualcuno sa spiegarmi come mai? :-k

P.S. Ho trovato questo thread di conraid in cui si afferma che il kernel generato in realtà non è huge, ma generic, potrebbe essere questo il problema? viewtopic.php?f=51&t=39250#p350080
"Be yourself. Everyone else is already taken." ~ Oscar Wilde

Avatar utente
boh
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven set 16, 2005 0:00
Slackware: 14.2 (x64)
Kernel: 4.4.111
Desktop: KDE 4.14.32
Località: Milano
Contatta:

Re: Kernel 4.15.1 non parte

Messaggioda boh » dom feb 04, 2018 22:09

Ho provato a usare un initrd con il kernel nuovo, ma il comportamento è sempre lo stesso.
Vedo le scritte di avvenuto caricamento del kernel e dell'initrd, ma poi schermo nero e si torna al prompt di elilo :-k
Non ho quindi messaggi di kernel panic evidenti!
"Be yourself. Everyone else is already taken." ~ Oscar Wilde

Meskalamdug
Iper Master
Iper Master
Messaggi: 3890
Iscritto il: ven mag 14, 2004 0:00

Re: Kernel 4.15.1 non parte

Messaggioda Meskalamdug » dom feb 04, 2018 22:43

Il kernel lo vedi partire?
Vedi i messaggi di avvio dischi,etc?
Se si e si interrompe è un panic.
Se no prova così
a) Avvia da livecd
b)monta la tua root su mnt
monta dev proc sys con l'opzione bind su /mnt/dev proc sys

Codice: Seleziona tutto

for i in dev proc sys
do mount -o bind -v /$i/ /mnt/$i
done


b1)chroot mnt

Codice: Seleziona tutto

chroot /mnt


c)Rimuovi i kernel huge e generic

d)Installa a tuo piacimento uno dei due kernel(io preferisco il generic)

e)Genera initrd

Codice: Seleziona tutto

mkinitrd...


f)Adesso arriva il bello..mai usato elilo,sempre grub
quindi da qui fai tu.

g)Prova a riavviare
p.s=perchè elilo e non grub?

Avatar utente
boh
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven set 16, 2005 0:00
Slackware: 14.2 (x64)
Kernel: 4.4.111
Desktop: KDE 4.14.32
Località: Milano
Contatta:

Re: Kernel 4.15.1 non parte

Messaggioda boh » dom feb 04, 2018 23:41

Io vedo solo due scritte:
Loading kernel... done
Loading initrd... done


Poi diventa tutto nero e dopo qualche secondo (2-3) ritorno al prompt di elilo.

Riesco comunque a far caricare l'altro kernel (quello ufficiale), il 4.15 è un'aggiunta al conf, non ha sostituito quello vecchio. Cosa dovrei ottenere con il chroot?

P.S. uso elilo perché è quello che viene proposto in fase di installazione, grub è più facile da usare?
"Be yourself. Everyone else is already taken." ~ Oscar Wilde

Meskalamdug
Iper Master
Iper Master
Messaggi: 3890
Iscritto il: ven mag 14, 2004 0:00

Re: Kernel 4.15.1 non parte

Messaggioda Meskalamdug » lun feb 05, 2018 0:25

boh ha scritto:Io vedo solo due scritte:
Loading kernel... done
Loading initrd... done


Poi diventa tutto nero e dopo qualche secondo (2-3) ritorno al prompt di elilo.

Riesco comunque a far caricare l'altro kernel (quello ufficiale), il 4.15 è un'aggiunta al conf, non ha sostituito quello vecchio. Cosa dovrei ottenere con il chroot?

P.S. uso elilo perché è quello che viene proposto in fase di installazione, grub è più facile da usare?

Chroot usalo solo se non riesci ad accedere al sistema.
Se riesci ad accedere usando un altro kernel,non è necessario.
Il kernel lo hai compilato tu?Se ti da schermata nera e riavvia è sicuramente un panic.
Riguardo grub è più complesso di elilo,se ti trovi bene con elilo tieni quello

Avatar utente
boh
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven set 16, 2005 0:00
Slackware: 14.2 (x64)
Kernel: 4.4.111
Desktop: KDE 4.14.32
Località: Milano
Contatta:

Re: Kernel 4.15.1 non parte

Messaggioda boh » lun feb 05, 2018 9:47

Sì, l'ho compilato io, ma usando il vecchio config e mettendo tutte le scelte di default, mi fa molto strano che non vada :-k
Nessun suggerimento? Posso provare a compilare l'ultimo del 4.14 visto che Pat lo sta mettendo in current, però boh...
"Be yourself. Everyone else is already taken." ~ Oscar Wilde

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2496
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: Kernel 4.15.1 non parte

Messaggioda ponce » lun feb 05, 2018 10:07

prova a prendere il config dal repository di David

https://dusk.idlemoor.tk/config/

ci sono anche i pacchetti gia' pronti

https://dusk.idlemoor.tk/linux-4.15/

occhio che e' un kernel-generic e dovrai usarci un initd: per vedere il comando per generare un initrd piu' adatto per le tue esigenze, esegui /usr/share/mkinitrd/mkinitrd_command_generator.sh quando stai facendo gia' girare un kernel funzionante (passandogli con l'opzione -k la versione del kernel per cui vuoi generare l'initrd).

Meskalamdug
Iper Master
Iper Master
Messaggi: 3890
Iscritto il: ven mag 14, 2004 0:00

Re: Kernel 4.15.1 non parte

Messaggioda Meskalamdug » lun feb 05, 2018 16:38

boh ha scritto:Sì, l'ho compilato io, ma usando il vecchio config e mettendo tutte le scelte di default, mi fa molto strano che non vada :-k
Nessun suggerimento? Posso provare a compilare l'ultimo del 4.14 visto che Pat lo sta mettendo in current, però boh...

Se non sei esperto è molto meglio non compilare il kernel.
Tempo fa(sto parlando del 2004..) il kernel me lo ricompilavo da solo e raramente ho avuto problemi di instabilità,non usavo neppure i config preimpostati di slackware o altri.
Ma nel 2004 linux era molto più semplice e arretrato di adesso,attualmente ho provato a ricompilare il kernel mettendo le opzioni
nuove a mio giudizio(ovviamente ho letto la descrizione con ?),ma l'unica cosa che ho ottenuto è stato un sistema si stabile..ma usando rsync con grossi blocchi di dati andava in panic(neppure magic sysrq poteva sbloccarlo,si inchiodava proprio) :o
Segno che ormai il kernel è diventato bello complesso e anche un utente con diversi anni di esperienza può fare qualche boiata,come è stato nel mio caso.
Fossi in te farei così,o usi il config di slackware e rimani nella serie 4.14*
O attendi il 4.15 di slackware e usi sempre il loro config.

Avatar utente
boh
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven set 16, 2005 0:00
Slackware: 14.2 (x64)
Kernel: 4.4.111
Desktop: KDE 4.14.32
Località: Milano
Contatta:

Re: Kernel 4.15.1 non parte

Messaggioda boh » lun feb 05, 2018 17:50

ponce ha scritto:prova a prendere il config dal repository di David

https://dusk.idlemoor.tk/config/

ci sono anche i pacchetti gia' pronti

https://dusk.idlemoor.tk/linux-4.15/

occhio che e' un kernel-generic e dovrai usarci un initd: per vedere il comando per generare un initrd piu' adatto per le tue esigenze, esegui /usr/share/mkinitrd/mkinitrd_command_generator.sh quando stai facendo gia' girare un kernel funzionante (passandogli con l'opzione -k la versione del kernel per cui vuoi generare l'initrd).


Grazie, appena ho tempo faccio un diff dei config e vedo un po' cosa c'è di diverso :D

Meskalamdug ha scritto:Se non sei esperto è molto meglio non compilare il kernel.


Non penso di essere esattamente un utente inesperto :lol:
Tuttavia, il kernel lo compilo poco, è vero :)
Una volta appurato con voi che si tratta solo di un "semplice" panic, voglio provare a divertirmi un po', vedo di giocare con i config e vedere se ci sono differenze sostanziali :thumbright:
"Be yourself. Everyone else is already taken." ~ Oscar Wilde