[RISOLTO] Errore nell'installazione dello SlackBuild di libspatialite sulla current

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
gian_d
Linux 0.x
Linux 0.x
Messaggi: 38
Iscritto il: mer lug 16, 2014 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 4.19.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

[RISOLTO] Errore nell'installazione dello SlackBuild di libspatialite sulla current

Messaggioda gian_d » dom apr 21, 2019 7:31

Segnalo che la compilazione sulla current, nel caso si abiliti il supporto opzionale di postgis (LWGeom=yes) dà questo errore:

Codice: Seleziona tutto

/tmp/SBo/libspatialite-4.2.0/src/.libs/libspatialite.so: undefined reference to `lw_vasprintf'


Il problema è stato segnalato l'anno scorso qui: https://lists.slackbuilds.org/pipermail ... August.txt
Lo slackbuild proposto via mail dal curatore di libspatialite su SBo mi sembra uguale a quello presente sia su slackbuilt.org sia sul fork di Ponce su GitHub. Sulla Slackware 14.2 l'installazione procede regolarmente, ma sulla current no.

Nella mailing list è segnalata però questa discussione: https://groups.google.com/forum/#!topic ... uFirW-60q4 che fa riferimento ad una patch per il pacchetto Debian di libspatialite.
La correzione delle stringhe indicate nella patch funziona e l'installazione si completa regolarmente anche sulla current

Ciao e buona pasqua