Repository 32bit  Forum
Repository 64bit  Wiki

Modem Conexant per laptop HP

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Modem Conexant per laptop HP

Messaggioda progger » mar lug 12, 2005 11:52

Parto subito con una domanda incasinata: nessuno di voi ha un portatile HP con modem Conexant? No, la domanda incasinata non era questa: ho scaricato il driver hsfmodem-7.18.00full.tar.gz, ed eseguito il make install. Il problema si presenta quando eseguo il hsfconfig, l' errore è il seguente:

ERROR: The kernel at '/lib/modules/2.4.29/build' was compiled without the following option enabled: CONFIG_SERIAL_CORE
This option is needed for DriverLoader. Please enable this kernel oprtion, re-compile the kernel and try again.

C'è un modo di sistemare il serial core senza ricompilare stò kernel? 8O
progger
Linux 1.0
Linux 1.0
 
Messaggi: 30
Iscritto il: lun lug 11, 2005 23:00

Messaggioda gianPrazio » mar lug 12, 2005 12:04

Ho proprio paura di no, sai... dovrai ricompilare il kernel.
Ciaoz
gianPrazio
Linux 2.4
Linux 2.4
 
Messaggi: 388
Iscritto il: mar set 28, 2004 23:00
Località: Castelfranco Veneto

Messaggioda People » mar lug 12, 2005 12:16

Mah, da quello che so io... modem conexant --> driver linuxant --> $$
trovi in giro delle vecche versioni gratuite (ma beta) che compilano solo sul 2.4... di più nin zo!

Ciao
P. :D
Avatar utente
People
Linux 2.4
Linux 2.4
 
Messaggi: 216
Iscritto il: lun giu 21, 2004 23:00
Slackware: 12.1
Kernel: 2.6.
Desktop: KDE

Messaggioda progger » mar lug 12, 2005 15:19

Ok, innanzi tutto grazie dell' attenzione!
Il problema non riguarda esclusivamente la ricompilazione del kernel (ho visto migliaia di HOWTO su come eseguire questa operazione...) ma come abilitare il CONFIG_SERIAL_CORE? Sono variabili di sistema tipo registro di Windows o tutt' altro? Non saprei dove cercare, AIUTO!!!! :?
progger
Linux 1.0
Linux 1.0
 
Messaggi: 30
Iscritto il: lun lug 11, 2005 23:00

Messaggioda napoleone1981 » mar lug 12, 2005 15:44

quando ricompilerai il kernel, vedrai tnate belle opzioni suddivise per categorie. Ad ognuna di queste puoi mettere Y, M, o niente ed ottiene la compilazione all'interno del kernel, come modulo, oppure non attivi il supporto. Tu dovresti cercare qualcosa che abbia ha che fare con Serial...
Avatar utente
napoleone1981
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: mer ago 25, 2004 23:00
Località: Sant'Elena

Messaggioda op15l » mar lug 12, 2005 20:42

si devi riconpilare il kernel con quella opzione, anche a me è capitato.
Avatar utente
op15l
Linux 2.6
Linux 2.6
 
Messaggi: 604
Iscritto il: mer gen 26, 2005 0:00
Località: Cattolica
Kernel: 2.6.27
Desktop: kde 4.1.3

Messaggioda op15l » mar lug 12, 2005 20:46

comunque per il key generator dei driver, c'è li ho a casa, se mai contattami
Avatar utente
op15l
Linux 2.6
Linux 2.6
 
Messaggi: 604
Iscritto il: mer gen 26, 2005 0:00
Località: Cattolica
Kernel: 2.6.27
Desktop: kde 4.1.3

Messaggioda useless » mar lug 12, 2005 20:55

ci pasti la riga di lspci relativa al tuo modem? xké quello del mio portatile compaq (~hp) non ho ancora capito con che driver funzioni, i conexant non paiono andare.
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Nebbia fitta...

Messaggioda progger » mer lug 13, 2005 11:57

Niente da fare! Prima di tutto non c' è un modulo CONFIG_SERIAL_CORE (sono presenti vari CONFIG_SERIAL_XX ma anche attivandoli tutti... NIENTE!) La stringa che ottengo dall' esecuzione di lspci è la seguente:

00:08.0 Modem: ALI corporation Intel 537 [M5457 AC-link Modem]

Ho provato anche con i driver per hcfpcimodem ma ho ottenuto lo stesso risultato...
Tengo a precisare che ho usato il kernel con ACPI incorporato (mi sembra si chiami acpiqualcosa.i) durante l' installazione del sistema, in questo modo funziona sia l' hotplug (con il kernel di default si impianta il sistema!) che il firewire. Potrebbe essere questo il problema?
progger
Linux 1.0
Linux 1.0
 
Messaggi: 30
Iscritto il: lun lug 11, 2005 23:00

Messaggioda absinthe » mer lug 13, 2005 15:36

ascolta ho trovato questo sul sito intel:

[url]http://downloadfinder.intel.com/scripts-df-external/filter_results.aspx?strTypes=all&ProductID=1230&OSFullName=Linux*&lang=eng&strOSs=39&submit=Go%21
[/url]

il modem è 537EP non so se sia lo stesso... spero ti possa aiutare.
tra l'altro fosse lui è munito pure di uno scipt intallante per la slack (anche se forse è meglio se lo butti a mano :)

ciao,
M.[/url]
Avatar utente
absinthe
Iper Master
Iper Master
 
Messaggi: 2354
Iscritto il: sab mag 14, 2005 23:00
Località: Prato
Nome Cognome: Matteo Nunziati
Slackware: 12.1 - defunct
Kernel: 2.6.32-5-amd64
Desktop: gnome
Distribuzione: debian squeeze

Messaggioda zzt » mer lug 13, 2005 16:23

Se non funziona quello di absinthe, dai un occhiata a
http://lists.qilinux.it/pipermail/qilinux-users-it/2005-May/000168.html
dice per AC'97 ma non di sa mai...
appena ho un po' di tempo (e un telefono) provo a smanettarci...
Avatar utente
zzt
Linux 2.4
Linux 2.4
 
Messaggi: 249
Iscritto il: lun mar 07, 2005 0:00

Messaggioda useless » mer lug 13, 2005 16:29

dunque:
- ho lo stesso identico model (magari anche lo stesso portatile? presario 2142eu)
- percoco mi ha segnalato http://linmodems.technion.ac.il, che mi ha detto che il modem è un conexant
- ho scaricato i driver: http://www.linuxant.com/drivers/hsf/ful ... ull.tar.gz
- effettivamente pare funzionare. non mi sono connesso ancora (ora uso il wireless), ma il modem pare reagire correttamente ai comandi AT che do con minicom, quindi credo non ci siano ulteriori problemi.
- non so come si abiliti il CONFIG_SERIAL_CORE, ma credo che se abiliti device drivers -> character devices -> serial drivers -> 8250/16550 and compatible serial support sei a posto.
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Messaggioda People » mer lug 13, 2005 18:36

Anche io ero riuscito a farlo funzionare con i linuxant (possiedo un presario 2175eu con lo stesso vostro modem) ma a 14400, che è una cosa da paura 8O. Non ho altri mezzi per connettermi se non un modem seriale esterno 56K che svolge il suo lavoro egregiamente. Ora sto provando i driver interl ma mi sa che ho qualche problema con gli header del kernel... vi farò sapere.
Ciao.
[EDIT] Ho provato ad aggiornare gli header del kernel con lo script che Salbutamolo ha postato qui visto che sul readme dei driver dicono
Prerequisites:
1. root access
2. bash shell to run install scripts
3. an Intel soft modem (537, 537EP, 537SP, 537AA or 537EA)
4. KERNEL SOURCE HEADERS FOR THE KERNEL YOU ARE RUNNING
(found on your distribution's CD)
ed io ho il kernel 2.6.12.1, ma se provo a comiplare con con make

576 l'errore che ottengo è sempre lo stesso.

root@andromeda:~/intel-537EP_secure-2.60.80.0# make 537
Module precompile check
Current running kernel is: 2.6.12.1
/lib/modules... autoconf.h exists
diff: /boot/vmlinuz.autoconf.h: No such file or directory
autoconf.h matches running kernel
diff: /boot/vmlinuz.version.h: No such file or directory
version.h matches running kernel
2.6.12.1
make[1]: Entering directory `/root/intel-537EP_secure-2.60.80.0/coredrv'
make -C /lib/modules/2.6.12.1/build SUBDIRS=/root/intel-537EP_secure-2.60.80.0/coredrv modules
make[2]: Entering directory `/usr/src/linux-2.6.12.1'
CC [M] /root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.o
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c:70: warning: type defaults to `int' in declaration of `EXPORT_SYMBOL_NOVERS'
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c:70: warning: parameter names (without types) in function declaration
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c:70: warning: data definition has no type or storage class
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c: In function `power_callback':
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c:295: error: `PM_SAVE_STATE' undeclared (first use in this function)
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c:295: error: (Each undeclared identifier is reported only once
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c:295: error: for each function it appears in.)
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c: In function `open':
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c:394: warning: `pm_register' is deprecated (declared at include/linux/pm.h:106)
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c: In function `close':
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c:416: warning: `pm_unregister' is deprecated (declared at include/linux/pm.h:111)
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c: At top level:
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c:754: warning: initialization from incompatible pointer type
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c:755: warning: initialization from incompatible pointer type
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c: In function `kScheduleDPC':
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c:861: warning: implicit declaration of function `pm_access'
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c: In function `dspdrv_CommRamISR':
/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.c:877: warning: function declaration isn't a prototype
make[3]: *** [/root/intel-537EP_secure-2.60.80.0/coredrv/coredrv.o] Error 1
make[2]: *** [_module_/root/intel-537EP_secure-2.60.80.0/coredrv] Error 2
make[2]: Leaving directory `/usr/src/linux-2.6.12.1'
make[1]: *** [537core_26] Error 2
make[1]: Leaving directory `/root/intel-537EP_secure-2.60.80.0/coredrv'
2.6.12.1
Failed to build driver


ergo... mi tengo il 56K esterno. :roll:

Ciao
P.
Avatar utente
People
Linux 2.4
Linux 2.4
 
Messaggi: 216
Iscritto il: lun giu 21, 2004 23:00
Slackware: 12.1
Kernel: 2.6.
Desktop: KDE

Messaggioda progger » sab lug 23, 2005 10:44

Ok, problema risolto! Ci ho messo un po di tempo perche dovevo compilare il kernel per la prima volta...comunque dopo i soliti kernel panic ho installato il 2.6.12.3 e... funziona! Il problema era che il kernel di default (2.4.29) non ha il supporto per le porte seriali non 8250 (dove si trova il CONFIG_SERIAL_CORE). Grazie a tutti x la collaboazione!
progger
Linux 1.0
Linux 1.0
 
Messaggi: 30
Iscritto il: lun lug 11, 2005 23:00

Messaggioda DaNiMoTh » sab lug 23, 2005 12:25

Io li ho installati da un mio amico, glieli ho anche crakkati.

Ma è possibile pagare per far funzionare un qualcosa che è già mio? Ma dove siamo finiti?
Avatar utente
DaNiMoTh
Linux 2.6
Linux 2.6
 
Messaggi: 941
Iscritto il: mar nov 30, 2004 0:00
Località: irc.syrolnet.org /// #slackware


Torna a Laptop

Chi c’è in linea

Visitano il forum: Exabot [Bot] e 1 ospite