Repository 32bit  Forum
Repository 64bit  Wiki

Errore gnome-slacky [RISOLTO]

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Errore gnome-slacky [RISOLTO]

Messaggioda algol » mer mag 09, 2007 0:23

Salve tipi e tipe,

ho un problemino problemuccio con la gnome slacky.

Cioè, la misi ad installare, ma mi accorsi che tipo ci metteva 1/4 d'ora a pacchetto l'ho lasciato fare tutta la notte, ma al mattino.. sorpresa! come temevo, spazio esaurito!

comunque, mi metto, faccio spazio e reinstallo quello che mi sembra corrotto, comunque non so se è per questa disavventura, ma ho questo problema:

quando avvio una applic gnome, ad es glines, mi dice questo:
Codice: Seleziona tutto
(glines:1920): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GnomeProgram' has no property named `goption-context'

(glines:1920): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GnomeProgram' has no property named `goption-context'


ecco l'output di gdb:
Codice: Seleziona tutto
gdb glines
GNU gdb 6.6
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i486-slackware-linux"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) run
Starting program: /usr/bin/glines
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1229019456 (LWP 1920)]

(glines:1920): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GnomeProgram' has no property named `goption-context'

(glines:1920): GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GnomeProgram' has no property named `goption-context'

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1229019456 (LWP 1920)]
0xb77a93c4 in gdk_x11_display_get_xdisplay () from /usr/X11R6/lib/libgdk-x11-2.0.so.0
(gdb) quit
The program is running.  Exit anyway? (y or n) n
Not confirmed.
(gdb) ni

Program terminated with signal SIGSEGV, Segmentation fault.
The program no longer exists.
(gdb) quit


ci sta questo file
usr/X11R6/lib/libgdk-x11-2.0.so.0
collegamento a /usr/X11R6/lib/libgdk-x11-2.0.so.0.1000.10 che sembra dare problemi... mah.

comunque fa così con varie app, anche con gnome-terminal, ma si avvia lo stesso...

che fare?

ciao, grazie, ciao

A
Ultima modifica di algol il gio giu 07, 2007 2:15, modificato 1 volta in totale.
Avatar utente
algol
Linux 2.6
Linux 2.6
 
Messaggi: 969
Iscritto il: gio set 07, 2006 0:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2

Messaggioda gohanz » mer mag 09, 2007 7:01

L'installazione dura parecchio perchè i pacchetti in fase di post installazione efettuano dei script accessori, inoltre molti effettuano l'upgrade!
Nel mio Pc Glines funziona benissimo! Probabilmente se l'installazione non è andata a bun fine per problemi di spazio, qualche pacchetto non è stato installato!

Prova a dare
Codice: Seleziona tutto
ldd /usr/bin/glines | grep missing
e controlla eventuali librerie mancanti!

Immagine
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda algol » mer mag 09, 2007 18:44

Beh il problema ovviamente non e' solo per glines, neanche a dirlo gnome non si avvia per niente.

Provero' con lo ldd che suggerisci, Gohanz.

Qualcuno sa in quale pacchetto dovrebbe stare il file /usr/X11R6/lib/libgdk-x11-2.0.so.0.1000.10?

Che mi consiliate di fare? reinstallare la gnome? e con quale modalita'? Per ora ho reinstallato vari pacchetti tipo librerie e parti centrali di gnome, ma nulla...
:cry:
Avatar utente
algol
Linux 2.6
Linux 2.6
 
Messaggi: 969
Iscritto il: gio set 07, 2006 0:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2

Messaggioda gohanz » mer mag 09, 2007 18:51

Sono le librerie Gtk+2, ma mi dici che versione di Gtk hai attualmente installato? Perchè quella libreria dovrebbe essere aggiornata! ma non è che sei sulla current?
Ultima modifica di gohanz il mer mag 09, 2007 18:54, modificato 1 volta in totale.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda algol » mer mag 09, 2007 18:53

Ah dici?
uhmma, avevo visto qualche indizioa in proposito via google, e le ho reinstallate dacccapo quelle della gnome-slacky proprio ieri sera ma non e' cambiato neinte!!

P.S. che sollecitudine! Stai online ORA... :o
Avatar utente
algol
Linux 2.6
Linux 2.6
 
Messaggi: 969
Iscritto il: gio set 07, 2006 0:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2

Messaggioda gohanz » mer mag 09, 2007 18:58

Controlla che siano installate le dipendenze delle librerie Gtk! Quindi Atk, Cairo, Glib2, Pango del Cd di Gnome-Slacky! Sono tutti in platform!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda gohanz » mer mag 09, 2007 18:59

Ma quanto spazio libero hai sul disco?
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda algol » mer mag 09, 2007 19:03

Ora non sto a casa, ma mi pare dia verlereinstallate proprio iersera...

spazio libero? credo intorno ai 250 mb!! :roll:

Si', io coltivo amabilmente hardware un po' desueto...
Avatar utente
algol
Linux 2.6
Linux 2.6
 
Messaggi: 969
Iscritto il: gio set 07, 2006 0:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2

Messaggioda gohanz » mer mag 09, 2007 19:06

Guarda per installare Gnome-Slacky 2.18.1 occorre un Giga libero! Con 250 mega non credo che puoi portare a termine un'installazione, comleta! Anche con la versiobe 2.18.0!

Comunque credo che il tuo problema derivi dalla mancata installazione delle glib2 aggiornate del cd di Gnome-Slacky!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda algol » mer mag 09, 2007 19:10

Beh, ora che lho insatllata ho 250 mb...

Non so quanto en avessi prima, dato che ho upgradato da una freerock...

Mi ha sforato perche con l'installer della gnome slacky ho fatto installare tutto, tipo pure roba grossa come evolution che non uso...

credi sia un'idea disintallrla e reinstallarla? :p
Avatar utente
algol
Linux 2.6
Linux 2.6
 
Messaggi: 969
Iscritto il: gio set 07, 2006 0:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2

Messaggioda gohanz » mer mag 09, 2007 19:20

Non devi toccare Evolution-data-server! Che è richiesto da tanti programmi! Per il resto non credo che Evolution venga richiesto da altri programmi Gnome! Comunque io un upgrade da Freerock non l'ho mai provato per ovvi motivi! Mi servirebbeo 10 Pc e ne ho uno! :roll: COmunque prova a reinstallare le Glib2
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda algol » mer mag 09, 2007 19:23

Vabbe' provero', grazie!

ciao
Avatar utente
algol
Linux 2.6
Linux 2.6
 
Messaggi: 969
Iscritto il: gio set 07, 2006 0:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2

Messaggioda algol » gio mag 10, 2007 17:16

:oops: :oops: :cry: :oops:

Nada... oggi ho reintallato barbaramente con installpkgs tutto platform, dipendenze slacky, bindings e devlibs ma nulla...

Se installo le glib e gtk della slack?
Avatar utente
algol
Linux 2.6
Linux 2.6
 
Messaggi: 969
Iscritto il: gio set 07, 2006 0:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2

Messaggioda gohanz » gio mag 10, 2007 17:44

Se installi glib e gtk della 11.0 non può funzionare, perchè Gnome 2.18.0 richiede le versioni aggiornate!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda algol » gio mag 10, 2007 23:34

Ok...

comunque mi sta zompando di tutto, mo non si avvia kde perchè crasha kbuildsyscoca!!!

Mi si propone il metodo windowz... reinstallo tutto! :cry:
Avatar utente
algol
Linux 2.6
Linux 2.6
 
Messaggi: 969
Iscritto il: gio set 07, 2006 0:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2

Prossimo

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron