Repository 32bit  Forum
Repository 64bit  Wiki

Ancora una volta swaret dietro proxy [RISOLTO]

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Ancora una volta swaret dietro proxy [RISOLTO]

Messaggioda legionario » sab ott 20, 2007 14:05

Ciao a tutti!!
Lo so che l'argomento e' gia' stato trattato piu' volte ma ho bisogno di superare il proxy con swaret per scaricare gli aggiornamenti. Ho seguito le indicazioni degli altri post ma non ho ottenuto risulati. Secondo voi puo' essere un problema di protocollo di autenticazione del server proxy?
Ho inserito in swaret.conf

Codice: Seleziona tutto
 WGET_PROXY=http://dominio\utente:password@proxy:porta


ho provato anche senza mettere il dominio ma niente...no va...

qualche suggerimento?
Ultima modifica di legionario il sab dic 15, 2007 2:05, modificato 1 volta in totale.
Avatar utente
legionario
Linux 2.6
Linux 2.6
 
Messaggi: 603
Iscritto il: mer dic 08, 2004 0:00
Località: Bergamo - Roma

Messaggioda albatrosla » sab ott 20, 2007 16:43

Io utilizzo swaret attraverso un proxy http con simple authentication e utilizzo la seguente stringa:
Codice: Seleziona tutto
WGET_PROXY=http://username:password@host:port

Quindi uguale alla tua. Che errore restituisce swaret? Dà un authentication failed?
albatrosla
Packager
Packager
 
Messaggi: 1294
Iscritto il: sab mar 27, 2004 0:00
Località: Bressa - Friuli / Torino
Slackware: current
Desktop: fluxbox.git

Messaggioda legionario » sab ott 20, 2007 20:29

Veramente non mi restituisce nessun errore...semplicemente non mi scarica niente. Piu' precisamente inizia lo scaricamento visualizzando la barretta che ruota in senso orario e, dopo un po', dice failed.

Codice: Seleziona tutto
root@105RN:~# swaret --update
swaret 1.6.3-2
[ http://sunsite.cnlab-switch.ch/ftp/mirror/slackware/slackware-current ]
### Scarico il File CHECKSUMS... FALLITO!
### Scarico il File FILELIST... FALLITO!
.......
.......


Questo e' quello che ho attivato nel mio swaret:

Codice: Seleziona tutto
 VERSION=current
LANGUAGE=ITALIANO
ROOT=http://sunsite.cnlab-switch.ch/ftp/mirror/slackware/slackware-$VERSION
ROOT=http://www.slackware.no/slackware/slackware-$VERSION
ROOT=http://www.slackware.at/data/slackware-$VERSION
ROOT=http://ftp.planetmirror.com/pub/slackware/slackware-$VERSION
REPOS_ROOT=Slacky%http://www.slacky.eu/repository/slackware-12.0
REPOS_ROOT=Slackware%http://darkstar.ist.utl.pt/slackware/addon/slacky/slackware-12.0/
REPOS_ROOT=Slacky_uglyplace%http://slacky.uglyplace.org/repository/slackware-12.0/
DEP_ROOT=http://swaret.sourceforge.net
RANDOMR=0
ROLLBACK=0
ROLLBACKMAX=3
USEPKGDESC=0
EXCLUDE=kernel alsa lilo
EXCLUDE=swaret
EXCLUDE=aaa_
EXCLUDE=MANIFEST.bz2$
EXCLUDE=.*dl$ .*PACKAGER$ .*MYBUILD$
DEPENDENCY=1
DSEARCHLIB=1
DSEARCHM=0
MD5CHECK=1
GPGCHECK=0
DESC=0
CACHE_DIR=/var/swaret
LOG=1
LOG_FILE=/var/log/swaret
WARNINGS=1
INFORMATION=1
NIC=eth0
PROGRESS=0
TIMEOUT=35
RETRIES=5
PASSIVE_FTP=1
WGET_PROXY=http://utente:password@proxy:porta


Ho pensato che, forse, swaret comunica su una porta diversa dalla 80, pertanto il proxy me la blocca. Almeno e' un'ipotesi...
Avatar utente
legionario
Linux 2.6
Linux 2.6
 
Messaggi: 603
Iscritto il: mer dic 08, 2004 0:00
Località: Bergamo - Roma

Messaggioda albatrosla » dom ott 21, 2007 9:56

No, swaret comunica sulla 80 con i repository http e sulla 21 con quelli ftp. Quindi non è quello il problema. Inoltre, se non ti dà errori di autenticazione, significa che il nodo proxy non è un problema. Prova, piuttosto, a cambiare repository: ce ne sono parecchi che mi danno problemi del genere, anche perchè talvolta hanno cambiato le path nel tempo...
albatrosla
Packager
Packager
 
Messaggi: 1294
Iscritto il: sab mar 27, 2004 0:00
Località: Bressa - Friuli / Torino
Slackware: current
Desktop: fluxbox.git

Messaggioda legionario » dom ott 21, 2007 10:05

Non e' che potresti mandarmi uno dei tuoi repository che sicuramente funzionano? Se il problema e' tutto li' allora e' meno grave di quanto pensassi...

Comunque mi confermi che non c'e' nessun errore nel swaret.conf vero?

Grazie per l'aiuto
Avatar utente
legionario
Linux 2.6
Linux 2.6
 
Messaggi: 603
Iscritto il: mer dic 08, 2004 0:00
Località: Bergamo - Roma

Messaggioda legionario » dom ott 21, 2007 11:09

Ho fatto un tentativo che mi induce a ritenere che i Repositories non c'entrino niente, anche perche' e' impossibile che tutti quelli che ho inserito siano inattivi. Infatti, anche inserendo una password sbagliata swaret non mi restituisce nessun messaggio di errore di autenticazione, ma il solito output ripetuto tante volte quanti sono i tentativi di scaricare i vari elementi:

Codice: Seleziona tutto
~# swaret --update
swaret 1.6.3-2

[ http://sunsite.cnlab-switch.ch/ftp/mirror/slackware/slackware-current ]
### Scarico il File CHECKSUMS... FALLITO!
### Scarico il File FILELIST... FALLITO!
### Scarico il File PACKAGES dei Pacchetti... FALLITO!
### Scarico il File PACKAGES dei Pacchetti Extra... FALLITO!
### Scarico il File ChangeLog... FALLITO!
.........
.........


Quale potrebbe essere il problema? SIcuramente swaret qualche problemino ce l'ha visto che omette di segnalare la mancata autenticazione da parte del proxy...
Avatar utente
legionario
Linux 2.6
Linux 2.6
 
Messaggi: 603
Iscritto il: mer dic 08, 2004 0:00
Località: Bergamo - Roma

Messaggioda legionario » dom ott 21, 2007 21:48

Da quanto ho capito dopo alcune ricerche wget, e quindi swaret, sembrerebbe non supportare l'autenticazione NTLM dei proxy...
E' una supposizione sbagliata? Questo vuol dire che non ho speranze di passare il proxy con swaret?
Avatar utente
legionario
Linux 2.6
Linux 2.6
 
Messaggi: 603
Iscritto il: mer dic 08, 2004 0:00
Località: Bergamo - Roma

Messaggioda legionario » sab dic 15, 2007 2:04

Riesumo dopo parecchio tempo questo post per comunicare che il problema si puo' risolvere installando ntlmaps da sorgenti, configurare opportunamente il file di configurazione inserendo i dati relativi al proxy, al tipo di autenticazione, al dominio, allo user e passwd. Quindi in swaret.conf bisogna inserire i dati relativi non al proxy aziendale ma ad ntlmaps. Infine si fa partire ntlmaps (tramite python)e si avvia swaret. La procedura in realta' e' molto semplice...
Spero possa essere di aiuto a qualcuno...
Avatar utente
legionario
Linux 2.6
Linux 2.6
 
Messaggi: 603
Iscritto il: mer dic 08, 2004 0:00
Località: Bergamo - Roma


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti