[RISOLTO] OpenVPN: problema configurazione

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
rik70
Master
Master
Messaggi: 1979
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 4.20
Desktop: Xfce 4.12
Distribuzione: archlinux

[RISOLTO] OpenVPN: problema configurazione

Messaggioda rik70 » ven mar 01, 2019 18:42

Stavo provando OpenVPN sulla slack 14.2 e ho notato un comportamento strano.

Ho generato correttamente tutti i file .pem .key .crt e li ho piazzati nella directory /etc/openvpn.
Tuttavia il server non parte perché non li trova.

Ho risolto modificando il server.conf in questo modo:

Codice: Seleziona tutto

*****
ca /etc/openvpn/ca.crt
cert /etc/openvpn/slackbox.crt
key /etc/openvpn/slackbox.key

*******

Però mi chiedo se sia normale dover specificare il percorso completo dei file.

Idee?

Grazie in anticipo.
Ultima modifica di rik70 il ven mar 01, 2019 18:54, modificato 1 volta in totale.

rik70
Master
Master
Messaggi: 1979
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 4.20
Desktop: Xfce 4.12
Distribuzione: archlinux

Re: OpenVPN: problema configurazione

Messaggioda rik70 » ven mar 01, 2019 18:53

Ok, risolti i miei dubbi grazie a SlackwareDocs.

Ciao.