Repository 32bit  Forum
Repository 64bit  Wiki

ASUS A2500L - Config modem SIS AC' 97: differenze tra le versioni

Da Slacky.eu.
Riga 1: Riga 1:
  +
([[Category:Laptop]])
  +
= Introduzione =
= Introduzione =

Versione delle 00:02, 8 mag 2007

()

Introduzione

Ciao, scrivo questa guida in seguito all' esperienza personale sul mio portatile [1], la dedico a tutti quelli che dopo vari tentativi ancora non sono riusciti a far lavorare il loro winmodem con SlackWare su ASUS A2 (penso valida anche in altre situazioni simili).

Preciso di non essere un esperto quindi in caso ho commesso qualche errore che può compromettere il sistema ò per suggerimenti e consigli sulla guida, gli esperti non esitassero.

Installazione

Punto primo bisogna scaricare il driver slmodem-2.9.11 da qui:

http://linmodems.technion.ac.il/packages/smartlink/ http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.11-20070204.tar.gz


Per l' installazione di tutti i driver, è necessario aver installato i sorgenti del kernel, ed è importante che siano quelli del vostro kernel in utilizzo. Una volta in possesso del driver, (io l'ho posizionato nella home) è necessario decomprimerlo, per fare ciò aprire un terminale decomprimetelo con il seguente comando:

[utente@localhost]$ tar -zxvf slmodem-2.9.11-20070204.tar.gz

oppure tasto destro estrai qui.

Una volta decompresso il driver si può operare come riportato sul readme dello stesso. Le operazioni di seguito riportate vengono eseguite da terminale. Consiglio ai meno esperti di partire con una macchina appena avviata per evitare problemi dovuti a tentativi precedenti.

Spostarsi all'interno della directory del driver:

[utente@localhost]$cd slmodem-2.9.11-20070204

e lanciare i comandi:

[utente@localhost slmodem-2.9.11-20070204]$ make clean

e

[utente@localhost slmodem-2.9.11-20070204]$ make

loggarsi come root:

[utente@localhost slmodem-2.9.11-20070204]$ su

seguito dalla password, e dare il comando:

[root@localhost slmodem-2.9.11-20070204]# make install

Installato il driver è necessario aggiungere sul file /etc/modprobe.conf le seguenti due righe:

alias char-major-212 slamr

alias char-major-213 slusb

Per fare ciò è necessario editare il file come root.

Adesso bisogna copiare lo script d'avvio rc.slmodemd che si trova nella cartella del modem /scripts/slackware/ e posizionarlo nella cartella /etc/rc.d/.

Avviare il modem con il comando:

[root@localhost slmodem-2.9.11-20070204]# /etc/rc.d/rc.slmodemd start

dovremo aver ottenuto un OK all'esecuzione del comando.

Per la configurazione con PPP o Kppp consiglio vivamente di documentarsi tramite La guida Slackware For Dummies S4D che trovate su Slacky. In linea di massima, se come me, usate KPPP, bisogna creare un link al device con:

[root@localhost slmodem-2.9.11-20070204]# ln -s /dev/ttySL0 /dev/modem

disattivare il controllo di linea (attendi il segnale...), di portare il tempo di attesa per la ricomposizione almeno a cinque secondi, ed il timeout modem a 60 secondi.

Purtroppo al riavvio il modem non verrà più riconosciuto e dovrete rieseguire tutta l'operazione.... scherzo! Per evitare appunto questo inconveniente dovrete apportare iin cima allo script di avvio del modem "/etc/rc.d/rc.slmodemd" le seguenti modifiche: Cambiare

SLMODEMD_DEVICE=/dev/slusb0

in

SLMODEMD_DEVICE=/dev/slamr0

ed aggiungere alle prime righe successive:

mknod -m 600 /dev/slamr0 c 242 0 ; mknod -m 600 /dev/slamr1 c 242 1 ; mknod -m 600 /dev/slamr2 c 242 2 ;

mknod -m 600 /dev/slamr3 c 242 3 ; echo -n

mknod -m 600 /dev/slusb0 c 243 0 ; mknod -m 600 /dev/slusb1 c 243 1 ; mknod -m 600 /dev/slusb2 c 243 2 ;

mknod -m 600 /dev/slusb3 c 243 3 ; echo -n

Serve inoltre avviare il modulo e generare il link al device in fase di avvio quindi aggiungere in /etc/rc.d/rc.local le relative seguenti righe:

/etc/rc.d/rc.slmodemd start

ln -s /dev/ttySL0 /dev/modem

Conclusioni

Per l' uso da parte degli utenti non dimenticate di aggiungere questi al gruppo uucp e di decommentare la riga (= togliere il segno # davanti ad una riga): #noauth all' interno di /etc/ppp/options.

In caso ci si connette ma non si riesce a trasmettere dati bisogna reinstradare il routing verso il modem evitando il gateway impostato di default, questo con il comando:

route add default ppp0

oppure ovviarvi stabilmente commentando in /etc/rc.d/rc.inet1.conf la riga:

  1. Default gateway IP address:
  2. GATEWAY="192.168.0.1"

Ecco fatto, ...a me funziona! Ciao a tutti

Strumenti personali
Namespace

Varianti