La ricerca ha trovato 248 risultati

da scartozzo
lun set 27, 2010 1:01
Forum: Programmazione
Argomento: Problema con uno script bash
Risposte: 18
Visite : 3519

Re: Problema con uno script bash

La prosecuzione della compilazione avviene con un altro script lanciato dall'utente root. Comunque rimane il problema che lo script precedente non termina. Mi spiego meglio. Ho enne script che vengono lanciati da un'altro script. Una parte devono essere eseguiti dall'utente pippo, che poi non serve ...
da scartozzo
lun set 27, 2010 0:42
Forum: Programmazione
Argomento: Problema con uno script bash
Risposte: 18
Visite : 3519

Re: Problema con uno script bash

Alla fine dello script vorrei che lo script si concludesse e che il controllo passasse dall'utente che ho utilizzato all'utente root.
da scartozzo
lun set 27, 2010 0:36
Forum: Programmazione
Argomento: Problema con uno script bash
Risposte: 18
Visite : 3519

Re: Problema con uno script bash

Codice: Seleziona tutto

if [ `whoami` = utente ]; then
    su -
fi
ed ho passato il controllo a root
da scartozzo
lun set 27, 2010 0:33
Forum: Programmazione
Argomento: Problema con uno script bash
Risposte: 18
Visite : 3519

Re: Problema con uno script bash

Ho fatto il contrario e funziona.
Ora mi rimane una questione: come mai il comando su funziona all'interno di un if e non da solo?

Comunque grazie.
da scartozzo
lun set 27, 2010 0:29
Forum: Programmazione
Argomento: Problema con uno script bash
Risposte: 18
Visite : 3519

Re: Problema con uno script bash

Ti ringrazio per il suggerimento.
Devo restituire il controllo all'utente root ed il comando su all'interno delle script non mi funziona
da scartozzo
lun set 27, 2010 0:05
Forum: Programmazione
Argomento: Problema con uno script bash
Risposte: 18
Visite : 3519

Problema con uno script bash

Ho script bash che installa un programma. Accedo con un altro utente e lo eseguo. su utente sh script Alla fine dell'esecuzione dello script vorrei anche fare in modo che il controllo ritorni al prmo utente con il quale mi sono loggato. Mi spiego: da linea di comando risolvo in un attimo con exit D'...
da scartozzo
dom dic 20, 2009 2:23
Forum: Slackware64
Argomento: Risolto [problemi con chroot in cross-tool environment]
Risposte: 0
Visite : 349

Risolto [problemi con chroot in cross-tool environment]

Ho finalmente risolto il problema. Premessa. Nella curiosità e nel desiderio di accrescere le mie conoscenze ho iniziato ad avvicinarmi a progetti quali LFS e DIY-linux [jaguar-linux]. Pur essendo ignorante, nel senso di non avere cognizioni di programmazione, ho iniziato a configurare e compilare u...
da scartozzo
dom dic 13, 2009 18:43
Forum: Slackware
Argomento: backlight control
Risposte: 0
Visite : 204

backlight control

Come posso fare per abilitare i tasti funzioni per il controllo della luninosità? Il portatile è un dell vostro 1320. A occhio mi sembra che con vesafb sia tutto ok. Può essere che con inteldrmfb nascano i problemi. Potrei aver compilato il kernel 2.6.32 senza tutte le opzioni necessarie. Qualche su...
da scartozzo
gio dic 03, 2009 11:01
Forum: Slackware
Argomento: ACPI conflict e drm ... error
Risposte: 1
Visite : 946

Re: ACPI conflict

Ho risolto con il kernell 2.6.32 tranne che per
ACPI: I/O resource 0000:00:1f.3 [0x1c00-0x1c1f] conflicts with ACPI region SMBI
da scartozzo
mer dic 02, 2009 10:04
Forum: Slackware
Argomento: Slackware 13.0 x86 problemi HDA intel
Risposte: 25
Visite : 1119

Re: Slackware 13.0 x86 problemi HDA intel

Avevo un problema analogo su un notebook Dell Vostro 1320. Card: HDA Intel Chip: IDT 92HD81B1C5 In pratica l'inserimento delle cuffie non escludeva le casse interne. Ho risolto passando al kernel 2.6.31.6 optando per il modulo specifico alla voce ALSA. Devo unicamente verificare il funzionamento del...
da scartozzo
mer dic 02, 2009 9:50
Forum: Slackware
Argomento: ACPI conflict e drm ... error
Risposte: 1
Visite : 946

ACPI conflict e drm ... error

All'avvio mi si presentano tre problemi. (Kernel 2.6.31.6, slackware 13.0. fluxbox, notebook dell Vostro 1320 con intel GMA 4500MHD) 1) ACPI: I/O resource 0000:00:1f.3 [0x1c00-0x1c1f] conflicts with ACPI region SMBI 2) atkbd.c: Unknown key pressed (translated set 2, code 0x8e on isa0060/serio0). atk...
da scartozzo
mer dic 02, 2009 9:29
Forum: Packages
Argomento: [Risolto] Problema con il modulo vboxadd [vbox-guest-addons]
Risposte: 3
Visite : 432

Re: Problema con il modulo vboxadd [vbox-guest-addons]

Ho risolto. Ho aggiunto al gruppo vboxusers gli utenti che utilizzano virtualbox e tutto funziona correttamente.
Grazie
da scartozzo
mar dic 01, 2009 12:32
Forum: Packages
Argomento: [Risolto] Problema con il modulo vboxadd [vbox-guest-addons]
Risposte: 3
Visite : 432

[Risolto] Problema con il modulo vboxadd [vbox-guest-addons]

Utilizzo slackware 13.0 con fluxbox. Ho installato virtualbox ed è tutto a posto. Procedendo con l'installazone di vbox-guest-addons si presenta il seguente problema: Starting VirtualBox Additions ...fail! (modprobe vboxadd failed) Come mai non carica il modulo? Grazie. PS. Ho provato con le varie v...
da scartozzo
gio nov 19, 2009 10:52
Forum: Slackware
Argomento: Montaggio dispositivi con UDEV
Risposte: 3
Visite : 353

Re: Montaggio dispositivi con UDEV

Grazie. Peccato che le regole UDEV debbano stare su un'unica riga. Con qualche ritocco tutto funziona. Unico inconveniente è un messaggio d'errore [journal commit I/O error] alla sconnessione dei dispositivi USB. Probabilmente le operazioni di umount, per questi dispositivi, vanno gestite manualmente.
da scartozzo
mar nov 17, 2009 13:12
Forum: Slackware
Argomento: Montaggio dispositivi con UDEV
Risposte: 3
Visite : 353

Montaggio dispositivi con UDEV

Ho diversi dischi da montare e sto sperimentando UDEV. Queste sono le regole per due dischi usb che ho inserito nel file 10-local.rules KERNEL=="sd[a-z][1-9]", SUBSYSTEM=="scsi", ATTRS{vendor}=="SanDisk ", ATTRS{model}=="Cruzer " ACTION=="add", RUN+=...