Pagina 1 di 1

apache e php su Jolinux

Inviato: mar 8 giu 2004, 18:46
da hebiten
Salve a tutti,
<BR>ho installato JoLinux (basata su Slack con kernerl 2.6.5)
<BR>Ho dei problemi con apache e php.
<BR>Il server funziona ma php non viene interpretato.
<BR>Ho controllato il php.ini e il http.conf, mi sembrano corretti solo che in http.conf mancano le famose righe LoadModuel, AddModule e AddType.
<BR>Potrebbe essere quello il problema?
<BR>Risolvo reinstallando i pacchetti della Slack-current di Apache e php?
<BR>
<BR>Grazie <br>

apache e php su Jolinux

Inviato: mar 8 giu 2004, 19:50
da Loris
Per attivare il supporto php, devi decommentare la riga Include /etc/apache/mod_php.conf che trovi in fondo al file /etc/apache/httpd.conf, fai ripartire apachectl e riprovi con il file info.php
<BR><br>

apache e php su Jolinux

Inviato: mar 8 giu 2004, 20:49
da hebiten
Grazie,
<BR>infatti ho notato che bisognava decommentare la riga ma quando avvio apache ottengo questo errore:
<BR>
<BR>Syntax error on line 6 of /etc/apache/mod_php.conf:
<BR>Cannot load /usr/libexec/apache/libphp4.so into server: libmhash.so.2: cannot open shared object file: No such file or directory
<BR>/usr/sbin/apachectl start: httpd could not be started
<BR>
<BR>Come posso risolvere?
<BR>
<BR>
<BR>Grazie
<BR><br>

apache e php su Jolinux

Inviato: mer 9 giu 2004, 0:11
da cRoW2k
Installando <!-- BBCode Start --><A HREF="http://www.linuxpackages.net/search_vie ... sh&ver=9.1" TARGET="_blank">questo</A><!-- BBCode End --><br>

apache e php su Jolinux

Inviato: mer 9 giu 2004, 9:40
da hebiten
Grazie 1000 :-) <br>