Pagina 1 di 1

non riesco a montare la pendrive

Inviato: dom 24 set 2006, 15:57
da goodchild
Ciao, ho letto vari post che ho trovato su questo sito e l'howto ma non ce la faccio lo stesso :(

Io ho dato come da copione

root:/mnt# dmesg | tail

per poi aver la risposta:

reiserfs_getopt: unknown option "umask=022"
usb.c: USB disconnect on device 00:03.3-5 address 2
hub.c: new USB device 00:03.3-5, assigned address 3
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 3
SCSI device sda: 2002000 512-byte hdwr sectors (1025 MB)
sda: Write Protect is off
sda: sda1
reiserfs_getopt: unknown option "umask=022"
reiserfs_getopt: unknown option "umask=022"

poi ho digitato
root:/etc/rc.d# tail -f /var/log/messages

quindi inserito la pendrive e:

Sep 24 12:15:22 darkstar kernel: USB Mass Storage support registered.
Sep 24 12:32:29 darkstar -- MARK --
Sep 24 12:52:29 darkstar -- MARK --
Sep 24 13:12:29 darkstar -- MARK --
Sep 24 13:32:29 darkstar -- MARK --
Sep 24 13:52:29 darkstar -- MARK --
Sep 24 14:12:29 darkstar -- MARK --
Sep 24 14:32:29 darkstar -- MARK --
Sep 24 14:52:29 darkstar -- MARK --
Sep 24 15:07:55 darkstar kernel: usb.c: USB disconnect on device 00:03.3-5 address 2
Sep 24 15:08:29 darkstar kernel: hub.c: new USB device 00:03.3-5, assigned address 3
Sep 24 15:09:14 darkstar kernel: sda: sda1


Quindi ho provato a montare il device sda1

root:/mnt# mount /dev/sda1 /mnt/pendrive/ -t fat32 reiserfs -o umask=022

ma mi ha dato:

Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .

Qualcuno sa dirmi che significa e che devo fare?
p.s.: oltre a FAT32 o provato pure FAT e NTFS

Inviato: dom 24 set 2006, 16:29
da manublade
Mi sa che hai fatto un po di confusione.
Se la penna è nuova, e la usi tranquillamente sotto windows allora è formattata fat.

per montarla da root (se non hai modificato il file /etc/fstab)

mount /dev/sda1 /mnt/pendrive

sempre che la directory /mnt/pendrive esista.

Da quello che scrivi leggo fra le altre cose
reiserfs_getopt: unknown option "umask=022"
root:/mnt# mount /dev/sda1 /mnt/pendrive/ -t fat32 reiserfs -o umask=022

ma cosa centra reiserfs? hai riformattato la penna?
hai modificato l'/etc/fstab?
si si postalo

Inviato: dom 24 set 2006, 19:20
da goodchild
Scusate, effettivamente devo aver fatto un casotto fra tutti i vari post che ho trovato sull'argomento....

facendo
mount /dev/sda1 /mnt/pendrive
si monta senza problemi ma non se faccio
mount /mnt/pendrive
che mi risponde
warning: no final newline at the end of /etc/fstab
mount: unknown filesystem type 'fat'
mount: maybe you meant 'vfat'?

sul fstab avevo scritto
/dev/sda1 /mnt/pendrive fat noauto,user,umask=022 0 0

Devo per caso scrivere vfat al posto di fat? L'ho provata sul windows e me la riconosce come fat

Inviato: dom 24 set 2006, 19:24
da pino.giaquinto
Confermo!
Devi mettere vfat nel file /etc/fstab e non fat come hai fatto tu.

Inviato: dom 24 set 2006, 20:29
da manublade
Ciao al posto dell'errato "fat" oltre che "vfat" puoi anche mettere un più pratico "auto".

Inviato: dom 24 set 2006, 21:03
da goodchild
ottimo, ora la monta, posso sia leggere che scrivere!
:D
Una sola domanda:
al montaggio mi scrive:
[mntent]: warning: no final newline at the end of /etc/fstab

Per carita, funziona lo stesso, ma cosa vuol dire?
Il mio fstab recita
/dev/sda1 /mnt/pendrive vfat noauto,user,umask=022 0 0

Grazie a tutti per la collaborazione!

Inviato: dom 24 set 2006, 21:11
da samiel
Vuol dire che dopo le righe
devi aggiungerne un'ultima bianca...
Tutto qui

M.

Inviato: dom 24 set 2006, 21:43
da goodchild
Ah, ok, grazie
:)