Problema installazione driver ati su kernel 2.6.18

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
Vito
Staff
Staff
Messaggi: 4175
Iscritto il: mar dic 05, 2006 17:28
Nome Cognome: Vito
Distribuzione: Linux Mint 17
Località: Augsburg (DE)
Contatta:

Problema installazione driver ati su kernel 2.6.18

Messaggioda Vito » mar dic 05, 2006 17:34

Ho da poco messo il kernel 2.6.18 ,installato usando i precompilati forniti nei cd di slackware,solo che quando ho provato ad installare i driver della ATI x l'accellerazione grafica ecco quello che mi viene detto:
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
kernel includes at /lib/modules/2.6.18/build/include not found or incomplete
file: /lib/modules/2.6.18/build/include/linux/version.h
[Error] Kernel Module : Failed to compile kernel module - please consult readme.

mi dà lo stesso errore sia cn l'intaller che con i driver ad compilare a mano. come posso fare?
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]

Avatar utente
Luke88
Linux 2.6
Linux 2.6
Messaggi: 624
Iscritto il: mer set 07, 2005 0:00
Slackware: 13.0
Kernel: 2.6.30-zen4
Desktop: xfce4
Località: Udine

Messaggioda Luke88 » mar dic 05, 2006 17:51

http://www.slacky.it/forum/viewtopic.php?p=113688#113688
qui se ne parla

se poi ti vuoi compilare i driver per il 2.6.19 vai qui
http://www.slacky.it/forum/viewtopic.php?t=16403
Meeting efficency = Average_Intelligence/( Number_Of_People^2 )

Avatar utente
Vito
Staff
Staff
Messaggi: 4175
Iscritto il: mar dic 05, 2006 17:28
Nome Cognome: Vito
Distribuzione: Linux Mint 17
Località: Augsburg (DE)
Contatta:

Messaggioda Vito » mar dic 05, 2006 18:16

niente :( mi dà lo stesso errore :
ATI module generator V 2.0
==========================
initializing...
kernel includes at /lib/modules/2.6.18/build/include not found or incomplete
file: /lib/modules/2.6.18/build/include/linux/utsrelease.h
root@Vito:/lib/modules/fglrx/build_mod#
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3949
Iscritto il: lun apr 25, 2005 0:00
Slackware: 13.1
Desktop: fluxbox
Località: Varese

Messaggioda Paoletta » mar dic 05, 2006 19:59


Avatar utente
zappa
Linux 2.0
Linux 2.0
Messaggi: 143
Iscritto il: gio set 08, 2005 0:00
Slackware: 13.37 & 14
Kernel: 3.4.11-RT & 3.2.29 & 2.6.37
Desktop: KDE
Località: cagliari
Contatta:

Messaggioda zappa » mar dic 05, 2006 20:25

prova ad installare i sorgenti e gli header, se non lo hai gia' fatto..... :)

Avatar utente
Vito
Staff
Staff
Messaggi: 4175
Iscritto il: mar dic 05, 2006 17:28
Nome Cognome: Vito
Distribuzione: Linux Mint 17
Località: Augsburg (DE)
Contatta:

Messaggioda Vito » mer dic 06, 2006 19:37

niente sn disperato :(:(:(
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]

Avatar utente
lucif3r0
Linux 2.6
Linux 2.6
Messaggi: 617
Iscritto il: mer mag 11, 2005 0:00
Slackware: 13.1
Kernel: 2.6.33.4
Desktop: KDE 4.3

Messaggioda lucif3r0 » mer dic 06, 2006 20:23

io uso i driver non proprietari e mi
girano benissimo sul 2.6.18 sta cosa
di voler usare per forza quelli di ATI
non la capisco, con i radeon ci gioco
tranquillamente a Enemy Territory,
Nexuiz, Tremulous e mi va anche il
3dDesktop, quindi perchè usare i
driver proprietari?
8)

Avatar utente
Vito
Staff
Staff
Messaggi: 4175
Iscritto il: mar dic 05, 2006 17:28
Nome Cognome: Vito
Distribuzione: Linux Mint 17
Località: Augsburg (DE)
Contatta:

Messaggioda Vito » mer dic 06, 2006 20:59

ah usi i driver mesa?comunque se m dici che girano xfettamente li rimango!
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]

Avatar utente
conqueror
Linux 2.0
Linux 2.0
Messaggi: 119
Iscritto il: mar dic 27, 2005 12:02
Località: Roma
Contatta:

Messaggioda conqueror » mer dic 06, 2006 22:28

John-Cena ha scritto:ah usi i driver mesa?comunque se m dici che girano xfettamente li rimango!


penso si riferisca ai driver radeon del kernel, quelli open source.

Avatar utente
lucif3r0
Linux 2.6
Linux 2.6
Messaggi: 617
Iscritto il: mer mag 11, 2005 0:00
Slackware: 13.1
Kernel: 2.6.33.4
Desktop: KDE 4.3

Messaggioda lucif3r0 » mer dic 06, 2006 23:48

si mi riferisco ai radeon del kernel, mi fanno
girare tutto alla perfezione, prima o poi fo
una prova pure con xgl
8)

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6365
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Messaggioda targzeta » gio dic 07, 2006 10:15

John-Cena ha scritto:kernel includes at /lib/modules/2.6.18/build/include not found or incomplete

Posta il risultato di

Codice: Seleziona tutto

ls /lib/modules/2.6.18/build/include/


Spina
Ultima modifica di targzeta il gio dic 07, 2006 10:47, modificato 2 volte in totale.

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6365
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Messaggioda targzeta » gio dic 07, 2006 10:17

lucif3r0 ha scritto:si mi riferisco ai radeon del kernel

Anche io uso quelli del kernel, solo che la scheda sul portatile non è riconosciuto e così o ripiegato su quelli proprietari.

Spina

Avatar utente
Vito
Staff
Staff
Messaggi: 4175
Iscritto il: mar dic 05, 2006 17:28
Nome Cognome: Vito
Distribuzione: Linux Mint 17
Località: Augsburg (DE)
Contatta:

Messaggioda Vito » gio dic 07, 2006 13:41

vito@Vito:~$ ls /lib/modules/2.6.18/build/include/
Kbuild asm-frv/ asm-m68k/ asm-s390/ asm-v850/ math-emu/ rxrpc/
acpi/ asm-generic/ asm-m68knommu/ asm-sh/ asm-x86_64/ media/ scsi/
asm-alpha/ asm-h8300/ asm-mips/ asm-sh64/ asm-xtensa/ mtd/ sound/
asm-arm/ asm-i386/ asm-parisc/ asm-sparc/ config/ net/ video/
asm-arm26/ asm-ia64/ asm-powerpc/ asm-sparc64/ keys/ pcmcia/
asm-cris/ asm-m32r/ asm-ppc/ asm-um/ linux/ rdma/


e comunque come faccio ad usare quelli pensource del kernel dei driver?? :? [/b]
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3949
Iscritto il: lun apr 25, 2005 0:00
Slackware: 13.1
Desktop: fluxbox
Località: Varese

Messaggioda Paoletta » gio dic 07, 2006 13:58

è scritto tutto in slackware for dummies

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6365
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Messaggioda targzeta » gio dic 07, 2006 14:02

Per usare quelli di linux devi ricompilarti il kernel :o .

Dimmi che cosa hai come scheda video, e la versione dei tuoi driver, che me li scarico e ci faccio una prova io.

Spina


Torna a “Slackware”

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti