Pagina 1 di 1

s2ram e illuminazione spenta

Inviato: mar 20 nov 2007, 10:21
da jacobbe
Ciao ragazzi... ho configurato la sospensione con s2ram... va alla grande se non fosse per un problema: al risveglio la retroilluminazione resta spenta.
Ho provato a lanciare "xset dpms force on" ma niente da fare... lo schermo si vede (non è nero) ma senza retroilluminazione.

Avete idea di come controllare la retroilluminazione?

Inviato: mar 20 nov 2007, 13:26
da Smjert
Non so se questo può cambiare le cose...
Nella configurazione del tuo kernel è attiva (sotto Device Drivers->Graphic Support) Backlight & LCD Support? (e la voce Lowlevel Backlight controls nel sottomenu?)
Ripeto non so se è dovuto a questo... ma io sono della filosofia testa e impara (e fatti male :P).

PS: tra l'altro scusa.. faccio una domanda a te... mi potresti dire cosa hai messo nella sezione Power Management per attivare la sospensione/standby?
Perchè io ho messo quasi tutto ma non me la fa fare (sono su Slamd64 mentre su Slackware me la faceva).

Inviato: mar 20 nov 2007, 14:12
da jacobbe
Lowlevel Backlight controls è attivato ma penso non sia supportata la mia interfaccia... dove dovrebbe comparire il supporto?
Adesso scrivendo noto che:

Codice: Seleziona tutto

cat /proc/acpi/video/C080/C13F/brightness 
levels:  100 51 30 37 44 51 58 65 72 79 86 93 100
current: 0
Mah..ora provo qualcosa.

comunque sotto Power Management ho:

Codice: Seleziona tutto

#
# Power management options (ACPI, APM)
#
CONFIG_PM=y
CONFIG_PM_LEGACY=y
CONFIG_PM_DEBUG=y
# CONFIG_PM_VERBOSE is not set
# CONFIG_DISABLE_CONSOLE_SUSPEND is not set
# CONFIG_PM_TRACE is not set
CONFIG_PM_SLEEP=y
CONFIG_SUSPEND_UP_POSSIBLE=y
CONFIG_SUSPEND=y
CONFIG_HIBERNATION_UP_POSSIBLE=y
CONFIG_HIBERNATION=y
CONFIG_PM_STD_PARTITION=""
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
# CONFIG_ACPI_PROCFS is not set
CONFIG_ACPI_PROC_EVENT=y
CONFIG_ACPI_AC=y
CONFIG_ACPI_BATTERY=y
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_VIDEO=y
CONFIG_ACPI_FAN=y
# CONFIG_ACPI_DOCK is not set
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_THERMAL=y
# CONFIG_ACPI_ASUS is not set
# CONFIG_ACPI_TOSHIBA is not set
CONFIG_ACPI_BLACKLIST_YEAR=2000
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_SYSTEM=y
CONFIG_X86_PM_TIMER=y
# CONFIG_ACPI_CONTAINER is not set
CONFIG_ACPI_SBS=m
# CONFIG_APM is not set

Inviato: mar 20 nov 2007, 17:43
da jacobbe
Beh scusate non ci avevo pensato prima.
Con

Codice: Seleziona tutto

echo 30 >  /proc/acpi/video/C080/C13F/brightness
O al posto di 30 i livelli tra "100 51 30 37 44 51 58 65 72 79 86 93 100" cambia la luminosità.
Ora c'è il problema che questo inibisce la funzionalità dei tasti del notebook che smettono di funzionare ma è già un passo avanti ;)