ntop non va...

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
barkode
Linux 0.x
Linux 0.x
Messaggi: 86
Iscritto il: lun ago 27, 2007 13:21
Località: Latina, Italy

ntop non va...

Messaggioda barkode » gio gen 17, 2008 19:33

Ciao ragazzi,

stavolta vi scrivo per quanto riguarda ntop, un network monitor. Ho scaricato il file dalla nostra comunità, ma appena lo avvio col comando suggerito su linux magazine di febbraio, mi dà il seguente errore:

Codice: Seleziona tutto

root@barkode:~/Desktop/dload# ntop -P /etc/ntop -W4242 -d
ntop: error while loading shared libraries: [b]librrd_th.so.2[/b]: cannot open shared object file: No such file or directory


per la cronaca, l'opzione "-P" legge i file di conf. presenti in /etc/ntop, "-W" attiva la porta su cui ntop è in ascolto (la 3000 di default), "-d" attiva ntop in modalità daemon.

Avatar utente
Loris
Admin
Admin
Messaggi: 7699
Iscritto il: lun mar 31, 2003 0:00
Nome Cognome: Loris Vincenzi
Località: Gradisca D'Isonzo
Contatta:

Re: ntop non va...

Messaggioda Loris » gio gen 17, 2008 19:40

rrdtool è installato ?
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett

Avatar utente
conraid
Staff
Staff
Messaggi: 13329
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: ntop non va...

Messaggioda conraid » gio gen 17, 2008 19:42

barkode ha scritto:Ciao ragazzi,

stavolta vi scrivo per quanto riguarda ntop, un network monitor. Ho scaricato il file dalla nostra comunità, ma appena lo avvio col comando suggerito su linux magazine di febbraio, mi dà il seguente errore:

Codice: Seleziona tutto

root@barkode:~/Desktop/dload# ntop -P /etc/ntop -W4242 -d
ntop: error while loading shared libraries: [b]librrd_th.so.2[/b]: cannot open shared object file: No such file or directory


per la cronaca, l'opzione "-P" legge i file di conf. presenti in /etc/ntop, "-W" attiva la porta su cui ntop è in ascolto (la 3000 di default), "-d" attiva ntop in modalità daemon.


Ti mancano gli rrdtool.
Non so dirti se li trovi qui, ntop e rrdtool l'ho sempre compilati a mano senza installare pacchetti

Avatar utente
Loris
Admin
Admin
Messaggi: 7699
Iscritto il: lun mar 31, 2003 0:00
Nome Cognome: Loris Vincenzi
Località: Gradisca D'Isonzo
Contatta:

Re: ntop non va...

Messaggioda Loris » gio gen 17, 2008 19:51

"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett

barkode
Linux 0.x
Linux 0.x
Messaggi: 86
Iscritto il: lun ago 27, 2007 13:21
Località: Latina, Italy

Re: ntop non va...

Messaggioda barkode » gio gen 17, 2008 19:59

Codice: Seleziona tutto

Executing install script for rrdtool-1.3beta1-i486-1sl...

root@barkode:~/Desktop/dload# ntop -P /etc/ntop -W4242 -d
Thu Jan 17 19:59:03 2008  NOTE: Interface merge enabled by default
Thu Jan 17 19:59:03 2008  Initializing gdbm databases
Thu Jan 17 19:59:03 2008  ntop will be started as user nobody
Thu Jan 17 19:59:03 2008  ntop v.3.3
Thu Jan 17 19:59:03 2008  Configured on Oct 24 2007 22:46:21, built on Oct 24 2007 22:47:09.
Thu Jan 17 19:59:03 2008  Copyright 1998-2007 by Luca Deri <deri@ntop.org>
Thu Jan 17 19:59:03 2008  Get the freshest ntop from http://www.ntop.org/
Thu Jan 17 19:59:03 2008  NOTE: ntop is running from 'ntop'
Thu Jan 17 19:59:03 2008  NOTE: (but see warning on man page for the --instance parameter)
Thu Jan 17 19:59:03 2008  NOTE: ntop libraries are in '/usr/lib'
Thu Jan 17 19:59:03 2008  Initializing ntop
Thu Jan 17 19:59:03 2008  No patterns to load: protocol guessing disabled.
Thu Jan 17 19:59:03 2008  No default device configured. Using eth0
Thu Jan 17 19:59:03 2008  **WARNING** Truncated network size (device eth0) to 1024 hosts (real netmask 255.255.248.0)
Thu Jan 17 19:59:03 2008  Checking eth0 for additional devices
Thu Jan 17 19:59:03 2008  Resetting traffic statistics for device eth0
Thu Jan 17 19:59:03 2008  Initializing device eth0 (0)
Thu Jan 17 19:59:03 2008  DLT: Device 0 [eth0] is 1, mtu 1514, header 14
Thu Jan 17 19:59:03 2008  Initializing gdbm databases
Thu Jan 17 19:59:03 2008  VENDOR: Loading MAC address table.
Thu Jan 17 19:59:03 2008  VENDOR: Checking for MAC address table file
Thu Jan 17 19:59:03 2008  VENDOR: Loading newer file '/etc/ntop/specialMAC.txt.gz'
Thu Jan 17 19:59:03 2008  VENDOR: ...found 61 lines
Thu Jan 17 19:59:03 2008  VENDOR: ...loaded 59 records
Thu Jan 17 19:59:03 2008  VENDOR: Checking for MAC address table file
Thu Jan 17 19:59:03 2008  VENDOR: Loading newer file '/etc/ntop/oui.txt.gz'
Thu Jan 17 19:59:04 2008  VENDOR: ...found 48541 lines
Thu Jan 17 19:59:04 2008  VENDOR: ...loaded 7853 records
Thu Jan 17 19:59:04 2008  Fingerprint: Loading signature file
Thu Jan 17 19:59:04 2008  Fingerprint: Checking for Fingerprint file... file
Thu Jan 17 19:59:04 2008  Fingerprint: Loading file '/etc/ntop/etter.finger.os.gz'
Thu Jan 17 19:59:04 2008  Fingerprint: ...loaded 1765 records
Thu Jan 17 19:59:04 2008  INIT: Parent process is exiting (this is normal)
root@barkode:~/Desktop/dload# Thu Jan 17 19:59:04 2008  INIT: Bye bye: I'm becoming a daemon...


Grande Loris, grazie mille, avevi ragione.

barkode
Linux 0.x
Linux 0.x
Messaggi: 86
Iscritto il: lun ago 27, 2007 13:21
Località: Latina, Italy

Re: ntop non va...

Messaggioda barkode » gio gen 17, 2008 20:12

l'unica cosa ora è che se faccio http://mioIP:3000

non mi accede a ntop, mi dà errore e non penso dipenda da shorewall (firewall), perchè ho provato anche dopo averlo "buttato giù"

Avatar utente
conraid
Staff
Staff
Messaggi: 13329
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: ntop non va...

Messaggioda conraid » gio gen 17, 2008 21:27

barkode ha scritto:l'unica cosa ora è che se faccio http://mioIP:3000

non mi accede a ntop, mi dà errore e non penso dipenda da shorewall (firewall), perchè ho provato anche dopo averlo "buttato giù"


Io non ti capisco.
Non ricordo a memoria le opzioni di ntop ma leggendo il tuo primo messaggio leggo questo

Codice: Seleziona tutto

root@barkode:~/Desktop/dload# ntop -P /etc/ntop -W4242 -d

per la cronaca, l'opzione "-P" legge i file di conf. presenti in /etc/ntop, "-W" attiva la porta su cui ntop è in ascolto (la 3000 di default), "-d" attiva ntop in modalità daemon.


Quindi lo avvi dalla porta 4242 e non dalla 3000, mi sbaglio?

barkode
Linux 0.x
Linux 0.x
Messaggi: 86
Iscritto il: lun ago 27, 2007 13:21
Località: Latina, Italy

Re: ntop non va...

Messaggioda barkode » gio gen 17, 2008 21:52

mmmm... mi sa che hai ragione...
ti faccio sapere grazie ;)

barkode
Linux 0.x
Linux 0.x
Messaggi: 86
Iscritto il: lun ago 27, 2007 13:21
Località: Latina, Italy

Re: ntop non va...

Messaggioda barkode » ven gen 18, 2008 1:37

no, niente da fare... proveremo con qualcos'altro
Grazie. Andrea. 8)

Avatar utente
conraid
Staff
Staff
Messaggi: 13329
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: ntop non va...

Messaggioda conraid » ven gen 18, 2008 11:41

barkode ha scritto:no, niente da fare... proveremo con qualcos'altro
Grazie. Andrea. 8)


MA perché arrendersi.
Ora è un po' che non lo uso, ma se vuoi appena ho tempo lo provo,
Ntop su Slack mi ha sempre funzionato. Certo, come ti dicevo me lo sono sempre compilato da solo.
Lo uso anche in svn con mysql, e li qualche problema c'è nella memorizzazione.

Per cosa ti serva?
se vuoi qualcosa che monitorizzi, rrdool o db, ma senza interfaccia grafica, c'è pmacct

Avatar utente
paxlex
Linux 0.x
Linux 0.x
Messaggi: 42
Iscritto il: mar set 04, 2007 11:16
Slackware: 12.1
Località: Udine
Contatta:

Re: ntop non va...

Messaggioda paxlex » ven gen 18, 2008 19:24

A onor di cronaca ho installato su un server la Slack 12 con ntop e rrdtool. Una volta lanciato il comando descritto in precedenza e avviato ntop in /etc/rc.d/rc.ntop ... tutto ha funzionato e devo dire che è un tool fantastico per verificare la rete. Inoltre ci sono diversi plugin aggiuntivi interessanti (ma devo ancora provarli).

Avatar utente
aLvArO
Linux 4.x
Linux 4.x
Messaggi: 1201
Iscritto il: mer mar 30, 2005 0:00
Nome Cognome: alessio
Slackware: current64
Kernel: 2.6.30-rc8-smp
Desktop: kde 4.2.4
Località: Catanzaro Lido (CZ)
Contatta:

Re: ntop non va...

Messaggioda aLvArO » ven gen 18, 2008 19:42

anche a me funziona anche se in /etc nn ho trovato il file ntop.conf
gli devo dare un okkiata con + attenzione.
comunque l'ho fatto per provare e funziona.

barkode
Linux 0.x
Linux 0.x
Messaggi: 86
Iscritto il: lun ago 27, 2007 13:21
Località: Latina, Italy

Re: ntop non va...

Messaggioda barkode » lun gen 21, 2008 23:24

Risolto, almeno in parte, nel senso...

Codice: Seleziona tutto

@barkode:~# ntop -P ntop -W4242   

così parte in ascolto sulla 3000 =D>


Codice: Seleziona tutto

@barkode:~# ntop -P ntop -W4242 -d   

così no :-k

...perchè in modalità demone non dovrebbe andare?

Avatar utente
conraid
Staff
Staff
Messaggi: 13329
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: ntop non va...

Messaggioda conraid » mar gen 22, 2008 0:51

barkode ha scritto:Risolto, almeno in parte, nel senso...

Codice: Seleziona tutto

@barkode:~# ntop -P ntop -W4242   

così parte in ascolto sulla 3000 =D>


-W imposta la porta https
-w la http

barkode ha scritto:

Codice: Seleziona tutto

@barkode:~# ntop -P ntop -W4242 -d   

così no :-k

...perchè in modalità demone non dovrebbe andare?


mi va ugualmente con -d
ma quel -P ntop mi piace poco, lascialo di default no? o hai usato percorsi tuoi?

Io ho fatto la "prima" volta

Codice: Seleziona tutto

ntop -P /usr/local/share/ntop -u ntop -A

ho impostato la pwd di Admin dopo aver dato i permessi all'utente ntop per /usr/local/share/ntop

e dopo l'ho lanciato o solo con

Codice: Seleziona tutto

ntop

oppure provando le tue configurazioni

leox
Linux 0.x
Linux 0.x
Messaggi: 1
Iscritto il: sab feb 02, 2008 0:18

Re: ntop non va...

Messaggioda leox » sab feb 02, 2008 0:31

Vi prego di scusarmi se mi intrometto,
ma ho notato che nelle opzioni di default di ntop è disabilitato l'avvio come demone come anche l'accesso via HTTPS.
Basta andare in Admin -> Configure -> Startup Options e si possono impostare i settaggi che interessano.

Salute a tutti