mozilla & java

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
samiel
Staff
Staff
Messaggi: 5510
Iscritto il: ven 16 gen 2004, 0:00
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian
Località: Venezia

mozilla & java

Messaggio da samiel »

Ho installato mozilla 1.7.3 e java 1_5
<BR>Java non funge mettendo in /usr/lib/mozilla/plugins
<BR>il classico link a libjavaplugin_oji.so e tanto meno
<BR>copiando il file (si impalla mozilla). Come uscirne?
<BR>Inoltre: quando esco da X vedo il messaggio:
<BR>file /usr/lib/i386/libjavaplugin_nscp.so - file not found.
<BR>Il file c´è, ma in un´altra dir, e /usr/lib/i386 non esiste.
<BR>Che devo fare secondo voi?
<BR>
<BR>Grazie
<BR>M.<br>

bukowsko
Linux 0.x
Linux 0.x
Messaggi: 90
Iscritto il: mar 28 set 2004, 0:00

mozilla & java

Messaggio da bukowsko »

Forse tu hai scaricato la J2SE Development Kit (JDK)
<BR>Ma credo ti serva il j2re Java(TM) 2 Runtime Environment, Standard Edition.
<BR>Credo si chiami J2SE 5.0 JRE
<BR>Ciaux!
<BR>PS: un ennesimo rigraziamento x la tua Slackware for dummies.Sono in Slacky grazie a quella guida!..(Per ora.Adesso mi metto con Gentoo e poi morta lì con il tour delle distro Gnu-Linux ;-))<BR><BR>[ Questo Messaggio è stato Modificato da: bukowsko il 21-10-2004 20:55 ]<br>

albatrosla
Packager
Packager
Messaggi: 1339
Iscritto il: sab 27 mar 2004, 0:00
Slackware: current
Desktop: fluxbox.git
Località: Collegno, but made in Friûl
Contatta:

mozilla & java

Messaggio da albatrosla »

Io ho sempre avuto problemi a far riconoscere Java RE a Mozilla/Firefox. Ho risolto installando Java SDK, senz´altro più voluminoso, ma che non mi ha mai dato problemi. Installato l´SDK, mi è bastato il classico link simbolico nella directory dell´utente (se lo fai nella directory plugins che sta nella radice dove viene installato Mozilla, non funziona!). A meno che il tuo non sia un problema di permessi (cosa che ho riscontrato un paio di versioni fa con un plugin Flash)... <br>

samiel
Staff
Staff
Messaggi: 5510
Iscritto il: ven 16 gen 2004, 0:00
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian
Località: Venezia

mozilla & java

Messaggio da samiel »

Ho scaricato il pacchetto della current.
<BR>Adesso provo a rismanettare...
<BR>Grazie
<BR>
<BR>M.
<BR>
<BR>PS
<BR>x bukowsko: mi fa piacere che la guida
<BR>sia risultata utile e apprezzata. Occhio:
<BR>nuova edizione in preparazione
<BR>con diverse novità!
<BR><br>

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom 12 ott 2003, 0:00
Località: A place where the streets have no name
Contatta:

mozilla & java

Messaggio da useless »

be´, il jdk contiene anche il jre...<br>

samiel
Staff
Staff
Messaggi: 5510
Iscritto il: ven 16 gen 2004, 0:00
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian
Località: Venezia

mozilla & java

Messaggio da samiel »

Ma tu il link lo hai fatto in /usr/include/mozilla-1.7/plugin
<BR>o in /usr/lib/mozilla-1.7/plugins?
<BR>Secondo me va in quest´ultima dir.
<BR>Ma il link simbolico mi impedisce di caricare del tutto Mozilla
<BR>e la copia fisica del file non mi attiva comunque java...
<BR>Fattosta che ho pure quell´altro messaggio sul file non trovato
<BR>in una dir assai strana...
<BR>
<BR>M.<br>

samiel
Staff
Staff
Messaggi: 5510
Iscritto il: ven 16 gen 2004, 0:00
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian
Località: Venezia

mozilla & java

Messaggio da samiel »

Non ci capisco più nulla. Nel sito di mozilla
<BR>suggeriscono la solita procedura, cioè creare
<BR>il famoso link simbolico. Ma (attenzione!)
<BR>da /usr/lib/jdk1.5.0/jre/plugin/i386/ns7-gcc32/libjavaplugin_oji.so
<BR>a /usr/lib/mozilla-1.7.3/plugins/.
<BR>Stranezza: nel jdk-1_5_0 scaricato dalla current esiste solo
<BR>/usr/lib/jdk1.5.0/jre/plugin/i386/ns7-gcc29/libjavaplugin_oji.so.
<BR>Cioè gcc 29 e non 32. Che stia qui l´inghippo?
<BR>In effetti se lancio mozilla con link realizzato ricevo un messaggio
<BR>che mi accerte che è impossibile raggiungere la dir dei plugins
<BR>e tutto si blocca lì...
<BR>Fatto sta che non funge :-((
<BR>
<BR>
<BR>M.<br>

ybossel
Linux 0.x
Linux 0.x
Messaggi: 1
Iscritto il: mer 10 nov 2004, 0:00

mozilla & java

Messaggio da ybossel »

I experimented the same problem and got it work executing following:
<BR>
<BR>login as root
<BR>
<BR>mkdir /home/lib
<BR>mkdir /home/lib/i386
<BR>cd $JAVA_HOME/jre/lib/i386
<BR>for f in $(ls *.so); do ln -s /usr/java/jdk1.5.0/jre/lib/i386/$f /home/lib/$f; done
<BR>
<BR>Note: my JAVA_HOME is /usr/java/jdk1.5.0
<BR>ciao ;)
<BR>
<BR>Sorry I don´t write italian but understand it a little bit.
<BR>
<BR>Yves
<BR>
<BR>
<BR>[ Questo Messaggio è stato Modificato da: ybossel il 10-11-2004 11:26 ]
<BR><BR><BR>[ Questo Messaggio è stato Modificato da: ybossel il 10-11-2004 11:31 ]<br>

valfe
Linux 2.x
Linux 2.x
Messaggi: 342
Iscritto il: mar 4 nov 2003, 0:00

mozilla & java

Messaggio da valfe »

il link da creare in plugins di mozilla/firefox deve puntare a:
<BR>
<BR>/usr/lib/java/jre/plugin/i386/ns7/libjavaplugin_oji.so
<BR>
<BR>ciao<br>

samiel
Staff
Staff
Messaggi: 5510
Iscritto il: ven 16 gen 2004, 0:00
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian
Località: Venezia

mozilla & java

Messaggio da samiel »

Sì, io avevo risolto da tempo.
<BR>Lo facevo puntare male...
<BR>
<BR>M.<br>

Rispondi