Banalita' disarmante. Eppure non ci riesco!

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
legionario
Linux 3.x
Linux 3.x
Messaggi: 603
Iscritto il: mer 8 dic 2004, 0:00
Località: Bergamo - Roma

Banalita' disarmante. Eppure non ci riesco!

Messaggio da legionario »

Scusate per la banalita' estrema di questa domanda, ma e' da un po' che ci sto sbattendo il muso.

Ho un hard disk usb con partizione ext3 che monto tranquillamente da utente, ma non riesco a scriverci. Ho provato pure a seguire il suggerimento di Samiel trovato in un vecchio post, mettendo cioe' l'utente nel gruppo plugdev (gia' c'era veramente) e aggiungendo "defaults" in fstab. Riporto qui di seguito la riga interessata dell'fstab della mia slack 12.0 (e' solo l'ultima configurazione delle tante che ho provato):

Codice: Seleziona tutto

/dev/sdb3               /mnt/sdb3        ext3        users,noauto,exec,rw                0  0
Questo invece e' l'output di "ls -l /mnt" dato quando la partizione ext3 non e' ancora montata:

Codice: Seleziona tutto

drwxr-xr-x 2 legionario users  4096 2008-04-28 15:04 sdb3/
E questo e' come diventa una volta montata (non capisco perche' si trasformi in root il proprietario):

Codice: Seleziona tutto

drwxr-xr-x 3 root       root   4096 2008-05-01 02:08 sdb3/
Questo e' l'output di groups dato dall'utente:

Codice: Seleziona tutto

bash-3.1$ groups
users disk lp audio cdrom plugdev scanner
Spero mi possiate dare una mano. In questi anni di utilizzo di linux non mi era mai capitato di dover scrivere su un hard disk esterno formattato in ext3...

Grazie per l'attenzione

Falko
Linux 0.x
Linux 0.x
Messaggi: 16
Iscritto il: lun 23 mag 2005, 0:00
Slackware: Current

Re: Banalita' disarmante. Eppure non ci riesco!

Messaggio da Falko »

Il disco che vai a montare avrà il proprietario settato come root evidentemente e quindi di conseguenza montandolo la directory diventa dello stesso, quindi se ci vuoi scrivere o dai il permesso all'intero disco col tuo utente (chown) oppure lo monti col gid relativo del tuo gruppo in modo da ereditare i permessi di scrittura. In ogni caso lo puoi montare tranquillamente con l'opzione "defaults" esattamente come faresti con una reiserfs, il risultato è equivalente ;)

Avatar utente
legionario
Linux 3.x
Linux 3.x
Messaggi: 603
Iscritto il: mer 8 dic 2004, 0:00
Località: Bergamo - Roma

Re: Banalita' disarmante. Eppure non ci riesco!

Messaggio da legionario »

Purtroppo con defaults il problema permane. Ho aggiunto il mio gid alla riga di fstab ma ricevo questo errore:

Codice: Seleziona tutto

EXT3-fs: Unrecognized mount option "gid=100" or missing value
EXT3-fs: Unrecognized mount option "gid=100" or missing value
La riga diventa quindi cosi':

Codice: Seleziona tutto

/dev/sdb3               /mnt/sdb3        ext3        user,noauto,exec,rw,gid=100      0    0
Ho anche cambiato l'utente e il gruppo proprietario di /dev/sdb3 ma continuo a non poter scrivere sulla partizione ext3:

Codice: Seleziona tutto

brw-rw---- 1 legionario users 8, 19 2007-10-21 00:27 /dev/sdb3
Dopo il montaggio continua a trasformarsi in root:

Codice: Seleziona tutto

drwxr-xr-x 3 root       root   4096 2008-05-01 02:08 sdb3/
A questo punto le ho provate tutte. Non credo debba cambiare regole a udev perche' sarebbe una cosa incredibilmente lunga dover modificare udev ogni volta che voglio mettere una periferica usb con ext3...

Avatar utente
ichabod
Linux 0.x
Linux 0.x
Messaggi: 74
Iscritto il: sab 27 mag 2006, 18:02
Slackware: 12.2
Kernel: 2.6.28.8
Desktop: xfce 4.4.3

Re: Banalita' disarmante. Eppure non ci riesco!

Messaggio da ichabod »

Non è che hai cambiato il proprietario e i permessi del dispositivo quando questo non era montato?
Prova a montare il dispositivo e dare:

Codice: Seleziona tutto

chown legionario:users /mnt/sdb3

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2902
Iscritto il: mer 13 feb 2008, 16:19
Slackware: 14.2
Kernel: 4.4.19
Desktop: KDE4
Località: Bulagna
Contatta:

Re: Banalita' disarmante. Eppure non ci riesco!

Messaggio da 414N »

L'opzione gid serve per partizioni FAT o NTFS che hanno ACL diverse da quelle Ext2/3 (quelle tipicamente di Unix).
Potresti provare con l'opzione group ma non credo ti cambi la situazione...
Potresti, in alternativa, creare una directory all'interno del device da root e poi, tramite chown, renderla ad uso esclusivo del tuo utente e/o gruppo. In pratica, una struttura simile a /home: /home è di root:root, ma le sottocartelle presenti al suo interno sono dei vari utenti.
Magari prendi spunto dalla riga /home nel tuo fstab.

enzo.bak
Linux 1.x
Linux 1.x
Messaggi: 144
Iscritto il: lun 28 apr 2008, 17:58
Località: Reggio Calabria

Re: Banalita' disarmante. Eppure non ci riesco!

Messaggio da enzo.bak »

Hai provato, una volta montato, a dare, da root:
chown -R legionario /mnt/sdb3/
?
Facci sapere se funziona...

Avatar utente
legionario
Linux 3.x
Linux 3.x
Messaggi: 603
Iscritto il: mer 8 dic 2004, 0:00
Località: Bergamo - Roma

Re: Banalita' disarmante. Eppure non ci riesco!

Messaggio da legionario »

enzo.bak ha scritto:Hai provato, una volta montato, a dare, da root:
chown -R legionario /mnt/sdb3/
?
Facci sapere se funziona...
Cosi' funziona!!

Pero' non capisco: dovrebbe essere fstab a gestire tutto quanto. Secondo me dovrebbe essere tutto automatizzato. A cosa puo' essere dovuto il problema? E poi ogni volta dovrei fare tutto manualmente...

johnpad
Linux 0.x
Linux 0.x
Messaggi: 66
Iscritto il: gio 10 gen 2008, 23:30
Slackware: Slackware 12.2
Kernel: 2.6.32
Desktop: Kde 3.5.10

Re: Banalita' disarmante. Eppure non ci riesco!

Messaggio da johnpad »

ciao, e' capitato anche a me e ho risolto cosi' anche se non so se per questioni di sicurezza e' molto giusto.
Oltretutto se dopo salvi o crei dopo file come root essi rimangono comunque sempre di proprieta' di root.
Fai il login da root e avvii kde.

-Konquerror
-Storage media
-tasto destro sull'hard disk della tua partizione
-Proprieta'-Permission
-Access Permission
-"Can View & Modify Content" a tutto.

Avatar utente
legionario
Linux 3.x
Linux 3.x
Messaggi: 603
Iscritto il: mer 8 dic 2004, 0:00
Località: Bergamo - Roma

Re: Banalita' disarmante. Eppure non ci riesco!

Messaggio da legionario »

Grazie johnpad...

Ora vado un paio di giorni in "ferie" e poi provo anche il tuo consiglio. Vi terro' comunque aggiornati. Magari se qualcuno nel frattempo puo' darmi qualche altro suggerimento lo provero' sabato al mio rientro..

Buon primo maggio

Avatar utente
anycolouryoulike
Packager
Packager
Messaggi: 1158
Iscritto il: ven 10 ago 2007, 0:00
Slackware: 12.2
Kernel: 2.6.34.8
Desktop: KDE 3.5.10

Re: Banalita' disarmante. Eppure non ci riesco!

Messaggio da anycolouryoulike »

Anche io ebbi lo stesso problema viewtopic.php?p=155766...
Le opzioni mode, gid e uid si usano solo se il filesystem non supporta nativamente i permessi stile UNIX. Per montarlo quindi è necessario impostarli tramite l'fstab, ad esempio con l'NTFS. Con, ad esempio, l'EXT3 invece non è possibile farlo perché ha già dei permessi impostati e si tratterebbe di modificarli.
Adesso ogni volta che lo monti ritroverai i permessi che hai appena dato, non quelli di default root:root.

Falko
Linux 0.x
Linux 0.x
Messaggi: 16
Iscritto il: lun 23 mag 2005, 0:00
Slackware: Current

Re: Banalita' disarmante. Eppure non ci riesco!

Messaggio da Falko »

Volendo si può anche usare il "suid" per il montaggio.
(Non sapevo che gid fosse per le partizioni non native, però devo dire che funziona tranquillamente anche con reiser e ext!)

Avatar utente
anycolouryoulike
Packager
Packager
Messaggi: 1158
Iscritto il: ven 10 ago 2007, 0:00
Slackware: 12.2
Kernel: 2.6.34.8
Desktop: KDE 3.5.10

Re: Banalita' disarmante. Eppure non ci riesco!

Messaggio da anycolouryoulike »

Falko ha scritto:Volendo si può anche usare il "suid" per il montaggio.
(Non sapevo che gid fosse per le partizioni non native, però devo dire che funziona tranquillamente anche con reiser e ext!)
Sicuro?
Allora proprio non ho capito niente...
Perché mi dà questi errori?

Codice: Seleziona tutto

root@darkstar:~# mount -t reiserfs /dev/sdc1 /media/sdc1 -o gid=755
mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
       missing codepage or helper program, or other error
       In alcuni casi si possono trovare informazioni utili in syslog. Provare
       ad esempio 'dmesg | tail'

root@darkstar:~# mount -t ext3 /dev/sdc1 /media/sdc1 -o gid=755
mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
       missing codepage or helper program, or other error
       In alcuni casi si possono trovare informazioni utili in syslog. Provare
       ad esempio 'dmesg | tail'

root@darkstar:~# dmesg | tail -n 2
ReiserFS: sdc1: warning: unknown mount option "gid=755"
EXT3-fs: Unrecognized mount option "gid=755" or missing value

Falko
Linux 0.x
Linux 0.x
Messaggi: 16
Iscritto il: lun 23 mag 2005, 0:00
Slackware: Current

Re: Banalita' disarmante. Eppure non ci riesco!

Messaggio da Falko »

anycolouryoulike ha scritto:Sicuro?
Allora proprio non ho capito niente...
Perché mi dà questi errori?

Codice: Seleziona tutto

root@darkstar:~# mount -t reiserfs /dev/sdc1 /media/sdc1 -o gid=755
mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
       missing codepage or helper program, or other error
       In alcuni casi si possono trovare informazioni utili in syslog. Provare
       ad esempio 'dmesg | tail'

root@darkstar:~# mount -t ext3 /dev/sdc1 /media/sdc1 -o gid=755
mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
       missing codepage or helper program, or other error
       In alcuni casi si possono trovare informazioni utili in syslog. Provare
       ad esempio 'dmesg | tail'

root@darkstar:~# dmesg | tail -n 2
ReiserFS: sdc1: warning: unknown mount option "gid=755"
EXT3-fs: Unrecognized mount option "gid=755" or missing value
Ho appena fatto una bella scoperta grazie a questo post, ho il Fs corrotto...
In effetti mi pareva strano che montasse col Gid se questo si usa su part non native. Meglio scoprirlo tardi che mai :D

Rispondi