Mouse problem...

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
tftd
Linux 0.x
Linux 0.x
Messaggi: 20
Iscritto il: sab lug 12, 2008 17:04
Slackware: 12.2
Kernel: 2.6.29.4
Desktop: Gnome 2.26.3

Mouse problem...

Messaggioda tftd » dom lug 27, 2008 20:02

Hey,

I bought a new mouse yesterday - Logitech RX250.
It has 7 buttons I think... You can scroll up/down and with the scroller you can go left/right.
I managed to get the scrolling ( up/down ) working with the usual xorg.conf settings:

Codice: Seleziona tutto


Section "InputDevice"
...
     Option "ZAxisMapping" "4 5 6 7"

EndSection



but still I can't find how to get left/right working ?

Here is a picture of my mouse http://www.fixsacomp.com/images/productos/15046121.jpg


Does anybody have an idea ? :) :-k

Thanks in advance,
tftd

Avatar utente
Blizzard
Master
Master
Messaggi: 1509
Iscritto il: mar gen 02, 2007 22:53
Nome Cognome: Giovanni Santostefano
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: Fluxbox
Contatta:

Re: Mouse problem...

Messaggioda Blizzard » dom lug 27, 2008 21:31

Hi!
I've a sphere mouse and I'm thankful if it has the scroll :lol: :lol: :lol: so I can't directly answer
but I think you need to emulate a X axis movement.
I've made a small search and found this
http://www.xfree86.org/current/mouse.4.html

Option "XAxisMapping" "N1 N2"
Specifies which buttons are mapped to motion in the X direction in wheel emulation mode. Button number N1 is mapped to the negative X axis motion and button number N2 is mapped to the positive X axis motion. Default: no mapping.

Maybe can help you! you have to discover the button number but I think they are sequential to the ZAxis buttons

hope this can help!
Bye
Gio

Avatar utente
neongen
Packager
Packager
Messaggi: 827
Iscritto il: ven mag 25, 2007 12:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5
Contatta:

Re: Mouse problem...

Messaggioda neongen » dom lug 27, 2008 22:12

you can try btnx. just detect buttons and bind them to key_left and key_right.

tftd
Linux 0.x
Linux 0.x
Messaggi: 20
Iscritto il: sab lug 12, 2008 17:04
Slackware: 12.2
Kernel: 2.6.29.4
Desktop: Gnome 2.26.3

Re: Mouse problem...

Messaggioda tftd » dom lug 27, 2008 23:34

Thanks for the replies !
I tried btnx but I can't find where "uinput" in the kernel is. So I can't enable it as a module ... :(

Avatar utente
neongen
Packager
Packager
Messaggi: 827
Iscritto il: ven mag 25, 2007 12:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5
Contatta:

Re: Mouse problem...

Messaggioda neongen » lun lug 28, 2008 0:44

tftd ha scritto:Thanks for the replies !
I tried btnx but I can't find where "uinput" in the kernel is. So I can't enable it as a module ... :(


device drivers > ATA/ATAPI... > Misc > User level driver support
:roll:

Johnn
Linux 0.x
Linux 0.x
Messaggi: 67
Iscritto il: sab apr 28, 2007 18:53
Slackware: current
Kernel: 2.6.29.4
Desktop: kde 4.2.4

Re: Mouse problem...

Messaggioda Johnn » lun lug 28, 2008 18:29

I have a Logitech Mx310 with 7 buttons. My xorg.conf in mouse section is:

Codice: Seleziona tutto

...
Option "Buttons" "7"
Option "ZAxisMapping" "4 5"
Option "ButtonMapping" "1 2 3 6 7"
...


If you run in a shell:

xev

you can understand if all your button are set correctly.

My configuration should be ok because I can swicth between application windows, but in Konqueror and Firefox 3.0.x back and forward don't work and I don't know why (maybe firefox requests a particularly compilation flag).

tftd
Linux 0.x
Linux 0.x
Messaggi: 20
Iscritto il: sab lug 12, 2008 17:04
Slackware: 12.2
Kernel: 2.6.29.4
Desktop: Gnome 2.26.3

Re: Mouse problem...

Messaggioda tftd » mer lug 30, 2008 0:00

Johnn ha scritto:I have a Logitech Mx310 with 7 buttons. My xorg.conf in mouse section is:

Codice: Seleziona tutto

...
Option "Buttons" "7"
Option "ZAxisMapping" "4 5"
Option "ButtonMapping" "1 2 3 6 7"
...


If you run in a shell:

xev

you can understand if all your button are set correctly.

My configuration should be ok because I can swicth between application windows, but in Konqueror and Firefox 3.0.x back and forward don't work and I don't know why (maybe firefox requests a particularly compilation flag).



Hey,

Sorry for the late reply but I had some work to do...
I tried your xorg.conf code but when i clicked the buttons in "xev" they weren't detected....

Also I tried to search in 'ATA/ATAPI' the User level driver support but no luck. Probably I need to update the kernel but I'm having cpu/memory problems with newer kernels. So probably I won't find a solution of the problem ;)


Thanks for all of your replies !

Best wishes,
tftd

Avatar utente
Blizzard
Master
Master
Messaggi: 1509
Iscritto il: mar gen 02, 2007 22:53
Nome Cognome: Giovanni Santostefano
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: Fluxbox
Contatta:

Re: Mouse problem...

Messaggioda Blizzard » mer lug 30, 2008 8:06

wow! xev is great!