Domanda sull'installazione del ramo current...

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
Webbino
Linux 2.x
Linux 2.x
Messaggi: 227
Iscritto il: ven ott 14, 2005 18:05

Domanda sull'installazione del ramo current...

Messaggioda Webbino » lun nov 24, 2008 17:52

Salve


Dato che devo formattare, volevo approfittare per passare alla current (sperando che Pat pacchettizzi anche Kde 4.1.3), ho letto (negli hotwo) la possibilità di fare un dvd del ramo current, la mia domanda è invece se è possibile seguire il seguente procedimento:

1) Scarico l'intero ramo current, salvo tutto su una partizione apposita contenente solo quello (es: disco usb esterno, o disco slave)

2) Inserisco il cd di installazione di slack 12.1 e quando mi indica la sorgente dove prendere i pacchetti, gli indico la partizione creata precedentemente..

I miei dubbi, sono ovviamente nel punto due, i programma di installazione di slack 12.1 cerca esattamente i pacchetti di slack 12.1, o come spero, il programma di installazione è un attimo più elastico e va a leggere il file PACKAGES.TXT e file affini per fare un elenco dei pacchetti...


Grazie in anticipo per i chiarimenti


Webbino

Avatar utente
d4z_c0nf
Packager
Packager
Messaggi: 1296
Iscritto il: mar mar 14, 2006 18:07
Nome Cognome: Rocco Aliberti
Slackware: 14.2-current64
Kernel: 4.14.73
Desktop: awesomeWM
Località: Pinerolo

Re: Domanda sull'installazione del ramo current...

Messaggioda d4z_c0nf » lun nov 24, 2008 18:03

Webbino ha scritto:Salve


Dato che devo formattare, volevo approfittare per passare alla current (sperando che Pat pacchettizzi anche Kde 4.1.3), ho letto (negli hotwo) la possibilità di fare un dvd del ramo current, la mia domanda è invece se è possibile seguire il seguente procedimento:

1) Scarico l'intero ramo current, salvo tutto su una partizione apposita contenente solo quello (es: disco usb esterno, o disco slave)

2) Inserisco il cd di installazione di slack 12.1 e quando mi indica la sorgente dove prendere i pacchetti, gli indico la partizione creata precedentemente..

I miei dubbi, sono ovviamente nel punto due, i programma di installazione di slack 12.1 cerca esattamente i pacchetti di slack 12.1, o come spero, il programma di installazione è un attimo più elastico e va a leggere il file PACKAGES.TXT e file affini per fare un elenco dei pacchetti...


Grazie in anticipo per i chiarimenti


Webbino


Se non sbaglio provai questa cosa, con la 11 verso la 12.1.
Mi pare che il problema fosse il kernel, nel senso che la 12.1 voleva un kernel superiore a quello utilizzato come boot per la 11.
rock

Avatar utente
Luci0
Staff
Staff
Messaggi: 3591
Iscritto il: lun giu 27, 2005 0:00
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce
Località: Forte dei Marmi
Contatta:

Re: Domanda sull'installazione del ramo current...

Messaggioda Luci0 » mar nov 25, 2008 9:28

Puoi scaricare l' immagine ...-current/usb-and-pxe-installers/usbboot.img e la copi in una usbpen anche piccola con

Codice: Seleziona tutto

dd if=usbboot.img of=/dev/sda bs=512
per altre info leggiti il file README_USB.txt, oppure crei una miniiso e masterizzi un CD di boot con questo script ... di Alien Bob modificato da me ... (spero in maniera corretta!)

Codice: Seleziona tutto

!/bin/sh
# $Id: create_miniiso.sh,v 1.3 2006/09/21 19:05:25 root Exp root $
# -------------------------------------------------------------------------
# Purpose:
#   Create mini ISO image for installing Slackware ('mini' meaning: not
#   containing any Slackware package. Some people want to use a creditcard
#   sized CD for their installs.
# Needed:
#   The 'isolinux' and 'kernels' directories from the Slackware tree.
# Author:
#   Eric Hameleers <alien@slackware.com> 21-sep-2006
# -------------------------------------------------------------------------
# Modificato da Luci0 aka gabsan ... non ricordo quando ne dove ... ma funziona !!

STAGING=${STAGING:-~/miniiso}
SLACKROOT=${SLACKROOT:-/home/ftp/slackware-current}

BUILDER="Alien <alien@slackware.com>"
RELEASE=12.2rc
DATE=`date +"%d_%b_%Y"`

# ----------------------------------------------------------------------

# Do not tolerate sloppy scripting:
set -u
set -e
trap 'echo "*** $0 FAILED ***"' ERR

# Delete any existing output files from a previous run:
rm -f ${STAGING}/slackware-mini-install-$RELEASE.iso*

if [ ! -d $SLACKROOT ]; then
  echo "*** I can't find the Slackware package tree $SLACKROOT!"
  exit 1
fi

# STAGING is where we will do all our work:
[ ! -d ${STAGING} ] && ( mkdir -p $STAGING || ( echo "*** Could not create directory
${STAGING}!"; exit 1 ) )

# OK... work starts here:

cd ${SLACKROOT}
mkisofs -o ${STAGING}/slackware-mini-install-$RELEASE.iso \
-R -J -V "Slackware Mini Install" \
-x ./extra \
-x ./pasture \
-x ./patches \
-x ./slackware \
-x ./source \
-x ./testing \
-x ./usb-and-pxe-installers \
-hide-rr-moved -hide-joliet-trans-tbl \
-v -d -N -no-emul-boot -boot-load-size 4 -boot-info-table \
-sort isolinux/iso.sort \
-b isolinux/isolinux.bin \
-c isolinux/isolinux.boot \
-preparer "Slackware-${RELEASE} build by ${BUILDER}" \
-publisher "The Slackware Linux Project - http://www.slackware.com/" \
-A "Slackware-${RELEASE} Install CD1 - build $DATE" . \

( cd  ${STAGING}
  md5sum slackware-mini-install-$RELEASE.iso > slackware-mini-install-$RELEASE.iso.md5
)

echo ""
echo "------------------------------------------------------------------------"
echo "The new slackware-mini-install.iso file is:"
echo "'${STAGING}/slackware-mini-install-$RELEASE.iso'"
echo "------------------------------------------------------------------------"
echo ""


Lo script va modificato in

Codice: Seleziona tutto

 SLACKROOT=${SLACKROOT:-/home/ftp/slackware-current}

e ci va messo il percorso corretto ...
Allegati
miniiso-current.sh.txt
(2.3 KiB) Scaricato 32 volte

Avatar utente
Webbino
Linux 2.x
Linux 2.x
Messaggi: 227
Iscritto il: ven ott 14, 2005 18:05

Re: Domanda sull'installazione del ramo current...

Messaggioda Webbino » mar nov 25, 2008 11:06

In teoria Luci0 farei questo procedimento per non masterizzare un cd in più :)
Purtroppo il mio Pc è vecchiotto (ha circa 8 anni), quindi niente boot usb...

Volevo approfittare di usare il cd della slack 12.1


Grazie comunque dei consigli...


O.T: Pat ha appena pacchettizzato Kde 4.1.3, quindi in questi giorni sperimento :)

Kronos
Linux 1.x
Linux 1.x
Messaggi: 133
Iscritto il: gio mar 09, 2006 21:50
Località: In Calabria

Re: Domanda sull'installazione del ramo current...

Messaggioda Kronos » mar nov 25, 2008 12:08

Secondo me potresti anche provare ad utilizzare il cd della 12.1; è vero che con il cd della 11 non era possibile andare ad installare una 12 o una 12.1 ma in quel caso il problema stava nel fatto che il kernel di default della 11 era ancora della serie 2.4.x ed era incompatibile con le glibc utilizzate a partire dalla 12 che invece richiedono un kernel 2.6.x.
Tra 12.1 e current non credo che ci siano di questi problemi e comunque...
per levarsi il dubbio basta provare.
Ciao

Avatar utente
d4z_c0nf
Packager
Packager
Messaggi: 1296
Iscritto il: mar mar 14, 2006 18:07
Nome Cognome: Rocco Aliberti
Slackware: 14.2-current64
Kernel: 4.14.73
Desktop: awesomeWM
Località: Pinerolo

Re: Domanda sull'installazione del ramo current...

Messaggioda d4z_c0nf » mar nov 25, 2008 12:15

Kronos ha scritto:Secondo me potresti anche provare ad utilizzare il cd della 12.1; è vero che con il cd della 11 non era possibile andare ad installare una 12 o una 12.1 ma in quel caso il problema stava nel fatto che il kernel di default della 11 era ancora della serie 2.4.x ed era incompatibile con le glibc utilizzate a partire dalla 12 che invece richiedono un kernel 2.6.x.
Tra 12.1 e current non credo che ci siano di questi problemi e comunque...
per levarsi il dubbio basta provare.
Ciao


Sì infatti, era quello che dicevo, il problema in quel caso era il kernel, e quindi non potei andare avanti nell'installazione.
rock

Avatar utente
shark1500
Linux 3.x
Linux 3.x
Messaggi: 785
Iscritto il: gio apr 03, 2008 14:33
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde
Località: Modna

Re: Domanda sull'installazione del ramo current...

Messaggioda shark1500 » mar nov 25, 2008 12:47

Potresti farlo, semplicemente avvii la 12.1, e poi "manualmente" installi tutti i pacchetti che ti servono sulla tua partizione (io almeno farei cosi')

Avatar utente
Webbino
Linux 2.x
Linux 2.x
Messaggi: 227
Iscritto il: ven ott 14, 2005 18:05

Re: Domanda sull'installazione del ramo current...

Messaggioda Webbino » mar nov 25, 2008 12:53

Si, spero anch'io che il problema era appunto il cambio di kernel (dato che i pacchetti come udev ecc.. ecc.., hanno bisogno del kernel serie 2.6).

Be, provo comunque a usare il cd della 12.1, ovviamente vi faccio sapere.. sperando che questo sia d'aiuto ad altri


*shark1500: Con upgrade violenti ho sempre avuto qualche problema, poi vorrei formattare, dato che, come al solito, regna l'anarchia più totale in ogni directory :)

Avatar utente
d4z_c0nf
Packager
Packager
Messaggi: 1296
Iscritto il: mar mar 14, 2006 18:07
Nome Cognome: Rocco Aliberti
Slackware: 14.2-current64
Kernel: 4.14.73
Desktop: awesomeWM
Località: Pinerolo

Re: Domanda sull'installazione del ramo current...

Messaggioda d4z_c0nf » mar nov 25, 2008 12:58

Webbino ha scritto:Si, spero anch'io che il problema era appunto il cambio di kernel (dato che i pacchetti come udev ecc.. ecc.., hanno bisogno del kernel serie 2.6).

Be, provo comunque a usare il cd della 12.1, ovviamente vi faccio sapere.. sperando che questo sia d'aiuto ad altri


*shark1500: Con upgrade violenti ho sempre avuto qualche problema, poi vorrei formattare, dato che, come al solito, regna l'anarchia più totale in ogni directory :)

Sì prova a partire con la 12.1, la cosa dovrebbe andare, ammessa la compatibilità del kernel.
Anche perchè il fatto che l'installazione fallisse a causa del kernel significa che prendeva i pacchetti nuovi.
rock

Avatar utente
Luci0
Staff
Staff
Messaggi: 3591
Iscritto il: lun giu 27, 2005 0:00
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce
Località: Forte dei Marmi
Contatta:

Re: Domanda sull'installazione del ramo current...

Messaggioda Luci0 » mar nov 25, 2008 15:09

Webbino ha scritto:In teoria Luci0 farei questo procedimento per non masterizzare un cd in più :)
Purtroppo il mio Pc è vecchiotto (ha circa 8 anni), quindi niente boot usb...

Volevo approfittare di usare il cd della slack 12.1


Grazie comunque dei consigli...


O.T: Pat ha appena pacchettizzato Kde 4.1.3, quindi in questi giorni sperimento :)


Puoi usare un riscrivibile .... sono solo 30Mb :-)

Oppure fare il boot dalla scheda di rete ... ma la cosa non é propriamente semplice!
e a dirti la verità non ho mai provato ... non dovrebbe essere poi così difficile...ma sicuramente più difficile che non masterizzarsi un CD!

Avatar utente
conraid
Staff
Staff
Messaggi: 13305
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Domanda sull'installazione del ramo current...

Messaggioda conraid » mar nov 25, 2008 17:32

Dalle sacre scritture secondo Pat

Codice: Seleziona tutto

Versions of the linux kernel less than 2.6.18 will not work - the lowest
  kernel version that glibc supports is 2.6.18, so don't bother trying anything
  older than that. If you use hal, then you'll need at least a 2.6.19 kernel.
  The 2.6.27.x series is planned to be maintained long-term by GregKH and
  others (similar to the 2.6.16.x series).


da ftp://ftp.slackware.com/pub/slackware/s ... _HINTS.TXT

Per l'installazione via rete
ftp://ftp.slackware.com/pub/slackware/s ... ME_PXE.TXT

al limite installi una versione minima minima della 12.1 e poi aggiorni alla -current completa

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2412
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.2
Kernel: 4.11.3-smp
Desktop: xfce4
Distribuzione: freeBSD-12.0-Release

Re: Domanda sull'installazione del ramo current...

Messaggioda slucky » mar nov 25, 2008 23:49

al limite installi una versione minima minima della 12.1 e poi aggiorni alla -current completa


nel caso in questione il consiglio di Conraid mi pare un'ottima idea, semplice e veloce per raggiungere lo scopo, anche considerando che hai una macchina non più di primo pelo :)

saluti

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1126
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: Domanda sull'installazione del ramo current...

Messaggioda lablinux » gio nov 27, 2008 12:25

La domanda è perchè usare la current? Per provarla o ci sono vantaggi che non comprendo?
Ciao Michele