ATI Radeon 7000

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Tongiu
Linux 0.x
Linux 0.x
Messaggi: 99
Iscritto il: mar mag 13, 2003 0:00

ATI Radeon 7000

Messaggioda Tongiu » mar dic 14, 2004 9:39

Mi sono procurato una nuova scheda video ATI Radeon 7000 con 64 M di memoria. <BR>Adesso devo abilitare l´accellerazione grafica. <BR>Nell´ottimo Slackware For Dummies si parla genericamente delle ATI Radeon ma nel sito di riferimento dell´ATI si dice che il driver è valido per le schede dalla 8500 in su e dalla X300 in su. <BR>Per farla breve: <BR>Le stesse operazioni indicate su Slackware For Dummies sono valide anche per la ATI Radeon 7000 ? <BR>Qualcuno ha una scheda come la mia ed è riuscito ad abilitare l´accellerazione ? <BR>Ho cercato su google ma ho trovato 100 modi tutti diversi e non tutti funzionanti quindi in pratica non ho trovato niente <BR>Ciao <BR>Tongiu<br>

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom ott 12, 2003 0:00
Località: A place where the streets have no name
Contatta:

ATI Radeon 7000

Messaggioda useless » mar dic 14, 2004 9:41

qua a lavoro ho una 7000 e non sono riuscito ad installare i driver ufficiali. al momento del modprobe si lamenta con "no such device", quindi penso che questo modello proprio non sia supportato, anche se non mi sono sbattuto molto a cercare se si può far funzionare con qualche truschino.<br>

pristan
Linux 0.x
Linux 0.x
Messaggi: 31
Iscritto il: dom nov 23, 2003 0:00
Contatta:

ATI Radeon 7000

Messaggioda pristan » mer dic 15, 2004 16:58

Purtroppo devo confermare che la ATI ha sviluppato i driver a partire dalla 8500, purtroppo bisogna accontentarsi dei driver vesa! <BR><br>

Tongiu
Linux 0.x
Linux 0.x
Messaggi: 99
Iscritto il: mar mag 13, 2003 0:00

ATI Radeon 7000

Messaggioda Tongiu » ven dic 17, 2004 16:52

Sono riuscito a far funzionare l´accellerazione grafica sulla ATI Radeon 7000 senza utilizzare i driver ATI (che comunque non funzionano con la 7000). <BR>Ho il kernel 2.6.7 presente sui cd di slack 10.0 installato come pacchetto e non ricompilato. <BR>Il segreto è questo: <BR>Accertarsi che in /etc/rc.d/rc.modules sia decommentata la riga in cui carica il modulo agpgart: <BR>/sbin/modprobe agpgart <BR>Dopo questa riga E´ NECESSARIO che sia caricato un modulo che permette di utilizzare l´AGP e che dipende dal chipset della propria scheda madre. Normalmente questo modulo non viene caricato. <BR>Nel mio caso (chipset intel 440 BX) il modulo si chiama intel-agp. <BR>Per i chipset via esiste il via-agp e così via. <BR>Il mio /etc/rc.d/rc.modules diventa quindi: <BR>/sbin/modprobe agpgart <BR>/sbin/modprobe intel-agp. <BR>Fatto questo ho modificato le righe di xorg.conf <BR>così: <BR> <BR>[.....] <BR># This loads the GLX module <BR>Load "glx" <BR>Load "dri" <BR>EndSection <BR> <BR>Section "DRI" <BR>Mode 0666 <BR>EndSection <BR> [.........] <BR> <BR>Section "Device" <BR>Identifier "ATI Radeon 7000" <BR>Driver "radeon" <BR>VideoRam 65536 <BR>Option "Accel" "1" <BR>Option "AGPMode" "2" # AGP 2x <BR>Option "AGPFastWrite" "1" <BR>Option "EnablePageFlip" "1" <BR># Insert Clocks lines here if appropriate <BR>vendorname "ATI" <BR>boardname "Radeon 7000" <BR>EndSection <BR> <BR>Fatto questo ho riavviato il tutto e il DRI è abilitato. <BR>Spero possa essere utile. <BR>Tongiu<br>

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom ott 12, 2003 0:00
Località: A place where the streets have no name
Contatta:

ATI Radeon 7000

Messaggioda useless » ven dic 17, 2004 16:57

così funziona anche a me, kernel 2.4.26, ma è orrendamente lento e sfarfalla assai :-[.<br>

Tongiu
Linux 0.x
Linux 0.x
Messaggi: 99
Iscritto il: mar mag 13, 2003 0:00

ATI Radeon 7000

Messaggioda Tongiu » dom dic 19, 2004 11:44

Mah, da me non sembra. <BR>Adesso sto usando il salvaschermo di KDE "venti solari" ed è molto fluido. <BR>Senza accellerazione manco a parlarne. <BR>Certo i driver Mesa non saranno il massimo .... <BR>Io non vedo nessuno sfarfallio. <BR>Prova il 2.6.7, mi sembra di aver letto da qualche parte che il modulo agpgart del 2.4 dava un po´ di problemi. <BR>Tongiu<br>

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom ott 12, 2003 0:00
Località: A place where the streets have no name
Contatta:

ATI Radeon 7000

Messaggioda useless » dom dic 19, 2004 13:51

sì, può essere, hai ragione. appena ho tempo compilo il 2.6.7, il precompilato purtroppo pare andare bene, ma appena compare kdm si inchioda tutto paurosamente :-(.<br>

samiel
Staff
Staff
Messaggi: 5510
Iscritto il: ven gen 16, 2004 0:00
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian
Località: Venezia

ATI Radeon 7000

Messaggioda samiel » dom dic 19, 2004 14:07

Io, che non amo i giochi (e poi manco avrei il tempo) <BR>ho l´accelerazione nativa. Ho provato a titolo di curiosità <BR>sulla mia vecchia ATI Radeon 9000 (che non è <BR>un modello da faville) e non mi pare vada male. <BR>Ho postato qualche giorno fa i dati... <BR> <BR>M.<br>

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom ott 12, 2003 0:00
Località: A place where the streets have no name
Contatta:

ATI Radeon 7000

Messaggioda useless » dom dic 19, 2004 14:13

guarda, noi abbiamo queste 7000 su metà dei pc del laboratorio. l´unico uso del 3d che serve è quello che ne fanno gli studenti del corso di informatica grafica, che programmano con l´opengl. quindi non pretendiamo framerate da capogiro, xò x quel che siamo riusciti ad ottenere ci vergognavamo persino un po´ a fargli usare ste schede... :-( ma magari è colpa di fedora. sul mio pc, che è uguale a tutti gli altri, c´è invece slack, e i risultati non differiscono di molto, xò io ho il kernel 2.4.26, fedora il 2.6.8. appena ho tempo, come scritto sopra, provo io con un 2.6.<br>

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom ott 12, 2003 0:00
Località: A place where the streets have no name
Contatta:

ATI Radeon 7000

Messaggioda useless » mar dic 21, 2004 9:48

ok, ho finalmente compilato un 2.6.7 personalizzato e, ironia della sorte, ho appurato che ciò che fa piantare X clamorosamente è proprio il direct rendering, così ho dovuto disattivarlo. nessuno di voi ha avuto problemi? il chipset qua è sis. <BR> <BR>@tongiu: <BR>quelle opzioni: <BR>VideoRam 65536 <BR>Option "Accel" "1" <BR>Option "AGPMode" "2" # AGP 2x <BR>Option "AGPFastWrite" "1" <BR>Option "EnablePageFlip" "1" <BR>le hai messe x un motivo specifico?<br>

samiel
Staff
Staff
Messaggi: 5510
Iscritto il: ven gen 16, 2004 0:00
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian
Località: Venezia

ATI Radeon 7000

Messaggioda samiel » mar dic 21, 2004 13:30

Il mio è un chipset SiS 648. <BR>Non ho aggiunto nessuna opzione particolare in xorg.conf. <BR>AGP e DRM sono attivate nel kernel <BR>e con ATI Radeon 9000 ottengo <BR> <BR>10396 frames in 5.0 seconds = 2079.200 FPS <BR>10399 frames in 5.0 seconds = 2079.800 FPS <BR>10399 frames in 5.0 seconds = 2079.800 FPS <BR>10398 frames in 5.0 seconds = 2079.600 FPS <BR>10398 frames in 5.0 seconds = 2079.600 FPS <BR>10400 frames in 5.0 seconds = 2080.000 FPS <BR>10398 frames in 5.0 seconds = 2079.600 FPS <BR>10397 frames in 5.0 seconds = 2079.400 FPS <BR> <BR>M. <BR><br>

Tongiu
Linux 0.x
Linux 0.x
Messaggi: 99
Iscritto il: mar mag 13, 2003 0:00

ATI Radeon 7000

Messaggioda Tongiu » gio dic 30, 2004 22:43

@useless <BR>Scusa sono stato in vacanza e non mi collegavo ad internet. <BR>No sono opzioni che avevo trovato su un altro forum ma non mi sembra che vadano male. <BR> <BR>@samiel <BR>Il mio PC adesso è lontano. Quando torno a casa ai primi di gennaio confrontiamo le prestazioni. <BR> <BR>Tongiu <BR><br>

Avatar utente
Rat_attack
Linux 1.x
Linux 1.x
Messaggi: 168
Iscritto il: lun set 13, 2004 0:00

ATI Radeon 7000

Messaggioda Rat_attack » ven dic 31, 2004 1:46

Scusate se mi intrometto.....piuttosto che aprire un nuovo topic chiedo qui una dritta... <BR>Ho comprato una ATI Radeon 9600Pro...e vorrei installare i Driver ATI... <BR>Sto leggendo come fare in Slackware for Dummies ma non riesco a capire come disabilitare le voci che gestiscono l´accellerazione grafica nativa nel Kernel (cioè AGP e DRM) <BR>Qualcuno mi sa dire in due parola dove le vado a pescare?<br>

aghnosci
Linux 0.x
Linux 0.x
Messaggi: 88
Iscritto il: lun set 13, 2004 0:00

ATI Radeon 7000

Messaggioda aghnosci » dom gen 02, 2005 15:06

nella mia ignoranza possosolo dare questo consiglio: <a href="http://dri.sourceforge.net/cgi-bin/moin.cgi/Building" target="_blank" target="_new">http://dri.sourceforge.net/cgi-bin/moin.cgi/Building</a> <BR>è la pagina di istruzioni per scaricare e installare i driver dri compatibili con schede ati. <BR>la mia è appunto una ati radeon ve 7000 con 64MB di memoria; uso il kernel 2.4.26 <BR>ma nella pagina ci sono anche le istruzioni per il kernel 2.6.x; funziona tutto bene senza prestazioni esilaranti, ma sicurammente sufficienti <BR>unico problema è che non si riesce ad attivare il tv-out; in un altro topic avevo chiesto qualche dritta sui driver gatos, ma non avendo ricevuto risposta non saprei dire.... <BR>ciao<br>