KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
Blallo
Packager
Packager
Messaggi: 3298
Iscritto il: ven 12 ott 2007, 11:37
Nome Cognome: Savino Liguori
Slackware: 14.2 / 12.2
Kernel: 4.4.14-smp
Desktop: DWM
Località: Torino / Torremaggiore (FG)
Contatta:

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da Blallo »

ponce ha scritto:non vi preoccupate, kde resta: non verra' messo il 4.4 finche' non riusciranno a far supportare a policykit le shadow utils invece di pam, ma ci stanno lavorando, lo chiarisce alien bob nei commenti al post citato. ;)
quello che dice e' che anche gli sviluppatori seguono le distribuzioni maggiori, andando dietro alle loro decisioni e rendendo standard cose opinabili, e poi gli altri (la Slack ad esempio) si dovrebbero adeguare... ovviamente non e' una situazione sostenibile piu' di tanto,

comunque anche senza policykit (uso la versione di alien bob che e' compilata cosi') va benissimo. :D
a quel punto chiedo, forse andando un po' in OT: dato che altre distro maggiori usano tutti sti ammenicoli (*kit, PAM, ecc)..hanno EFFETTIVA utilità o sono cose che possono essere "aggirate" usando sistemi già esistenti anche facendo qualche giro di comandi in più (riguardo alla mera funzionalità intendo)?

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2744
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.6.5
Desktop: lxde
Località: Pisa
Contatta:

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da ponce »

dipende, a volte alcune delle cose supportate da pam/policykit si perdono, perche' specifiche di quei sistemi: le shadow utils, ad esempio, non supportano tutte le funzionalita' di pam, ma magari gli sviluppatori nemmeno ce le vogliono aggiungere :D
che siano utili o superflue viene valutato principalmente dall'utente (per me che uso kde4.4 senza policykit, ad esempio, sono superflue), che non siano controproducenti o impossibili da integrare e' una valutazione che fanno gli sviluppatori dei sistemi di autentica e delle distribuzioni.

Avatar utente
shark1500
Linux 3.x
Linux 3.x
Messaggi: 785
Iscritto il: gio 3 apr 2008, 14:33
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde
Località: Modna

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da shark1500 »

Ma dove avete letto che la >= 4.4 non verra` messa su slackware?

Queste sono le parole di Alien:
Alien ha scritto: KDE 4.4 is surrounded by some “political” issues involving the influence of certain big distros, which keep it from being included into Slackware in the near future
Significa che ci stanno lavorando su come includerla in slackware!

Ad ogni modo se la volete potete gia` scaricarla dal repository di Alien (per 64 bit o te la ricompili tu con gli SlackBuild).

Avatar utente
danix
Staff
Staff
Messaggi: 3287
Iscritto il: ven 27 ott 2006, 19:32
Nome Cognome: Danilo M.
Slackware: 64 14.1
Kernel: 4.4.0
Desktop: kde4
Località: Siderno (RC)
Contatta:

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da danix »

shark1500 ha scritto:Ma dove avete letto che la >= 4.4 non verra` messa su slackware?

Queste sono le parole di Alien:
Alien ha scritto: KDE 4.4 is surrounded by some “political” issues involving the influence of certain big distros, which keep it from being included into Slackware in the near future
Significa che ci stanno lavorando su come includerla in slackware!
La tua mi sembra una traduzione piuttosto ottimista :p , li c'è scritto che l'influenza di alcune grandi distribuzioni sta bloccando kde 4.4 dall'essere incluso in Slackware nel prossimo futuro... dove l'hai letto che stanno lavorando per includerlo? Io posso capire che ci stiano lavorando dal fatto che Alien continua a rilasciare le rc, quindi un interesse, almeno da parte del team, ci deve essere, ma questo non è scritto da nessuna parte, semmai li c'è scritto il contrario... ;)
danix
myself ha scritto:non sono molto presente sul forum, e di ciò mi scuso con tutti

Avatar utente
NetNightmare
Linux 1.x
Linux 1.x
Messaggi: 175
Iscritto il: lun 18 ago 2008, 11:00
Nome Cognome: Giuseppe De Nicolo'
Slackware: 13.37 x86_64
Kernel: 2.6.37.6-smp
Desktop: Fluxbox
Località: Rome

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da NetNightmare »

Postato oggi in reply al suo blog a cui fa riferimento l'articolo, detto sincermanete io mi schiero con il team di slackware e con AlienBoB:
Comment from alienbob
Time January 26, 2010 at 23:48

My remark about “politics” was indeed referring to the fact that KDE 4.4 loses functionality if it is compiled while PolicyKit is not present on the system. This is questionable, since KDE4 should be using kauth as an abstraction instead, but as it stands, kauth integration will not be ready until KDE 4.5.
In the meantime some of KDE 4.4’s components “need” PolicyKit and there is no way around it, thanks to hard-headed developers.

The whole issue with PolicyKit, and more generally the whole set of “*Kit” libraries is that not only are they pushed into Linux by the big distros while at the same time dropping support for HAL, but support for the generic UNIX authentication backend “shadow utils” is ignored in favour of PAM. This is understandable if you consider that the other popular Linux distros are all using PAM. However, if we look upon X.Org and KDE as an Operating System’s core components, then these should not be intimately tied to Linux. Instead, their developers should strive to keep their code applicable to a wider range of OS’es.
Creating a dependency on PolicyKit (which is the work of a single Redhat employee and which is unstable as hell), and DeviceKit which was written by the former HAL developer after he left the HAL code to rot, is a very bad decision in my view.

Yes, it is the issue of the big players defining the rules of the playground, and many other developers (have to) follow suit (X.Org will drop support for HAL in their future releases).

It’s not just the big distros of course. Look at the devastating entanglement of kernel, mesa, X.Org and Intel developers, who managed to keep X.Org in a pretty useless state for more than a year.

I do think that Free Software is being hi-jacked for the sake of the Big Bucks. It used to be just the Big Egos and I could live with that. Nowadays, we are being pushed in all directions, and I am speaking of Slackware of course. It is a miracle that Pat manages to maintain a stable and useable distro at all! Even with a team of helpers, Pat is the one who defines Slackware and makes it stand out in the crowd of distros that strive to look alike even if they do not admit it.

End rant. I need another Trappist now.

Eric

Note: I never stated that Slackware will not add KDE 4.4 because of these issues. I merely said that this will not happen in the immediate future. We are working with developers to get our shadow utils supported in polkit which is one way to take away the pain. Another alternative is to take the loss and add KDE 4.4 with reduced fuctionality. Look at my KDE 4.4 prerelease packages… they still offer a great desktop environment!

Avatar utente
shark1500
Linux 3.x
Linux 3.x
Messaggi: 785
Iscritto il: gio 3 apr 2008, 14:33
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde
Località: Modna

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da shark1500 »

@danix: la nota finale del commento di Alien sembra avvalere la mia traduzione :-).

Comunque aveva scritto che avrebbe fatto un post del suo blog su questo. Magari si e` "limitato" ad un commento, mi sembra sia stato abbastanza chiaro

Avatar utente
danix
Staff
Staff
Messaggi: 3287
Iscritto il: ven 27 ott 2006, 19:32
Nome Cognome: Danilo M.
Slackware: 64 14.1
Kernel: 4.4.0
Desktop: kde4
Località: Siderno (RC)
Contatta:

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da danix »

si si, ma infatti anche io nelle sue parole precedenti ho intuito questo stato di cose, però ti dicevo che la traduzione esatta significava che non avrebbero incluso il 4.4 nell'immediato futuro... In ogni caso questo chiarimento di Alien è sacrosanto e io sono pienamente d'accordo con lui e con il team di Slackware cui andrebbe dedicata una statua d'oro per il miracolo che creano ogni giorno, una distro stabile nonostante tutte le schifezze che da tutte le parti provano a farci usare è realmente un miracolo...

Il mio appunto era riferito a questa tua:
Ma dove avete letto che la >= 4.4 non verra` messa su slackware?
;)
danix
myself ha scritto:non sono molto presente sul forum, e di ciò mi scuso con tutti

Avatar utente
shark1500
Linux 3.x
Linux 3.x
Messaggi: 785
Iscritto il: gio 3 apr 2008, 14:33
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde
Località: Modna

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da shark1500 »

Si`, tranquillo, non mi ero offeso :-), ad ogni modo la traduzione letteraria l'avevo capita, ma guardando i vecchi post (dato che seguo il blog) e leggendo quel post (di quanto lodasse kde) non mi sembrava venir fuori un'idea che kde venisse eliminato dalla Slackware, e (per fortuna) ci ho azzeccato :-).

Avatar utente
Blallo
Packager
Packager
Messaggi: 3298
Iscritto il: ven 12 ott 2007, 11:37
Nome Cognome: Savino Liguori
Slackware: 14.2 / 12.2
Kernel: 4.4.14-smp
Desktop: DWM
Località: Torino / Torremaggiore (FG)
Contatta:

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da Blallo »

(X.Org will drop support for HAL in their future releases)
scusate la mia ignoranza...ma vuol dire che X.Org toglierà il supporto ad Hal? (magari :-' :-' )

Avatar utente
DarthSteve
Linux 1.x
Linux 1.x
Messaggi: 126
Iscritto il: mer 1 apr 2009, 10:00
Nome Cognome: Stefano
Slackware: --Current--
Kernel: 5.5..x
Desktop: KDE
Località: Lucca

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da DarthSteve »

@jimmy_page_89

Sembra di si... c'e un'articolo anche su Phoronix (Dicembre 2, 2009)

URL: "http://www.phoronix.com/scan.php?page=n ... &px=Nzc2Mw"
--- The Jedi Code ---
There is no emotion; there is peace.
There is no ignorance; there is knowledge.
There is no passion; there is serenity.
There is no death; there is the Force

Avatar utente
conraid
Staff
Staff
Messaggi: 13459
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da conraid »


Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun 9 ago 2004, 0:00
Località: Rimini

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da Bart »

Ma sapete perché HAL non viene più sviluppato ma solo mantenuto?

Avatar utente
conraid
Staff
Staff
Messaggi: 13459
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da conraid »

Bart ha scritto:Ma sapete perché HAL non viene più sviluppato ma solo mantenuto?
http://freedesktop.org/wiki/Software/DeviceKit

anche se da quel poco che ho capito verrà "spostato" tutto su udev

http://lists.freedesktop.org/archives/d ... 00140.html

Avatar utente
michelino
Staff
Staff
Messaggi: 871
Iscritto il: gio 21 dic 2006, 11:59
Nome Cognome: Michelino Chionchio
Slackware: -current
Kernel: 2.6.29.6
Desktop: kde (current)
Località: Foggia

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da michelino »

Volevo segnalarvi la risposta di Aaron Seigo[url] sulla questione

Avatar utente
conraid
Staff
Staff
Messaggi: 13459
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: KDE3, KDE4 and Slackware 13.0 (AlienBOB)

Messaggio da conraid »

michelino ha scritto:Volevo segnalarvi la risposta di Aaron Seigo[url] sulla questione
dalle sue parole sembra (ma il mio inglese peggiora a vista d'occhio) che kauth potrà avere un backend alternativo, anzi vari backend, ma che ancora non è pronta e che mancano risorse per svilupparlo, in finale chiede una mano per questo
would you care to write a blog entry to your audience about the issue with the hopes of us finding a solution together in the form of a pair of motivated hands?
non mi sembra una chiusura del mondo kde verso sistemi diversi di autenticazione, tra l'altro da quel che dice nemmeno PAM è supportato direttamente, ma solo tramite policykit

il fatto è che le altre distribuzioni hanno sviluppatori pagati per fare queste cose, e quindi sarà sempre più facile trovare sviluppatori per integrare questi sistemi in quelle distribuzioni

tra l'altro
with KDE 4 we decided to side with a policy of not running GUIs as root. this was not an easy decision since it meant a lot of work for us.
non mi trova in disaccordo, anzi, solo che forse il problema è che si vuole anche far fare all'utente comune operazioni "da root" con quei sistemi, il che invece non lo trovo molto sensato

comunque che redhat, novell e canonical hanno risorse da "prestare" a kde e quindi in parte ne condizionano lo sviluppo mi sembra evidente e normale, se domani si sveglia sun o ibm e dice "vogliamo far interagire kauth con le shadow utils" penso che in pochi giorni avremmo il backend

Offtopic: p.s.
certo che continuare a tenere fuori PAM limita molto la Slackware, ma va beh

Rispondi