NVIDIA: Unable to determine the version of the kernel

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
daniele50
Linux 3.x
Linux 3.x
Messaggi: 964
Iscritto il: mar 10 apr 2007, 13:58
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.1
Kernel: 3.10.17
Desktop: Xfce 4.10
Località: San Zenone al Lambro (MI)
Contatta:

NVIDIA: Unable to determine the version of the kernel

Messaggio da daniele50 »

Ciao,
anche questa volta i driver nvidia (190.53) mi fanno diventare scemo, ecco cosa ho fatto:
ho rimosso i driver nvidia, ho aggiornato con slackpkg, ho ricompilato il kernel generic-smp-2.6.33 e quando ho provato a reinstallare i driver nvidia è uscito questo simpatico errore:

ERROR: Unable to determine the version of the kernel sources located in '/lib/modules/2.6.33-smp/source'. Please make sure you have installed the kernel source files for your kernel and that they are properly configured: on Red Hat Linux system, for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM installed. If you know the correct kernel source files are instaled, you may specify the kernel source path whit the '--kernel-source-path' command line option.

Allora ho ricompilato il kernel da capo un'altra volta (pensando di aver sbagliato qualcosa la prima) ma da ancora lo stesso errore...

Ovviamente tutti i pacchetti kernel* sono installati...

Che cavolo potrà essere??

erio
Linux 4.x
Linux 4.x
Messaggi: 1209
Iscritto il: ven 9 ott 2009, 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da erio »

prova a usare i driver certificati ,nvidia versione 195.36.08 per il kernel 2.6.33, quelli che hai messo tu vogliono una patch per quel kernel.

Avatar utente
daniele50
Linux 3.x
Linux 3.x
Messaggi: 964
Iscritto il: mar 10 apr 2007, 13:58
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.1
Kernel: 3.10.17
Desktop: Xfce 4.10
Località: San Zenone al Lambro (MI)
Contatta:

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da daniele50 »

Ma trovo solamente i driver 195.30 che mi danno altri errori, se cerco i 195.36.08 arrivo sempre su una pagina inesistente del sito nvidia :-(

Avatar utente
Kristos
Packager
Packager
Messaggi: 630
Iscritto il: sab 19 dic 2009, 11:40
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE
Distribuzione: PCLinuxOS

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da Kristos »

daniele50 ha scritto:Ma trovo solamente i driver 195.30 che mi danno altri errori, se cerco i 195.36.08 arrivo sempre su una pagina inesistente del sito nvidia :-(
I driver NVIDIA 195.36.08 li hanno postati in distrowatch per un paio di giorni, poi li hanno tolti e rimesso i 190.53 questo non me lo sò spiegare, forse perchè davano ancora problemi. :-k

Avatar utente
daniele50
Linux 3.x
Linux 3.x
Messaggi: 964
Iscritto il: mar 10 apr 2007, 13:58
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.1
Kernel: 3.10.17
Desktop: Xfce 4.10
Località: San Zenone al Lambro (MI)
Contatta:

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da daniele50 »

E quindi rimango fermo fino a quando li rimetteranno... vorrà dire che aggiornero a current quando nvidia rilascerà i driver... che altro posso fare?

Avatar utente
daniele50
Linux 3.x
Linux 3.x
Messaggi: 964
Iscritto il: mar 10 apr 2007, 13:58
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.1
Kernel: 3.10.17
Desktop: Xfce 4.10
Località: San Zenone al Lambro (MI)
Contatta:

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da daniele50 »

Come non detto:
c'è una patch per i driver nvidia che mi ha permesso di installare il driver 190.53 e di avviare kde, pare funzioni tutto!!
http://www.nvnews.net/vbulletin/showthr ... ost2164440

Avatar utente
Kristos
Packager
Packager
Messaggi: 630
Iscritto il: sab 19 dic 2009, 11:40
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE
Distribuzione: PCLinuxOS

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da Kristos »

Scoperto il motivo percui hanno tolto gli ultimi driver NVIDIA da distrowatch, il problema riguarda la ventola e del tipo del kernel installato, girando un pò per il forum ho trovato questo che chiarisce il mistero. :lol:

viewtopic.php?f=6&t=31510

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2413
Iscritto il: mar 1 mag 2007, 15:30
Slackware: 14.2
Kernel: 4.11.3-smp
Desktop: xfce4
Distribuzione: freeBSD-13.0-current

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da slucky »

quel "simpatico" errore lo dava anche a me...
malgrado compili sempre i sorgenti e non utilizzi i pacchetti-kernel di Pat, risolto installando gli ultimi driver nvidia-legacy 173.14.25

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4615
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 4.14.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da aschenaz »

Dunque, sto usando (forzatamente) i driver 'nv'... :|
I 195.30 sono riuscito ad installarli (con la patch), ma al lancio di startx mi dà
i seguenti errori:

Codice: Seleziona tutto

NVIDIA: Failed to load the NVIDIA kernel module. Please check your
(EE) NVIDIA:     system's kernel log for additional error messages.
(II) UnloadModule: "nvidia"
(II) Unloading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(EE) Failed to load module "nvidia" (module-specific error, 0)
(EE) No drivers available.

Fatal server error:
no screens found
Eppure l'installazione è andata a buon fine...!

Stesso problema coi driver legacy...
Magari riprovo coi 190.53 patchati?

P.S. (di sicuro sto scoprendo l'acqua calda) Notato cosa dice all'avvio di X:
"Build Operating System: Slackware 13.1 Slackware Linux Project" :p

F4B1CK
Linux 2.x
Linux 2.x
Messaggi: 264
Iscritto il: dom 11 gen 2004, 0:00
Slackware: current 64 bit
Kernel: 4.4.x
Desktop: KDE 5
Località: Cosenza
Contatta:

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da F4B1CK »

Ho avuto problemi simili, risolti utilizzando il kernel generic e l'ultima versione dei drivers (che però pare portino problemi, sto valutando la cosa).
Il mio topic lo trovi qui : viewtopic.php?f=1&t=31497
spero ti sia utile. Ciao! :p

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4615
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 4.14.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da aschenaz »

F4B1CK ha scritto:Ho avuto problemi simili, risolti utilizzando il kernel generic e l'ultima versione dei drivers (che però pare portino problemi, sto valutando la cosa).
Il mio topic lo trovi qui : viewtopic.php?f=1&t=31497
spero ti sia utile. Ciao! :p
Grazie, stavo appunto leggendo...
Ora provo anche questa strada (i 190.53 li ho provati senza esito).

Non vedo l'ora che siano usabili i nouveau!!!

F4B1CK
Linux 2.x
Linux 2.x
Messaggi: 264
Iscritto il: dom 11 gen 2004, 0:00
Slackware: current 64 bit
Kernel: 4.4.x
Desktop: KDE 5
Località: Cosenza
Contatta:

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da F4B1CK »

aschenaz ha scritto:
F4B1CK ha scritto:Ho avuto problemi simili, risolti utilizzando il kernel generic e l'ultima versione dei drivers (che però pare portino problemi, sto valutando la cosa).
Il mio topic lo trovi qui : viewtopic.php?f=1&t=31497
spero ti sia utile. Ciao! :p
Grazie, stavo appunto leggendo...
Ora provo anche questa strada (i 190.53 li ho provati senza esito).

Non vedo l'ora che siano usabili i nouveau!!!

Ho appena installato i 195.30, ritenuti affidabili, con la patch e funziona tutto per bene. Penso che risolverai anche tu in questo modo!

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4615
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 4.14.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da aschenaz »

Niente da fare: ho provato sia il kernel generic che il generic-smp. Il risultato è
sempre quello. Non riesco a capire. È come se non creasse di fatto il modulo! :(
Ripeto: con le patch i driver riesco ad installarli (sia 195.30 che 190.53, ma ho
provato anche i 173.14.25).
Sia con gli "nv" che coi "vesa" X parte...!

Avatar utente
Kristos
Packager
Packager
Messaggi: 630
Iscritto il: sab 19 dic 2009, 11:40
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE
Distribuzione: PCLinuxOS

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da Kristos »

In questo momento da parte mia ho installato i 195.22 e tutto sembra funzionare bene, ma ho voluto provare anche con i 173.14.30 (se non ricordo male) e con i 96.x.x eppure tutto funziona bene a parte ovviamente dei rallentamenti dovuti ai driver troppo vecchi per la mia scheda video, per il resto anche i 190.53 funzionano bene. Non capisco per quale motivo con gli ultimi kernel in alcuni casi non vadano, mentre i driver 195.08.36 li ho eliminati a priori non trovandoli più in giro. Boh :-k

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4615
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 4.14.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Re: NVIDIA: Unable to determine the version of the kernel

Messaggio da aschenaz »

Se provo a dare direttamente modprobe nvidia, ecco cosa mi dice:

Codice: Seleziona tutto

WARNING: Error inserting agpgart (/lib/modules/2.6.33-smp/kernel/drivers/char/agp/agpgart.ko): Invalid module format
FATAL: Error inserting nvidia (/lib/modules/2.6.33-smp/kernel/drivers/video/nvidia.ko): Invalid module format

Rispondi