akonadi Risolto?

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
pino
Linux 3.x
Linux 3.x
Messaggi: 591
Iscritto il: ven 18 gen 2008, 15:34
Nome Cognome: Pino
Slackware: 14
Desktop: kde
Località: Torino

akonadi Risolto?

Messaggio da pino »

Sto provando slackware 13.1 Problema io uso normalmente kmail ma quando lo lancio mi ritrovo sempre la finestra di akonadi tra i piedi se la chiudo si chiude anche kmail
Akonadi mi da errori su d bus. Ho provato a disistallarlo come avevo fatto sulla 13 ma non funziona piu kmail
Che fare?
Ultima modifica di pino il gio 27 mag 2010, 12:04, modificato 1 volta in totale.

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: akonadi

Messaggio da phobos3576 »

Teorema 1: il principio di funzionamento di Akonadi è sconosciuto pure ai suoi sviluppatori.

Teorema 2: la possibilità di eliminare i messaggi di errore in avvio di Akonadi è legata alle leggi del caso.

Io ci sono riuscito (con la 13.0) ma non so dirti come ho fatto.
In pratica, Akonadi non partiva per l'utente root e così, cercando in Rete, ho letto che dovevo dare i permessi di esecuzione a MySql per l'utente root; a tale proposito, bisogna editare il file /root/.local.share/akonadi/mysql.conf e aggiungere alla fine:

Codice: Seleziona tutto

user=root
In effetti, adesso Akonadi funziona perfettamente per l'utente root. La sorpresa è che dopo quelle modifiche ora per gli utenti normali non compare più quella barra che indicava il caricamento di Akonadi.

Sempre in base a ciò che ho trovato in Rete, ho provveduto allora a chiudere KDE e a cancellare le directory: $HOME/.config/akonadi e $HOME/.local/share/akonadi per gli utenti normali; dopo aver riavviato KDE ho eseguito il comando:

Codice: Seleziona tutto

kres-migrator
Adesso, in avvio di KDE Akonadi parte e carica i tre resource-agents: Calendar, Compleanni e Addressbook, mentre è sparita la risorsa VCard che creava un sacco di problemi.
Cliccando su "prova" nel centro di controllo KDE, il server Akonadi supera tutti i test senza errori.

Non chiedermi il significato delle cose che ho scritto perché non ti so rispondere.

Tra l'altro, improvvisamente si è messo a funzionare pure Nepomuk, Strigi e tutto il resto; adesso, anche Gwenview vede tutti i plugin di Digikam, mentre prima non accadeva.

pino
Linux 3.x
Linux 3.x
Messaggi: 591
Iscritto il: ven 18 gen 2008, 15:34
Nome Cognome: Pino
Slackware: 14
Desktop: kde
Località: Torino

Re: akonadi

Messaggio da pino »

Qui il casini è sempre lo stesso
Akonadi continua avviarsi ogni volta che lancio kmail e l'errore che da è "Il processo di controllo di Akonadi non è registrato su D-Bus"
Non c'è un modo per far fuori akonadi ed usare Calendar,kmail, Compleanni e Addressbook senza questo mostro invadente.
KDE per il resto, sulla mia macchina che ha un paio di anni, 2 giga di ram ed gforce integrata con 250 mega di, gira veloce e senza intoppi

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: akonadi

Messaggio da phobos3576 »

pino ha scritto:Akonadi continua avviarsi ogni volta che lancio kmail e l'errore che da è "Il processo di controllo di Akonadi non è registrato su D-Bus"
Pensavo che quel problema l'avessero risolto visto che è conosciuto da anni.
A quanto pare, l'errore di D-Bus sembra legato al fatto che Akonadi tenta di avviarsi prima che vengano caricate varie risorse di KDE4; in effetti, un modo abbastanza scomodo per risolvere questo problema consiste nel chiudere e riavviare KDE4.

Prova ad andare nel centro di controllo KDE, "Avanzate" - "Configurazione di Akonadi".
Nella sezione "Configurazione risorse Akonadi" prova a rimuovere (se è presente) la risorsa VCard e poi aggiungi altre risorse come Calendar, Addressbook, etc; assegna dei file a quelle risorse (io ho messo nomi a caso tipo mycalendar, myaddressbook, etc), applica i cambiamenti e prova a riavviare KDE.

Avatar utente
neongen
Packager
Packager
Messaggi: 827
Iscritto il: ven 25 mag 2007, 12:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5
Contatta:

Re: akonadi

Messaggio da neongen »

corollario al teorema 1: ne é ignoto anche lo scopo.

io pensavo che potesse essere utile per sincronizzare le risorse tra computer e dispositivi differenti... ma... boh...

Avatar utente
j0kers
Linux 2.x
Linux 2.x
Messaggi: 418
Iscritto il: dom 22 lug 2007, 1:31
Slackware: 13
Kernel: 2.6.32
Desktop: xfce4

Re: akonadi

Messaggio da j0kers »

Prova questa stringa:

Codice: Seleziona tutto

kwriteconfig --file kres-migratorrc --group Migration --key Enabled --type bool false

Avatar utente
ammatwain
Linux 0.x
Linux 0.x
Messaggi: 29
Iscritto il: lun 19 dic 2005, 8:47
Slackware: 13
Kernel: 2.6.x
Desktop: KDE, XFCE
Distribuzione: Ubuntu
Località: Calci

Re: akonadi

Messaggio da ammatwain »

j0kers ha scritto:Prova questa stringa:

Codice: Seleziona tutto

kwriteconfig --file kres-migratorrc --group Migration --key Enabled --type bool false
...funziona... ti odio!!! ;)

pino
Linux 3.x
Linux 3.x
Messaggi: 591
Iscritto il: ven 18 gen 2008, 15:34
Nome Cognome: Pino
Slackware: 14
Desktop: kde
Località: Torino

Re: akonadi

Messaggio da pino »

Ora funziona, non chiedetemi come e perche non ne ho idea.L' unica cosa che ho fatto è:
phobos3576 ha scritto:bisogna editare il file /root/.local.share/akonadi/mysql.conf e aggiungere alla fine:Codice: user=root
Ora continua a dare lo stesso errore "Il processo di controllo di Akonadi non è registrato su D-Bus" in root ma dopo l'avvio si toglie dai piedi e non ricompare, da utente non si vede più
Ciao Pino

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: akonadi Risolto?

Messaggio da phobos3576 »

Per avere la certezza che tutto stia funzionando a dovere, appena avviato KDE4 apri il Monitor di Sistema e assicurati che il server Akonadi sia in esecuzione. In caso affermativo, apri le "Impostazioni di Sistema" - "Avanzate" - "Configurazione di Akonadi" - "Configurazione del server Akonadi" e clicca su "Prova"; se non compaiono messaggi di errore (tranne quello relativo al Registro degli Errori) significa che è tutto a posto.

Per quanto riguarda l'errore relativo ai resource agents non trovati, bisogna assicurarsi che la variabile XDG_DATA_DIRS contenga anche la directory /usr/share (dove appunto sono presenti gli agents di akonadi); questa variabile si trova nel file /usr/bin/startkde:

Codice: Seleziona tutto

if test -z "$XDG_DATA_DIRS"; then
    XDG_DATA_DIRS="`kde4-config --prefix`/share:/usr/share:/usr/local/share"
    export XDG_DATA_DIRS
fi
Eventuali modifiche di questo file vanno fatte dalla modalità testo, altrimenti KDE4 va in crash!

pino
Linux 3.x
Linux 3.x
Messaggi: 591
Iscritto il: ven 18 gen 2008, 15:34
Nome Cognome: Pino
Slackware: 14
Desktop: kde
Località: Torino

Re: akonadi Risolto?

Messaggio da pino »

phobos3576 ha scritto:Per avere la certezza che tutto stia funzionando a dovere, appena avviato KDE4 apri il Monitor di Sistema e assicurati che il server Akonadi sia in esecuzione. In caso affermativo, apri le "Impostazioni di Sistema" - "Avanzate" - "Configurazione di Akonadi" - "Configurazione del server Akonadi" e clicca su "Prova"; se non compaiono messaggi di errore (tranne quello relativo al Registro degli Errori) significa che è tutto a posto.
E' in esecuzione per il resto vedrò in seguito
Per adesso l'installazione della 13.1 è un esperimento per l'uso corrente rimango con la mia super affidabile 12.1
Grazie molte Pino

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3559
Iscritto il: sab 26 giu 2004, 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: akonadi

Messaggio da Trotto@81 »

ammatwain ha scritto:
j0kers ha scritto:Prova questa stringa:

Codice: Seleziona tutto

kwriteconfig --file kres-migratorrc --group Migration --key Enabled --type bool false
...funziona... ti odio!!! ;)
Bastava un piccola ricerca sul forum o nelle guide di kde presenti sul sito ufficiale. ;)

gengisdave
Linux 0.x
Linux 0.x
Messaggi: 14
Iscritto il: mar 22 set 2009, 13:26
Slackware: beyond current64
Kernel: git
Desktop: KDE 4 git
Località: Torino

Re: akonadi Risolto?

Messaggio da gengisdave »

Io ho risolto creando $HOME/.local/share/akonadi/db_data/mysql e schiaffandoci dentro l'elenco delle tabelle di /var/lib/mysql/mysql, ovviamente dopo averle vuotate... funziona...

Rispondi